• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信短线多彩K线主图指标公式

通达信公式 第一股票指标公式网 2个月前 (11-21) 30次浏览 已收录 0个评论 扫描二维码

M1:=5;M2:=8;M3:=21;M4:=60;ma1:MA(CLOSE,M1);MA2:MA(CLOSE,M2);MA3:MA(CLOSE,M3);MA4:MA(CLOSE,M4);天际: (MA(CLOSE,40)) + 2*stD(CLOSE,40),LINETHICK2,COLORBLUE;海底: (MA(CLOSE,40)) – 2*STD(CLOSE,40),LINETHICK2,COLORBLUE;三一:H-(H-L)*0.333,NODRAW;二一:H-(H-L)*0.5,NODRAW;三二:H-(H-L)*0.666,NODRAW;实体三一:O+(C-O)*0.666,NODRAW;实体腰线:O+(C-O)*0.5,NODRAW;C_: CONST(C),COLORLIRED,POINTDOT;{现价线}MA5:=MA(C,5);MA5角度: ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416,NODRAW;DRAWKLINE(H,O,L,C);{重绘k线}RC1:=REF(C,1);CS:=IF(C>=1,10000,100000);C涨停10:=1.10*RC1-49/CS;{考虑到4舍5入}C涨停5 :=1.05*RC1-49/CS;C跌停10:=0.90*RC1+51/CS;C跌停5 :=0.95*RC1+51/CS;ST:=NAMELIKE(‘S’) OR NAMELIKE(‘*S’);涨停:= IF(ST, C>=C涨停5, C>=C涨停10);跌停:= IF(ST, C<=C跌停5, C<=C跌停10);盘中涨停:=IF(ST, H>=C涨停5, H>=C涨停10);盘中跌停:=IF(ST, L<=C跌停5, L<=C跌停10);STICKLINE(盘中涨停,H,MAX(C,O),0,0),COLORMAGENTA;{涨停后回落}STICKLINE(盘中跌停,L,MIN(C,O),0,0),COLORLICYAN;{跌停后回升}大阳线:=C>O AND (C>=C涨停5 OR C>(1.05*O-51/CS) ) OR (C>1000 AND C>RC1*1.024);STICKLINE(大阳线,O,C,1,0),COLOR0000BB;大阴线:=C<O AND (C<=C跌停5 OR C<(0.95*O+49/CS) ) OR (C>1000 AND C<RC1*0.976);STICKLINE(大阴线,O,C,1,0),COLORLIGREEN;STICKLINE(涨停,O,C,1,0),COLORMAGENTA;STICKLINE(跌停,O,C,1,0),COLORLICYAN;假阴:=C<O AND C>REF(C,1);STICKLINE(假阴,O,C,0,0),COLORRED;{假阴柱};假阳:=C>O AND C<REF(C,1);STICKLINE(假阳,O,C,0,0),COLORGREEN;{假阳柱};大盘TJ:=PERIOD=5 AND NAMELIKE(‘上证指数’) AND (Abs((C-REF(C,1)))/REF(C,1)>=0.025 OR ABS(C-O)>=60);STICKLINE(大盘TJ,(H+L)/2,(H+L)/2,2,0),COLORYELLOW;{显示大盘日线的60点大K线中值};STICKLINE((大阳线 OR 大阴线 OR 涨停 OR 跌停) AND BETWEEN(C,1,500),L+(H-L)/2,L+(H-L)/2,1,0),COLORYELLOW;{大K线画中点线};DRAWTEXT_FIX(ISLASTBAR,0.10,0.01,1, DYBLOCK), COLORYELLOW;DRAWTEXT_FIX(ISLASTBAR,0.20,0.01,1, HYBLOCK), COLORYELLOW;DRAWTEXT_FIX(ISLASTBAR ,0.55,0.10,1, GNBLOCK), COLORWHITE;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址