• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信筹码资金主图指标公式

通达信公式 第一股票指标公式网 7个月前 (01-06) 61次浏览 已收录 0个评论 扫描二维码

本文指标含有选股公式如下:筹码资金主图之伏击涨停选股指标公式 筹码资金主图之红底选股指标公式 筹码资金主图之买点选股指标公式 筹码资金主图之绝对底部选股指标公式 筹码资金主图之庄进选股指标公式 筹码资金主图之启爆选股指标公式 筹码资金主图之钻石王选股指标公式获利盘:WINNER(C)*100,COLORYELLOW,NODRAW;活筹:(WINNER(C*1.075)-WINNER(C*0.925))*100,COLORFFFFFF,NODRAW;获利纵横:获利盘-活筹,NODRAW,COLORmaGENTA;换手率:=vol/CAPITAL*100,COLORWHITE,NODRAW;预换手:IF(CURRBARSCOUNT=1 AND PERIOD=5,换手率*240/FROMOPEN,DRAWNULL),NODRAW;ZLCM:=ema(WINNER(C)*70,3);SHCM:=EMA((WINNER(C*1.10)-WINNER(C*0.90))*80,3);主力控盘系数:(ZLCM/(ZLCM+SHCM))*100,COLORYELLOW,NODRAW;【穿筹量】:(WINNER(CLOSE)-REF(WINNER(C),1))*100,NODRAW,COLORMAGENTA;顶筹价:COst(99.99),COLORRED,LINETHICK2;中筹价:COST(50),COLORRED,LINETHICK2;底筹价:COST(0.01),COLORCYAN,LINETHICK2;DRAWBAND(COST(99.99),RGB(100,0,0),COST(90),RGB(150,0,0));DRAWBAND(COST(90.00),RGB(0,200,0),COST(80.00),RGB(0,250,0));DRAWBAND(COST(80.00),RGB(200,110,250),COST(70.00),RGB(200,100,250));DRAWBAND(COST(70.00),RGB(250,200,0),COST(60.00),RGB(250,200,0));DRAWBAND(COST(60.00),RGB(0,150,250),COST(50.00),RGB(0,150,250));DRAWBAND(COST(50.00),RGB(200,0,0),COST(40.00),RGB(0,250,0));DRAWBAND(COST(40.00),RGB(0,200,0),COST(30.00),RGB(0,250,0));DRAWBAND(COST(30.00),RGB(200,110,250),COST(20.00),RGB(200,110,250));DRAWBAND(COST(20.00),RGB(250,200,0),COST(10.00),RGB(250,200,0));DRAWBAND(COST(10.00),RGB(0,150,250),COST(00.01),RGB(0,150,250));MA5:MA(CLOSE,5),LINETHICK3,COLORGREEN;MA5上升:IF(MA5>=REF(MA5,1),MA5,DRAWNULL),LINETHICK3,COLORRED; X_54:=MA(CLOSE,5);{MA5角度取自量学太极线} MA5角度:ATAN((X_54/REF(X_54,1)-1)*100)*180/3.1416,NODRAW;MA10:MA(CLOSE,10),LINETHICK3,COLORGREEN;MA30:MA(CLOSE,30),LINETHICK2,COLORMAGENTA;MA60:MA(CLOSE,60),LINETHICK2,COLORYELLOW;{MA120:MA(CLOSE,120),LINETHICK2,COLORCYAN;MA250:MA(CLOSE,250),LINETHICK2,COLORBLUE;}{主力成本线:EMA(COST(9),250),COLORYELLOW,,DOTLINE;{原有}cyc∞:CYC.CYC∞,CIRCLEDOT,COLORYELLOW;{DRAWBAND(MA5,RGB(150,0,0),MA10,RGB(0,150,0));}MA20:MA(CLOSE,20),COLORCYAN,LINETHICK4;上升趋势:IF(MA(CLOSE,20)>=REF(MA(CLOSE,20),1),MA(CLOSE,20),DRAWNULL),COLORMAGENTA,LINETHICK4;{DRAWKLINE(H,O,L,C);} {画k线}超B:=L2_AMO(0,0)/10000.0;大B:=L2_AMO(1,0)/10000.0;中B:=L2_AMO(2,0)/10000.0;小B:=L2_AMO(3,0)/10000.0;超S:=-L2_AMO(0,1)/10000.0;大S:=-L2_AMO(1,1)/10000.0;中S:=-L2_AMO(2,1)/10000.0;小S:=-L2_AMO(3,1)/10000.0;主力:(超B+大B)+(超S+大S),COLORYELLOW,NODRAW;{散户净买:(中B+小B)+(中S+小S),NODRAW;}成交额:=AMOUNT/10000;主力占比:主力/成交额*100,COLORYELLOW,NODRAW;机构:(超B)+(超S),COLORYELLOW,NODRAW;大户:(大B)+(大S)COLORRED,NODRAW;中户:(中B)+(中S),COLORMAGENTA,NODRAW;小户:(小B)+(小S),COLORWHITE,NODRAW;STICKLINE(主力>0,O,C,2,1),COLORYELLOW;STICKLINE(主力<0,O,C,2,1),COLORLIBLUE;STICKLINE(机构>0,O,C,1,0),COLORYELLOW;STICKLINE(机构<0,O,C,1,0),COLORBLUE;STICKLINE(大户>0,O,(O+C)/2,1,0),COLORRED;STICKLINE(大户<0,O,(O+C)/2,1,0),COLORGREEN;累计:=SUM(主力,30),COLORMAGENTA;均值:=EMA(累计,MIN(10,30)),COLORWHITE;{红}STICKLINE(crOSS(累计,均值),H,L,0,0),COLORRED,LINETHICK1;STICKLINE(CROSS(累计,均值),CLOSE,OPEN,1.4,0),COLOR000088;STICKLINE(CROSS(累计,均值),CLOSE,OPEN,1,0),COLOR0000BB;STICKLINE(CROSS(累计,均值),CLOSE,OPEN,0.6,0),COLOR0000DD; STICKLINE(CROSS(累计,均值),CLOSE,OPEN,{0}0.2,0),COLOR0000FF;{蓝}STICKLINE(CROSS(均值,累计),H,L,0,0),COLORFF8800,LINETHICK1;STICKLINE(CROSS(均值,累计),CLOSE,OPEN,1.4,0),COLORBB4400;STICKLINE(CROSS(均值,累计),CLOSE,OPEN,1,0),COLORCC5500;STICKLINE(CROSS(均值,累计),CLOSE,OPEN,0.6,0),COLORDD6600;STICKLINE(CROSS(均值,累计),CLOSE,OPEN,{0}0.2,0),COLOREE7700;半分位:=(REF(C,1)+REF(O,1))/2,COLORWHITE,DOTLINE;STICKLINE(半分位,半分位,半分位,4,0),COLORWHITE;{五线顺上的拐点定位线,有未来函数}局部低点预选A:=BacKSET(LLV(L,5)<REF(LLV(L,4),1),4);局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);局部高点预选A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);缺口判断:=IF(L>REF(H,1),1,IF(H<REF(L,1),-1,0));距前高天:=BArslAST(局部高点预选C=1);距前低天:=BARSLAST(局部低点预选C=-1);小值周期:=LOwrANGE(L);大值周期:=topRANGE(H);低保留AA:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);低保留AB:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR LLV(L,距前低天+2)<REF(LLV(L,距前低天+1),1)),-1,0);低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L<REF(H,距前高天+1),-1,0);预判:=IF((距前低天<4 AND HHV(缺口判断,距前低天)!=1) OR REF(低保留S,距前低天)=0,1,0);判断:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND 预判=1 AND 大值周期>REF(小值周期,距前低天+1) AND 大值周期>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);高保留B:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND REF(低保留S,距前低天)=-1 AND (距前低天>=4 OR HHV(缺口判断,距前低天)=1),1,0);高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H>REF(L,距前低天+1),1,0);预判A:=IF((距前高天<4 AND HHV(缺口判断,距前高天)!=1) OR REF(高保留,距前高天)=0,1,0);判断A:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND 预判A=1 AND 小值周期>REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);低保留B:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-1),-1,0);低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L<REF(H,距前高天+1),-1,0);距前高天A:=BARSLAST(高保留=1);距前低天A:=BARSLAST(低保留=-1);预判X:=IF((距前低天A<4 AND HHV(缺口判断,距前低天A)!=1) OR REF(低保留,距前低天A)=0,1,0);判断X:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND 预判X=1 AND 大值周期>REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);高保留XA:=IF(局部高点预选C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);高保留XB:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND REF(低保留,距前低天A)=-1 AND (距前低天A>=4 OR HHV(缺口判断,距前低天A)=1),1,0);高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判断X=1) AND H>REF(L,距前低天A+1),1,0);预判XA:=IF((距前高天A<4 AND HHV(缺口判断,距前高天A)!=1) OR REF(高保留XA,距前高天A)=0,1,0);判断XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND 预判XA=1 AND 小值周期>REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);低保留XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)<REF(LLV(L,距前高天A+1),1),-1,0);低保留XB:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND (距前高天A>=4 OR LLV(缺口判断,距前高天A)=-1 OR 判断XA=-1),-1,0);低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND L<REF(H,距前高天A+1),-1,0);距前高天YA:=BARSLAST(高保留X=1);距前低天YA:=BARSLAST(低保留X=-1);预判YX:=IF((距前低天YA<4 AND HHV(缺口判断,距前低天YA)!=1) OR REF(低保留X,距前低天YA)=0,1,0);判断YX:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND 预判YX=1 AND 大值周期>REF(小值周期,距前低天YA+1) AND 大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);高保留YXA:=IF(局部高点预选C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);高保留YXB:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND REF(低保留X,距前低天YA)=-1 AND (距前低天YA>=4 OR HHV(缺口判断,距前低天YA)=1),1,0);高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判断YX=1) AND H>REF(L,距前低天YA+1),1,0);预判YXA:=IF((距前高天YA<4 AND HHV(缺口判断,距前高天YA)!=1) OR REF(高保留YXA,距前高天YA)=0,1,0);判断YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND 预判YXA=1 AND 小值周期>REF(大值周期,距前高天YA+1) AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);低保留YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)<REF(LLV(L,距前高天YA+1),1),-1,0);低保留YXB:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND (距前高天YA>=4 OR LLV(缺口判断,距前高天YA)=-1 OR 判断YXA=-1),-1,0);低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND L<REF(H,距前高天YA+1),-1,0);AAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L<REF(L,REF(距前低天YA,1)+2),-1,0));极点保留:=IF(AAAD=0,高保留YX+低保留YX,AAAD);局部极点:IF(极点保留=-1,L,IF(极点保留=1,H,DRAWNULL)),CIRCLEDOT,COLORYELLOW;DRAWLINE(极点保留=-1,局部极点,极点保留=1,局部极点,0)COLORGREEN,LINETHICK1;DRAWLINE(极点保留=1,局部极点,极点保留=-1,局部极点,0)COLORYELLOW,LINETHICK1;DD1:=BARSLAST(Abs(极点保留)!=1); DRAWTEXT(极点保留=1,局部极点*1.01,’↓卖’),COLORGREEN;{ STICKLINE(极点保留=1,局部极点,局部极点,30,1),COLORCYAN;}{ DRAWNUMBER(极点保留=1,局部极点,局部极点)COLORGREEN;} DRAWTEXT(极点保留=-1,局部极点*0.95,’↖买’),COLORYELLOW;{ STICKLINE(极点保留=-1,局部极点,局部极点,30,1),COLORRED;}{ DRAWNUMBER(极点保留=-1,局部极点,局部极点)COLORYELLOW;}{一绝}Q_1:=C-REF(C,1);Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);Q_3:=CROSS(EMA(C,19),EMA(C,7));Q_4:=CROSS(EMA(C,7),EMA(C,19));ZD1:=L=LLV(L,BARSLAST(Q_3)+1);ZD2:=LLV(L,BARSLAST(Q_3)+1);ZD3:=H=HHV(H,BARSLAST(Q_4)+1);ZD4:=HHV(H,BARSLAST(Q_4)+1);Q_A:=DRAWLINE(ZD1,ZD2,ZD3,ZD4,0);U1:=H=HHV(H,BARSLAST(Q_4)+1);U2:=HHV(H,BARSLAST(Q_4)+1);U3:=L=LLV(L,BARSLAST(Q_3)+1);U4:=LLV(L,BARSLAST(Q_3)+1);Q_B:=DRAWLINE(U1,U2,U3,U4,0);TJ:=IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,1,0);BB:=REF(TJ,1)=0 AND TJ>=1 ;DRAWICON(BB,L*0.998,34);{图标_黄圆、对勾向上}SS:=REF(Q_A<REF(Q_A,1) AND Q_B=Q_A,1)=0 AND TJ<1; DRAWICON(SS,H*1.002,35);{图标_绿源、对勾向下}{私募公式}AAE:= WINNER(CLOSE+CLOSE*15/100)*100;BBE:= WINNER(CLOSE+CLOSE*0/100)*100;CCE:= AAE-BBE;dde:= (WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;EEE:= CCE<3 AND DDE<0.5 AND OPEN>LOW;AE1:= DYNAINFO(6);AE2:= IF(LOW>AE1,0,IF(HIGH<AE1,1,(AE1-LOW+0.01)/(HIGH-LOW+0.01)));AE3:= VOL/WINNER(LOW);AE4:= REF(HHV(CLOSE,120),1);AE5:= REF(LLV(CLOSE,120),1);AE6:= 100*(CLOSE-AE5)/(AE4-AE5);AE7:= AE2>0 OR AE2=1;AE8:= AE7 AND AE3/REF(AE3,3)>=3 AND AE6<80;AE9:= REF(AE8,1) OR REF(AE8,2) OR REF(AE8,3) OR REF(AE8,4);AE10:= AE8 AND AE9;AE11:= IF(FILTER(AE8,3),5,0);AE12:= FILTER(IF(FILTER(AE10,3) OR EEE,10,0),3);DRAWICON(AE12,L-0.0018,13);{图标_粉红圆、右上飘}{伏击涨停}T1:=MA(C,21)>REF(MA(C,21),1);T2:=EXIST(C>REF(C,1)*1.093,21);T3:=C<O AND C<REF(C,1) AND EVERY(MA(C,5)<REF(MA(C,5),1),3);T5:=EVERY(V<REF(V,1),2) AND EVERY(V<MA(V,5),2);T6:=MA(C,5)>MA(C,21);DRAWTEXT(T1 AND T2 AND T3 AND T5 AND T6,L,’↖伏击涨停’); {红底绿顶} 低:=REF(LLV(L,150),3); 近期底:=REFDATE(低,DATE); 最底:=REFDATE(近期底,DATE); 入:=最底=L AND ((C+L)<(O+C) OR (O+L)<(C+O)); STICKLINE(入,O,(C+O)/2,2,0),COLORRED; STICKLINE(入,H,L,0.1,0),COLORRED; DRAWTEXT(入,L*0.9958,’↖红底’),COLORLIMAGENTA; 高:=REF(HHV(H,150),3); 近期顶:=REFDATE(高,DATE); 最顶:=REFDATE(近期顶,DATE),NODRAW; 出:=最顶=H AND ((C-L)<(O-C) OR (O-L)<(C-O)),NODRAW; STICKLINE(出,O,(C+O)/2,2,0),COLORGREEN; STICKLINE(出,H,L,0.1,0),COLORGREEN; DRAWTEXT(出,H*1.008,’–绿顶’),COLORGREEN;XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04)); XL2:=(((CLOSE – EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100); XL3:=CROSS(XL2,(0 – 20)); DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW – 0.0014),’●买点’); DRAWTEXT((XL3 > 0),(LOW – 0.010),’●绝对底部’)COLORYELLOW; X6:=REF(CLOSE,1); X7:=((SMA(MAX((CLOSE – X6),0),7,1) / SMA(ABS((CLOSE – X6)),7,1)) * 100); X8:=CROSS(79,X7); X9:=FILTER(X8,4); DRAWTEXT(X9,(HIGH * 0.9989),’-●出货’),COLORGREEN; {金牛启动}年:=MA(CLOSE,240);涨幅%:=(C-REF(C,1))/REF(C,1)*100;RSVV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;VARB2:=(RSVV/2+22)*1;量:=EMA(VOL,13);资金:=EMA(AMOUNT,13);过滤:=((资金 /量) / 100);提纯:=(((CLOSE -过滤) / 过滤) * 100);黄金:=((提纯 < (0)) AND ZXNH);买:=IF(黄金 AND RSVV<VARB2-2,180,0) AND 涨幅%>0 AND C<年;DRAWTEXT(买>0,L*0.995,’↖牛’),COLORFFFFFF;{DRAWTEXT(买>0,L*0.985,’▲’),COLORFF00FF;} 五日乖离率:=((C-MA5)/MA5)*100; BB05:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416; 速度5:=SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1); 加速度5:EMA((速度5-REF(速度5,1)),3),NODRAW; BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416; 三拾日乖离率:=(C-MA30)/MA30*100; VAR11:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1); VAR22:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1); BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416; 强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10); 加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA5>REF(MA5,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1),10) ; 清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>MA30 OR O>MA30) AND MA5<REF(MA5,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10); DRAWICON(加仓 ,LOW*0.997,21);{图标_小房子} DRAWICON(清仓 ,HIGH*1.005,12);{黄手指向下} DRAWICON(强势狙击 ,LOW*0.997,11);{黄手指向上}{俊俊出击-选股}S1:=MA((2*C+H+L)/4,5); S2:=S1*(200-102)/100;S3:=(1-7/100)*dma(C,ABS((2*C+H+L)/4-MA(C,20))/MA(C,20)); S4:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100; S5:=3*SMA(S4,3,1)-2*SMA(SMA(S4,3,1),3,1); S6:=((H+L+C)/3-MA((H+L+C)/3,14))/(0.015*AVEDEV((H+L+C)/3,14)); DRAWTEXT(S2<S3&&S5>REF(S5,1)&&REF(S5,1)<REF(S5,2)&&S6<-100&&S6>REF(S6,1),L-0.0018,’俊’),COLORYELLOW; N:=10; T1K:=CONST(LLVBARS(LOW,N)); T1HIGH:=CONST(REF(HIGH,T1K)); CC:=CONST(CURRBARSCOUNT); T2K:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T1K)) AND (HIGH>T1HIGH))); T2HIGH:=CONST(REF(HIGH,T2K)); T3K:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T2K)) AND (HIGH>T2HIGH))); T3HIGH:=CONST(REF(HIGH,T3K));洗盘杀入线:DRAWLINE(CURRBARSCOUNT=10+1,T3HIGH,ISLASTBAR, T3HIGH,1),LINETHICK1,COLORLIRED; DRAWTEXT(ISLASTBAR, T3HIGH,’杀入线’)LINETHICK1,COLORLIRED; AQ1:=REF(V,1);AQ2:=DVOL;AQ3:=AQ2/AQ1; LNX:=AQ3-REF(AQ3,1); E1:=REF(C,1);E2:=DCLOSE;E3:=(E2-E1)/E1*100; QMX:=E3-REF(E3,1); XG:=CROSS(LNX,500) AND CROSS(QMX,10); DRAWTEXT(XG=1,L*0.995,’↖钻石’),COLORFFCC88;{ DRAWICON(XG=1,L*0.993,25);}{有庄控盘}VAW1:=EMA(EMA(CLOSE,13),13);控盘:=(VAW1-REF(VAW1,1))/REF(VAW1,1)*1000;无庄控盘:=控盘<0;有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;{分时价格原码}JJ:=DYNAINFO(11);{波段买卖原码}P:=21;S:=8;M1:=3;财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*50;神:=EMA(财,M1);{股价与均线偏离买卖条件}BTJ1:=(C-JJ)/JJ<-0.03;BTJ11:=(C-JJ)/JJ<-0.03;BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;STJ1:=(C-JJ)/JJ>0.005;{控盘买卖条件}STJ01:=控盘<REF(控盘,1) AND 控盘>0.5;STJ02:=控盘>0;BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;{波段买卖条件}BTJ3:=CROSS(财,神) AND 财<-0.3;BTJ32:=CROSS(财,神) AND 财<-0.1;STJ31:=CROSS(神,财);STJ32:=CROSS(神,财) AND 财>1.618;{以下为信号}BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);STJ82:=FILTER(STJ02 AND STJ32 ,13);STJ83:=STJ81 AND STJ82;DRAWTEXT(STJ83,H*1.002,’↓庄出’),COLORGREEN;{DRAWICON(STJ83,H+0.003,24);}庄:= BTJ11 AND BTJ2 AND BTJ3;有庄:=FILTER(庄,30);DRAWTEXT(有庄,L-0.0011,’↖庄进’),COLORYELLOW;{DRAWICON(有庄,L*0.999,23);}{牛熊轨道上抓启爆点 适合抓爆涨股} AHC1:=CLOSE*VOL; AHC22:=EMA((expma(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34); 上轨:=1.06*AHC22; 下轨:=AHC22*0.94; ZT:=REF(C,1)*1.1-C<0.01 AND H=C; 启爆:=CROSS(C,上轨) OR CROSS(C,下轨) AND ZT; DRAWTEXT(启爆,L,’↖启爆’),COLORCYAN;{STYLE:抄底钻石王–可以用于选股预警,也可以放到附图}YY:=(REF(H,4)-REF(L,1))/C*100>10;{4天前的最高到昨天最低跌幅为10个点}YY1:=(REF(L,1)-L)/C*100>=0;{昨天的最低价跟今天最低价相平或收下影线}YY2:=REF(C<O,1) AND C>O;{昨天收阴,今天收阳线}YY3:= CLOSE>REF(CLOSE,1)*1.03 ;{股价3个点预警}YY4:=(H-C)/C*100<1.5;{上影线少于1.5个点}YY5:=V<=LLV(V,5) OR V>=HHV(V,5);{成交量是五天最低或五天最高}DRAWICON(YY AND YY1 AND YY2 AND YY3 AND YY4 AND YY5,L*0.988,26);{满足所有条件,图标};DRAWTEXT(YY AND YY1 AND YY2 AND YY3 AND YY4 AND YY5,L*0.920,’↖钻石王’),COLORRED;{波段顶底,属未来,大马路123}VAR111:=zig(3,10);DRAWICON((REF(VAR111,2) > REF(VAR111,1)) AND (VAR111 > REF(VAR111,1)),LOW*0.97,5);{DRAWTEXT((REF(VAR111,2) > REF(VAR111,1)) AND (VAR111 > REF(VAR111,1)),LOW*0.95,’全仓’),COLORYELLOW;}DRAWICON((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),HIGH*1.10,6);{DRAWTEXT((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),HIGH*1.06,’清仓’),COLORYELLOW;} Y_1:=STRCAT(HYBLOCK,’ ‘);{行业} Y_2:=STRCAT(Y_1,DYBLOCK);{地域} Y_3:=STRCAT(Y_2,’ ‘); Y_4:=STRCAT(Y_3,GNBLOCK);{所属概念} Y_5:=STRCAT(Y_4,’ ‘); Y_6:=STRCAT(Y_5,FGBLOCK);{所属风格} DRAWTEXT_FIX(ISLASTBAR,0.00,0.00,0,STRCAT(Y_5,FGBLOCK)),COLORYELLOW;{以上组合};DRAWTEXT_FIX(1,0.00,0.06,0,STRCAT(‘业绩预报:’,EXTERNSTR(0,3))),COLORYELLOW;DRAWTEXT_FIX(1,0.00,0.12,0,STRCAT(‘解禁日期:’,EXTERNSTR(0,4))),COLORYELLOW;今日波幅:=100*(DYNAINFO(5)-DYNAINFO(6))/DYNAINFO(6);今日价差:=DYNAINFO(5)-DYNAINFO(6);DRAWTEXT_FIX(1,0.00,0.18,0,STRCAT(STRCAT(‘今日最大振幅: ‘,CON2STR(今日波幅,2)),’ %’)),COLORWHITE;DRAWTEXT_FIX(1,0.12,0.18,0,STRCAT(STRCAT(‘今日高低价差: ‘,CON2STR(今日价差,2)),’ 元’)),COLORWHITE;DRAWNUMBER(ISLASTBAR ,C,C),COLORFF00FF;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址