• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信完美趋势波段主图指标公式

通达信公式 第一股票指标公式网 2周前 (01-06) 11次浏览 已收录 0个评论 扫描二维码

本文指标含有选股公式如下:完美趋势波段主图之红加号选股指标公式 完美趋势波段主图之黄圈红杠选股指标公式DRAWGBK(C>0, RGB(0,0,00),RGB(0,0,0),0,’竹’,0);DRAWNUMBER(ISLAstBAR ,C,C),COLORmaGENTA;SJTJ:=DATE<1590301;AA:=Abs((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,30))/MA(CLOSE,30);长期趋势线:=dma((2*CLOSE+LOW+HIGH)/4,AA);CC:=(CLOSE/长期趋势线);MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);MAAA:=((MA1-长期趋势线)/长期趋势线)/3;TMP:=MA1-MAAA*MA1;长期趋势上升:IF(TMP>长期趋势线 ,长期趋势线,DRAWNULL),LINETHICK4,COLORRED;IF(TMP>长期趋势线,长期趋势线,DRAWNULL),COLORYELLOW,POINTDOT,LINETHICK4;长期趋势下降:IF(TMP<=长期趋势线,长期趋势线,DRAWNULL),LINETHICK4,COLORGREEN;IF(TMP<=长期趋势线,长期趋势线,DRAWNULL),COLORBLUE,POINTDOT,LINETHICK4;HZS:=crOSS(TMP,长期趋势线);LZS:=CROSS(长期趋势线,TMP);DRAWICON(HZS,长期趋势线-0.1,23);DRAWICON(LZS,长期趋势线+0.1,24);{DRAWICON(TMP<=长期趋势线 AND NOT(LZS),长期趋势线-0.1,14)};{DRAWICON(TMP>长期趋势线 AND NOT(HZS),长期趋势线+0.1,13)};MAH:=(H*18+REF(H,1)*17+REF(H,2)*16+REF(H,3)*15+REF(H,4)*14+REF(H,5)*13+REF(H,6)*12+REF(H,7)*11+REF(H,8)*10+REF(H,9)*9+REF(H,10)*8+REF(H,11)*7+REF(H,12)*6+REF(H,13)*5+REF(H,14)*4+REF(H,15)*3+REF(H,16)*2+REF(H,17)*1)/171;MAL:=(L*18+REF(L,1)*17+REF(L,2)*16+REF(L,3)*15+REF(L,4)*14+REF(L,5)*13+REF(L,6)*12+REF(L,7)*11+REF(L,8)*10+REF(L,9)*9+REF(L,10)*8+REF(L,11)*7+REF(L,12)*6+REF(L,13)*5+REF(L,14)*4+REF(L,15)*3+REF(L,16)*2+REF(L,17)*1)/171;MA5:=MA(CLOSE,5);MA10:=MA(CLOSE,10);MA20:=MA(CLOSE,20);MA60:=MA(CLOSE,60);DK:= SJTJ AND( CLOSE>=MAH OR (C>MA5 AND C>MA10 AND C>MA20 AND C>MA60));KK:= SJTJ AND( MAL>CLOSE OR (C<MA5 AND C<MA10 AND C<MA20 AND C<MA60));DK1:=BArslAST(DK);KK1:=BARSLAST(KK);DK2:=BARSLAST(CROSS(KK1,DK1));KK2:=BARSLAST(CROSS(DK1,KK1));HS:=DK2<KK2;LS:=KK2<DK2;W2:=OPEN-CLOSE;HT:=IF(OPEN>CLOSE,OPEN,CLOSE);LT:=IF(OPEN<CLOSE,OPEN,CLOSE);STICKLINE(W2>0 AND HS,OPEN,CLOSE,2,0),COLORRED;STICKLINE(W2>0 AND HS,OPEN,H,0.0,0),COLORRED;STICKLINE(W2>0 AND HS,C,L,0.0,0),COLORRED;STICKLINE(W2<=0 AND HS,OPEN,CLOSE,2,1),COLORRED;STICKLINE(W2<=0 AND HS,O,L,0.0,0),COLORRED;STICKLINE(W2<=0 AND HS,C,H,0.0,0),COLORRED;STICKLINE(W2>0 AND LS,OPEN,CLOSE,2,0),COLORGREEN;STICKLINE(W2>0 AND LS,OPEN,H,0.0,0),COLORGREEN;STICKLINE(W2>0 AND LS,C,L,0.0,0),COLORGREEN;STICKLINE(W2<=0 AND LS,OPEN,CLOSE,2,1),COLORGREEN;STICKLINE(W2<=0 AND LS,C,H,0.0,0),COLORGREEN;STICKLINE(W2<=0 AND LS,O,L,0.0,0),COLORGREEN;DRAWICON(HS=1 AND REF(LS,1),LOW*0.995,34),COLORYELLOW;DRAWICON(LS=1 AND REF(HS,1),H*1.005,35),COLORYELLOW;DRAWNUMBER(ISLASTBAR AND LS,MAH,MAH),COLORYELLOW;DRAWNUMBER(ISLASTBAR AND HS,MAL,MAL),COLORYELLOW;趋势线:=(MAH+MAL)/2 COLORGREEN,,LINETHICK2;中级趋势上升:IF(HS,趋势线,DRAWNULL),LINETHICK2,COLORRED;中级趋势下降:IF(LS,趋势线,DRAWNULL),LINETHICK2,COLORGREEN;最新价:IF(SJTJ, C,DRAWNULL),LINETHICK0,COLORYELLOW;DRAWTEXT_FIX(C>0,0.004,1,0,EXTERNSTR(0,1)),COLORBLUE,LINETHICK2;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址