• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

复合周期MACD

股票公式编写 第一股票指标公式网 2年前 (2020-05-31) 155次浏览 已收录 0个评论 扫描二维码

复合周期MACD 指标公式:红色MACD、实战型MACD、MACD上主图,MACD零轴主图,MACD交易主图:精准的变异MACDMACD仓位控制。

通达信复合周期MACD指标公式

来源:Internet,编辑:第一股票指标公式网,2013-04-26

使用经验:如果是周金叉比月金叉要前的话,就很可能是月周共振成功的概率非常大。如果月金叉比周金叉要前的话,那就有可能不共振。但是至少短线共振力度很明显的。如果MACD与KDJ在周K共振的话一周就可以确定下来了。

DRAWGBK(1>0, RGB(50,100,80),RGB(100,50,100),0,”,0);
DIFW:"MACD.DIF#WEEK",COLORYELLOW;
DEAW:"MACD.DEA#WEEK",COLORWHITE;
DIFM:="MACD.DIF#MONTH",COLORMAGENTA;
DEAM:="MACD.DEA#MONTH",COLORGREEN;
DRAWBAND(DIFW,RGB(200,200,0),DEAW,RGB(0,0,200));
MACD:("MACD.DIF#WEEK"-"MACD.DEA#WEEK")*2,COLORSTICK;
M周叉:=IF(CROSS(DIFW,DEAW),1,0),COLORRED,NODRAW;
M月叉:=IF(CROSS(DIFM,DEAM),1,0),COLORCYAN,NODRAW;
DRAWTEXT(M周叉=1,DIFW,’MACD周’),COLOR8000FF;
DRAWTEXT(M月叉=1,DEAW,’MACD月’),COLORCYAN;
{KDJ复合}
AA:="KDJ.K#WEEK";
BB:="KDJ.D#WEEK";
AAA:="KDJ.K#MONTH";
BBB:="KDJ.D#MONTH";
K周叉:=IF(CROSS(AA,BB),1,0),COLORRED;
K月叉:=IF(CROSS(AAA,BBB),1,0),LINETHICK2,COLORCYAN;
MK周共振:IF(M周叉=1 AND K周叉=1,0,DEAW),COLORLICYAN;
DRAWTEXT(MK周共振=0,0,’MK周共振’),COLORYELLOW;
MK月共振:IF(M月叉=1 AND K月叉=1,1,0),NODRAW;
DRAWTEXT(MK月共振=1,MACD,’MK月共振’),COLORYELLOW;
M周月共振:IF((EXIST(M月叉=1,21) AND M周叉=1) OR (EXIST(M周叉=1,21) AND M月叉=1),0,DIFW),COLORYELLOW;
DRAWTEXT((EXIST(M月叉=1,21) AND M周叉=1) OR (EXIST(M周叉=1,21) AND M月叉=1),0,’M周月共振’),COLORWHITE;

通达信涨跌超前MACD指标公式

0,COLORGRAY;
DIF12:=(EMA(CLOSE,12)-EMA(CLOSE,26))/((EMA(CLOSE,12)+EMA(CLOSE,26))/2)*1000;
DEA12:=EMA(DIF12,9);
KDIF12:=3*(DIF12-DEA12);
KDEA12:=SMA(KDIF12,5,2);
微分DIF:=KDIF12*5,COLORWHITE,LINETHICK1;
微分DEA:=KDEA12*5,COLORYELLOW,LINETHICK1;
MACD2:2*(微分DIF-微分DEA),COLORBLACK;
MAMACD:=MA(MACD2,3),,COLORBLACK;
STICKLINE(MACD2>REF(MACD2,1) AND MACD2>0,0,MACD2,1,0),COLORRED;
STICKLINE(MACD2<=REF(MACD2,1) AND MACD2>0,0,MACD2,1,0),COLORYELLOW;
STICKLINE(MACD2<REF(MACD2,1) AND MACD2<0,0,MACD2,1,0),COLORCYAN;
STICKLINE(MACD2>=REF(MACD2,1) AND MACD2<0,0,MACD2,1,0),COLORMAGENTA;
STICKLINE(MAMACD<1*REF(MAMACD,1), MAMACD, MACD2 ,3, 0),COLORBLUE;
STICKLINE(MAMACD>1*REF(MAMACD,1), MAMACD, MACD2 , 3, 0),COLORLIRED;
微分DIF2:KDIF12*5,COLORRED,LINETHICK1;
微分DEA2:KDEA12*5,COLORMAGENTA,LINETHICK1;
NOTEXT强:IF(微分DIF2<MA(微分DIF2,2),微分DIF2,DRAWNULL),COLORGREEN;
NOTEXT弱:IF(微分DEA2<MAX(微分DEA2,REF(微分DEA2,1)),微分DEA2,DRAWNULL),COLORYELLOW;
DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*300,COLORWHITE,DOTLINE;
DEA:=EMA(DIF,9),COLORYELLOW,DOTLINE;
DIF普:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA普:=EMA(DIF,9);
MACD:=(DIF普-DEA普)*2,COLORSTICK;
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");
{DRAWTEXT(B1>0,DIF*0.7,’↙MACD底背’),COLORFF00FF; }
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");
{DRAWTEXT(D1>0,DIF*1.2,’↙MACD顶离’),COLORBLUE;}{MACD顶背离}
JC := DEA-DIF;
绿柱面积:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);
红柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));
X1:=IF (MACD<0,BARSLAST(CROSS(DIF,DEA)),0);
前次绿柱面积:=REF(绿柱面积,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积)
AND 本次最低价<前次最低价 ),1,0);
RS1:= MACD<0 AND REF(MACD,1)<0 AND C<前次最低价
AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(MACD)<ABS(REF(MACD,1));
底背驰: IF (CROSS(DIF,DEA),REF(Y1,1),0);
DRAWTEXT(底背驰,DIF*0.8,’↙积底背’),COLOR00FFFF;
X2:=IF (MACD>0,BARSLAST(CROSS(DEA,DIF)),0);
前次红柱面积:=REF(红柱面积,X2+1);
前次最高价:=REF(本次最高价,X2+1);
Y2:=IF((红柱面积>0 AND 红柱面积<前次红柱面积 AND 本次最高价>前次最高价 ),1,0);
RS2:= MACD>0 AND REF(MACD,1)>0 AND C>前次最高价 AND ABS(红柱面积)<ABS(前次红柱面积) AND ABS(MACD)<ABS(REF(MACD,1));
顶背驰:= IF (CROSS(DEA,DIF),REF(Y2,1),0);
DRAWTEXT(顶背驰,DIF*0.8,’↙顶底背’),COLORGREEN;
MACD高:=HHV(MACD,5);
E:=REF(C,C1+1)>C AND DEA>0 AND REF(MACD高,C1+1)<MACD高 AND CROSS("MACD.DEA","MACD.DIF") ;
{DRAWTEXT(E>0,DIF*1.1,’↙柱顶背’),COLORRED;}
F:=REF(C,A1+1)>C AND DEA<0 AND REF(MACD高,A1+1)<MACD高 AND CROSS("MACD.DIF","MACD.DEA");
{DRAWTEXT(F>0,DIF*0.9,’↙柱底背’),COLORYELLOW;}

MACD+神奇数字+挖坑MACD和KDJ组合,量化MACD主图、无钝化滞后的MACD,波段MACD主图复合MACD,MACD水下三金叉股价双背离副图。


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址