• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

布林轨道下跌极限主图/选股预警源码

通达信公式 第一股票指标公式网 10个月前 (03-31) 136次浏览 已收录 0个评论 扫描二维码

通达信布林轨道下跌极限主图/选股预警源码
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
BOLL:=MA(CLOSE,20),COLORLIGRAY,LINETHICK1;
上一轨:=BOLL+2*STD(CLOSE,20),COLORRED,LINETHICK1;
上二轨:=BOLL+STD(CLOSE,20),COLORMAGENTA;
下二轨:=BOLL-STD(CLOSE,20),COLORCYAN;
下一轨:=BOLL-2*STD(CLOSE,20),COLORGREEN,LINETHICK1;
MID:MA(CLOSE,5),COLORGRAY;
UPPER:MID*(100+10)/100,COLORLICYAN;
LOWER:MID*(100-10)/100,,COLORA68064,LINETHICK1;
LOWER下:LOWER*(100-2)/100,COLORGREEN{,DOTLINE};
LOWER上:UPPER*(100+2)/100,COLORLIMAGENTA,DOTLINE;
XG:=CROSS(LOWER下,C);
XG2:=L<=LOWER+0.01;
下极限:=L<=LOWER下;
{DRAWTEXT(下极限,L*0.98,’下极限’),COLOR00FF00;}
DRAWICON(下极限,LOW*0.98,1);
M5:(L+REF(C,1)+REF(C,2)+REF(C,3)+REF(C,4))/5,COLORLIGRAY,DOTLINE;
SGD:=M5*(100+10)/100,COLORLICYAN;
XGD:M5*(100-10)/100,,COLORA68064,,DOTLINE;
XGD下:XGD*(100-2)/100,COLORLIGRAY,DOTLINE;
SGD上:=SGD*(100+2)/100,COLORLIGRAY,DOTLINE;
极限:=L<=XGD下*1.001;
STICKLINE(极限,XGD下,XGD下,4,1),COLORYELLOW;
角度:ATAN((MID/REF(MID,1)-1)*100)*180/3.1416,COLOR008888,NODRAW;
五日平均角度:SUM(角度,5)/5,COLOR008888,NODRAW;
平均角度:=SUM(角度,5)/5;
平均角度1:=SUM(角度,1)/1;
平均角度2:=SUM(角度,2)/2;
平均角度3:=SUM(角度,3)/3;
平均角度4:=SUM(角度,4)/4;
IF(角度>=45,MID,DRAWNULL),COLORRED,LINETHICK1;
IF(角度<=-45,MID,DRAWNULL),COLORBLUE,LINETHICK1;
{IF(角度>=50,UPPER,DRAWNULL),COLORRED,LINETHICK1;
IF(角度>=28,LOWER,DRAWNULL),COLORRED,LINETHICK3;}
IF(平均角度>=45,LOWER,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(平均角度1>=45,LOWER,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(平均角度2>=45,LOWER,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(平均角度3>=45,LOWER,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(平均角度4>=45,LOWER,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(平均角度<=-45,LOWER,DRAWNULL),COLORBLUE,LINETHICK1;
IF(平均角度1<=-45,LOWER,DRAWNULL),COLORBLUE,LINETHICK1;
IF(平均角度2<=-45,LOWER,DRAWNULL),COLORBLUE,LINETHICK1;
IF(平均角度3<=-45,LOWER,DRAWNULL),COLORBLUE,LINETHICK1;
IF(平均角度4<=-45,LOWER,DRAWNULL),COLORBLUE,LINETHICK1;

选股公式源码:
MID:=MA(CLOSE,5),COLORGRAY;
LOWER:=MID*(100-10)/100,,COLORA68064,LINETHICK1;
LOWER下:=LOWER*(100-2)/100,COLORGREEN;
下极限:L<=LOWER下;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址