• 欢迎访问第一股票公式网,是专业的股票公式网站,汇集目前最全、最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码并配以说明图片和下载 QQ群

根据“壹瓣杺埖”【简睿余玉】指标修改的飞狐版(源码+图)

飞狐公式 171415.com 1个月前 (09-21) 9次浏览 未收录 0个评论 扫描二维码

根据“壹瓣杺埖”【简睿余玉】指标修改的飞狐版(源码+图)介绍

{简睿余玉–飞狐版–loy518改}
{简睿余玉–通达信版–壹瓣杺埖.原作.}
INPUT:高点(9,0,50),低点(8,0,50),自留地(20,10,100);
STICKLINE(C,H,L,8,1),COLOR888888;
ZQ1:=DATACOUNT-BARPOS; ZQ2:=DATACOUNT-BARPOS+1;
TL1:=REFX(IF(ISLASTBAR,L,1),ZQ1);
TL2:=REFX(LINEVALUE(ZQ2=2,L,REF(ZQ2,1)=2,REF(L,1),1,0),ZQ1);
TL3:=REFX(LINEVALUE(ZQ2=3,L,REF(ZQ2,1)=3,REF(L,1),1,0),ZQ1);
TL4:=REFX(LINEVALUE(ZQ2=4,L,REF(ZQ2,1)=4,REF(L,1),1,0),ZQ1);
TL5:=REFX(LINEVALUE(ZQ2=5,L,REF(ZQ2,1)=5,REF(L,1),1,0),ZQ1);
TL6:=REFX(LINEVALUE(ZQ2=6,L,REF(ZQ2,1)=6,REF(L,1),1,0),ZQ1);
TL7:=REFX(LINEVALUE(ZQ2=7,L,REF(ZQ2,1)=7,REF(L,1),1,0),ZQ1);
TL8:=REFX(LINEVALUE(ZQ2=8,L,REF(ZQ2,1)=8,REF(L,1),1,0),ZQ1);
TL9:=REFX(LINEVALUE(ZQ2=9,L,REF(ZQ2,1)=9,REF(L,1),1,0),ZQ1);
TL10:=REFX(LINEVALUE(ZQ2=10,L,REF(ZQ2,1)=10,REF(L,1),1,0),ZQ1);
TL11:=REFX(LINEVALUE(ZQ2=11,L,REF(ZQ2,1)=11,REF(L,1),1,0),ZQ1);
TL12:=REFX(LINEVALUE(ZQ2=12,L,REF(ZQ2,1)=12,REF(L,1),1,0),ZQ1);
TL13:=REFX(LINEVALUE(ZQ2=13,L,REF(ZQ2,1)=13,REF(L,1),1,0),ZQ1);
TL14:=REFX(LINEVALUE(ZQ2=14,L,REF(ZQ2,1)=14,REF(L,1),1,0),ZQ1);
TL15:=REFX(LINEVALUE(ZQ2=15,L,REF(ZQ2,1)=15,REF(L,1),1,0),ZQ1);
TL16:=REFX(LINEVALUE(ZQ2=16,L,REF(ZQ2,1)=16,REF(L,1),1,0),ZQ1);
TL17:=REFX(LINEVALUE(ZQ2=17,L,REF(ZQ2,1)=17,REF(L,1),1,0),ZQ1);
TL18:=REFX(LINEVALUE(ZQ2=18,L,REF(ZQ2,1)=18,REF(L,1),1,0),ZQ1);
TL19:=REFX(LINEVALUE(ZQ2=19,L,REF(ZQ2,1)=19,REF(L,1),1,0),ZQ1);
TL20:=REFX(LINEVALUE(ZQ2=20,L,REF(ZQ2,1)=20,REF(L,1),1,0),ZQ1);
TL21:=REFX(LINEVALUE(ZQ2=21,L,REF(ZQ2,1)=21,REF(L,1),1,0),ZQ1);
TL22:=REFX(LINEVALUE(ZQ2=22,L,REF(ZQ2,1)=22,REF(L,1),1,0),ZQ1);
TL23:=REFX(LINEVALUE(ZQ2=23,L,REF(ZQ2,1)=23,REF(L,1),1,0),ZQ1);
TL24:=REFX(LINEVALUE(ZQ2=24,L,REF(ZQ2,1)=24,REF(L,1),1,0),ZQ1);
TL25:=REFX(LINEVALUE(ZQ2=25,L,REF(ZQ2,1)=25,REF(L,1),1,0),ZQ1);
TL26:=REFX(LINEVALUE(ZQ2=26,L,REF(ZQ2,1)=26,REF(L,1),1,0),ZQ1);
TL27:=REFX(LINEVALUE(ZQ2=27,L,REF(ZQ2,1)=27,REF(L,1),1,0),ZQ1);
TL28:=REFX(LINEVALUE(ZQ2=28,L,REF(ZQ2,1)=28,REF(L,1),1,0),ZQ1);
TL29:=REFX(LINEVALUE(ZQ2=29,L,REF(ZQ2,1)=29,REF(L,1),1,0),ZQ1);
TL30:=REFX(LINEVALUE(ZQ2=30,L,REF(ZQ2,1)=30,REF(L,1),1,0),ZQ1);
TL31:=REFX(LINEVALUE(ZQ2=31,L,REF(ZQ2,1)=31,REF(L,1),1,0),ZQ1);
TL32:=REFX(LINEVALUE(ZQ2=32,L,REF(ZQ2,1)=32,REF(L,1),1,0),ZQ1);
TL33:=REFX(LINEVALUE(ZQ2=33,L,REF(ZQ2,1)=33,REF(L,1),1,0),ZQ1);
TL34:=REFX(LINEVALUE(ZQ2=34,L,REF(ZQ2,1)=34,REF(L,1),1,0),ZQ1);
TL35:=REFX(LINEVALUE(ZQ2=35,L,REF(ZQ2,1)=35,REF(L,1),1,0),ZQ1);
TL36:=REFX(LINEVALUE(ZQ2=36,L,REF(ZQ2,1)=36,REF(L,1),1,0),ZQ1);
TL37:=REFX(LINEVALUE(ZQ2=37,L,REF(ZQ2,1)=37,REF(L,1),1,0),ZQ1);
TL38:=REFX(LINEVALUE(ZQ2=38,L,REF(ZQ2,1)=38,REF(L,1),1,0),ZQ1);
TL39:=REFX(LINEVALUE(ZQ2=39,L,REF(ZQ2,1)=39,REF(L,1),1,0),ZQ1);
TL40:=REFX(LINEVALUE(ZQ2=40,L,REF(ZQ2,1)=40,REF(L,1),1,0),ZQ1);

TH1:=REFX(IF(ISLASTBAR,H,1),ZQ1);
TH2:=REFX(LINEVALUE(ZQ2=2,H,REF(ZQ2,1)=2,REF(H,1),1,0),ZQ1);
TH3:=REFX(LINEVALUE(ZQ2=3,H,REF(ZQ2,1)=3,REF(H,1),1,0),ZQ1);
TH4:=REFX(LINEVALUE(ZQ2=4,H,REF(ZQ2,1)=4,REF(H,1),1,0),ZQ1);
TH5:=REFX(LINEVALUE(ZQ2=5,H,REF(ZQ2,1)=5,REF(H,1),1,0),ZQ1);
TH6:=REFX(LINEVALUE(ZQ2=6,H,REF(ZQ2,1)=6,REF(H,1),1,0),ZQ1);
TH7:=REFX(LINEVALUE(ZQ2=7,H,REF(ZQ2,1)=7,REF(H,1),1,0),ZQ1);
TH8:=REFX(LINEVALUE(ZQ2=8,H,REF(ZQ2,1)=8,REF(H,1),1,0),ZQ1);
TH9:=REFX(LINEVALUE(ZQ2=9,H,REF(ZQ2,1)=9,REF(H,1),1,0),ZQ1);
TH10:=REFX(LINEVALUE(ZQ2=10,H,REF(ZQ2,1)=10,REF(H,1),1,0),ZQ1);
TH11:=REFX(LINEVALUE(ZQ2=11,H,REF(ZQ2,1)=11,REF(H,1),1,0),ZQ1);
TH12:=REFX(LINEVALUE(ZQ2=12,H,REF(ZQ2,1)=12,REF(H,1),1,0),ZQ1);
TH13:=REFX(LINEVALUE(ZQ2=13,H,REF(ZQ2,1)=13,REF(H,1),1,0),ZQ1);
TH14:=REFX(LINEVALUE(ZQ2=14,H,REF(ZQ2,1)=14,REF(H,1),1,0),ZQ1);
TH15:=REFX(LINEVALUE(ZQ2=15,H,REF(ZQ2,1)=15,REF(H,1),1,0),ZQ1);
TH16:=REFX(LINEVALUE(ZQ2=16,H,REF(ZQ2,1)=16,REF(H,1),1,0),ZQ1);
TH17:=REFX(LINEVALUE(ZQ2=17,H,REF(ZQ2,1)=17,REF(H,1),1,0),ZQ1);
TH18:=REFX(LINEVALUE(ZQ2=18,H,REF(ZQ2,1)=18,REF(H,1),1,0),ZQ1);
TH19:=REFX(LINEVALUE(ZQ2=19,H,REF(ZQ2,1)=19,REF(H,1),1,0),ZQ1);
TH20:=REFX(LINEVALUE(ZQ2=20,H,REF(ZQ2,1)=20,REF(H,1),1,0),ZQ1);
TH21:=REFX(LINEVALUE(ZQ2=21,H,REF(ZQ2,1)=21,REF(H,1),1,0),ZQ1);
TH22:=REFX(LINEVALUE(ZQ2=22,H,REF(ZQ2,1)=22,REF(H,1),1,0),ZQ1);
TH23:=REFX(LINEVALUE(ZQ2=23,H,REF(ZQ2,1)=23,REF(H,1),1,0),ZQ1);
TH24:=REFX(LINEVALUE(ZQ2=24,H,REF(ZQ2,1)=24,REF(H,1),1,0),ZQ1);
TH25:=REFX(LINEVALUE(ZQ2=25,H,REF(ZQ2,1)=25,REF(H,1),1,0),ZQ1);
TH26:=REFX(LINEVALUE(ZQ2=26,H,REF(ZQ2,1)=26,REF(H,1),1,0),ZQ1);
TH27:=REFX(LINEVALUE(ZQ2=27,H,REF(ZQ2,1)=27,REF(H,1),1,0),ZQ1);
TH28:=REFX(LINEVALUE(ZQ2=28,H,REF(ZQ2,1)=28,REF(H,1),1,0),ZQ1);
TH29:=REFX(LINEVALUE(ZQ2=29,H,REF(ZQ2,1)=29,REF(H,1),1,0),ZQ1);
TH30:=REFX(LINEVALUE(ZQ2=30,H,REF(ZQ2,1)=30,REF(H,1),1,0),ZQ1);
TH31:=REFX(LINEVALUE(ZQ2=31,H,REF(ZQ2,1)=31,REF(H,1),1,0),ZQ1);
TH32:=REFX(LINEVALUE(ZQ2=32,H,REF(ZQ2,1)=32,REF(H,1),1,0),ZQ1);
TH33:=REFX(LINEVALUE(ZQ2=33,H,REF(ZQ2,1)=33,REF(H,1),1,0),ZQ1);
TH34:=REFX(LINEVALUE(ZQ2=34,H,REF(ZQ2,1)=34,REF(H,1),1,0),ZQ1);
TH35:=REFX(LINEVALUE(ZQ2=35,H,REF(ZQ2,1)=35,REF(H,1),1,0),ZQ1);
TH36:=REFX(LINEVALUE(ZQ2=36,H,REF(ZQ2,1)=36,REF(H,1),1,0),ZQ1);
TH37:=REFX(LINEVALUE(ZQ2=37,H,REF(ZQ2,1)=37,REF(H,1),1,0),ZQ1);
TH38:=REFX(LINEVALUE(ZQ2=38,H,REF(ZQ2,1)=38,REF(H,1),1,0),ZQ1);
TH39:=REFX(LINEVALUE(ZQ2=39,H,REF(ZQ2,1)=39,REF(H,1),1,0),ZQ1);
TH40:=REFX(LINEVALUE(ZQ2=40,H,REF(ZQ2,1)=40,REF(H,1),1,0),ZQ1);

T:=低点; G:=高点; N:=自留地;
LL:=IF(T=0,TL1,IF(T=1,TL2,IF(T=2,TL3,IF(T=3,TL4,IF(T=4,TL5,IF(T=5,TL6,IF(T=6,TL7,
IF(T=7,TL8,IF(T=8,TL9,IF(T=9,TL10,IF(T=10,TL11,IF(T=11,TL12,IF(T=12,TL13,IF(T=13,TL14,
IF(T=14,TL15,IF(T=15,TL16,IF(T=16,TL17,IF(T=17,TL18,IF(T=18,TL19,IF(T=19,TL20,
IF(T=20,TL21,IF(T=21,TL22,IF(T=22,TL23,IF(T=23,TL24,IF(T=24,TL25,IF(T=25,TL26,IF(T=26,TL27,
IF(T=27,TL28,IF(T=28,TL29,IF(T=29,TL30,IF(T=30,TL31,IF(T=31,TL32,IF(T=32,TL33,IF(T=33,TL34,
IF(T=34,TL35,IF(T=35,TL36,IF(T=36,TL37,IF(T=37,TL38,IF(T=38,TL39,IF(T=39,TL40,C))))))))))))))))))))))))))))))))))))))));
HH:=IF(G=0,TH1,IF(G=1,TH2,IF(G=2,TH3,IF(G=3,TH4,IF(G=4,TH5,IF(G=5,TH6,IF(G=6,TH7,
IF(G=7,TH8,IF(G=8,TH9,IF(G=9,TH10,IF(G=10,TH11,IF(G=11,TH12,IF(G=12,TH13,IF(G=13,TH14,
IF(G=14,TH15,IF(G=15,TH16,IF(G=16,TH17,IF(G=17,TH18,IF(G=18,TH19,IF(G=19,TH20,
IF(G=20,TH21,IF(G=21,TH22,IF(G=22,TH23,IF(G=23,TH24,IF(G=24,TH25,IF(G=25,TH26,IF(G=26,TH27,
IF(G=27,TH28,IF(G=28,TH29,IF(G=29,TH30,IF(G=30,TH31,IF(G=31,TH32,IF(G=32,TH33,IF(G=33,TH34,
IF(G=34,TH35,IF(G=35,TH36,IF(G=36,TH37,IF(G=37,TH38,IF(G=38,TH39,IF(G=39,TH40,C))))))))))))))))))))))))))))))))))))))));
TD:=LINEVALUE(ZQ2=(N+T),LL,REF(ZQ2,1)=(N+T),REF(LL,1),1,0);{REFX(LL,ZQ1);//}
GD:=LINEVALUE(ZQ2=(N+G),HH,REF(ZQ2,1)=(N+G),REF(HH,1),1,0);{REFX(HH,ZQ1);//}
天线:IF(IF(G<T,ZQ2<=(N+T),ZQ2<=(N+G)),REFX(GD,ZQ1),0),COLOR8E0000,LINETHICK;
PARTLINE(IF(G<T,ZQ2<=(N+T),ZQ2<=(N+G)),REFX(GD,ZQ1)),COLOR8E0000;
地线:IF(IF(G<T,ZQ2<=(N+T),ZQ2<=(N+G)),REFX(TD,ZQ1),0),COLOR00FEFE,LINETHICK;
PARTLINE(IF(G<T,ZQ2<=(N+T),ZQ2<=(N+G)),REFX(TD,ZQ1)),COLOR00FEFE;

FILLRGN(G<T AND (天线-地线)*0.33+地线>(地线+天线)/2,(天线-地线)*0.33+地线,(地线+天线)/2),Color1C5896;
FILLRGN(G<T AND (天线-地线)*0.33+地线<(地线+天线)/2,(天线-地线)*0.33+地线,(地线+天线)/2),Color1C5896;
FILLRGN(G>T AND (地线+天线)/2>(天线-地线)*0.67+地线,(地线+天线)/2,(天线-地线)*0.67+地线),Color1C5814;
FILLRGN(G>T AND (地线+天线)/2<(天线-地线)*0.67+地线,(地线+天线)/2,(天线-地线)*0.67+地线),Color1C5814;

DRAWTEXT(ZQ2=5&&G<T,(天线-地线)*0.33+地线,’支撑带’),COLOR22FFFF;
DRAWTEXT(ZQ2=5&&T<G,(天线-地线)*0.67+地线,’压力带’),COLORFF8800;
//DRAWTEXT(ZQ2=8,地线,’壹瓣杺埖原创’),COLORBLACK;
STICKLINE(ZQ2=N,TL1,TH1,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+1),TL2,TH2,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+2),TL3,TH3,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+3),TL4,TH4,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+4),TL5,TH5,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+5),TL6,TH6,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+6),TL7,TH7,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+7),TL8,TH8,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+8),TL9,TH9,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+9),TL10,TH10,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+10),TL11,TH11,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+11),TL12,TH12,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+12),TL13,TH13,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+13),TL14,TH14,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+14),TL15,TH15,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+15),TL16,TH16,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+16),TL17,TH17,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+17),TL18,TH18,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+18),TL19,TH19,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+19),TL20,TH20,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+20),TL21,TH21,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+21),TL22,TH22,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+22),TL23,TH23,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+23),TL24,TH24,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+24),TL25,TH25,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+25),TL26,TH26,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+26),TL27,TH27,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+27),TL28,TH28,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+28),TL29,TH29,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+29),TL30,TH30,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+30),TL31,TH31,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+31),TL32,TH32,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+32),TL33,TH33,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+33),TL34,TH34,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+34),TL35,TH35,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+35),TL36,TH36,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+36),TL37,TH37,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+37),TL38,TH38,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+38),TL39,TH39,2.67,0),COLORFFFFFF;
STICKLINE(ZQ2=(N+39),TL40,TH40,2.67,0),COLORFFFFFF;
GLT:=IF(G=0,TL1,IF(G=1,TL2,IF(G=2,TL3,IF(G=3,TL4,IF(G=4,TL5,IF(G=5,TL6,IF(G=6,TL7,
IF(G=7,TL8,IF(G=8,TL9,IF(G=9,TL10,IF(G=10,TL11,IF(G=11,TL12,IF(G=12,TL13,IF(G=13,TL14,
IF(G=14,TL15,IF(G=15,TL16,IF(G=16,TL17,IF(G=17,TL18,IF(G=18,TL19,IF(G=19,TL20,
IF(G=20,TL21,IF(G=21,TL22,IF(G=22,TL23,IF(G=23,TL24,IF(G=24,TL25,IF(G=25,TL26,IF(G=26,TL27,
IF(G=27,TL28,IF(G=28,TL29,IF(G=29,TL30,IF(G=30,TL31,IF(G=31,TL32,IF(G=32,TL33,IF(G=33,TL34,
IF(G=34,TL35,IF(G=35,TL36,IF(G=36,TL37,IF(G=37,TL38,IF(G=38,TL39,IF(G=39,TL40,C))))))))))))))))))))))))))))))))))))))));
THG:=IF(T=0,TH1,IF(T=1,TH2,IF(T=2,TH3,IF(T=3,TH4,IF(T=4,TH5,IF(T=5,TH6,IF(T=6,TH7,
IF(T=7,TH8,IF(T=8,TH9,IF(T=9,TH10,IF(T=10,TH11,IF(T=11,TH12,IF(T=12,TH13,IF(T=13,TH14,
IF(T=14,TH15,IF(T=15,TH16,IF(T=16,TH17,IF(T=17,TH18,IF(T=18,TH19,IF(T=19,TH20,
IF(T=20,TH21,IF(T=21,TH22,IF(T=22,TH23,IF(T=23,TH24,IF(T=24,TH25,IF(T=25,TH26,IF(T=26,TH27,
IF(T=27,TH28,IF(T=28,TH29,IF(T=29,TH30,IF(T=30,TH31,IF(T=31,TH32,IF(T=32,TH33,IF(T=33,TH34,
IF(T=34,TH35,IF(T=35,TH36,IF(T=36,TH37,IF(T=37,TH38,IF(T=38,TH39,IF(T=39,TH40,C))))))))))))))))))))))))))))))))))))))));
STICKLINE(ZQ2=(N+T),LL,THG,2.67,0),COLOR008800;
STICKLINE(ZQ2=(N+G),GLT,HH,2.67,0),COLOR0000D8;

根据“壹瓣杺埖”【简睿余玉】指标修改的飞狐版(源码+图)


第一股票公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。版权投诉邮箱:313707241@qq.com 投放广告 QQ:313707241(验证:投放广告)
喜欢 (0)
[18566368118]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址