• 欢迎访问第一股票公式网,是专业的股票公式网站,汇集目前最全、最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码并配以说明图片和下载 QQ群

极品成交量组合-(源码)

通达信公式 171415.com 1个月前 (09-21) 10次浏览 未收录 0个评论 扫描二维码

极品成交量组合-(源码)介绍

N:1,100,3;
S:0,3,1;

VAR1:=(VOL / (((HIGH – LOW) * 2) – ABS((CLOSE – OPEN))));
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH – LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH – OPEN) + (CLOSE – LOW))),(VOL / 2)));
卖盘:=IF((CLOSE > OPEN),(0 – (VAR1 * ((HIGH – CLOSE) + (OPEN – LOW)))),IF((CLOSE < OPEN),(0 – (VAR1 * (HIGH – LOW))),(0 – (VOL / 2))));
买卖差:=(买盘 + 卖盘);
STICKLINE((买卖差 < 0),0,买卖差,3,0),COLOR33FF33;
量比:=(VOL / MA(VOL,5));
JX1:=BARSSINCE(买盘);
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
VAR30:=MA(VOL,JY2);
神比:=(买盘 / VAR30);
鬼比:=(卖盘 / VAR30);
VAR2:=(HIGH – LOW);
VAR3:=ABS((OPEN – CLOSE));
VAR4:=(HIGH – IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) – LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
VARA:=(((CLOSE – MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60))); VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
VARD:=REF(CLOSE,1);
VARE:=((SMA(MAX((CLOSE – VARD),0),6,1) / SMA(ABS((CLOSE – VARD)),6,1)) * 100);
DRAWTEXT(((DATE > 700101) AND CROSS(84,VARE)),HIGH,’卖出’),COLORF2A3A4;
VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,买盘) + 买盘) / 2);
VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,买盘) + 买盘) / 2);
VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,买盘) + 买盘) / 2);
VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,卖盘) + 卖盘) / 2);
三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
三日下攻:=MA(VAR50,JY2);
多头:STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,3,1),COLOR0000FF;
空头:STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,3,1),COLOR00FF00;

STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),0,VAR6,2,0),COLOR00FFFF;
STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),0,VAR6,2,0),COLORFF0000;
STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,2,0),COLORFFFFFF;
STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,2,0),COLORFF00FF;
STICKLINE((VOL > (MA(VOL,5) * 2.5)),0,VOL,1,0);
STICKLINE((买盘 > 0),买盘,0,1,0),COLOR0000FF;
上攻均量:=MA(买盘,JY1);
下攻均量:=MA(卖盘,JY1);
DRAWTEXT(((((((((VAR7 > VAR6) AND (VARA > 2)) AND (VAR9 > VAR8)) AND (CLOSE > MA(CLOSE,5))) AND (CLOSE > MA(CLOSE,30))) AND (HIGH > MA(CLOSE,60))) AND (VOL > MA(VOL,5))) AND (VAR7 >= MA(VOL,5))),VOL,’出货’);
DRAWTEXT(((((((VAR8 > VAR6) AND (VAR8 > VAR7)) AND (VARA < (0 – 2))) AND (CLOSE < MA(CLOSE,30))) AND (VAR8 < (MA(VOL,5) / 2))) AND (MA(VOL,5) < MA(VOL,10))),VOL,’低进’);
DRAWTEXT((((((VAR6 > (MA(VOL,5) * 2)) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB)),VOL,’强势’);

DRAWTEXT((((((量比 > 1) AND ((买盘 / 三日上攻) > 1.58)) AND IF((三日上攻 > 上攻均量),(三日上攻 > 三日下攻),(三日上攻 > REF(三日上攻,1)))) AND (三日下攻 < REF(三日下攻,1))) AND ((((CLOSE – REF(CLOSE,3)) / REF(CLOSE,3)) * 100) < 14)),(买盘 * 1.3),’或参与’),COLOR99FF00;
换手%:=((VOL / CAPITAL) * 100);
DRAWTEXT((((VOL / REF((SUM(VOL,5) / 5),1)) >= 2) AND (换手% > 1)),(VOL * 1.1),’量变’),COLOR00FFFF;
涨幅:=100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
量大涨少卖:=C>REF(C,1) AND V>REF(V,1)AND 涨幅<REF(涨幅,1);
DRAWTEXT(量大涨少卖,V,’量大涨少卖’);

VAR0:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,VAR0*(HIGH-LOW),IF(CLOSE<OPEN,VAR0*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
AVAR1:=(VOL / (((HIGH – LOW) * 2) – ABS((CLOSE – OPEN))));
A买盘:=IF((CLOSE > OPEN),(AVAR1 * (HIGH – LOW)),IF((CLOSE < OPEN),(AVAR1 * ((HIGH – OPEN) + (CLOSE – LOW))),(VOL / 2)));
主买占%:A买盘/10000,COLORRED,NODRAW;
A主卖:IF(CLOSE>OPEN,0-VAR0*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR0*(HIGH-LOW),0-VOL/2)),COLOR00FF00,POINTDOT;
A卖盘:=IF((CLOSE > OPEN),(0 – (VAR1 * ((HIGH – CLOSE) + (OPEN – LOW)))),IF((CLOSE < OPEN),(0 – (VAR1 * (HIGH – LOW))),(0 – (VOL / 2))));
主卖占%:-A卖盘/10000,COLOR00FF00,POINTDOT,NODRAW;
震动调整:=(A买盘 + A卖盘);
STICKLINE((震动调整 < 1),1,震动调整,3,0),COLOR70DB93;

市盈率:=IF(FINANCE(33)>0,DYNAINFO(39),0)*0.35;
每股收益:=IF(FINANCE(33)>0.01,FINANCE(33)*0.65,0);
参考定价:每股收益*市盈率*4;

年认同价:=MA(C,240);
毛利润率:=FINANCE(21)/FINANCE(20);
成长价值:年认同价*(1+毛利润率),COLORYELLOW;
收益价值:年认同价+FINANCE(33),COLORRED;
回调认同:EMA(EXPMA(C,20),13),COLORRED;

DRAWTEXT(((((换手% <= 1) AND 换手%) AND (DYNAINFO(7) = CLOSE)) AND (DYNAINFO(10) = AMOUNT)),(VOL * 0.618),’地量’);
DRAWTEXT(((((换手% <= 2) AND (换手% > 1)) AND (DYNAINFO(7) = CLOSE)) AND (DYNAINFO(10) = AMOUNT)),(VOL * 0.618),’低靡’);
DRAWTEXT(((((换手% <= 3) AND (换手% > 2)) AND (DYNAINFO(7) = CLOSE)) AND (DYNAINFO(10) = AMOUNT)),(VOL * 0.618),’温和’);
DRAWTEXT(((((换手% <= 5) AND (换手% > 3)) AND (DYNAINFO(7) = CLOSE)) AND (DYNAINFO(10) = AMOUNT)),(VOL * 0.618),’活跃’);
DRAWTEXT(((((换手% <= 8) AND (换手% > 5)) AND (DYNAINFO(7) = CLOSE)) AND (DYNAINFO(10) = AMOUNT)),(VOL * 0.618),’带量’);
DRAWTEXT(((((换手% <= 15) AND (换手% > 8)) AND (DYNAINFO(7) = CLOSE)) AND (DYNAINFO(10) = AMOUNT)),(VOL * 0.618),’放量’);
DRAWTEXT(((((换手% <= 25) AND (换手% > 15)) AND (DYNAINFO(7) = CLOSE)) AND (DYNAINFO(10) = AMOUNT)),(VOL * 0.618),’巨量’);

VARCYC:=AMOUNT/(100*VOL);
CYCMAX:=DMA(VARCYC,VOL/CAPITAL);
CYC13:=0.01*EMA(AMOUNT,13)/EMA(VOL,13);
CYS13:=CYS;
CYSW:=CLOSE/CYCMAX*100-100;
AA:=INDEXA;AV:=INDEXV;AC:=INDEXC;{原来是0号指数}
AO:=INDEXO;AH:=INDEXH;AL:=INDEXL;
M:=CLOSE;
VAR21:=AA/AV/100;
VAR22:=(3*AH+AL+AO+2*AC)/7;
VAR23:=SUM(AA,13)/VAR21/100;
ACYC:=DMA(VAR22,AV/VAR23);
ACYS13:=(AC-ACYC)/ACYC*100;
A4:=CYS13<-17 AND CYSW<-40 AND ACYS13<-8 AND ACYS13<REF(CYS13,1);
A5:=CYS13<-20 AND CYSW<-40 AND ACYS13<-10 AND ACYS13<REF(ACYS13,1);
DRAWTEXT(A5>0,M*4.1,’【全仓杀入】’),COLORGREEN;
DRAWTEXT(A4>0 AND A5<M*5.5,M*3.1,’【分仓介入】’),COLORCYAN;

VAR31:=HIGH-LOW;
VAR32:=ABS(OPEN-CLOSE );
VAR33:=HIGH-IF(CLOSE>OPEN,CLOSE,O);
VAR34:=IF(CLOSE>OPEN,O,CLOSE)-LOW;
VAR35:=(VAR32/VAR31)*VOL;
VAR36:=(VAR33/VAR31)*VOL;
VAR37:=(VAR34/VAR31)*VOL;
V1:=H-L;
V2:=ABS(O-C);
V3:=H-IF(C>O,C,O);
V4:=IF(C>O,O,C)-L;
V5:=V2/V1*V;
V6:=V3/V1*V;
V7:=V4/V1*V;
M5:=MA(V,5),COLORWHITE;
M10:=MA(V,10),COLORYELLOW;
V8:=IF(V/CAPITAL>0.001,1,EXP(ABS(LOG(V/CAPITAL*100))));

RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1;
RSV:=(C-LLV(L,26))/(HHV(H,26)-LLV(L,26))*100;
K:=SMA(RSV, 6, 1);
D:=SMA(K, 3, 1);
J:=3*K-2*D;
LC:=REF(C,1);
XA:=IF(CROSS(J1,J) AND J<20,-1,0)+IF(CROSS(J,J1) AND J>80,1,0);
TYP:=(H+L+C)/3;
CCJ:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14))/2;
RSI1:=SMA(MAX(C-LC, 0), 6, 1)/SMA(ABS(C-LC), 6, 1)*100;

K2:=EMA((C-LLV(L,36))/(HHV(H,36)-LLV(L,36))*100, 9);
XB:=IF(CCJ>100 AND K2>50 AND C>O, 0.5, 0)+IF(RSI1>80 AND K2>50 AND C>O, 0.5, 0);
RSV3:=(C-LLV(L,100))/(HHV(H,100)-LLV(L,100))*100;
K13:=SMA(RSV3, 21, 1);
D13:=SMA(K1, 3, 1);
J13:=3*K13-2*D13;
XC:=IF(J13>80 AND RSI1>85, 0.5, 0);

DRAWTEXT(FILTER(V5>MA(V,5)*2 AND V5>=V6 AND V5>=V7 AND C>O OR V>MA(VOL,5)*3,2),1.2*V,’强势参与’),COLORRED;
DRAWTEXT(V6>V5 AND V6>V7 AND C>MA(C,5) AND C>MA(C,34) AND H>MA(C,55) AND V>M5 AND V6>MA(V,5),V,’逢高出货’),COLORGREEN;
DRAWTEXT(VAR36>VAR35 AND VAR36>VAR37 AND C>MA(C,5) AND C>MA(C,30) AND H>MA(C,60) AND V>MA(V,5) AND VAR6>=MA(V,5),VOL,’逢高出货’),COLORRED;

GJ1:=AMOUNT/VOL/100;
成本: EMA(EMA(GJ1,2),30),COLORGREEN,NODRAW;

A1:=SUMBARS(V,CAPITAL);
CMA:=IF(CAPITAL>0,SUM(AMOUNT,A1)/SUM(V,A1)/100,EMA(C,120));
百分百换手均价:CMA,NODRAW,COLORRED;

极品成交量组合-(源码)


第一股票公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。版权投诉邮箱:313707241@qq.com 投放广告 QQ:313707241(验证:投放广告)
喜欢 (0)
[18566368118]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址