• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

通达信均线定势主图指标公式

通达信公式 第一股票指标公式网 2年前 (2019-11-28) 74次浏览 已收录 0个评论 扫描二维码

M5:MA(C,5),COLORWHITE;
M10:MA(C,10),COLORYELLOW;
M20:MA(C,20),COLORBLUE;
MA30:MA(C,30),COLORRED,LINETHICK2;
M60:MA(C,60),COLORFFCC66;
平衡线:EMA(CLOSE,8),COLORFF9966;
PMA:=MA(C,5);
X:=(3*C+L+O+H)/6;
多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLORFF00FF,LINETHICK2;
IF(MA(CLOSE,30)<=REF(MA(CLOSE,30),1),MA(CLOSE,30),DRAWNULL),COLORGREEN,LINETHICK2;
IF(MA(CLOSE,5)<=REF(MA(CLOSE,5),1),MA(CLOSE,5),DRAWNULL),COLORGREEN;
IF(MA(CLOSE,10)<=REF(MA(CLOSE,10),1),MA(CLOSE,10),DRAWNULL),COLORGREEN;
IF(平衡线<=REF(平衡线,1),平衡线,DRAWNULL),COLORGREEN;
DRAWTEXT(CLOSE>=1.094*REF(CLOSE,1),CLOSE*1.02,’停,’),COLORCYAN;
VARZT:=BARSLAST(C/REF(C,1)>1.094);
DRAWTEXT(VARZT=2,L*0.95,’3T’),COLORYELLOW;
DRAWTEXT(VARZT=4,H*1.06,’5T’),COLORYELLOW;
DRAWTEXT(VARZT=7,L*0.95,’8T’),COLORYELLOW;
DRAWTEXT(VARZT=12,H*1.06,’13T’),COLORYELLOW;
DRAWTEXT(VARZT=20,L*0.95,’21T’),COLORYELLOW;
DRAWTEXT(VARZT=33,H*1.06,’34T’),COLORYELLOW;
DRAWTEXT(VARZT=54,L*0.95,’55T’),COLORYELLOW;
DRAWTEXT(VARZT=88,H*1.06,’89T’),COLORYELLOW;
DRAWTEXT(VARZT=143,L*0.95,’144T’),COLORYELLOW;
DRAWTEXT(VARZT=232,H*1.06,’233T’),COLORYELLOW;
DRAWTEXT(VARZT=376,L*0.95,’377T’),COLORYELLOW;
DD:=多空线<REF(多空线,1);
IF(DD,多空线,DRAWNULL),COLOR00FFFF,LINETHICK2;
A:=(PMA>多空线);
IF(A,多空线,DRAWNULL),COLOR33FF33,POINTDOT,LINETHICK4;
{—–对于有些软件不能通过公式的,删除以下源码,我用的是官方6.15测试版——————-}
DRAWTEXT_FIX(1,0,0,0,’总股本(亿):’),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.06,0,0,CONST(FINANCE(1)/100000000)),COLORLIGRAY;
DRAWTEXT_FIX(1,0.13,0,0,’流通股本(亿):’),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.2,0,0,CONST(CAPITAL/1000000)),COLORLIGRAY;
DRAWTEXT_FIX(1,0.25,0,0,’所属板块:’),COLORLIGRAY;
DRAWTEXT_FIX(1,0.302,0,0,HYBLOCK),COLORLIGRAY;
DRAWTEXT_FIX(1,0.35,0,0,DYBLOCK),COLORLIGRAY;
AL2:=ABS((REF(C,1)-(REF(O,1)))/(REF(O,1)));
AL3:=ABS((REF(H,1)-(REF(O,1)))/(REF(O,1)));
AL4:=ABS((REF(L,1)-(REF(O,1)))/(REF(O,1)));
ELE:=(((REF(HIGH,1))+(REF(LOW,1))+(REF(OPEN,1))+2*(REF(CLOSE,1)))/5);
上升突破价:=(ELE+((REF(HIGH,1))-(REF(LOW,1))));
上升阻力价:=(2*ELE-(REF(LOW,1)));
下跌支撑价:=(2*ELE-(REF(HIGH,1)));
下跌反转价:=(ELE-((REF(HIGH,1))-(REF(LOW,1))));
预测低一:=O-(O*(ABS((AL2+AL3+AL4)/3)));
预测低二:=(预测低一+((((ELE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5)+O)/2))/2;
{www.gUPang.com 第一股票指标公式网_最新股票指标公式}
VARM:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买盘:=IF(CLOSE>OPEN,VARM*(HIGH-LOW),IF(CLOSE<OPEN,VARM*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
DRAWTEXT_FIX(1,0,0.10,0,’预测低一:’),COLORLIGRAY;
DRAWTEXT_FIX(1,0,0.18,0,’预测低二:’),COLORLIGRAY;
DRAWTEXT_FIX(1,0.25,0.18,0,’系数:’),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.06,0.10,0,CONST(预测低一)),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.06,0.18,0,CONST(预测低二)),COLORLIGRAY;
DRAWTEXT_FIX(1,0.13,0.10,0,’成交量比:’),COLORLIGRAY;
DRAWTEXT_FIX(1,0.13,0.18,0,’换手率★:’),COLORLIGRAY;
DRAWTEXT_FIX(1,0.25,0.10,0,’量比:’),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.19,0.10,0,CONST(买盘/VOL*100)),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.19,0.18,0,CONST(DYNAINFO(37)*100)),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.28,0.10,0,CONST(DYNAINFO(17))),COLORLIGRAY;
DRAWNUMBER_FIX(1,0.28,0.18,0,CONST(IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1))),COLORLIGRAY;

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址