• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

通达信单阳不破+将军柱+布林轨道主图指标公式

通达信公式 第一股票指标公式网 2年前 (2019-11-29) 78次浏览 已收录 0个评论 扫描二维码

N:=20;
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA30:MA(CLOSE,30),LINETHICK2;
MA60:MA(CLOSE,60),COLORRED,LINETHICK2;
MA144:MA(CLOSE,144),COLOR9F5F9F;
MA250:MA(CLOSE,250);
{布林轨道}
BOLL:=MA(CLOSE,N),POINTDOT,LINETHICK1;
UB:BOLL+2*STD(CLOSE,N),POINTDOT,LINETHICK4,COLORRED;
LB:BOLL-2*STD(CLOSE,N),POINTDOT,LINETHICK4,COLORYELLOW;
{5、10周均线}
ZRR:=(YEAR-1992)*365+INTPART((YEAR-1989)/4)+IF(MONTH<=2,DAY+(MONTH-1)*31,DAY+
INTPART(13*(MONTH+1)/5)-7+(MONTH-1)*28+IF(INTPART(YEAR/4)=YEAR/4,1,0)),NODRAW;
T:=BARSLAST(ZRR-REF(ZRR,1)>WEEKDAY-REF(WEEKDAY,1))+1,NODRAW;
T1:=REF(T,T)+T,NODRAW;
T2:=REF(T,T1)+T1,NODRAW;
T3:=REF(T,T2)+T2,NODRAW;
T4:=REF(T,T3)+T3,NODRAW;
T5:=REF(T,T4)+T4,NODRAW;
T6:=REF(T,T5)+T5,NODRAW;
T7:=REF(T,T6)+T6,NODRAW;
T8:=REF(T,T7)+T7,NODRAW;
周5:=(REF(CLOSE,T)+REF(CLOSE,T1)+REF(CLOSE,T2)+REF(CLOSE,T3)+CLOSE)/5,COLORE6E8FA,LINETHICK2;
周10:=(REF(CLOSE,T)+REF(CLOSE,T1)+REF(CLOSE,T2)+REF(CLOSE,T3)+REF(CLOSE,T4)+
REF(CLOSE,T5)+REF(CLOSE,T6)+REF(CLOSE,T7)+REF(CLOSE,T8)
+CLOSE)/10,COLORBLUE,LINETHICK2;
日跌:= L*0.99,NODRAW,COLORFF00FF;
周跌:= L*0.94,NODRAW,COLORFF00FF;
{支撑压力}
HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高压:=DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORFF00FF,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DRAWICON(CC1,L*0.98,1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低支:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORFF00FF,LINETHICK1;
ZGSTAR:=(高压+低支)/2;
ZGEND:=CONST((高压+低支)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
中轨:=DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF00FF,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT,;
DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
{涨停标注}
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;
{财务数据}
DRAWTEXT_FIX(ISLASTBAR ,0.06,0.01,1,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.065,0.01,0,HYBLOCK),COLORYELLOW;
{DRAWTEXT_FIX(ISLASTBAR,0.16,0.01,1,’上市日期:’),COLOR00FF00;
DRAWNUMBER_FIX(ISLASTBAR,0.16,0.01,0,FINANCE(42)),COLOR00FF00;
DRAWTEXT_FIX(ISLASTBAR,0.06,0.04,1,’主营收入:’),COLORFFAAFF;
DRAWNUMBER_FIX(ISLASTBAR,0.062,0.04,0,FINANCE(20)),COLORFFAAFF;
DRAWTEXT_FIX(ISLASTBAR,0.21,0.04,1,’主营利润:’),COLORFFAAFF;
DRAWNUMBER_FIX(ISLASTBAR,0.22,0.04,0,FINANCE(21)),COLORFFAAFF;
DRAWTEXT_FIX(ISLASTBAR,0.06,0.07,1,’每股净资产:’),COLORFFAAFF;
DRAWNUMBER_FIX(ISLASTBAR,0.062,0.07,0,FINANCE(34)),COLORFFAAFF;
DRAWTEXT_FIX(ISLASTBAR,0.21,0.07,1,’每股公积金:’),COLORFFAAFF;
DRAWNUMBER_FIX(ISLASTBAR,0.22,0.07,0,FINANCE(18)),COLORFFAAFF;
DRAWTEXT_FIX(ISLASTBAR,0.06,0.1,1,’每股收益 年:’),COLORFFAAFF;
DRAWNUMBER_FIX(ISLASTBAR,0.062,0.1,0,FINANCE(33)),COLORFFAAFF;
DRAWTEXT_FIX(ISLASTBAR,0.21,0.1,1,’每股未分配利润:’),COLORFFAAFF;
DRAWNUMBER_FIX(ISLASTBAR,0.22,0.1,0,FINANCE(32)),COLORFFAAFF;
DRAWTEXT_FIX(ISLASTBAR,0.06,0.13,1,’经营现金流量:’),COLORFFAAFF;
DRAWNUMBER_FIX(ISLASTBAR,0.062,0.13,0,FINANCE(25)),COLORFFAAFF;
DRAWTEXT_FIX(ISLASTBAR,0.21,0.13,1,’其它利润:’),COLORFFAAFF;
DRAWNUMBER_FIX(ISLASTBAR,0.22,0.13,0,FINANCE(22)),COLORFFAAFF;};
{涨停秘籍}
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
A1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
A2:=BARSLAST(REF(CROSS(DIFF,DEA),1));
VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
HONGJU:=IF(VAR1>0,VAR1,0);
GAOPAO:=CROSS(DIFF,DEA) AND HONGJU>=40;
DRAWICON(GAOPAO,HIGH*1.01,6);
DRAWTEXT(GAOPAO,HIGH*1.02,’顶背’),COLORGREEN;
LLVV:=LLV(LOW,5);
DIXI:=CROSS(DEA,DIFF) AND REF(DEA,A1+1)>0 AND DEA<0;
{DRAWICON(DIXI,LOW*0.90,38);
DRAWTEXT(DIXI,LOW*0.90,’波段低吸’),COLORYELLOW;}
工作线:=EMA(CLOSE,17),COLORYELLOW;
生命线:=MA(CLOSE,56),COLORRED;
M0:=MA(CLOSE,5);
M10:=MA(CLOSE,12);
M1:=MA(CLOSE,20);
M30:=MA(CLOSE,30);
M2:=MA(CLOSE,60);
M3:=MA(CLOSE,240);
M4:=MA(CLOSE,120);
M41:=MA(CLOSE,41);
TJ2:=MA(CLOSE,3)<M2;
VAR2:=(CLOSE*2+HIGH+LOW)/4;
SK:=EMA(VAR2,13)-EMA(VAR2,73);
SD:=EMA(SK,2);
短线:=CROSS(SK,SD) AND SK<0.05 AND (VOL/MA(VOL,5)>2 OR CLOSE/REF(CLOSE,1)>0.035 AND CLOSE>EMA(CLOSE,17));
{STICKLINE(短线,HIGH,LOW,0.5,0),COLORFFFF00;
STICKLINE(短线,OPEN,CLOSE,10,1),LINETHICK2,COLORFFFF00;}
CY:=BARSLAST(短线);
MACD双底:=REF(LOW,A2+1)<CLOSE AND CROSS(DIFF,DEA);
介入:=COUNT(短线,4)=1 AND COUNT(MACD双底,1)=1 AND CLOSE/MA(CLOSE,56)*1000>980 AND CLOSE>OPEN AND VOL>=MA(VOL,5) AND DIFF>=-0.1;
DRAWTEXT(介入,LOW*0.98,’起涨点’),COLORRED;
DRAWICON(介入,LOW*0.98,1);
反向顶背:=REF(CLOSE,A2+1)>CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
逃顶:=CROSS(SD,SK) AND SK>0.2 AND VOL/MA(VOL,5)<2;
逃顶成立:=COUNT(逃顶,4)=1 AND COUNT(反向顶背,1)=1;
DRAWICON(逃顶成立,HIGH*1.05,15);
DRAWTEXT(逃顶成立,HIGH*1.05,’逃顶’),COLORGREEN;
N1G:=CLOSE/REF(CLOSE,1)>=1.097 AND HIGH=CLOSE AND NOT(OPEN=HIGH);
A1G:=BARSLAST(N1G);
A2G:=LLV(LOW,A1G-1)>REF(LOW,A1G) AND CLOSE/REF(OPEN,A1G)>1 AND CLOSE/REF(OPEN,A1G)<=1.04;
XGGG:=FILTER(A2G,3) AND A1G>=4 AND A1G<=20;
DRAWICON(XGGG,LOW*0.96,41);
DRAWTEXT(XGGG,LOW*0.96,’涨停秘笈’),COLORYELLOW;
{第一股票指标公式网-股票公式网站 }
XPP1:=CROSS(DEA,DIFF) AND CLOSE>MA20 AND MA20>REF(MA20,1) AND DIFF>REF(DIFF,A2+1);
DRAWICON(XPP1,LOW*0.96,3);
DRAWTEXT(XPP1,LOW*0.96,’强势洗盘’),COLORWHITE;
XPP2:=XPP1 AND A1G>=4 AND A1G<=20;
DRAWICON(XPP2,LOW*0.98,17);
{单阳不破}
短线A:=MA(C,5);
中线:=((MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4+EXPMA(CLOSE,10))/2;
密码线:=((EMA(C,6)+EMA(C,18)+EMA(C,54)+EMA(C,162))/4+EXPMA(CLOSE,24)+MA(C,25))/3;
神奇线:=(MA(C,35)+EXPMA(CLOSE,50))/2;
阳涨幅:=3.5;
阳倍量:=1.9;
单阳收:=C;
单阳开:=O;
单阳:=单阳收>=REF(C,1)*(1+阳涨幅/100)AND VOL>REF(VOL,1)*阳倍量;
DRAWTEXT(CURRBARSCOUNT<100 AND 单阳,L*0.98,’阳’),COLOR00FFFF;
高不破价:=REF(C,BARSLAST(单阳));
低不破价:=REF(L,BARSLAST(单阳));
单阳不破:=CURRBARSCOUNT<100 AND BARSLAST(单阳)<11 AND (LLV(L,BARSLAST(单阳))>低不破价 OR LLV(L,BARSLAST(单阳))=低不破价);
{STICKLINE(单阳不破,低不破价-低不破价*0.0005,低不破价,4,0),COLORGREEN;
STICKLINE(单阳不破,高不破价,高不破价,4,0),COLORRED;
STICKLINE(单阳,单阳开,单阳收,2,0),COLORYELLOW;}
DRAWTEXT(BARSLAST(单阳)=1 AND 单阳不破,低不破价*0.98,’1′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=2 AND 单阳不破,低不破价*0.98,’2′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=3 AND 单阳不破,低不破价*0.98,’3′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=4 AND 单阳不破,低不破价*0.98,’4′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=5 AND 单阳不破,低不破价*0.98,’5′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=6 AND 单阳不破,低不破价*0.98,’6′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=7 AND 单阳不破,低不破价*0.98,’7′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=8 AND 单阳不破,低不破价*0.98,’8′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=9 AND 单阳不破,低不破价*0.98,’9′),COLORGREEN;
DRAWTEXT(BARSLAST(单阳)=10 AND 单阳不破,低不破价*0.98,’10’),COLORGREEN;
{将军柱}
三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);
三日量缩:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));
三日价涨A:=C>=REF(C,1);
三日价涨B:=C<REF(C,1);
三日价涨C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);
TIM:=IF(DATE<1140214,1,0);
缩倍柱:=(VOL*1.95<=REF(VOL,1))*TIM;
百日低量:=(VOL=LLV(VOL,100))*TIM;
倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1))*TIM;
四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4))*TIM;
四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量缩)*TIM;
前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0;
倍量黄金柱:=四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量黄金柱:=四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
黄金柱:=倍量黄金柱 OR 高量黄金柱;
次倍量黄金柱:=NOT(黄金柱) AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量黄金柱:=NOT(黄金柱) AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次黄金柱:=次倍量黄金柱 OR 次高量黄金柱;
准倍量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (COUNT(倍量柱,3)>=1 AND 三日不破)) AND 前三引用不成立;
准高量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立;
准黄金柱:=准倍量黄金柱 OR 准高量黄金柱;
倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
将军柱:=倍量将军柱 OR 高量将军柱;
次倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次将军柱:=次倍量将军柱 OR 次高量将军柱;
准倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前倍量柱 AND 三日价涨C AND 前三引用不成立;
准高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前高量柱 AND 三日价涨C AND 前三引用不成立;
准将军柱:=准倍量将军柱 OR 准高量将军柱;
BACKSET100:=BACKSET(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱 OR 准将军柱,4);
FILTER100:=FILTER(BACKSET100,3),NODRAW;
BACKSET101:=BACKSET(黄金柱,4);
FILTER101:=FILTER(BACKSET101,3);
BACKSET102:=BACKSET(次黄金柱,4);
FILTER102:=FILTER(BACKSET102,3);
BACKSET103:=BACKSET(准黄金柱,4);
FILTER103:=FILTER(BACKSET103,3);
BACKSET104:=BACKSET(将军柱,4);
FILTER104:=FILTER(BACKSET104,3);
BACKSET105:=BACKSET(次将军柱,4);
FILTER105:=FILTER(BACKSET105,3);
BACKSET106:=BACKSET(准将军柱,4);
FILTER106:=FILTER(BACKSET106,3);
黄金线下影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=REF(L,3);
黄金线实体下端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=MIN(REF(C,3),REF(O,3)) AND MIN(MIN(L,REF(L,1)),REF(L,2))>REF(L,3),LINETHICK0;
黄金线上影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(H,3);
黄金线实体上端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<REF(H,3);
黄金线实体中间:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3));
黄金线实体中间1:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,2)=MIN(MIN(L,REF(L,1)),REF(L,2));
黄金线实体中间2:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,1)=MIN(MIN(L,REF(L,1)),REF(L,2));
黄金线实体中间3:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND L=MIN(MIN(L,REF(L,1)),REF(L,2));
BACKSET201:=BACKSET(黄金线下影线,4);
FILTER201:=FILTER(BACKSET201,3),NODRAW;
BACKSET202:=BACKSET(黄金线实体下端,4);
FILTER202:=FILTER(BACKSET202,3),NODRAW;
BACKSET203:=BACKSET(黄金线上影线,4);
FILTER203:=FILTER(BACKSET203,3),NODRAW;
BACKSET204:=BACKSET(黄金线实体上端,4);
FILTER204:=FILTER(BACKSET204,3),NODRAW;
BACKSET205:=BACKSET(黄金线实体中间,4);
FILTER205:=FILTER(BACKSET205,3),NODRAW;
BACKSET2051:=BACKSET(黄金线实体中间1,4);
FILTER2051:=FILTER(BACKSET2051,3),NODRAW;
BACKSET2052:=BACKSET(黄金线实体中间2,4);
FILTER2052:=FILTER(BACKSET2052,3),NODRAW;
BACKSET2053:=BACKSET(黄金线实体中间3,4);
FILTER2053:=FILTER(BACKSET2053,3),NODRAW;
BT201:=IF(BARSLAST(FILTER201)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER201));
BT202:=IF(BARSLAST(FILTER202)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER202));
BT203:=IF(BARSLAST(FILTER203)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER203));
BT204:=IF(BARSLAST(FILTER204)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER204));
BT205:=IF(BARSLAST(FILTER205)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER205));
BT2051:=IF(BARSLAST(FILTER2051)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2051));
BT2052:=IF(BARSLAST(FILTER2052)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2052));
BT2053:=IF(BARSLAST(FILTER2053)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2053));
最近黄金线:=MIN(MIN(MIN(MIN(MIN(MIN(BT201,BT202),BT203),BT204),BT2051),BT2052),BT2053);
DAY1:=SUMBARS(FILTER100,1),NODRAW;
HJX1_1:=IF(SUMBARS(FILTER201,1)=DAY1,IF(DAY1=1,LOW,REF(LOW,DAY1-1)),0),NODRAW;
HJX1_2:=IF(SUMBARS(FILTER202,1)=DAY1,IF(DAY1=1,MIN(C,O),MIN(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
HJX1_3:=IF(SUMBARS(FILTER203,1)=DAY1,IF(DAY1=1,HIGH,REF(HIGH,DAY1-1)),0),NODRAW;
HJX1_4:=IF(SUMBARS(FILTER204,1)=DAY1,IF(DAY1=1,MAX(C,O),MAX(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
HJX1_51:=IF(SUMBARS(FILTER2051,1)=DAY1,IF(DAY1=2,LOW,IF(DAY1<2,DRAWNULL,REF(LOW,DAY1-2))),0),NODRAW;
HJX1_52:=IF(SUMBARS(FILTER2052,1)=DAY1,IF(DAY1=3,LOW,IF(DAY1<3,DRAWNULL,REF(LOW,DAY1-3))),0),NODRAW;
HJX1_53:=IF(SUMBARS(FILTER2053,1)=DAY1,IF(DAY1=4,LOW,IF(DAY1<4,DRAWNULL,REF(LOW,DAY1-4))),0),NODRAW;
黄金线:=HJX1_1+HJX1_2+HJX1_3+HJX1_4+HJX1_51+HJX1_52+HJX1_53,COLORYELLOW,NODRAW;
立桩量:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);
立桩量三日突破:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
立桩量三日不破:=BARSLAST(立桩量)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));
BACKSET300:=BACKSET(立桩量三日不破,4);
BACKSET301:=BACKSET(立桩量三日突破,4);
立桩量成立:=FILTER(BACKSET300,3) AND BACKSET301 AND 立桩量;
DRAWTEXT(立桩量成立,HIGH*1.01,’↙立桩量’),COLOR00FF00;
DRAWTEXT(FILTER101,LOW*0.986,’↖黄金柱’),COLORYELLOW;
DRAWTEXT(FILTER102,LOW*0.986,’↖次黄金柱’),COLORYELLOW;
DRAWTEXT(FILTER104,LOW*0.986,’↖将军柱’),COLORYELLOW;

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址