• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

通达信精华集成2主图指标公式

通达信公式 第一股票指标公式网 2年前 (2019-11-29) 82次浏览 已收录 0个评论 扫描二维码

{短期底部}
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=2*(S2-S6);
主力成本1:EMA(X,13),COLORFF00FF,LINETHICK0;
短期底部:LLV(HIGH,30),LINETHICK2,COLORFFCC00;
IF(MA(C,9),MA(C,9),DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(MA(C,23.5),MA(C,23.5),DRAWNULL),COLORWHITE;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
{追涨}
MA5:=MA(C,5);
MA10:=MA(C,10);
MA30:=MA(C,30);
FA:=BARSLAST(CROSS(MA10,MA5)) AND CROSS(MA5,MA10);
FB:=FA AND MA5>MA30 AND MA10>MA30 AND MA10>REF(MA10,1);
DRAWTEXT(FB,L-0.58,’★追涨’),COLORRED;
{牛起步}
V1:=EMA(CLOSE,5);
V2:=EMA(EMA(CLOSE,90)*1.01,10);
DRAWTEXT(CROSS(V1,V2),V1+0.05,’牛起步’),COLOR00FF00;
{关注}
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE – VAR1) / (VAR2 – VAR1)) * 100),5);
AK:=EMA((((CLOSE – VAR1) / (VAR2 – VAR1)) * 50),13);
AB:=CROSS(AK1,AK);
DRAWTEXT((AB = 1),(LOW * 0.99),’○关注’),COLORYELLOW;
{介入}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
介入:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0,COLOR0099FF;
DRAWTEXT(介入,L*0.99,’介入’),COLOR0099FF;
{买入}
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),’★买入 ‘),COLOR00FFFF;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),’★加仓’),COLOR00FFFF;
{小心变盘}
A1AA:=9;
A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);
{第一股票指标公式网-股票公式网站 }
DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),’小心变盘’),COLORFFFFFF;
VAR6:=REF(C,1);
VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
DRAWTEXT(CROSS(82,VAR7),H*1.01,’▼逃顶’),COLORYELLOW;
{大胆杀入}
SG:=EMA(HHV(HIGH,1),8);
XA1:=EMA(CLOSE,8);
X30:=((XA1 < REF(XA1,1)) AND (CLOSE < XA1));
X31:=IF(((SG < REF(SG,1)) OR X30),1,0);
全仓出击:=((((COUNT((X31 = 1),4) = 3) AND (X31 = 0)) AND (((CLOSE – REF(CLOSE,1)) / REF(CLOSE,1)) > 0.085)) * 89);
DRAWTEXT((全仓出击 >= 89),(LOW * 0.95),’←大胆杀入’);
{二次金叉}
DIF1:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:=(DIF1-DEA1)*2*60;
MACD上:=IF(MACD1>REF(MACD1,1),MACD1,DRAWNULL),
STICK,COLORRED,LINETHICK1;
MACD下:=IF(MACD1<REF(MACD1,1),MACD1,DRAWNULL),
STICK,COLORFF9900,LINETHICK1;
低位金叉:=CROSS(DIF1,DEA1) AND DIF1<-0.1;
DRAWTEXT(低位金叉,(LOW * 0.97),’←低位金叉’),COLORRED;
JCCOUNT:=COUNT(CROSS(DIF1,DEA1),BARSLAST(DEA1>=0));
二次金叉:=CROSS(DIF1,DEA1) AND DEA1<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWTEXT(二次金叉,(LOW * 0.97),’←二次金叉’),COLORFF00FF;

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址