• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

通达信延伸均线主图指标公式

通达信公式 第一股票指标公式网 2年前 (2019-11-30) 93次浏览 已收录 0个评论 扫描二维码

STICKLINE(8=8,H,L,4,1),COLOR000000;{隐藏K线[设置与背景色一样]}
CURR:=CURRBARSCOUNT;
DRAWKLINE(IF(CURR>3,REFX(H,3),DRAWNULL),IF(CURR>3,REFX(O,3),DRAWNULL),
IF(CURR>3,REFX(L,3),DRAWNULL),IF(CURR>3,REFX(C,3),DRAWNULL));
RM5:IF(CURR>3,REFX(MA(C,5),3),DRAWNULL),COLOR0000FF;
RM10:IF(CURR>3,REFX(MA(C,10),3),DRAWNULL),COLOR00FFFF;
RM20:IF(CURR>3,REFX(MA(C,20),3),DRAWNULL),COLORFF0000;
ABSM5:=CONST(IF(MA(C,5)-REF(MA(C,5),1)>0,ABS(MA(C,5)-REF(MA(C,5),1)),0-ABS(MA(C,5)-REF(MA(C,5),1))));
ABSM10:=CONST(IF(MA(C,10)-REF(MA(C,10),1)>0,ABS(MA(C,10)-REF(MA(C,10),1)),0-ABS(MA(C,10)-REF(MA(C,10),1))));
ABSM20:=CONST(IF(MA(C,20)-REF(MA(C,20),1)>0,ABS(MA(C,20)-REF(MA(C,20),1)),0-ABS(MA(C,20)-REF(MA(C,20),1))));
{第一股票指标公式网-股票公式网站 }
R2M5:=IF(CURR=3,CONST(MA(C,5))+ABSM5,DRAWNULL);
R2M10:=IF(CURR=3,CONST(MA(C,10))+ABSM10,DRAWNULL);
R2M20:=IF(CURR=3,CONST(MA(C,20))+ABSM20,DRAWNULL);
R1M5:=IF(CURR=2,CONST(MA(C,5))+2*ABSM5,DRAWNULL);
R1M10:=IF(CURR=2,CONST(MA(C,10))+2*ABSM10,DRAWNULL);
R1M20:=IF(CURR=2,CONST(MA(C,20))+2*ABSM20,DRAWNULL);
R0M10:=IF(ISLASTBAR,CONST(MA(C,10))+3*ABSM10,DRAWNULL);
R0M20:=IF(ISLASTBAR,CONST(MA(C,20))+3*ABSM20,DRAWNULL);
DRAWLINE(CURR=4,RM5,CURR=3,R2M5,0),COLOR0000FF,DOTLINE;
DRAWLINE(CURR=3,R2M5,CURR=2,R1M5,0),COLOR0000FF,DOTLINE;
DRAWLINE(CURR=4,RM10,CURR=3,R2M10,0),COLOR00FFFF,DOTLINE;
DRAWLINE(CURR=3,R2M10,CURR=2,R1M10,0),COLOR00FFFF,DOTLINE;
DRAWLINE(CURR=2,R1M10,ISLASTBAR,R0M10,0),COLOR00FFFF,DOTLINE;
DRAWLINE(CURR=4,RM20,CURR=3,R2M20,0),COLORFF0000,DOTLINE;
DRAWLINE(CURR=3,R2M20,CURR=2,R1M20,0),COLORFF0000,DOTLINE;
DRAWLINE(CURR=2,R1M20,ISLASTBAR,R0M20,0),COLORFF0000,DOTLINE;

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址