• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

通达信神奇价轨主图指标公式

通达信公式 第一股票指标公式网 2年前 (2019-11-30) 76次浏览 已收录 0个评论 扫描二维码

N1:=102;N:=13;M:=7;
GJ:=(C+H+L+O)/4;
阻:=L+(GJ-L)+(C-L);
支:=L+(C-GJ);
NN:=100;
日压:REF(阻 , 1),NODRAW,COLOR00FF00;
日支:REF(支 , 1),NODRAW,COLORYELLOW;
下档线:=(((CLOSE – LLV(LOW,13)) / (HHV(HIGH,13) – LLV(LOW,13))) * 100);
RRRSV:=SMA(下档线,3,1);
KKK:=SMA(RRRSV,3,1);
DDDDD:=((3 * RRRSV) – (2 * KKK));
JJ12:=(((CLOSE – LLV(LOW,55)) / (HHV(HIGH,55) – LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) – (2 * K24));
高点:=CONST(HHV(H,NN));
低点:=CONST(LLV(L,NN));
明日阻力:=L+(GJ-L)+(C-L);
明日支撑:=L+(C-GJ);
明日阻力2:=L+2*(GJ-L)+(C-L);
压力2:=IF(CROSS(D24,DDDDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDDDD)))),COLORFFFFFF;
底部:=LLV(HIGH,30),COLOR00FF00;
压力位:=IF(ISLASTBAR,压力2,DRAWNULL),NODRAW;
底部位:=IF(ISLASTBAR,底部,DRAWNULL),NODRAW;
明日支撑2:=L+(C-GJ)-(GJ-L);
今日阻力:=CONST(REF(明日阻力 , 1)),NODRAW;
今日支撑:=CONST(REF(明日支撑 , 1)),NODRAW;
今日阻力2:=CONST(REF(明日阻力2 , 1)),NODRAW;
今日支撑2:=CONST(REF(明日支撑2 , 1)),NODRAW;
{第一股票指标公式网-股票公式网站 }
STICKLINE(ISLASTBAR,今日阻力,今日阻力2,5,0),COLORGRAY;
STICKLINE(ISLASTBAR,今日支撑,今日支撑2,5,0),COLORGRAY;
AX:=MA((2*CLOSE+HIGH+LOW)/4,5);
通道1:AX*N1/100,COLORRED;
通道2:AX*(200-N1)/100,COLORRED;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
通道3:(1+M/100)*DD,COLORGREEN;
通道4:(1-M/100)*DD,COLORGREEN;
TT2:=DMA((((HIGH+LOW)+(CLOSE*2))/4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE-LC),0),3,1)/SMA(ABS((CLOSE-LC)),3,1))*100);
日线止损价位:(LC*1.0035*97+0.2)/99.65,COLOR03B4EC,NODRAW;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,1),COLORYELLOW;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,H,O,4,2),COLORWHITE{98FD};
TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
TYX4:=MA((C+L+O+H)/4,13);
TYX5:=EMA((C+L+O+H)/4,21);
VAR1Z:=EMA(CLOSE,4)-EMA(CLOSE,13);
AA:=VAR1Z>=REF(VAR1Z,1);
BB:=VAR1Z<REF(VAR1Z,1);
买入:=DRAWICON(CROSS(AA,BB),L,1);
卖出:=DRAWICON(CROSS(BB,AA),H,2);
STICKLINE(C<TYX5 AND C<O,H,L,0,0),COLOR007700;
STICKLINE(C<TYX5 AND C<O,C,O,3,0),COLOR005500;
STICKLINE(C<TYX5 AND C<O,C,O,2,0),COLOR006600;
STICKLINE(C<TYX5 AND C<O,C,O,1,0),COLOR007700;
STICKLINE(买入,O,(C-O)/2+O,3.5,0),COLOR335555;
STICKLINE(买入,O,(C-O)/2+O,2.2,0),COLOR338888;
STICKLINE(买入,O,(C-O)/2+O,1.5,0),COLOR33AAAA;
STICKLINE(买入,O,(C-O)/2+O,1,0),COLOR33CCCC;
STICKLINE(买入,O,(C-O)/2+O,0,0),COLOR33EEEE;
STICKLINE(卖出,O,(C-O)/2+O,3.5,0),COLOR550055;
STICKLINE(卖出,O,(C-O)/2+O,2.2,0),COLOR880088;
STICKLINE(卖出,O,(C-O)/2+O,1.5,0),COLORAA00AA;
STICKLINE(卖出,O,(C-O)/2+O,1,0),COLORCC00CC;
STICKLINE(卖出,O,(C-O)/2+O,0.5,0),COLOREE00EE;
STICKLINE(ISLASTBAR ,压力位,压力位,30,0),COLORFFFFFF;
STICKLINE(ISLASTBAR ,底部位,底部位,30,0),COLOR00FF00;
AAF:LLV(LOW,34),LINETHICK1,COLORWHITE;
BBF:IF(VAR19>0,MA(AAF,4)*1.06,MA(AAF,4)),LINETHICK1,COLORFFAAFF;
XXS:=MA(LOW,5)*(1-5/100);
XXS1:=MA(HIGH,5)*(1+5/100);
均线:=C,COLORGREEN;
AAAA:=CLOSE/REF(CLOSE,3)<=0.85 AND CROSS(C,XXS) AND C>REF(C,1),LINETHICK0 ;
BBAA:=CROSS(XXS1,C);
DDDD:=CROSS(C,XXS1);
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
BB1:=0;
B1万元:=DVOL*DCLOSE/100;
B1差:=B1万元-REF(B1万元,1);
B2万元:=DVOL*DCLOSE/100;
B2比:=B2万元/REF(B2万元,1);
净流入万元:=(AAA2-AAA3-0.5*AAA4);
PM:=MA(净流入万元,1);
PMA:=PM/REF(PM,1)>1;
PMB:=REF(PMA,1)<1 AND PMA;
密码:=(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW;
二日比:=密码/REF(密码,1);
选股:=PMB AND 密码>REF(密码,1) AND 二日比>1,COLORRED,NODRAW;
收盘价:IF(C,CONST(C),DRAWNULL),COLORWHITE;
DRAWNUMBER(ISLASTBAR,C,C),COLORWHITE;
{DRAWNUMBER(ISLASTBAR,收盘价,收盘价),COLORGRAY;}
开盘价:IF(O,CONST(O),DRAWNULL),COLORLIGRAY;
{DRAWTEXT(ISLASTBAR,C,’———-现价’),COLORWHITE;}
DRAWNUMBER(ISLASTBAR,O,O),COLORLIGRAY;
最高价:IF(H,CONST(H),DRAWNULL),{COLORGRAY},COLORCYAN,LINETHICK2;
最低价:IF(L,CONST(L),DRAWNULL),{COLORGRAY},COLORGREEN,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=1, 收盘价*1.00285,’———收盘价位’),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=2,开盘价*1.00285,’开盘价位’),COLORLIGRAY;
DRAWNUMBER(ISLASTBAR,H,H),COLORCYAN;
DRAWNUMBER(ISLASTBAR,L,L),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=3,最低价*1.00285,’最低价’),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=4,最高价*1.00285,’最高价’),COLORCYAN;
DRAWICON(CROSS(CLOSE,TT1)AND J<55,LOW,26);
DRAWICON(CROSS(88,RSI),HIGH*0.996,24);
DRAWNUMBER(选股=1 ,L,密码),COLORYELLOW;
DRAWTEXT(AAAA,L*0.95,’下影买’),COLORRED;
DRAWTEXT(CROSS(XXS1,C),H,’开盘逃’),COLORWHITE;
DRAWTEXT(DDDD,H,’明日走’),COLORYELLOW;
DRAWICON(选股,L*0.975,25);
STICKLINE(CURRBARSCOUNT=1 ,日线止损价位 ,日线止损价位,15,1),COLORRED;
DRAWTEXT(CURRBARSCOUNT=1,日线止损价位*1.00285,’日线止损价位’),COLORRED;

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址