• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信反转柱副图指标

通达信公式 第一股票指标公式网 4个月前 (06-14) 40次浏览 已收录 0个评论 扫描二维码

VAR1:=IF(DATETODAY(DATE)<11700,1,1);VAR2:=MA(CLOSE,5);VAR3:=MA(CLOSE,30);VAR4:=MA(CLOSE,5);VAR5:=MA(CLOSE,13);VAR6:=MA(CLOSE,34);VAR7:=IF(1>=2442.459961*500,0,1);VAR8:=ATAN((VAR4/REF(VAR4,1)-1)*VAR7*100)*180/3.1416;VAR9:=ATAN((VAR5/REF(VAR5,1)-1)*VAR7*100)*180/3.1416;VAR10:=ATAN((VAR6/REF(VAR6,1)-1)*VAR7*100)*180/3.1416;VAR11:=IF(1<2442.459961*500,1,DRAWNULL);VAR12:=SMA(EMA((VAR4-REF(VAR4,1))/REF(VAR4,1),3)*100,3,1)*VAR1;VAR13:=EMA((VAR12-REF(VAR12,1))*VAR7,3)*VAR1;VAR14:=(CLOSE-VAR2)*VAR7/VAR2*100;VAR15:=(CLOSE-VAR6)*VAR1/VAR6*100;VAR16:=COUNT(CROSS(VAR14,0),3)>=1 AND VAR15>REF(VAR15,1)*VAR7 AND VAR2>REF(VAR2,1)*VAR1 AND (CLOSE/REF(CLOSE,1)-1)*100>5 AND REF(CLOSE,1)<VAR3;VAR17:=FILTER(VAR16,10)*VAR1;VAR18:=MA(CLOSE,13)*VAR1;VAR19:=MA(CLOSE,34)*VAR11;VAR20:=MA(CLOSE,55)*VAR11;VAR21:=OPEN<VAR18 AND CLOSE>VAR18*VAR7;VAR22:=OPEN<VAR19 AND CLOSE>VAR19*VAR7;VAR23:=OPEN<VAR20 AND CLOSE>VAR20*VAR7;VAR24:=CLOSE/OPEN>=1.04*VAR1;VAR25:=VOL>HHV(HIGH,10)*VAR1;VAR26:=VAR18>=REF(VAR18,1)*VAR1;VAR27:=VAR21 AND VAR22 AND VAR23 AND VAR24 AND VAR25 AND VAR26;VAR28:=EMA(CLOSE,2)*VAR7;VAR29:=EMA(CLOSE,5)*VAR7;VAR30:=EMA(CLOSE,13)*VAR7;VAR31:=EMA(CLOSE,34)*VAR7;VAR32:=EMA(CLOSE,55)*VAR7;VAR33:=EMA(CLOSE,89)*VAR7;VAR34:=VAR29>=REF(VAR29,1)*VAR7;VAR35:=MAX(MAX(VAR29,VAR30),VAR31)*VAR1;VAR36:=MIN(MIN(VAR29,VAR30),VAR31)*VAR1;VAR37:=HHV(HIGH,10)/LLV(LOW,10)<1.25 AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85)*VAR11 AND CLOSE>OPEN AND DYNAINFO(4)>0 AND CLOSE>=HHV(HIGH,10) AND VAR35<CLOSE AND REF(CLOSE,1)<VAR36 AND VAR34 AND VAR28>REF(VAR28,1)*VAR1;VAR38:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3);VAR39:=IF(CROSS(VAR38,0),40,0);VAR40:=(2*CLOSE+HIGH+LOW)/4;VAR41:=LLV(LOW,94);VAR42:=HHV(HIGH,89);VAR43:=EMA((CLOSE-VAR41)/(VAR42-VAR41)*100,8);VAR44:=EMA(0.667*REF(VAR43,1)+0.333*VAR43,10);VAR45:=COUNT(VAR39>=40,5)>0;VAR46:=IF(CROSS(VAR43,VAR44) AND VAR45,60,0);VAR47:=VAR39+VAR46>=1;VAR48:=(EMA(CLOSE,4)+MA(CLOSE,8)+MA(CLOSE,16))/3;VAR49:=(EMA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/3;VAR50:=(EMA(CLOSE,9)+MA(CLOSE,18)+MA(CLOSE,36))/3;VAR51:=(EMA(CLOSE,13)+MA(CLOSE,26)+MA(CLOSE,52))/3;VAR52:=(EMA(CLOSE,18)+MA(CLOSE,36)+MA(CLOSE,72))/3;VAR53:=(EMA(CLOSE,24)+MA(CLOSE,48)+MA(CLOSE,96))/3;VAR54:=OPEN<VAR48 AND OPEN<VAR49 AND OPEN<VAR50 AND OPEN<VAR51 AND OPEN<VAR52 AND OPEN<VAR53 AND CLOSE>VAR48 AND CLOSE>VAR49 AND CLOSE>VAR50 AND CLOSE>VAR51 AND CLOSE>VAR52 AND CLOSE>VAR53;VAR55:=HHV(EMA(VOL/5,4),240);VAR56:=LLV(EMA(VOL/5,4),240);VAR57:=MA(CLOSE,35);VAR58:=EMA(CLOSE,15)-EMA(CLOSE,30);VAR59:=EMA(VAR58,12);VAR60:=2*(VAR58-VAR59);VAR61:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;VAR62:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;VAR63:=(CLOSE-LLV(LOW,225))/(HHV(HIGH,225)-LLV(LOW,225))*100;VAR64:=SMA(VAR61,3,1);VAR65:=SMA(VAR62,15,1);VAR66:=SMA(VAR63,45,1);VAR67:=MACD.MACD>0;VAR68:=(VAR66-REF(VAR66,1))*50;VAR69:=(VAR65-REF(VAR65,1))*10;VAR70:=REF(VAR65,1)-REF(VAR66,1);VAR71:=(VAR65-VAR70-VAR66)*30;VAR72:=VAR64-REF(VAR64,1);VAR73:=EMA((EMA(VOL/5,4)-VAR56)/VAR56*VAR57,13);VAR74:=EMA((VAR55-EMA(VOL/5,4))/EMA(VOL/5,4)*VAR57,13);VAR75:=VAR60>=(-0.035) AND VAR60<=0.045 AND CLOSE>MA(CLOSE,5) AND CLOSE>MA(CLOSE,10) AND VAR74>(-100);VAR76:=EXIST(CLOSE/REF(CLOSE,1)>1.055,60);VAR77:=IF(VAR75 AND VAR72>7 AND REF(VAR72,1)<0 AND VAR72-REF(VAR72,1)>9,1,0) AND VAR76 AND VAR67;GYJ:VAR17+VAR27+VAR37+VAR47+VAR54+VAR77>=4,COLORRED;STICKLINE(IF(GYJ,(-120),0),12,0,7,0),COLOR000044;STICKLINE(IF(GYJ,(-120),0),12,0,2,0),COLORLIMAGENTA;
 


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址