• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信三指标多周期共振指标公式

通达信公式 第一股票指标公式网 5个月前 (06-14) 52次浏览 已收录 0个评论 扫描二维码

{使用说明:底下彩色柱是对应周期已经金叉,紫色线是强弱指标线(这里参数取7),当紫色线上穿50中线为走强形态,反之则是走弱。蓝色为仓位建议,蓝色面积越高说明仓位越大。}DIF30:=EMA(CLOSE,12/4)-EMA(CLOSE,26/4);
DEA30:=EMA(DIF30,9/4);
DIF60:=EMA(CLOSE,12/2)-EMA(CLOSE,26/2);
DEA60:=EMA(DIF60,9/2);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
周MD:=MACD.DIF#WEEK;
周MA:=MACD.DEA#WEEK;
月MD:=MACD.DIF#MONTH;
月MA:=MACD.DEA#MONTH;
RSV601:=(CLOSE-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3));
K30:=SMA(RSV601,3,1);
D30:=SMA(K30,3,1);
RSV60:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6));
K60:=SMA(RSV60,3,1);
D60:=SMA(K60,3,1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
周K:="KDJ.K#WEEK" ;
周D:="KDJ.D#WEEK" ;
月K:="KDJ.K#MONTH" ;
月D:="KDJ.D#MONTH" ;
LC:=REF(CLOSE,1);
RSI9:SMA(MAX(CLOSE-LC,0),9,1)/SMA(ABS(CLOSE-LC),9,1)*100,COLORRED;
BIAS60:=(CLOSE-MA(CLOSE,60))/MA(CLOSE,60)*100;
BIAS20:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100;
K0:=DIF30>DEA30;
K1:=DIF60>DEA60;
K2:=DIF>DEA;
K3:=周MD>周MA;
K4:=月MD>月MA;
K5:=K30>D30;
K6:=K60>D60;
K7:=K>D;
K8:=周K>周D;
K9:=月K>月D;
K10:=RSI9>50;
STICKLINE(SUM(K0+K1+K2+K3+K4+K5+K6+K7+K8+K9,1)>3 AND K10 AND V<=LLV(V,15) AND ((BIAS20>-1 AND BIAS20<2) OR (BIAS60>-1 AND BIAS60<2)),58,65,4,0),COLOR781816;
STICKLINE(SUM(K0+K1+K2+K3+K4+K5+K6+K7+K8+K9,1)=4 AND K10,51,70,4,0),COLOR781816;
STICKLINE(SUM(K0+K1+K2+K3+K4+K5+K6+K7+K8+K9,1)=5 AND K10,51,75,4,0),COLOR781816;
STICKLINE(SUM(K0+K1+K2+K3+K4+K5+K6+K7+K8+K9,1)=6 AND K10,51,80,4,0),COLOR781816;
STICKLINE(SUM(K0+K1+K2+K3+K4+K5+K6+K7+K8+K9,1)=7 AND K10,51,85,4,0),COLOR781816;
STICKLINE(SUM(K0+K1+K2+K3+K4+K5+K6+K7+K8+K9,1)=8 AND K10,51,90,4,0),COLOR781816;
STICKLINE(SUM(K0+K1+K2+K3+K4+K5+K6+K7+K8+K9,1)=9 AND K10,51,95,4,0),COLOR781816;
STICKLINE(SUM(K0+K1+K2+K3+K4+K5+K6+K7+K8+K9,1)=10 AND K10,51,100,4,0),COLOR781816;
STICKLINE(DIF30>=DEA30,45.5,49,5,0),COLORLIRED;
STICKLINE(DIF60>=DEA60,40.5,44,5,0),COLOR00BBBB;
STICKLINE(DIF>=DEA,35.5,39,5,0),COLOR0000BB;
STICKLINE(周MD>=周MA,30.5,34,5,0),COLORBB00BB;
STICKLINE(月MD>=月MA,25.5,29,5,0),COLORBBBB00;
STICKLINE(K30>= D30,20.5,24,5,0),COLORLIRED;
STICKLINE(K60>= D60,15.5,19,5,0),COLOR00FFFF;
STICKLINE(K>=D,10.5,14,5,0),COLOR0000FF;
STICKLINE(周K>=周D,5.5,9,5,0),COLORFF00FF;
STICKLINE(月K>=月D,0.5,4,5,0),COLORBBBB00;
DRAWTEXT(CURRBARSCOUNT=25,47.5,’M30′),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=20,42.5,’M60′),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=25,37.5,’M日’),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=20,32.5,’M周’),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=25,27.5,’M月’),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=20,22.5,’K30 ‘),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=25,17.5,’K60 ‘),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=20,12.5,’K日’),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=25,7.5,’K周’),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=20,2.5,’K月’),COLORWHITE;
RSI:SMA(MAX(CLOSE-LC,0),9,1)/SMA(ABS(CLOSE-LC),9,1)*100,COLORMAGENTA;
超卖:20,DOTLINE,COLORYELLOW;
强弱分界:50,COLORRED;
超买:80,DOTLINE,COLORGREEN;
满仓:100,DOTLINE,COLORRED;
0;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址