• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

更新:集合竞价预警、选股指标公式源码

通达信公式 第一股票指标公式网 1个月前 (07-02) 14次浏览 已收录 0个评论 扫描二维码

前期上传了集合竞价预警的公式,然后一直在优化、调试,终于开成可行的指标。很有实战性。
我重新优化成:一个是预警备选指标,用于每天收盘后进行选股,选出第二日的预警目标用;另一个是预警指标,用于第二天针对备选股个的预警,这样能保证在最快的时间内于第二天竞价时段即9点15到9点30分间出目标个股。
同时,上传两个主图指标(一个是资金突破指标、一个是筹码均价指标)、四个副图指标(浮筹、开盘换手率、大资金进出量、竞价预警)、还有两个引用指标。指标有半加密,请见谅。请各自下载后导入通达信。
指标及选股,需要用到L2数据和自定义的开盘金额数据,因此,需要各位注意每日下载高级行情盘后交易数据;至于开盘金额数据,我会每天在此帖更新发布。

为看盘方便,你可以建立一个模板如下图。
为预警方便,你应该自定义两个板块:集合竞价预选、集合竞价预警
设置预警时,预警的范围要选定“集合竞价预告”的板块,预警的结果,保存到“集合竞价预警”板块。
{ 原文链接:http://www.goodgupiao.com/gupiaogongshi/62061.html }
N:=95;
开幅%:(O-REF(C,1))/REF(C,1)*100,NODRAW;
去ST股:=IF(NAMELIKE(‘S’),0,1);
去ST股1:=IF(NAMELIKE(‘*’),0,1);
去停牌:=DYNAINFO(17)>0;
流通值:=FINANCE(40)/100000000;
一字板:=C/REF(C,1)>1.0975 AND H=L;
TJA:=REF(WINNER(C)*100,1)>=N AND WINNER(O)*100>=N AND BETWEEN(开幅%,3,9) AND 去ST股 AND 去ST股1 AND 流通值<100000 {AND NOT( 一字板)};
{方案二:
振幅:=(H-L)/REF(C,1)*100;
竞价涨幅:=(O/REF(C,1)-1)*100;
竞价量:=DYNAINFO(15)/DYNAINFO(4)/100;
去ST:=IF(NAMELIKE(‘S’) OR NAMELIKE(‘*’),0,1);
竞价换手:=DYNAINFO(15)/DYNAINFO(4)/FINANCE(46)*100;
XG:竞价涨幅>REF(竞价涨幅,1) AND REF(振幅,1)<10 AND 竞价涨幅>3 AND BETWEEN(竞价量/REF(V,1),0.06,0.5) AND 竞价换手>0.3 AND O<REF(C,1)*1.095 AND 去ST;}

今开盘换手:=IF(ISLASTBAR=1,DYNAINFO(15)/O/FINANCE(46)*100,DRAWNULL),NODRAW;
开盘金额:=IF(NOT(ISLASTBAR),SIGNALS_USER(9601,0),DYNAINFO(15));
J开盘换手:开盘金额/O/FINANCE(46)*100,NODRAW;
Z开盘换手:=REF(SIGNALS_USER(9601,0),1)/REF(O,1)/FINANCE(46)*100,COLORRED,NODRAW;
Q开盘换手:=REF(SIGNALS_USER(9601,0),2)/REF(O,2)/FINANCE(46)*100,COLORRED,NODRAW;
TJB:=O>=REF(C,1) AND REF(O,1)>=REF(C,2);
TJC:=J开盘换手>Z开盘换手 AND Z开盘换手>=Q开盘换手 AND J开盘换手>0.12;
TJD:=TJB AND TJC;
筹码价位低:=COST(0.001);
筹码价位1:=COST(0.001)+(COST(99.999)-COST(0.001))/10*1;
筹码价位2:=COST(0.001)+(COST(99.999)-COST(0.001))/10*2;
筹码价位3:=COST(0.001)+(COST(99.999)-COST(0.001))/10*3;
筹码价位4:=COST(0.001)+(COST(99.999)-COST(0.001))/10*4;
筹码价位5:=COST(0.001)+(COST(99.999)-COST(0.001))/10*5;
筹码价位6:=COST(0.001)+(COST(99.999)-COST(0.001))/10*6;
筹码价位7:=COST(0.001)+(COST(99.999)-COST(0.001))/10*7;
筹码价位8:=COST(0.001)+(COST(99.999)-COST(0.001))/10*8;
筹码价位9:=COST(0.001)+(COST(99.999)-COST(0.001))/10*9;
筹码价位高:=COST(99.999);
区间最大筹码:=MAX(MAX(MAX(MAX(WINNER(筹码价位1)-WINNER(筹码价位低),WINNER(筹码价位2)-WINNER(筹码价位1)),MAX(WINNER(筹码价位3)
-WINNER(筹码价位2),WINNER(筹码价位4)-WINNER(筹码价位3))),MAX(MAX(WINNER(筹码价位5)-WINNER(筹码价位4),WINNER(筹码价位6)-WINNER(筹码价位5)),
MAX(WINNER(筹码价位7)-WINNER(筹码价位6),WINNER(筹码价位8)-WINNER(筹码价位7)))),MAX(WINNER(筹码价位9)-WINNER(筹码价位8),WINNER(筹码价位高)-WINNER(筹码价位9)));
筹码密集均价A:=IF(区间最大筹码=WINNER(筹码价位1)-WINNER(筹码价位低),(筹码价位1+筹码价位低)/2,
IF(区间最大筹码=WINNER(筹码价位2)-WINNER(筹码价位1),(筹码价位2+筹码价位1)/2,
IF(区间最大筹码=WINNER(筹码价位3)-WINNER(筹码价位2),(筹码价位3+筹码价位2)/2,
IF(区间最大筹码=WINNER(筹码价位4)-WINNER(筹码价位3),(筹码价位4+筹码价位3)/2,
IF(区间最大筹码=WINNER(筹码价位5)-WINNER(筹码价位4),(筹码价位5+筹码价位4)/2,
IF(区间最大筹码=WINNER(筹码价位6)-WINNER(筹码价位5),(筹码价位6+筹码价位5)/2,
IF(区间最大筹码=WINNER(筹码价位7)-WINNER(筹码价位6),(筹码价位7+筹码价位6)/2,
IF(区间最大筹码=WINNER(筹码价位8)-WINNER(筹码价位7),(筹码价位8+筹码价位7)/2,
IF(区间最大筹码=WINNER(筹码价位9)-WINNER(筹码价位8),(筹码价位9+筹码价位8)/2,(筹码价位高+筹码价位9)/2)))))))));
筹码密集均价:=MA(筹码密集均价A,1),COLOR00FFFF,LINETHICK2;
筹码密集度%:(WINNER(筹码密集均价A*1.1)-WINNER(筹码密集均价A*0.9))*100,COLORGREEN,NODRAW;
TJE:=O>筹码密集均价 AND 筹码密集度%>40;
获利盘:=WINNER(O)*100 ,COLORRED,NODRAW;{主力筹码集中度}
近邻筹码:=(WINNER(O*1.075)-WINNER(O*0.925))*100;{收盘价上下7.5%的获利盘之差,散户筹码集中度}
近邻浮筹:=近邻筹码/WINNER(HHV(H,0)),COLORGREEN,LINETHICK2,NODRAW;{散户筹码集中度}
获利纵横:获利盘-近邻浮筹,COLORWHITE,NODRAW;
TJF:=获利纵横>50 {AND 获利纵横>REF(获利纵横,1)};
换手%:=VOL/CAPITAL*100,COLORYELLOW,NODRAW;
十换%:SUM(换手%,10),COLORRED,NODRAW;
预警:TJA AND TJD AND TJE AND TJF,COLOR00FFFF;

{彩色K线}
X3:=MA(REF(HHV((C+L+O+H)/4,30),1),3),COLORFFFFFF,LINETHICK1;
X5:MA((C+L+O+H)/4,5),COLORFFFFFF,LINETHICK1,DOTLINE;
X13:MA((C+L+O+H)/4,13),COLOR00FFFF,LINETHICK1;
X21:MA((C+L+O+H)/4,21),COLOR00FF00,LINETHICK2;
IF(X21>REF(X21,1),X21,DRAWNULL),COLOR0000FF,LINETHICK2;
X60:MA((C+L+O+H)/4,60),COLOR99FF00,LINETHICK1;
筹码价位低:=COST(0.001);
筹码价位1:=COST(0.001)+(COST(99.999)-COST(0.001))/10*1;
筹码价位2:=COST(0.001)+(COST(99.999)-COST(0.001))/10*2;
筹码价位3:=COST(0.001)+(COST(99.999)-COST(0.001))/10*3;
筹码价位4:=COST(0.001)+(COST(99.999)-COST(0.001))/10*4;
筹码价位5:=COST(0.001)+(COST(99.999)-COST(0.001))/10*5;
筹码价位6:=COST(0.001)+(COST(99.999)-COST(0.001))/10*6;
筹码价位7:=COST(0.001)+(COST(99.999)-COST(0.001))/10*7;
筹码价位8:=COST(0.001)+(COST(99.999)-COST(0.001))/10*8;
筹码价位9:=COST(0.001)+(COST(99.999)-COST(0.001))/10*9;
筹码价位高:=COST(99.999);
区间最大筹码:=MAX(MAX(MAX(MAX(WINNER(筹码价位1)-WINNER(筹码价位低),WINNER(筹码价位2)-WINNER(筹码价位1)),MAX(WINNER(筹码价位3)-WINNER(筹码价位2),WINNER(筹码价位4)-WINNER(筹码价位3))),MAX(MAX(WINNER(筹码价位5)-WINNER(筹码价位4),WINNER(筹码价位6)-WINNER(筹码价位5)),MAX(WINNER(筹码价位7)-WINNER(筹码价位6),WINNER(筹码价位8)-WINNER(筹码价位7)))),MAX(WINNER(筹码价位9)-WINNER(筹码价位8),WINNER(筹码价位高)-WINNER(筹码价位9)));
筹码密集均价A:=IF(区间最大筹码=WINNER(筹码价位1)-WINNER(筹码价位低),(筹码价位1+筹码价位低)/2,IF(区间最大筹码=WINNER(筹码价位2)-WINNER(筹码价位1),(筹码价位2+筹码价位1)/2,IF(区间最大筹码=WINNER(筹码价位3)-WINNER(筹码价位2),(筹码价位3+筹码价位2)/2,IF(区间最大筹码=WINNER(筹码价位4)-WINNER(筹码价位3),(筹码价位4+筹码价位3)/2,IF(区间最大筹码=WINNER(筹码价位5)-WINNER(筹码价位4),(筹码价位5+筹码价位4)/2,IF(区间最大筹码=WINNER(筹码价位6)-WINNER(筹码价位5),(筹码价位6+筹码价位5)/2,IF(区间最大筹码=WINNER(筹码价位7)-WINNER(筹码价位6),(筹码价位7+筹码价位6)/2,IF(区间最大筹码=WINNER(筹码价位8)-WINNER(筹码价位7),(筹码价位8+筹码价位7)/2,IF(区间最大筹码=WINNER(筹码价位9)-WINNER(筹码价位8),(筹码价位9+筹码价位8)/2,(筹码价位高+筹码价位9)/2)))))))));
筹码密集均价:MA(筹码密集均价A,1),COLOR00FFFF,LINETHICK2;
DRAWTEXT(ISLASTBAR,筹码密集均价,STRCAT(‘–密集位’,VARCAT(VAR2STR(筹码密集均价,3),’ 元’))),COLOR00FFFF;
筹码密集度%:(WINNER(筹码密集均价A*1.1)-WINNER(筹码密集均价A*0.9))*100,COLORGREEN,NODRAW;
{黄金分割分析顶底}
高1:=REF(HHV(C,M),N);
低1:=REF(LLV(L,M),N);
H50:=高1-(高1-低1)*0.500;
分界位:REFDATE(H50,DATE),COLOREEEEEE,DOTLINE;
DRAWTEXT(CURRBARSCOUNT=1,分界位,’—%50位 ‘),COLOREEEEEE;

利润同比:=FINANCE(43);
净利润:=FINANCE(30)/100000000;
JJJ1A:=STRCAT(STRCAT(‘ 利润同比增长:’,CON2STR(利润同比,2)),’ % ‘);
JJJ2A:=IF(FINANCE(30)> 100000000,STRCAT(CON2STR(FINANCE(30)/100000000,2),’ 亿元 ‘),
IF(FINANCE(30)<=100000000,STRCAT(CON2STR(FINANCE(30)/10000,2),’ 万元 ‘),DRAWNULL));
JJJ3A:=STRCAT(‘当期净利润:’,JJJ2A);
DRAWTEXT_FIX(ISLASTBAR,0.01,0.06,0,’【净利分析】’),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.10,0.06,0,STRCAT(JJJ3A,JJJ1A)),COLORFFFFFF;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址