• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

MACD顶底背离变盘点副图指标

通达信公式 第一股票指标公式网 1个月前 (07-02) 16次浏览 已收录 0个评论 扫描二维码

MACD顶底背离变盘点副图指标 源码 通达信 贴图
DI1F:=(EMA(OBV,12) – EMA(OBV,26));
DE1A:=EMA(DI1F,9);
MACD:(2 * (DI1F – DE1A)),NODRAW,COLORFF8000;
0;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,3,1),COLOR0080FF,LINETHICK2;
STICKLINE(MACD>=REF(MACD,1) AND MACD>0,0,MACD,3,1),COLOR0000FF,LINETHICK2;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,3,1),COLORFF8000,LINETHICK2;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,3,1),COLORFFFF00,LINETHICK2;
DIF:(EMA(OBV,12) – EMA(OBV,26)),COLORFFFFFF,LINETHICK3;
DEA:EMA(DIF,9),COLOR00FFFF,LINETHICK3;
{ 以下是可能出现的变盘点,关注 }
TJ:=MACD>0;
T:=MACD<0;
DRAWTEXT(BARSLAST(TJ)=5,0.03,’5′),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=8,0.03,’8′),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=13,0.03,’13’),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=21,0.03,’21’),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=34,0.03,’34’),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=55,0.03,’55’),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=5,-0.03,’5′),COLORGREEN;
DRAWTEXT(BARSLAST(T)=8,-0.03,’8′),COLORGREEN;
DRAWTEXT(BARSLAST(T)=13,-0.03,’13’),COLORGREEN;
DRAWTEXT(BARSLAST(T)=21,-0.03,’21’),COLORGREEN;
DRAWTEXT(BARSLAST(T)=34,-0.03,’34’),COLORGREEN;
DRAWTEXT(BARSLAST(T)=55,-0.03,’55’),COLORGREEN;
ZSJR4:=CROSS(DIF,0);
ZSJR5:=CROSS(0,DIF);
ZSJR6:=BARSLAST(ZSJR4);
ZSJR7:=BARSLAST(ZSJR5);
ZSJR8:=REF(ZSJR4,1);
ZSJR9:=REF(ZSJR5,1);
DIF0:=BARSLAST(ZSJR8);
DIF1:=BARSLAST(ZSJR9);
DIF2:=IF((DIF0 < DIF1),REF(HHV(HIGH,2),DIF0),REF(LLV(LOW,2),DIF1));
DIF3:=(((REF(OBV,1) <= REF(DIF2,1)) AND (OBV > DIF2)) AND (ZSJR6 < ZSJR7));
DIF33:=(((REF(OBV,1) >= REF(DIF2,1)) AND (OBV < DIF2)) AND (ZSJR7 < ZSJR6));
DIF4:=(DIF3 AND (COUNT(DIF3,ZSJR6) = 1));
DIF5:=(DIF33 AND (COUNT(DIF33,ZSJR7) = 1));
DIF6:=(DIF4 AND (REF(BARSLAST(DIF5),1) < REF(BARSLAST(DIF4),1)));
DIF7:=(DIF5 AND (REF(BARSLAST(DIF5),1) > REF(BARSLAST(DIF4),1)));
DIF8:=(DIF4 AND (REF(BARSLAST(DIF5),1) > REF(BARSLAST(DIF4),1)));
DIF9:=(DIF5 AND (REF(BARSLAST(DIF5),1) < REF(BARSLAST(DIF4),1)));
BSLINE:=IF((BARSLAST(DIF6) < BARSLAST(DIF7)),IF(REF(CROSS(0,MACD),1),LLV(LOW,2),REF(LLV(LOW,2),BARSLAST(REF(CROSS(0,MACD),1)))),IF(REF(CROSS(MACD,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD,0),1)))));
DEA3:=BARSLAST(CROSS(MACD,0));
DEA5:=BARSLAST(CROSS(0,MACD));
DEA4:=IF((MACD >= 0),HHV(MACD,(DEA3 + 1)),REF(HHV(MACD,(DEA3 + 1)),(DEA5 + 1)));
DEA6:=IF((MACD < 0),LLV(MACD,(DEA5 + 1)),REF(LLV(MACD,(DEA5 + 1)),(DEA3 + 1)));
DEA7:=REF(DEA4,(DEA3 + 1));
DEA8:=REF(DEA6,(DEA5 + 1));
零下金叉:CROSS(DIF,DEA) AND DIF<0,NODRAW,COLOR0000FF;
零上金叉:CROSS(DIF,DEA) AND DIF>=0 AND DIF<0.25 ,NODRAW,COLOR4080FF;
DRAWICON(零上金叉,DEA,1) ;
DRAWICON(零下金叉,DEA,1) ;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,NODRAW,COLOR00FFFF;
DRAWTEXT(二次金叉,DEA*0.4,’★二金’),COLORYELLOW;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背离:=REF(OBV,A1+1)>OBV AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
{STICKLINE(底背离,-0.2,-0.3,6,1),COLOR00FF00;}
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,POINTDOT;
DRAWTEXT(底背离,DEA*0.6,’底背离’),COLORRED;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(OBV,A2+1)<OBV AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,POINTDOT;
DRAWTEXT(顶背离,DEA*1.3,’顶背离’),COLORGREEN;
DRAWTEXT(零下金叉 AND 二次金叉 AND 底背离,DIF*-1,’★底现★’),COLORFFFFFF;
H1J_19:=HHVBARS(MACD,BARSLAST(MACD<0)+1);
H1J_20:=CROSS(BACKSET(CROSS(0,MACD),REF(H1J_19,1)+2),0.5);
H1J_22:=DRAWLINE(H1J_20,MACD,REF(H1J_20,1),REF(MACD,1),1);
H1J_23:=LLVBARS(MACD,BARSLAST(MACD>0)+1);
H1J_24:=CROSS(BACKSET(CROSS(MACD,0),REF(H1J_23,1)+2),0.5);
H1J_25:=BARSLAST(FILTERX(CROSS(0,MACD),BARSCOUNT(OBV)));
H1J_26:=DRAWLINE(H1J_24,MACD,REF(H1J_24,1),REF(MACD,1),1);
MACD0:=BACKSET(ISLASTBAR,BARSLAST(H1J_20)+1);
MACD1:=MACD0>REF(MACD0,1);
前1高:REF(MACD,BARSLAST(MACD1)),COLORYELLOW,LINETHICK2;
STICKLINE(MACD>H1J_22,MACD,H1J_22,2,0),COLORYELLOW;
STICKLINE(MACD<0 AND MACD<H1J_26 AND H1J_26<0,MACD,H1J_26,1,0),COLORFFFFFF;
H7:=BARSLASTCOUNT(DIF>DEA );
DRAWNUMBER(ISLASTBAR,0,H7),COLORFFFFFF,LINETHICK9;
IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED;
STICKLINE(DIF<0 AND CROSS(DIF,DEA),DEA,0,0,0),COLORRED;
STICKLINE(DIF>0 AND CROSS(DEA,DIF),DEA,0,0,0),COLORGREEN;
STICKLINE(DIF<0 AND CROSS(DIF,DEA),DEA,0,0,0),COLORRED;
STICKLINE(DIF>0 AND CROSS(DEA,DIF),DEA,0,0,0),COLORGREEN;
DRAWTEXT(DIF<0 AND CROSS(DIF,DEA),DEA/2,’———————————’);
DRAWTEXT(DIF>0 AND CROSS(DEA,DIF),DEA/2,’———————————’);
X_21:=MACD.DIF#WEEK(12,26,9);
X_22:=MACD.DEA#WEEK(12,26,9);
X_23:=MACD.MACD#WEEK(12,26,9);
X_24:=CROSS(X_21,X_22);
0,COLOR00FF00;
IF(X_23>0,0,DRAWNULL),COLOR0000FF;
DRAWTEXT(X_24,DIF/2*-1,’周金叉’),COLORWHITE;
DRAWTEXT(CROSS(X_22,X_21),DIF/2*-1,’周死叉’),COLORFFFF00;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址