• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信分时量能指标公式

通达信公式 第一股票指标公式网 5个月前 (07-05) 56次浏览 已收录 0个评论 扫描二维码

计算周期:=13;
INC:=IF(C>REF(C,1), VOL,0);
DEC:=IF(C<REF(C,1), VOL,0);
START0:=BARSLAST(TIME=931 AND CURRBARSCOUNT<=FROMOPEN+1);
START:=IF(START0=DRAWNULL,FROMOPEN+1,START0+1);
昨拉升最高值:CONST(REFV(HHV(INC,240),START+1)),DOTLINE,COLORYELLOW;
昨拉升最高价:=REF(C,BARSLAST(VOL=昨拉升最高值));
昨抛压最高值:=CONST(REFV(HHV(DEC,240),START+1));
昨抛压最低价:=REF(C,BARSLAST(VOL=昨抛压最高值));
抛压:=DEC>昨抛压最高值 AND C < 昨抛压最低价;
多方资金:=SUM(IF(C>REF(C,1),AMOUNT,0),计算周期);
空方资金:=SUM(IF(C<REF(C,1),AMOUNT,0),计算周期);
TIMETADAY:=TIME>931 AND CURRBARSCOUNT<=FROMOPEN+1;
量能攻击波:=INC>昨拉升最高值 AND C>昨拉升最高价 AND 多方资金>=空方资金 AND NOT(抛压) AND TIMETADAY;
ATTCK1:=BARSSINCEN(COUNT(BARSSINCEN(量能攻击波=1,13)<=0,START-1)=1,START)<=0;
ATTCK2:=BARSSINCEN(COUNT(BARSSINCEN(量能攻击波=1,13)<=0,START-1)=2,START)<=0;
今拉升最高值:CONST(HHV(INC,START-1)),COLORMAGENTA;
攻击力度:今拉升最高值/昨拉升最高值,NODRAW,COLORRED;
涨幅:=(C-DYNAINFO(3))*100/DYNAINFO(3);
CON1:=ATTCK1 AND BETWEEN(涨幅,-0.2,5) OR ATTCK2 AND BETWEEN(涨幅,-0.2,7),NODRAW;
AA:=AMOUNT/V/100;
YL:=REF(LLV(L,240),START+1),NODRAW;
CON2:=LLV(L,START-1)>=YL,NODRAW;
CON3:=HHV(INC,START+1)>=HHV(DEC,START+1)*0.5,NODRAW;
CON4:=BARSLAST(AA>=REF(AA,1))<=1,NODRAW;
OUT:=CON1 AND CON2 AND CON3 AND CON4;
STICKLINE(C>REF(C,1),0,V,0,0),COLOR0000FF;
STICKLINE(C<REF(C,1),0,V,0,0),COLOR00FF00;
STICKLINE(C=REF(C,1),0,V,0,0),COLORFFFFFF;
DRAWICON(OUT ,昨拉升最高值,17);


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址