• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

集合竞价副图/选股预警无未来

通达信公式 第一股票指标公式网 4周前 (07-09) 16次浏览 已收录 0个评论 扫描二维码

集合竞价预警选股,在股友“妖牛股怪”源码基础上再加条件进行优化,回测比较适用。明天即将开盘,现打包发出来供大家一起测试。指标暂时半加密,后市会继续优化,成熟后完全放开。
公式用到自定义数据,见提供的附件,包括到2021年5月21日止的开盘金额数据文件,请各自通过自定义数据管理器导入。方法:打开自定义数据管理器,建立一个序列数据“数据号:9601;属性选择:序列数据;名称取:开盘金额”,然后点“修改数据”,点开后,点“导入”,选择我上传的文件“序列数据(日期,数值)_9601”,导入方式选择“补充”,然后确定保存,关闭管理器,就可以了。
选股公式最好在早晨集合竞价后的9点25分到9点30分间进行选股,当然就是开盘后进行选股也是可以的。

N:=95;
开幅%:=(O-REF(C,1))/REF(C,1)*100;
去ST股:=IF(NAMELIKE(‘S’),0,1);
去ST股1:=IF(NAMELIKE(‘*’),0,1);
去停牌:=DYNAINFO(17)>0;
流通值:=FINANCE(40)/100000000;
一字板:=C/REF(C,1)>1.0975 AND H=L;
TJ2:=BETWEEN(O/REF(C,1),1.03,1.07);{开盘涨幅在3%到7%之间}
TJ3:=BETWEEN(DYNAINFO(15),1000000,100000000); {开盘金额在100万到1亿之间}
TJ4:=BETWEEN(FINANCE(40),1500000000,10000000000); {流通市值在15亿到100亿之间}
TJ5:=BETWEEN(O,2,50);{开盘价在2元到50元之间}
TJA:=REF(WINNER(C)*100,1)>=N AND WINNER(O)*100>=N AND BETWEEN(开幅%,5,9) AND 去ST股 AND 去ST股1 AND 流通值<100000 {AND NOT( 一字板)};

今开盘换手:=IF(ISLASTBAR=1,DYNAINFO(15)/O/FINANCE(46)*100,DRAWNULL),NODRAW;
开盘金额:=IF(NOT(ISLASTBAR),SIGNALS_USER(9601,0),DYNAINFO(15));
J开盘换手:=开盘金额/O/FINANCE(46)*100,NODRAW;
Z开盘换手:=REF(SIGNALS_USER(9601,0),1)/REF(O,1)/FINANCE(46)*100,COLORRED,NODRAW;
Q开盘换手:=REF(SIGNALS_USER(9601,0),2)/REF(O,2)/FINANCE(46)*100,COLORRED,NODRAW;
TJB:=O>=REF(C,1) AND REF(O,1)>=REF(C,2);
TJC:=J开盘换手>Z开盘换手 AND Z开盘换手>=Q开盘换手 AND J开盘换手>0.12;
TJD:=TJB AND TJC;
筹码价位低:=COST(0.001);
筹码价位1:=COST(0.001)+(COST(99.999)-COST(0.001))/10*1;
筹码价位2:=COST(0.001)+(COST(99.999)-COST(0.001))/10*2;
筹码价位3:=COST(0.001)+(COST(99.999)-COST(0.001))/10*3;
筹码价位4:=COST(0.001)+(COST(99.999)-COST(0.001))/10*4;
筹码价位5:=COST(0.001)+(COST(99.999)-COST(0.001))/10*5;
筹码价位6:=COST(0.001)+(COST(99.999)-COST(0.001))/10*6;
筹码价位7:=COST(0.001)+(COST(99.999)-COST(0.001))/10*7;
筹码价位8:=COST(0.001)+(COST(99.999)-COST(0.001))/10*8;
筹码价位9:=COST(0.001)+(COST(99.999)-COST(0.001))/10*9;
筹码价位高:=COST(99.999);
区间最大筹码:=MAX(MAX(MAX(MAX(WINNER(筹码价位1)-WINNER(筹码价位低),WINNER(筹码价位2)-WINNER(筹码价位1)),MAX(WINNER(筹码价位3)
-WINNER(筹码价位2),WINNER(筹码价位4)-WINNER(筹码价位3))),MAX(MAX(WINNER(筹码价位5)-WINNER(筹码价位4),WINNER(筹码价位6)-WINNER(筹码价位5)),
MAX(WINNER(筹码价位7)-WINNER(筹码价位6),WINNER(筹码价位8)-WINNER(筹码价位7)))),MAX(WINNER(筹码价位9)-WINNER(筹码价位8),WINNER(筹码价位高)-WINNER(筹码价位9)));
筹码密集均价A:=IF(区间最大筹码=WINNER(筹码价位1)-WINNER(筹码价位低),(筹码价位1+筹码价位低)/2,
IF(区间最大筹码=WINNER(筹码价位2)-WINNER(筹码价位1),(筹码价位2+筹码价位1)/2,
IF(区间最大筹码=WINNER(筹码价位3)-WINNER(筹码价位2),(筹码价位3+筹码价位2)/2,
IF(区间最大筹码=WINNER(筹码价位4)-WINNER(筹码价位3),(筹码价位4+筹码价位3)/2,
IF(区间最大筹码=WINNER(筹码价位5)-WINNER(筹码价位4),(筹码价位5+筹码价位4)/2,
IF(区间最大筹码=WINNER(筹码价位6)-WINNER(筹码价位5),(筹码价位6+筹码价位5)/2,
IF(区间最大筹码=WINNER(筹码价位7)-WINNER(筹码价位6),(筹码价位7+筹码价位6)/2,
IF(区间最大筹码=WINNER(筹码价位8)-WINNER(筹码价位7),(筹码价位8+筹码价位7)/2,
IF(区间最大筹码=WINNER(筹码价位9)-WINNER(筹码价位8),(筹码价位9+筹码价位8)/2,(筹码价位高+筹码价位9)/2)))))))));
筹码密集均价:=MA(筹码密集均价A,1),COLOR00FFFF,LINETHICK2;
筹码密集度%:=(WINNER(筹码密集均价A*1.1)-WINNER(筹码密集均价A*0.9))*100,COLORGREEN,NODRAW;
TJE:=O>筹码密集均价 AND 筹码密集度%>40;
预警:TJA AND TJD AND TJE;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址