• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

马泰老师飞狐帝纳波利dmp指标转指标编辑独特见

通达信公式 第一股票指标公式网 4周前 (07-10) 24次浏览 已收录 0个评论 扫描二维码

我不用飞狐,对飞狐的指标编写语法不熟悉,函数也不熟悉叫我在飞狐平台上写飞狐能用的指标我自认没这个本事。
但是知识的道理是互通的,那么顺手借此附件内容写一篇学习方法论文。解析源码含义如何移植通达信。

BB:=CLOSE;
EMA08A:=BB;
EMA17A:=BB;
FAST1:=0;
SLOW1:=0;
EMA(C,8);
EMA(C,17);
EMA08:=(BB*2+EMA08A*7.3896)/9.3896;
EMA17:=(BB*2+EMA17A*16.5185)/18.5185;
FAST:=EMA08-EMA17,COLORRED;
SLOW:=(FAST*2+SLOW1*(8.0503))/(10.0503),COLORCYAN;
DMP:(18.5185*9.3896*SLOW+EMA17*9.3896*16.5185-EMA08* 18.5185*7.3896)/18.2578;
DRAWNUMBER(ISLASTBAR,DMP,2),COLORRED;
首先,飞狐软件的指标语法偏向于程序语言,不同于通达信函数直接用。这也是为什么现在折腾通达信指标人多的原因。
那么我们先看下#SUBCHART这句是什么意思?使用子图(Subchart)能够将复杂的图表分解成一系列按层次组织起来简单的
计算机专业的程序员可能会解释的更清楚更专业,我们不是程序员不懂这个我只要理解这个是建模起始开头就够了。那么这句可以直接删除
再看第二句BB:=CLOSE;CLOSE时候收盘价通用函数,直接去掉BB,注意这个二B在通达信上不要随便取名用,可能会有造成不可预知的计算错误的可能。
通达信系统自带指标BB为布林极限,取名时最好不要与系统自带指标名重名。那么我们记住这个指标要用到CLOSE就可以了。
第三步我们看下EMA08[1]:=BB[1];和EMA17[1]:=BB[1];这两句。EMA指数移动平均线函数,08和17是均线计算天数。那么这两句就简单了直接为EMA(C,8);
EMA(C,17);
第四步我们看下FAST[1]:=0;和SLOW[1]:=0;FAST快的意思,SLOW慢的意思。
飞狐的datacount函数是什么意思?这个可以找一下函数解释。表示从第一根K线到最后一根K线总共的周期数(也就是K线根数)
begin这是啥?英 [bɪˈɡɪn] 美 [bɪˈɡɪn] v.开始;启动;起始;开始存在(或进行);起初是;本来是。
那么do 是啥?(英语单词)中文名做,干。那么for是啥?(表示对象、用途等)FOR I我估摸着应该是程序员常说的输出的操作指令循环吧。
通过英文翻译以上大概意思出来了,那么对于通达信来讲这些都没用。这段直接删掉即可。
第五步,我们看下EMA08[I]:=(BB[I]*2+ EMA08[I-1]*7.3896)/9.3896; 和EMA17[I]:=(BB[I]*2+ EMA17[I-1]*16.5185)/18.5185;
因为纯数学算式码字不好打直接截图示意如下:

由此可见这些7.3896,9.3896还有16.5185)/18.5185这些数值我们根本就不用管是怎么来的。可见为纯数学算式计算机程序化,我们不用钻牛角尖去研究这些数字,这是计算机专业程序员做的事。除非你非要从编程入手以软件形式来写指标,这就本末倒置了。
那么回到前面第三步看,直接就是EMA(C,8);和EMA(C,17);
第六步我们再看FAST[I]:=EMA08[I]-EMA17[I],COLORRED;和SLOW[I]:=(FAST[I]*2+ SLOW[I-1]*(8.0503))/(10.0503),COLORCYAN;
从这两句看到有颜色函数,那么就可以判定为线性输出语句画色了。
END;这个是啥?END结束啊!~!我了个去了。。一个指标搞的近似与编程语言,很烦琐真的很烦琐这也是我不用飞狐的原因。编个简单的指标还得会计算机编程语言。
第七步看下// DMP这是啥?找了半天就这句解释还能符合点,数据管理平台(Data Management Platform,简称DMP)。把END前面的运行的结果总结,我估摸着应该是这个意思。那么最后一句输出DMP:(18.5185*9.3896*SLOW + EMA17*9.3896*16.5185 – EMA08* 18.5185*7.3896 )/18.2578,COLORRED,SHIFT1;
瞧又有颜色函数了COLORRED,那么可以认定最后一句为最终输出线。
那么这个指标就是一条线,COLORRED红色,COLORCYAN青色。总共两种颜色。
最后做成通达信应该最多是几句语句呢?5句。如果不要两色变色线只要单色线的最多为4句。如果想一句也行嵌套一下就可以做到。
论述结束,我也来END!
结果看图:


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址