• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

通达信超短共振主图指标公式

通达信公式 第一股票指标公式网 3周前 (07-12) 30次浏览 已收录 0个评论 扫描二维码

价量:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
主力活跃力度:=(((价量-LLV(价量,27))/(HHV(价量,27)-LLV(价量,27)))*(4))*(25);
快线:=(((价量-LLV(价量,9))/(HHV(价量,9)-LLV(价量,9)))*(4))*(25);
{☆精确风险}
{【参数定义】}
RSV:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
K1:=SMA(RSV,10,1);
D1:=SMA(K1,5,1);
KK:=INTPART(K1);
DD:=INTPART(D1);
TFXXS:=KK+DD;{//变异KD风险系数}
TGLD:=MOD(TFXXS,10);{//踏浪涨停概率点}
TGLXS:=(TFXXS-REF(TFXXS,1))*10;
{//变异KD乖离系数}
乖离系数:=TGLXS,,NODRAW,COLORRED;
主线:=EMA(EMA(C,1),5);
本:=EMA(HHV(主线,5),1);
急:=EMA(HHV(本,21),1);
稳:=EMA(HHV(急,21),2);
投:=EMA(HHV(稳,21),3);
散:=EMA(HHV(投,21),4);
集:=EMA(HHV(散,21),5);
疯牛马线:EMA(HHV(集,21),6),COLORFF0080,LINETHICK3;
日线:=CLOSE;
涨幅:=(C-REF(C,1))*100/REF(C,1);
涨幅50:=(C-REF(C,50))*100/REF(C,50);
B1:=MA(C,1);
持币阶段:SMA(SMA(SMA(B1,2,1),2,1),2,1),COLORFF6100,LINETHICK4;
主升持股波段:HHV(MA(持币阶段,1),13),COLOR00FFFF,LINETHICK4;
牛股出现预警:=WINNER(C/1.10)*100,COLOR00FFFF,NODRAW;
主力赢利25持仓:=WINNER(C/1.25)*100,COLORFF00FF,NODRAW;
主力筹码:=EMA(WINNER(CLOSE)*70,3);
散户筹码:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
散户套牢筹码:=散户筹码/(主力筹码+散户筹码)*100;
主升浪波段:=主力筹码/(主力筹码+散户筹码)*100,COLORFF6100,NODRAW;
主力主导行情:=EMA(主升浪波段,55),NODRAW,COLORFF00FF;
金叉疯牛:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2);
界:=MA(CLOSE,27);
ER:=V/FINANCE(7)*100;
A0:=TMA(ER,(1-ER),1);
MAXCYC:=DMA((C+O)/2,ER/TMA(ER,(1-ER),1));
T1:=BARSLAST(C>MAXCYC*POW(1.1,0.9));
T2:=BARSLAST(C<MAXCYC*POW(1.1,-0.9));
T3:=CROSS(T1,T2) OR CROSS(T2,T1) OR BARSSINCE(T1+1)=0 OR BARSSINCE(T2+1)=0 OR BARSCOUNT(C)=0;
T4:=REF(MAXCYC,BARSLAST(T3));
VAR11:=3*SMA((C-LLV(L,480))/(HHV(H,480)-LLV(L,480))*100,5,1)
-2*SMA(SMA((C-LLV(L,480))/(HHV(H,480)-LLV(L,480))*100,180,1),15,1);
超级主升:=EMA(VAR11,5);
主升1:=超级主升-100;
D8:=EMA(C,5);
D2:=(EMA(C,1)+EMA(C,5)+EMA(C,10)+EMA(C,15)+EMA(C,20)+EMA(C,25)+EMA(C,30)+EMA(C,35)+EMA(C,40)+EMA(C,45)+
EMA(C,50)+EMA(C,55)+EMA(C,60)+EMA(C,65)+EMA(C,70)+EMA(C,75)+EMA(C,80)+EMA(C,85)+EMA(C,90)+EMA(C,95)+
EMA(C,100)+EMA(C,105)+EMA(C,110)+EMA(C,115)+EMA(C,120)+EMA(C,125)+EMA(C,130)+EMA(C,135)+EMA(C,140)+EMA(C,150))/30;
DDE:=(D8/D2)*100;
主升2:=DDE-110;
A:=(H+L+2*C)/4;
A1:=(A-REF(A,3))/3+A;
MA5:=EMA(A1,7);
J:=EMA(HHV(A1,20),60),LINETHICK3;
CB5:=EMA(COST(80),30),CIRCLEDOT;
HMX:=EMA(1.4*EMA(FORCAST(A1,20),40),20),LINETHICK2;
金牛线:=(J+CB5+HMX)/3,LINETHICK2;
MA20:=MA(C,20);
UP:=EMA(EMA(C*1.38,50),50),DOTLINE,COLOR0000FF;
白色:=SMA(HIGH,21,2)*1.05;
黄色:=SMA(LOW,21,2)*0.95;
中线:=(白色+黄色)/2;
UP1:=中线+2*STD(中线,20);
UP2:=REF(UP1,0);
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(A1,20))/MA(A1,20);
DT:=DMA(CLOSE,CC);
通道3:=(1+9/100)*DT;
通道4:=(1-7/100)*DT;
界限:=(REF((金牛线+UP+EMA(UP1*1.04,40)+通道3)/4,10)+MA(C,20)*1.04)/2;
AHC1:=H*VOL;
AHC24:=EMA((EXPMA(AHC1,180)/EXPMA(VOL,180)+EXPMA(AHC1,360)/EXPMA(VOL,360)+EXPMA(AHC1,720)/EXPMA(VOL,720)+EXPMA(AHC1,1440)/EXPMA(VOL,1440))/4,34);
C上X:=1.06*AHC24;
C下X:=AHC24*0.94;
AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);
上X:=1.06*AHC22;
下X:=AHC22*0.94;
AHC23:=EMA((EXPMA(AHC1,5)/EXPMA(VOL,5)+EXPMA(AHC1,10)/EXPMA(VOL,10)+EXPMA(AHC1,20)/EXPMA(VOL,20)+EXPMA(AHC1,40)/EXPMA(VOL,40))/4,34);
D上X:=1.06*AHC23;
D下X:=AHC23*0.94;
T:=(C上X+D上X+上X)/3*1.05;
主升3:=(MA5*2/(界限+T)-1)*100;
CBX80:=MA(COST(80),20);
主升4:=(MA5/CBX80-1)*100;
FT:=((HHV(H,42)-LLV(L,42)))/2+LLV(L,42);
FT1:=ABS(HHV(H,40)-LLV(L,40)-LLV(L,40))+FT*0.5;
主升5:=(FT/FT1-1)*100;
P:=EMA(EMA(C*1.14,55),20);
主升6:=(MA5/P-1)*100;
金K线:=(EMA(HHV(H,60),60)+EMA(FT,453)*1.62)/2;
主升7:=(MA5/金K线-1)*100;
超牛拉升:=(主升1+主升2+主升3+主升4+主升5+主升6+主升7)/2,LINETHICK2;
持股时段:=IF((金叉疯牛>界)AND(散户筹码<主力筹码)AND((主力活跃力度>50)OR(主力活跃力度>REF(主力活跃力度,1))),-40,0),COLORRED,NODRAW;
主力最大盈利:=LN(C/T4)/LN(1.1)*10,NODRAW,COLORFF0080;
VAR1:=AMOUNT/VOL/100;
VAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
疯牛强势分界线:=IF(C>200,C,DMA(VAR2,VOL/CAPITAL))*1.1,COLOR00FFFF,LINETHICK0;
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,21);
V3:=EMA(V2,5);
WY:=2*(V2-V3)*100;
角度2:=ATAN((主升持股波段/REF(主升持股波段,1)-1)*100)*57.296;
SMA2:=MA(持币阶段,3);
IF(持币阶段<REF(持币阶段,1) AND 持币阶段<疯牛马线,持币阶段,DRAWNULL),COLORFF6100,LINETHICK4;
IF(持币阶段>REF(持币阶段,1) AND 持币阶段<疯牛马线,持币阶段,DRAWNULL),COLORFF00FF,LINETHICK4;
双线合一关注:主升持股波段,COLOR4169E1,LINETHICK4;
IF(双线合一关注>REF(双线合一关注,1) AND 主升持股波段>疯牛马线,双线合一关注,DRAWNULL),COLORRED,LINETHICK4;
IF(双线合一关注<=REF(双线合一关注,1),双线合一关注,DRAWNULL),COLOR808A87,LINETHICK4;
IF(双线合一关注>REF(双线合一关注,1) AND 主升持股波段<=疯牛马线,双线合一关注,DRAWNULL),COLOR1E90FF,LINETHICK2;
疯牛:IF((主升浪波段>50)AND(超牛拉升>=REF(超牛拉升,1))AND(双线合一关注>=REF(双线合一关注,1)),双线合一关注,DRAWNULL),COLOR00FFFF,LINETHICK4;
FN:疯牛;
超牛高:=H=HHV(超牛拉升,10);
日振幅:=(H-L)/REF(C,1)*100;
振幅15:=HHV(日振幅,15);
剔除新股:=BARSCOUNT(CLOSE)>60;
涨幅1:=(REF(C,1)-REF(C,2))/REF(C,2)*100;
涨幅2:=(REF(C,2)-REF(C,3))/REF(C,3)*100;
涨幅20:=(REF(C,1)-REF(C,21))/REF(C,21)*100;
涨幅10:=(REF(C,1)-REF(C,11))/REF(C,11)*100;
涨幅5:=HHV(CLOSE,5)/LLV(CLOSE,5);
振幅:=(C-O)/O*100;
跌幅:=(REF(C,1)-C)/REF(C,1)*100;
低开阳线:=((O>REF(H,1) AND L>REF(H,1) AND C>O AND (O-REF(C,1))/REF(C,1)*100>1.5));
大阳线:=(O-REF(C,1))/REF(C,1)*100>5;
连阳1:=COUNT(O>REF(C,1),2)=2;
跳空1:=COUNT(O>REF(H,1) AND L>REF(H,1),10);
跳空2:=COUNT(O>REF(C,1) AND L>REF(C,1),10) AND L<O;
跳空3:=COUNT(O>REF(C,1) AND (O-REF(C,1))/REF(C,1)*100>0.1 AND C>REF(H,1),10);
VAR21:=SMA(ABS(HIGH-VAR1),13,1)/SMA(MIN(HIGH-VAR1,0),10,1);
VAR31:=EMA(VAR21,10);
VAR41:=HHV(HIGH,33);
VAR51:=EMA(IF(HIGH>=VAR41,VAR31,0),3);
主力推升股价:=IF(VAR51<REF(VAR51,1)AND(跌幅<3),18,0),COLORRED,NODRAW;
{低开阳线}
STICKLINE((REF(C,1)-O)/REF(C,1)*100>2.5 AND (C-O)/O*100>2 AND BARSCOUNT(C)>20,O,C,3,0),COLORYELLOW;
DRAWTEXT((REF(C,1)-O)/REF(C,1)*100>2.5 AND (C-O)/O*100>2 AND 涨幅5<30 AND 涨幅10<40 AND 超牛高 AND 超牛拉升>=REF(超牛拉升,1)AND(BARSCOUNT(C)>20),O-1,’老鼠仓’),COLORFF00FF;
{快马加鞭}
快马加鞭:=FILTER((涨幅>5)AND(涨幅1>5)AND(超牛拉升>=REF(超牛拉升,1)AND(C>疯牛马线)AND(涨幅10<40)AND(超牛拉升>=REF(超牛拉升,1))),3);
STICKLINE(快马加鞭>0.1,O,C,3,0),COLORYELLOW;
STICKLINE(快马加鞭>0.1,O,C,1.5,0),COLORRED;
连续下跌:=COUNT(REF(C,2)>REF(C,1),4)>=2;
连续缩量:=COUNT(V<=REF(V,1),4)>=2;
{超强洗筹}
洗筹1:=IF((REF(涨幅>5,1)AND(REF(涨幅1,1))AND(振幅<2)AND((涨幅<2)AND(跌幅<2)AND(涨幅20<28)AND(主升持股波段=持币阶段))),18,0),COLORYELLOW,NODRAW;
洗筹2:=IF((REF(涨幅>2,1)AND(涨幅<2)AND(跌幅<2)AND(主升持股波段>REF(主升持股波段,1))),18,0),COLORYELLOW,NODRAW;
超强洗筹:=IF((洗筹1>8)OR(洗筹2>8)OR((连续下跌)AND(连续缩量)AND(LLV(C,1)>REF(C,5))AND(涨幅>1)AND(LLV(C,4)>REF(C,7))),18,0),COLORYELLOW,NODRAW;
STICKLINE((洗筹1>8)OR(洗筹2>8)OR((连续下跌)AND(连续缩量)AND(COUNT(持币阶段,10)>=3)AND(LLV(C,1)>REF(C,5))AND(C>O)AND(LLV(C,4)>REF(C,7))),O,C,3,0),COLORFF00FF;
STICKLINE((洗筹1>8)OR(洗筹2>8)OR((连续下跌)AND(连续缩量)AND(COUNT(持币阶段,10)>=3)AND(LLV(C,1)>REF(C,5))AND(C>O)AND(LLV(C,4)>REF(C,7))),O,C,1,0),COLORFF0080;
{大黑马}
STICKLINE(((COUNT(低开阳线,10)=1)AND(连阳1))OR((振幅15<20)AND(跳空3))AND(涨幅>5)AND(涨幅1<5)AND(涨幅20<20)AND(涨幅50<40)AND(主升持股波段=持币阶段)AND(BARSCOUNT(C)>20)AND(主力推升股价>0)AND 超牛拉升>=REF(超牛拉升,1),O,C,3,0),COLORFF00FF;
STICKLINE(((COUNT(低开阳线,10)=1)AND(连阳1))OR((振幅15<20)AND(跳空3))AND(涨幅>5)AND(涨幅1<5)AND(涨幅20<20)AND(涨幅50<40)AND(主升持股波段=持币阶段)AND 超牛拉升>=REF(超牛拉升,1)AND(主力推升股价>0)AND(BARSCOUNT(C)>20),O,C,1,0),COLORFF0080;
DRAWICON(((COUNT(低开阳线,10)=1)AND(连阳1))OR((振幅15<20)AND(跳空3))AND(涨幅>5)AND(涨幅1<5)AND(涨幅20<20)AND(涨幅50<40)AND(主升持股波段=持币阶段)AND(BARSCOUNT(C)>20)AND(主力推升股价>0)AND(超牛拉升>=REF(超牛拉升,1)),O-1,25);
DRAWTEXT(((COUNT(低开阳线,10)=1)AND(连阳1))OR((振幅15<20)AND(跳空3))AND(涨幅>5)AND(涨幅1<5)AND(涨幅20<20)AND(涨幅50<40)AND(主升持股波段=持币阶段)AND(主力推升股价>0)AND 超牛拉升>=REF(超牛拉升,1)AND(BARSCOUNT(C)>20),O-1.8,’大黑马’),COLORRED;
DRAWTEXT(REF(涨幅>5,1)AND(REF(涨幅1,1))AND(振幅<2)AND((涨幅<2)AND(跌幅<2)AND(涨幅20<28)AND(主升持股波段=持币阶段)),H+0.3,”),COLORRED;
{狂飙主升}
XA_2:=5;
XA_3:=3;
XA_4:=(EMA(CLOSE,5)*7+EMA(CLOSE,10)*3)/10;
XA_5:=IF(YEAR>=2025,0,1);
XA_6:=EMA(EMA(LOW,21)+6.8*STD(LOW,2),55);
XA_7:=EMA(CLOSE/XA_6*(1.88*CLOSE+LOW+OPEN)/2.75,3);
XA_8:=(XA_7-XA_6)/XA_6/2;
XA_9:=EMA(XA_7-XA_8*XA_7,5)*XA_5;
XA_10:=EMA(CLOSE,34)-3*STD(CLOSE,34);
主升浪:=IF(XA_4>XA_9,XA_4,XA_9)*XA_5,COLORGREEN,LINETHICK2;
狂飙主升浪:=IF(主升浪>REF(主升浪,1),主升浪,主升浪),COLORRED,LINETHICK2;
下轨:=IF(XA_9<XA_4 AND XA_9<CLOSE*0.15,EMA(CLOSE,34)-3*STD(CLOSE,34),XA_9),COLORFF0080,LINETHICK2;
XA_1:=涨幅>0.5 AND CROSS(CLOSE,狂飙主升浪);
STICKLINE(XA_1,CLOSE,OPEN,3,0),COLORYELLOW;
STICKLINE(XA_1,OPEN+(CLOSE-OPEN)/2,OPEN,3,0),COLORFF00FF;
IF(XA_9>XA_4,DRAWNULL,DRAWNULL),COLORGREEN,LINETHICK0;
角度:=ATAN((狂飙主升浪/REF(狂飙主升浪,1)-1)*100)*180/3.1416;
角度选股:=(BARSLASTCOUNT(狂飙主升浪>下轨)=1 AND MA(CLOSE,21)>REF(MA(CLOSE,21),1) AND 剔除新股);
DRAWICON(角度选股,MIN(下轨,狂飙主升浪)*0.96,25);
DRAWTEXT(角度选股,LOW,71),COLORYELLOW;
{超强主升浪}
STICKLINE((狂飙主升浪>下轨 AND 日线>狂飙主升浪 AND 角度>45)AND 涨幅>0,OPEN,CLOSE,3,0),COLORRED;
STICKLINE((狂飙主升浪>下轨 AND 日线>狂飙主升浪 AND 角度>45),OPEN,OPEN+(CLOSE-OPEN)/3,3,0),COLORYELLOW;
{次日涨停开口重仓}
STICKLINE((XA_1 AND REF(涨幅,1)>7 AND CROSS(REF(日线,1),狂飙主升浪) AND 涨幅>7),CLOSE,OPEN,3,0),COLORYELLOW;
STICKLINE((XA_1 AND REF(涨幅,1)>7 AND CROSS(REF(日线,1),狂飙主升浪) AND 涨幅>7),OPEN+(CLOSE-OPEN)/3,OPEN+(CLOSE-OPEN)/3*2,3,0),COLORGREEN;
{清仓离场}
STICKLINE((CLOSE<狂飙主升浪 AND 涨幅50>30 AND CLOSE<OPEN),CLOSE,OPEN,3,0),COLORGREEN;
{强势调整1}
STICKLINE((狂飙主升浪>下轨)AND (日线>狂飙主升浪)AND(涨幅<5)AND(OPEN>REF(CLOSE,1)OR(OPEN<(REF(CLOSE,1)-REF(OPEN,1))/2))AND(HIGH>CLOSE),CLOSE,OPEN,3,0),COLORBLUE;
STICKLINE((狂飙主升浪>下轨)AND (日线>狂飙主升浪)AND(涨幅<5)AND(OPEN>REF(CLOSE,1)OR(OPEN<(REF(CLOSE,1)-REF(OPEN,1))/2))AND(HIGH>CLOSE),OPEN+(CLOSE-OPEN)/3,OPEN+(CLOSE-OPEN)/4,3,0),COLORGREEN;
{强势调整2}
STICKLINE((狂飙主升浪>下轨)AND (日线>狂飙主升浪)AND(涨幅<5)AND(OPEN>REF(CLOSE,1))AND(OPEN>CLOSE)AND(HIGH>CLOSE),CLOSE,OPEN,3,0),COLORGREEN;
STICKLINE((狂飙主升浪>下轨)AND (日线>狂飙主升浪)AND(涨幅<5)AND(OPEN>REF(CLOSE,1))AND(OPEN>CLOSE)AND(HIGH>CLOSE),OPEN,OPEN+(CLOSE-OPEN)/3,3,0),COLORFF0080;
STICKLINE((狂飙主升浪>下轨 AND 日线>狂飙主升浪 AND 角度>45)AND 涨幅<0,OPEN,CLOSE,3,0),COLORBLUE;
{超强突破}
STICKLINE((XA_1 AND 涨幅>7 AND CROSS(日线,狂飙主升浪)),CLOSE,OPEN,3,0),COLORYELLOW;
STICKLINE((XA_1 AND 涨幅>7 AND CROSS(日线,狂飙主升浪)),OPEN+(CLOSE-OPEN)/3*2,OPEN,3,0),COLORBLUE;
STICKLINE((XA_1 AND 涨幅>7 AND CROSS(日线,狂飙主升浪)),OPEN+(CLOSE-OPEN)/3,OPEN,3,0),COLORRED;
STICKLINE(XA_1 AND 涨幅>7 AND CROSS(日线,狂飙主升浪),CLOSE*1.1,CLOSE*1.3,0.5,0),COLORRED;
DRAWICON(XA_1 AND 涨幅>7 AND CROSS(日线,狂飙主升浪),CLOSE*1.1,12),COLORRED;
DRAWTEXT(XA_1 AND 涨幅>7 AND CROSS(日线,狂飙主升浪),CLOSE*1.36,’超强转势’),COLORRED;
DRAWTEXT(REF(涨幅>5,1)AND(REF(涨幅1,1))AND(振幅<2)AND((涨幅<2)AND(跌幅<2)AND(涨幅20<28)AND(主升持股波段=持币阶段)),H+1,’超强洗筹’),COLORFF6610;
DRAWTEXT(快马加鞭>0.1,O*0.98,’快马加鞭’),COLORFFFF00;
{重仓介入}
重仓介入:=FILTER((COUNT(角度选股,5)=1 AND 涨幅>0.5 AND 主力赢利25持仓>50 AND 涨幅10<50 AND 乖离系数>=REF(乖离系数,1)),15),COLORFFFF00,LINETHICK2;
STICKLINE(重仓介入>0.8,O*0.72,O*0.82,0.5,0),COLORFFFF00,LINETHICK2;
STICKLINE(重仓介入>0.8,O*0.72,O*0.79,2,0),COLORFF0080,LINETHICK2;
STICKLINE(重仓介入>0.8,O*0.72,O*0.76,4,0),COLORFF00FF,LINETHICK2;
DRAWTEXT(重仓介入>0.8,O*0.70,’重仓介入’),COLORYELLOW;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址