• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

通达信黑马波段指标公式

通达信公式 第一股票指标公式网 1个月前 (08-08) 19次浏览 已收录 0个评论 扫描二维码

A1:=1;
A2:=(5);
A3:=(((2 * CLOSE) + HIGH) + LOW) / 4;
A4:=LLV(LOW,34);
A5:=HHV(HIGH,34);
A6:=EMA((((A3 – A4) / (A5 – A4)) * 100),13);
A7:=(EMA(((0.667 * (REF(A6,1))) + (0.333 * A6)),2)) * A1;
黑马决策线:(EMA(A7,A2)) * A1,COLORRED;
A8:=(HHV(HIGH,9)) – (LLV(LOW,9));
A9:=(HHV(HIGH,9)) – CLOSE;
A10:=CLOSE – (LLV(LOW,9));
A11:=((A9 / A8) * 100) – 70;
A12:=((CLOSE – (LLV(LOW,60))) / ((HHV(HIGH,60)) – (LLV(LOW,60)))) * 100;
A13:=SMA(((A10 / A8) * 100),3,1);
A14:=(SMA(A13,3,1)) – (SMA(A11,9,1));
A15:=IF((A14 > 100),(A14 – 100),0);
A16:=(EMA((((A3 – A4) / (A5 – A4)) * 100),8)) * A1;
A17:=(EMA(A16,5)) * A1;
STICKLINE(((A16 – A17) > 0),A16,A17,3,1),COLORFFAA18;
STICKLINE(((A16 – A17) < 0),A16,A17,3,0),COLORGREEN;
A18:=(EMA(CLOSE,2)) * A1;
A19:=(EMA((((SLOPE(CLOSE,21)) * 20) + CLOSE),42)) * A1;
A20:=(HHV((MA(HIGH,13)),13)) * A1;
A21:=(LLV((MA(HIGH,13)),1)) * A1;
A22:=(EMA(CLOSE,4)) * A1;
A23:=((((A18 >= A19) AND (A21 = A20)) AND (A18 > A22)) AND (CLOSE > A21)) AND ((REF(A21,1)) < (REF(A20,1)));
A24:=BARSLAST(A23) + 1;
A25:=(LLV(LOW,A24)) * 1.3;
A26:=(LLV(LOW,20)) * 1.418;
A27:=(((((A18 >= A19) AND (A21 = A20)) AND ((CLOSE / (REF(CLOSE,1))) >= 1.07)) AND (A24 <= 30)) AND (CLOSE <= A25)) AND (CLOSE <= A26);
A28:=A27 AND (FILTER(A27,A24));
{A29:=(STRFIND(STKNAME,’ST’,1)) > 0;}
A30:=((((((A18 >= A19) AND (A21 = A20)) AND ((CLOSE / (REF(CLOSE,1))) >= 1.035)) AND (A24 <= 30)) AND (CLOSE <= A25)) AND (CLOSE <= A26)) ;
A31:=A30 AND (FILTER(A30,20));
DRAWICON((A28 OR A31),黑马决策线,1);
DRAWTEXT((A28 OR A31),黑马决策线,’黑马’),COLORRED;
{DRAWTEXTREL(3,30,’XXXX:XXXXXXXXX’),COLORWHITE;};


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (1)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址