• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信双隧道主图指标公式

通达信公式 第一股票指标公式网 2个月前 (08-08) 125次浏览 已收录 0个评论 扫描二维码

买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
STICKLINE(买线>=卖线,LOW,HIGH,0,0),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,3,0),COLORRED;
STICKLINE(买线<卖线,CLOSE,OPEN,3,0),COLORFFF000;
STICKLINE(买线<卖线,LOW,HIGH,0,0),COLORFFF000;
M60:MA(C,60),COLORGREEN,LINETHICK2;
上扬M60:=M60>=REF(M60,1);
下降M60:=M60<REF(M60,1);
M60上:IF(上扬M60,M60,DRAWNULL),COLORMAGENTA,LINETHICK2;
M20:MA(C,20),COLORGRAY,LINETHICK2;
上扬M20:=M20>=REF(M20,1);
下降M20:=M20<REF(M20,1);
M20上:IF(上扬M20,M20,DRAWNULL),COLORRED,LINETHICK2;
MA144:EMA(CLOSE,144),LINETHICK1,DOTLINE,COLORBLUE,LINETHICK1;
MA169:EMA(CLOSE,169),LINETHICK1,DOTLINE,COLORGREEN,LINETHICK1;
DRAWTEXT_FIX(1,0,0.00,0,’地区: ‘),COLORYELLOW;DRAWTEXT_FIX(1,0.03,0.00,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.10,0.00,0,’行业: ‘),COLORYELLOW;DRAWTEXT_FIX(1,0.13,0.00,0,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.20,0.00,0,’概念: ‘),COLORYELLOW;DRAWTEXT_FIX(1,0.23,0.00,0,GNBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.07,0,’主营同比:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.05,0.07,0,CONST(FINANCE(44))),COLORYELLOW;
DRAWTEXT_FIX(1,0.10,0.07,0,’毛利率:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.14,0.07,0,CONST((FINANCE(20)-FINANCE(21))/FINANCE(20))*100),COLORYELLOW;
DRAWTEXT_FIX(1,0.20,0.07,0,’净益率:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.24,0.07,0,CONST(FINANCE(30)/FINANCE(19)*100)),COLORYELLOW;
DRAWTEXT_FIX(1,0.29,0.07,0,’净利同比:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.34,0.07,0,CONST(FINANCE(43))),COLORYELLOW;
DRAWTEXT_FIX(1,0.40,0.07,0,’净利润:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.44,0.07,0,CONST(FINANCE(30)/10000)),COLORYELLOW;
净资收益率:=(FINANCE(33)/FINANCE(34)*100);
主营利润率:=(FINANCE(23)/FINANCE(20)*100);
现金负债比:=(FINANCE(25)/FINANCE(15));
主营业增长率:=FINANCE(44);
净利润增长率:=FINANCE(43);
每股收益:=CONST(FINANCE(38));
每股净资产:=CONST(FINANCE(34));
每股现金流:=CONST((FINANCE(25)/FINANCE(1)));
每股未分配:=CONST(FINANCE(32));
每股公积金:=CONST(FINANCE(18));
流通市值:=ROUND(FINANCE(40)/100000000);
A股流通:=FINANCE(7)/100000000;
市盈率:=DYNAINFO(39);
内外比:=DYNAINFO(51);
量比:=DYNAINFO(17);
成交方向:=DYNAINFO(40);
主动买单:=ISBUYORDER;
均价:=DYNAINFO(11);
PEG指标:=DYNAINFO(39)/FINANCE(43);
市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));
现价:=DYNAINFO(7);
振幅:=DYNAINFO(13)*100;
区间成本:=COSTEX(CLOSE,REF(CLOSE,BARSCOUNT(C)-1));
昨收盘价:=DYNAINFO(3);
今开盘价:=DYNAINFO(4);
ER1:=净资收益率>3;
ER12:=净资收益率>0.01 AND 净资收益率<=3;
ER2:=主营利润率>2;
ER22:=主营利润率>0;
ER4:=主营业增长率>1;
ER42:=主营业增长率>0;
ER5:=净利润增长率>2;
ER52:=净利润增长率>0.2;
SAX1:=每股收益>0.01;
SAX12:= 每股收益>0.001;
SAX2:=每股净资产>2;
SAX22:=每股净资产>0.01;
SAX4:=每股未分配>0.5;
SAX42:=每股未分配>0.001;
SAX5:=每股公积金>0.5;
SAX52:=每股公积金>0.002;
优秀:=ER1 AND ER2 AND ER4 AND ER5 AND SAX1 AND SAX2
AND SAX4 AND SAX5,COLORRED;
较好:=ER12 AND ER22 AND ER42 AND ER52 AND SAX12 AND SAX22
AND SAX42 AND SAX52,COLORMAGENTA;
DRAWTEXT_FIX(优秀 AND 较好=0,0.645,0.01,0,’基本面:优秀!’),COLORRED;
DRAWTEXT_FIX(较好,0.645,0.06,0,’基本面:较好!’),COLORMAGENTA;
DRAWTEXT_FIX(1,0,0.00,0,’地区: ‘),COLORYELLOW;DRAWTEXT_FIX(1,0.03,0.00,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.10,0.00,0,’行业: ‘),COLORYELLOW;DRAWTEXT_FIX(1,0.13,0.00,0,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.20,0.00,0,’概念: ‘),COLORYELLOW;DRAWTEXT_FIX(1,0.23,0.00,0,GNBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.07,0,’主营同比:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.05,0.07,0,CONST(FINANCE(44))),COLORYELLOW;
DRAWTEXT_FIX(1,0.10,0.07,0,’毛利率:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.14,0.07,0,CONST((FINANCE(20)-FINANCE(21))/FINANCE(20))*100),COLORYELLOW;
DRAWTEXT_FIX(1,0.20,0.07,0,’净益率:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.24,0.07,0,CONST(FINANCE(30)/FINANCE(19)*100)),COLORYELLOW;
DRAWTEXT_FIX(1,0.29,0.07,0,’净利同比:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.34,0.07,0,CONST(FINANCE(43))),COLORYELLOW;
DRAWTEXT_FIX(1,0.40,0.07,0,’净利润:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.44,0.07,0,CONST(FINANCE(30)/10000)),COLORYELLOW;
主力筹码估算:=EMA(WINNER(CLOSE)*70,3),NODRAW,LINETHICK0;
散户筹码估算:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3),NODRAW;
散户套牢比率:=散户筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW;
主力控盘比率:=主力筹码估算/(主力筹码估算+散户筹码估算)*100,NODRAW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0,0.13,0,’■ 主力筹码估算:’),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.11,0.13,0,’ %’),COLORMAGENTA;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.08,0.13,0,主力筹码估算),COLORMAGENTA;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.20,0.13,0,’■ 主力控盘比率:’),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.31,0.13,0,’ %’),COLORMAGENTA;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.28,0.13,0,主力控盘比率),COLORMAGENTA;
LC:=REF(CLOSE,1);
WRSI:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
获利筹码:=CONST(WINNER(C)*100);
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和:=(IF(SAT>1,1,SAT)*100);
WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;
活跃:=(WRSI-WR10);
活跃度比:=IF(活跃>=0,(活跃+100)/2,100-ABS((活跃-100)/2));
DRAWTEXT_FIX(1,0.0,0.18,0,STRCAT(STRCAT(‘量能饱和: ‘,CON2STR(量能饱和,2)),’%’)),COLORRED;
DRAWTEXT_FIX(1,0.12,0.18,0,STRCAT(STRCAT(‘活跃度比: ‘,CON2STR(活跃度比,2)),’%’)),COLORRED;
DRAWTEXT_FIX(1,0.24,0.18,0,STRCAT(STRCAT(‘获利筹码: ‘,CON2STR(获利筹码,2)),’%’)),COLORMAGENTA;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址