• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

通达信CCI操盘手副图指标

通达信公式 第一股票指标公式网 1个月前 (08-16) 20次浏览 已收录 0个评论 扫描二维码

M:=14;Q:=6;N:=20;N1:=5;N2:=5;MM:=IF(PERIOD=1,M,IF(PERIOD=2,M,IF(PERIOD=3,M,IF(PERIOD=4,M,IF(PERIOD=5,M,IF(PERIOD=6,Q,IF(PERIOD=7,Q,IF(PERIOD=8,Q,0))))))));AVG:=(HIGH+LOW+CLOSE)/3;CCI:=(AVG-MA(AVG,MM))/(0.015*AVEDEV(AVG,MM));PI:=ATAN(1)*4;PERIODS:=30;HIGHHIGH:=HHV(HIGH,PERIODS);LOWLOW:=LLV(LOW,PERIODS);RANGEV:=25/(HIGHHIGH-LOWLOW)*LOWLOW;EMA34:=EMA(CLOSE,34);X1_EMA34:=0;X2_EMA34:=1;Y1_EMA34:=0;Y2_EMA34:=(REF(EMA34,1)-EMA34)/AVG*RANGEV;C_EMA34:=SQRT((X2_EMA34-X1_EMA34)*(X2_EMA34-X1_EMA34)+(Y2_EMA34-Y1_EMA34)*(Y2_EMA34-Y1_EMA34));ANGLE_EMA34V:=ROUND(ABS(180*ACOS((X2_EMA34-X1_EMA34)/C_EMA34)/PI));ANGLE_EMA34:=IF(Y2_EMA34 > 0,-ANGLE_EMA34V,ANGLE_EMA34V);LSMA25:=FORCAST(CLOSE,25);X1_LSMA25:=0;X2_LSMA25:=1;Y1_LSMA25:=0;Y2_LSMA25:=(REF(LSMA25,1)-LSMA25)/AVG*RANGEV;C_LSMA25:=SQRT((X2_LSMA25-X1_LSMA25)*(X2_LSMA25-X1_LSMA25)+(Y2_LSMA25-Y1_LSMA25)*(Y2_LSMA25-Y1_LSMA25));ANGLE_LSMA25V:=ROUND(ABS(180*ACOS((X2_LSMA25-X1_LSMA25)/C_LSMA25)/PI));ANGLE_LSMA25:=IF(Y2_LSMA25 > 0,-ANGLE_LSMA25V,ANGLE_LSMA25V);ARRAY:=CCI;HIGHBARS:=BARSLAST(NOT(ARRAY > 0));LOWBARS:=BARSLAST(NOT(ARRAY < 0));UPCONDITION:=BARSLAST(HIGHBARS >=6 AND SUM(ARRAY > 100,5) > 0);DNCONDITION:=BARSLAST(LOWBARS >=6 AND SUM(ARRAY < -100,5) > 0);UPTREND:=ARRAY > 0 AND UPCONDITION;DNTREND:=ARRAY < 0 AND UPCONDITION > DNCONDITION;TRTREND:=HIGHBARS >=5 AND NOT(UPTREND) OR LOWBARS >=5 AND NOT(DNTREND);SW:=IF(ABS(ANGLE_EMA34) >=15 AND ABS(ANGLE_EMA34+ANGLE_LSMA25) >=50,IF(ANGLE_LSMA25 > 0,2,-2),IF(ABS(ANGLE_EMA34) >=0 AND (ANGLE_EMA34 >=0 AND ANGLE_LSMA25 >=0 OR ANGLE_EMA34 <=0 AND ANGLE_LSMA25 <=0) AND ABS(ANGLE_EMA34+ANGLE_LSMA25) >=5,IF(ANGLE_LSMA25 > 0,1,-1),0));DIF:CCI-REF(CCI,1),LINETHICK0,COLOR00FF00;前差值:ABS(REF(CCI,1)-REF(CCI,2)),NODRAW;差值20:IF(DIF > 15 AND DIF < 120,DIF,0),NODRAW,COLOR0000FF;STICKLINE(UPTREND,0,CCI,1,0),COLORFF0000;STICKLINE(DNTREND,0,CCI,1,0),COLOR0000FF;STICKLINE(TRTREND,0,CCI,1,0),COLOR00FFFF;STICKLINE(NOT(UPTREND OR DNTREND OR TRTREND),0,CCI,1,0),COLOR808080;WCCI:CCI,LINETHICK2,COLORBLACK;TCCI:(AVG-MA(AVG,N))/(0.015*AVEDEV(AVG,N)),COLOR7A56B7,LINETHICK1;STICKLINE(ANGLE_EMA34 >=5,-301,-321,2,0),COLORD0E040;STICKLINE(ANGLE_EMA34 < 5 AND ANGLE_EMA34 >=3.57,-301,-321,2,0),COLOR006400;STICKLINE(ANGLE_EMA34 < 3.57 AND ANGLE_EMA34 >=2.14,-301,-321,2,0),COLOR98FB98;STICKLINE(ANGLE_EMA34 < 2.14 AND ANGLE_EMA34 >=0.71,-301,-321,2,0),COLOR00FF00;STICKLINE(ANGLE_EMA34 < 0.71 AND ANGLE_EMA34 > -0.71,-301,-321,2,0),COLOR00FFFF;STICKLINE(ANGLE_EMA34 <=-0.71 AND ANGLE_EMA34 > -2.14,-301,-321,2,0),COLORE0FFFF;STICKLINE(ANGLE_EMA34 <=-2.14 AND ANGLE_EMA34 > -3.57,-301,-321,2,0),COLOR00A5FF;STICKLINE(ANGLE_EMA34 <=-3.57 AND ANGLE_EMA34 > -5,-301,-321,2,0),COLOR0000FF;STICKLINE(ANGLE_EMA34 <=-5,-301,-321,2,0),COLOR00008B;STICKLINE(ABS(SW)=2,301,321,2,0),COLOR00FF00;STICKLINE(ABS(SW)=1,301,321,2,0),COLOR00FFFF;STICKLINE(ABS(SW)=0,301,321,2,0),COLOR0000FF;;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址