• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信红绿操盘王主图指标 源码 贴图

通达信公式 第一股票指标公式网 1个月前 (08-16) 30次浏览 已收录 0个评论 扫描二维码

SJ:=1;
DRAWKLINE(H,O,L,C);
Z1:=STRCAT(HYBLOCK,’ ‘);
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,’ ‘);
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
ZK1:(XMA(XMA(H,25),25)*SJ-XMA(XMA(L,25),25))*1*SJ+XMA(XMA(H,25),25)*SJ,LINETHICK1,COLORFF0000;

{ZK1:(XMA(XMA(H,25),25)*SJ-XMA(XMA(L,25),25))*1*SJ+XMA(XMA(H,25),25)*SJ,DOTLINE,COLORBLUE;}
ZD1:XMA(XMA(L,25),25)*SJ-(XMA(XMA(H,25),25)*SJ-XMA(XMA(L,25),25))*1*SJ,LINETHICK2,COLORRED;
ZD2:EMA(ZD1,25)*SJ,COLORFF00FF,LINETHICK3;
DRAWBAND(ZD1*SJ,RGB(55,0,0),ZD2*SJ,RGB(0,91,0));
DRAWKLINE(H,O,L,C);{{www.171415.com}}
{STICKLINE(ZD1*SJ>LOW AND ZD1<HIGH,ZD1,MIN(MIN(OPEN,CLOSE),ZD1),2,0),COLORYELLOW;
STICKLINE(ZD1*SJ>MIN(C,O) AND ZD1<MAX(C,O),ZD1,MIN(OPEN,CLOSE),2,0),COLORYELLOW;
STICKLINE(ZD1*SJ>HIGH,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(ZD1*SJ>HIGH,HIGH,LOW,0,0),COLORYELLOW;}
DRAWTEXT_FIX(1,0.980,20,1,’★{www.171415.com}’),COLORYELLOW;

{HJ:=MAX(MA(C,3),MAX(MAX(MA(C,5),MA(C,10)),MAX(MA(C,30),MA(C,60))));
HJ1:MA(HJ,5),COLORYELLOW,LINETHICK1;
HJ2:MA(HJ,60),COLORYELLOW,LINETHICK2;
MA1:MA(C,30),COLORGREEN,LINETHICK1;
MA2:MA(C,60),COLORYELLOW,LINETHICK2;}
HX:=HHV(HIGH,3);
LX:=LLV(LOW,3);
H1:=IF(HX<REF(HX,1)&&HX<REF(HX,2)&&HX<REF(HX,4)&&LX<REF(LX,1)&&LX<REF(LX,3)&&LX<REF(LX,5)&&OPEN>CLOSE&&(HHV(OPEN,0)-CLOSE)>0,REF(HX,4),0);
L1:=IF(LX>REF(LX,1)&&LX>REF(LX,3)&&LX>REF(LX,5)&&HX>REF(HX,1)&&HX>REF(HX,2)&&HX>REF(HX,4)&&OPEN<CLOSE&&(CLOSE-LLV(OPEN,0))>0,REF(LX,4),0);
H2:=VALUEWHEN(H1>0,H1);
L2:=VALUEWHEN(L1>0,L1);
K1:=IF(CLOSE>H2,-3,IF(CLOSE<L2,1,0));
K2:=VALUEWHEN(K1<>0,K1);
G:=IF(K2=1,H2,L2);
G1:=VALUEWHEN(ISLASTBAR,G);
TMP:=K2;
W1:=K2;
W2:=OPEN-CLOSE;
HT:=IF(OPEN>CLOSE,OPEN,CLOSE);
LT:=IF(OPEN<CLOSE,OPEN,CLOSE);
STICKLINE(W1=1,HIGH,HT,0,0),COLORCYAN;
STICKLINE(W1=1,LOW,LT,0,0),COLORCYAN;
STICKLINE(W1=-3,HIGH,HT,0,0),COLORRED;
STICKLINE(W1=-3,LOW,LT,0,0),COLORRED;
STICKLINE(W1>0,OPEN,CLOSE,3,1),COLORCYAN;
STICKLINE(W1<=0,OPEN,CLOSE,3,1),COLORRED;
STICKLINE(W2>0&&W1<=0,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(W2>0&&W1>0,OPEN,CLOSE,3,0),COLORCYAN;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址