• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

通达信峰谷线主图指标 看压力支撑的主图

通达信公式 第一股票指标公式网 4周前 (08-19) 18次浏览 已收录 0个评论 扫描二维码

LL:=ZIG(3,10)<REFX(ZIG(3,10),1) AND ZIG(3,10)<REF(ZIG(3,10),1);
HH:=ZIG(3,10)>REFX(ZIG(3,10),1) AND ZIG(3,10)>REF(ZIG(3,10),1);
FL:=DYNAINFO(37)>MA(DYNAINFO(37),5);
SY:=H/MAX(C,O)>1;
XY:=MIN(C,O)/L>1.01;
SXZT:=SY AND HH AND FL;
SXGD:=XY AND LL;
ZQ:=BARSLAST(SXZT);
HX:DRAWLINE(SXZT,MAX(C,O),REF(SXZT,1),REF(MAX(C,O),1),1),COLORWHITE,LINETHICK2;
TM:=120082399;
涨停:IF(DATE<TM,ZTPRICE(REF(C,1),IF(FINANCE(3)=4,0.2,IF(NAMEINCLUDE(S),0.05,0.1))),ZTPRICE(REF(C,1),IF(FINANCE(3)>2,0.2,IF(NAMEINCLUDE(S),0.05,0.1)))),NODRAW,COLORRED;
跌停:IF(DATE<TM,DTPRICE(REF(C,1),IF(FINANCE(3)=4,0.2,IF(NAMEINCLUDE(S),0.05,0.1))),DTPRICE(REF(C,1),IF(FINANCE(3)>2,0.2,IF(NAMEINCLUDE(S),0.05,0.1)))),NODRAW,COLORGREEN;
明涨停:IF(DATE<TM,C*IF(FINANCE(3)=4,1.2,IF(NAMEINCLUDE(S),1.05,1.1)),C*(FINANCE(3)>2,1.2,IF(NAMEINCLUDE(S),1.05,1.1))),NODRAW,COLORLIMAGENTA;
明跌停:IF(DATE<TM,C*IF(FINANCE(3)=4,0.8,IF(NAMEINCLUDE(S),0.45,0.9)),C*(FINANCE(3)>2,0.8,IF(NAMEINCLUDE(S),0.45,0.9))),NODRAW,COLORFFFF00;
ZT:=C>=IF(DATE<TM,ZTPRICE(REF(C,1),IF( FINANCE(3)=4,0.2,IF(NAMEINCLUDE(S),0.05,0.1))),ZTPRICE(REF(C,1),IF( FINANCE(3)>2,0.2,IF(NAMEINCLUDE(S),0.05,0.1))));
DT:=C<=IF(DATE<TM,DTPRICE(REF(C,1),IF( FINANCE(3)=4,0.2,IF(NAMEINCLUDE(S),0.05,0.1))),DTPRICE(REF(C,1),IF( FINANCE(3)>2,0.2,IF(NAMEINCLUDE(S),0.05,0.1))));
ZT1:=H>=IF(DATE<TM,ZTPRICE(REF(C,1),IF( FINANCE(3)=4,0.2,IF(NAMEINCLUDE(S),0.05,0.1))),ZTPRICE(REF(C,1),IF( FINANCE(3)>2,0.2,IF(NAMEINCLUDE(S),0.05,0.1)))) AND H>C;
DT1:=L<=IF(DATE<TM,DTPRICE(REF(C,1),IF( FINANCE(3)=4,0.2,IF(NAMEINCLUDE(S),0.05,0.1))),DTPRICE(REF(C,1),IF( FINANCE(3)>2,0.2,IF(NAMEINCLUDE(S),0.05,0.1)))) AND L<C;

JJ:=(C+O+H+L)/4;
AQ:=EMA(JJ,10);
乖离1:=H/AQ,COLORRED,NODRAW;
乖离2:=L/AQ,COLORRED,NODRAW;
DRAWTEXT(乖离1>1.45 AND SY,H,顶背),COLORGREEN;
DRAWTEXT(乖离2<-1.1,L,底背),COLORRED;

STICKLINE(ZT,C,(O+C)/2,3,0),COLOR000099;
STICKLINE(ZT,C,(O+C)/2,2.2,0),COLOR0000CC;
STICKLINE(ZT,C,(O+C)/2,1.5,0),COLOR0000FF;
STICKLINE(ZT,C,(O+C)/2,0.5,0),COLORCC66FF;

STICKLINE(ZT,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(ZT,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(ZT,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(ZT,O,(O+C)/2,0.5,0),COLORFFFFFF;

STICKLINE(DT,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(DT,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(DT,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(DT,O,(O+C)/2,0.5,0),COLORFFFFFF;

STICKLINE(DT,C,(O+C)/2,3,0),COLOR009900;
STICKLINE(DT,C,(O+C)/2,2.2,0),COLOR00BB00;
STICKLINE(DT,C,(O+C)/2,1.5,0),COLOR00DD00;
STICKLINE(DT,C,(O+C)/2,0.5,0),COLOR00FF00;

{曾涨跌停打开K线颜色设置}
STICKLINE(ZT1,C,(O+C)/2,3,0),COLORFF00FF;
STICKLINE(ZT1,C,(O+C)/2,2.2,0),COLORFF00FF;
STICKLINE(ZT1,C,(O+C)/2,1.5,0),COLOR0000FF;

STICKLINE(ZT1,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(ZT1,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(ZT1,O,(O+C)/2,1.5,0),COLORDDDDDD;

STICKLINE(DT1,O,(O+C)/2,3,0),COLOR888888;
STICKLINE(DT1,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(DT1,O,(O+C)/2,1.5,0),COLORDDDDDD;

STICKLINE(DT1,C,(O+C)/2,3,0),COLOR009900;
STICKLINE(DT1,C,(O+C)/2,2.2,0),COLOR00BB00;
STICKLINE(DT1,C,(O+C)/2,1.5,0),COLOR00DD00;
STICKLINE(DT1,C,(O+C)/2,0.5,0),COLOR00FF00;

市值:(FINANCE(40)/100000000),NODRAW,COLORRED;

半分:(C+O)/2,COLORYELLOW,NODRAW;
现价:REFDATE(C,DATE),DOTLINE,COLORLIGRAY;

JYZY1:=(REF(C>=O,1) OR O>REF(H,1)) AND AMOUNT/V/100>REF(C,1) AND C<O;
假阳1:=REF(C<=O,1) AND H<REF(O,1) AND C<(REF(O-C,1))/3+REF(C,1) AND AMOUNT/V/100<REF(C,1) AND C>O;

JYZY:=AMOUNT/V/100>REF(C,1) AND C<O;
假阳:=AMOUNT/V/100<REF(C,1) AND C>O;
STICKLINE(JYZY,O,C,0.5,0),COLORRED;{假阴柱};
STICKLINE(假阳,O,C,0.5,0),COLORLIGREEN;{假阳柱};

阳阴太监:=REF(ZT OR ZT1 ,1) AND (DT OR DT1);

DRAWTEXT(阳阴太监,H,太监),COLORGREEN;

K1:=C>O;

K2:=C>REF(C,1);

K3:=O>=REF(O,1) AND O<=REF(C,1);

K4:=H/C-1<=0.01;K5:=V>REF(V,1);

K6:=SUM(K1,4)=3 AND SUM(K1,3)=3 AND SUM(K2,3)=3 AND SUM(K3,2)=2 AND SUM(K4,3)=3 AND SUM(K5,2)=2;

HSB:=EXIST(L<=LLV(L,20),5) AND EVERY(H>REF(H,1) AND L>REF(L,1) AND C>REF(C,1),3);
DRAWTEXT(K6,L,红三兵),COLORRED;

STICKLINE(K6,O,C,2,0),COLORYELLOW;

MA5:=MA(C,5),COLORWHITE;
MA10:=MA(C,10),COLORYELLOW;
MA20:=MA(C,20),COLORFF00FF;
MA30:=MA(C,30);
MA55:=MA(C,55);
低ZK:=REF(C,1)<MA5 AND REF(C,1)<MA10 AND REF(C,1)<MA20 AND REF(L,1)<MA30 AND REF(L,1)<MA55;
低K:=O<MA5 AND O<MA10 AND O<MA20 AND L<MA30 AND L<MA55;
高K:=C>MA5 AND C>MA10 AND H>MA20 AND H>MA30 AND H>MA55;
HSLZ:=V*10000/FINANCE(46);{{www.171415.com}}

穿多线:=C>REF(C,1)*1.02 AND H<C+0.06 AND (低K OR 低ZK) AND 高K AND V>REF(V,1) AND HSLZ>=1.5;

DRAWTEXT(穿多线,L*0.99,↖一穿五),COLORYELLOW;
VASS1:=HHV(H,60);
VASS2:=LLV(L,60);
VASS3:=REF((VASS1/VASS2-1)*100<=30,1);
AHC1:=C*V;
AHC22:=EMA((EXPMA(AHC1,23)/EXPMA(V,23)+EXPMA(AHC1,54)/EXPMA(V,54)+EXPMA(AHC1,108)/EXPMA(V,108)+EXPMA(AHC1,316)/EXPMA(V,316))/4,34);
通道:=1.0668*AHC22;
起爆:=CROSS(C,通道) AND REF(C,1)*1.05-C<0.005 AND C>O*0.5;
VARR1:=V;
VARR2:=VARR1>MA(V,89);
VARR3:=EXPMA(C,5);
VARR4:=EXPMA(C,29);
VARR5:=VARR3>VARR4;
LC:=REF(C,1);
RSI1:=SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),12,1)*100;
RSI2:=SMA(MAX(C-LC,0),56,1)/SMA(ABS(C-LC),56,1)*100;
VARR6:=RSI1>RSI2 AND VARR5 AND VARR2 AND C>REF(HHV(H,60),1);

黑马起爆:=起爆 AND VARR6 AND VASS3,COLORFF00FF,LINETHICK2;

DRAWTEXT(黑马起爆,L,↖黑马1号),COLORFF00FF;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址