• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信跟庄回踩主图指标公式

通达信公式 第一股票指标公式网 1个月前 (08-19) 28次浏览 已收录 0个评论 扫描二维码

MA480:MA(C,480);
TJ360:=C=HHV(C,150);{黑马线}
TS360:=BARSLAST(TJ360);
HHC360:=REF(C,TS360);
RHHC360:=REF(HHC360,1);
TJ1360:=H>L AND C>RHHC360 ;
CS1360:=BARSLASTCOUNT(TJ1360);
CSS:=COUNT(CS1360=1,60);
MR:=CS1360=1 AND CSS=1;
STICKLINE(MR,O,C,3,0),COLORBLUE;
DRAWTEXT(MR,L,’黑马线’),COLORYELLOW;
HMXTS:=BARSLAST(MR);
黑马线:CONST(REF(C,HMXTS)),COLORFFFF00,LINETHICK2;
高D:=REF(HHV(H,72),5);
龙门:REFDATE(高D,DATE),COLORWHITE,LINETHICK2;
TM:=1200823;
涨停:IF(DATE<TM,ZTPRICE(REF(C,1),IF(CODELIKE(‘688’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1))),ZTPRICE(REF(C,1),IF(CODELIKE(‘688’) OR CODELIKE(‘300’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1)))),NODRAW,COLORRED;
跌停:IF(DATE<TM,DTPRICE(REF(C,1),IF(CODELIKE(‘688’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1))),DTPRICE(REF(C,1),IF(CODELIKE(‘688’) OR CODELIKE(‘300’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1)))),NODRAW,COLORGREEN;
明涨停:IF(DATE<TM,C*IF(CODELIKE(‘688’),1.2,IF(NAMEINCLUDE(‘S’),1.05,1.1)),C*(IF(CODELIKE(‘688’) OR CODELIKE(‘300’),1.2,IF(NAMEINCLUDE(‘S’),1.05,1.1)))),NODRAW,COLORLIMAGENTA;
明跌停:IF(DATE<TM,C*IF(CODELIKE(‘688’),0.8,IF(NAMEINCLUDE(‘S’),0.45,0.9)),C*(IF(CODELIKE(‘688’) OR CODELIKE(‘300’),0.8,IF(NAMEINCLUDE(‘S’),0.45,0.9)))),NODRAW,COLORFFFF00;
ZT:=C=涨停 AND PERIOD=5 AND H=C;
ZT1:=H=涨停 AND PERIOD=5 AND H>C;
DT:=C=跌停 AND PERIOD=5 AND L=C;
DT1:=L=跌停 AND PERIOD=5 AND L<C;
DRAWTEXT(CURRBARSCOUNT=1,L*0.995,EXTERNSTR(0,4)); { 涨停原因}
半分:(O+C)/2,NODRAW;
昨半:REF((O+C)/2,1),NODRAW,COLORYELLOW;
STICKLINE(ISLASTBAR,昨半,昨半,8,2),COLORLIRED;
LB:=REF(EVERY(ZT,3),2) AND REF(H=HHV(H,20),1) AND H<REF(H,1);
LBQ:=BARSLAST(LB);
打折:=REF(H,LBQ+1)*0.7,NODRAW,COLORWHITE;
STICKLINE(打折,打折,打折,5,0),COLORFFFF44;
Q3:=STRCAT(CON2STR(打折,2),’打折线’);
DRAWTEXT(ISLASTBAR,打折,VARCAT(VARCAT(‘打折线’,VAR2STR(打折,2)),’元’))COLORFFFF00;
基柱:=C>REF(C,1)*1.05 AND V>=REF(V,1)*1.85;
周期:=BARSLAST(基柱);
STICKLINE(基柱,O,C,2.8,0),COLORFF00FF;
DRAWLINE(基柱,C,REF(基柱,1),REF(C,1),1),COLORWHITE,DOTLINE;
DRAWLINE(基柱,O,REF(基柱,1),REF(O,1),1),COLORLIGREEN,DOTLINE;
小K:=BETWEEN(C,REF(C,1)*0.98,REF(C,1)*1.02);
买点1:=小K AND BETWEEN(周期,3,100) AND BETWEEN(L, REF(C,周期)*0.99,REF(C,周期)*1.005) AND V<=REF(V,1)*0.85;
DRAWICON(买点1,MIN(C,O),7);
买点2:=小K AND BETWEEN(周期,3,100) AND BETWEEN(L, REF(L,周期),REF(L,周期)*1.01) AND V<=REF(V,1)*0.85;
DRAWICON(买点2,MIN(C,O),1);
买点3:=EXIST(买点1 OR 买点2,60) AND CROSS(C,REF(H,周期));
DRAWICON(买点3,MIN(C,O),13);
{涨停K线颜色设置}
STICKLINE(ZT,C,(O+C)/2,3,0),COLOR000099;
STICKLINE(ZT,C,(O+C)/2,2.2,0),COLOR0000CC;
STICKLINE(ZT,C,(O+C)/2,1.5,0),COLOR0000FF;
STICKLINE(ZT,C,(O+C)/2,0.5,0),COLORCC66FF;
STICKLINE(ZT,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(ZT,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(ZT,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(ZT,O,(O+C)/2,0.5,0),COLORFFFFFF;
STICKLINE(DT,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(DT,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(DT,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(DT,O,(O+C)/2,0.5,0),COLORFFFFFF;
STICKLINE(DT,C,(O+C)/2,3,0),COLOR009900;
STICKLINE(DT,C,(O+C)/2,2.2,0),COLOR00BB00;
STICKLINE(DT,C,(O+C)/2,1.5,0),COLOR00DD00;
STICKLINE(DT,C,(O+C)/2,0.5,0),COLOR00FF00;
{曾涨跌停打开K线颜色设置}
STICKLINE(ZT1 AND C>=O,H,L,0,0),COLORRED;
STICKLINE(ZT1 AND C<O,H,L,0,0),COLORLIBLUE;
STICKLINE(DT1 AND C>=O,H ,L,0,0),COLORRED;
STICKLINE(DT1 AND C<O,H,L,0,0),COLORLIBLUE;
STICKLINE(ZT1,C,(O+C)/2,3,0),COLORFF00FF;
STICKLINE(ZT1,C,(O+C)/2,2.2,0),COLORFF00FF;
STICKLINE(ZT1,C,(O+C)/2,1.5,0),COLOR0000FF;
STICKLINE(ZT1,C,(O+C)/2,0.5,0),COLORCC66FF;
STICKLINE(ZT1,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(ZT1,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(ZT1,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(ZT1,O,(O+C)/2,0.5,0),COLORFFFFFF;
STICKLINE(DT1,O,(O+C)/2,2.5,0),COLOR888888;
STICKLINE(DT1,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(DT1,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(DT1,O,(O+C)/2,0.5,0),COLORFFFFFF;
STICKLINE(DT1,C,(O+C)/2,2.5,0),COLOR009900;
STICKLINE(DT1,C,(O+C)/2,2.2,0),COLOR00BB00;
STICKLINE(DT1,C,(O+C)/2,1.5,0),COLOR00DD00;
STICKLINE(DT1,C,(O+C)/2,0.5,0),COLOR00FF00;
假阴:=REF(C>=O,1) AND AMOUNT/V/100>REF(C,1) AND C<O;
假阳:=REF(C<=O,1) AND H<REF(O,1) AND C<(REF(O-C,1))/3+REF(C,1) AND AMOUNT/V/100<REF(C,1) AND C>O;
STICKLINE(假阴,O,C,0.2,0),COLORRED;{假阴柱};
STICKLINE(假阳,O,C,0.7,0),COLORLIGREEN;{假阳柱};
首板:=ZT AND COUNT(ZT,2)=1;
二板:=REF(首板,1) AND ZT;
三板:=REF(二板,1) AND ZT;
四板:=REF(三板,1) AND ZT;
五板:=REF(四板,1) AND ZT;
六板:=REF(五板,1) AND ZT;
七板:=REF(六板,1) AND ZT;
八板:=REF(七板,1) AND ZT;
九板:=REF(八板,1) AND ZT;
十板:=REF(九板,1) AND ZT;
DRAWTEXT(首板,0.1+(C+O)/2,’1′),COLORWHITE;
DRAWTEXT(二板,0.1+(C+O)/2,’2′),COLORYELLOW;
DRAWTEXT(三板,0.1+(C+O)/2,’3′),COLOR00CC99;
DRAWTEXT(四板,0.1+(C+O)/2,’4′),COLORGREEN;
DRAWTEXT(五板,0.1+(C+O)/2,’5′),COLORLIGRAY;
DRAWTEXT(六板,0.1+(C+O)/2,’6′),COLORLIRED;
DRAWTEXT(七板,0.1+(C+O)/2,’7′),COLORLIBLUE;
DRAWTEXT(八板,0.1+(C+O)/2,’8′),COLORBLUE;
DRAWTEXT(九板,0.1+(C+O)/2,’9′),COLORWHITE;
DRAWTEXT(十板,0.1+(C+O)/2,’10’),COLORYELLOW;
月:REF(O,BARSLAST(MONTH!=REF(MONTH,1))),COLORRED,NODRAW;
STICKLINE(C>月,月,月,5,0),COLORRED;
STICKLINE(C<月,月,月,5,0),COLORFFFF00;
STICKLINE(C=月,月,月,5,0),COLORWHITE;
收阴:=(C<REF(C,1) OR L<REF(L,1) OR AMOUNT/V/100<REF((C+O)/2,1)) AND O<=REF(C,1);
多阴:=EVERY(收阴,2);
小阳:=O-L<=0.03 AND H>C AND C>O AND O<REF(C,1) AND C<REF(MAX(C,O),1) AND V<REF(V,1);
宝莲灯:=REF(多阴,1) AND 小阳;
STICKLINE(宝莲灯,O,C,2.5,0),COLORCC22FF;
STICKLINE(宝莲灯,(O+C)/2-0.007,(O+C)/2+0.007,1,0),COLORWHITE;
A1:=EMA(C,12)-EMA(C,25);
A2:=EMA(A1,6);
获利回吐:=(A2>=0)*A2,COLORWHITE,LINETHICK0;
大黑马:=(A2<0)*A2,COLORD4FF7F,LINETHICK0;
坚绝做空:=(A1<0)*A1,COLORB00058,LINETHICK0;
买入持股:=(A1>=0)*A1,COLORRED,LINETHICK0;
VAR8:=VOL>2*MA(VOL,30);
VARB:=CLOSE>MA(CLOSE,30) AND CLOSE<MA(CLOSE,30)*1.04;
VARC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);
VARD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))<BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));
VARF:=TROUGHBARS(3,15,1)<4;
VAR10:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);
VAR11:=IF(VARF=1,50,0);
多空:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE;
STICKLINE(FILTER(VARF=1,5) AND 多空<-10,C,O,2.8,0),COLORF00FF0;
STICKLINE(FILTER(VARF=1,5),(C+O)*0.5-0.007,(C+O)*0.5+0.007,1,0),COLORBLACK;
DRAWTEXT(FILTER(VARF=1,3),L,’黑马’),COLORRED ;
VAR121:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR141:=ZIG(3,25)<REF(ZIG(3,25),1) AND REF(ZIG(3,25),1)>=REF(ZIG(3,25),2) AND REF(ZIG(3,25),2)>=REF(ZIG(3,25),3);
VAR161:=ZIG(3,55)<REF(ZIG(3,55),1) AND REF(ZIG(3,55),1)>=REF(ZIG(3,55),2) AND REF(ZIG(3,55),2)>=REF(ZIG(3,55),3);
VAR181:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
卖:=VAR121+VAR141+VAR161+VAR181;
DRAWLINE(卖,O,BARSLAST(卖)>=1,REF(O,BARSLAST(卖)),1),COLORYELLOW,LINETHICK2;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址