• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信卧龙战法副图指标

通达信公式 第一股票指标公式网 1个月前 (08-19) 34次浏览 已收录 0个评论 扫描二维码

{定义}

{参数M:=5}
警示:=NAMEINCLUDE(S);
W:=IF(NAMELIKE(W) OR NAMELIKE(*W),0.05,0.1);
ZT:=C>=ZTPRICE(REF(C,1),IF(警示,0.05,0.099));
DT:=(REF(C,1)/C-1>=W-0.01/REF(C,1) AND L=C AND PERIOD=5) OR C=DTPRICE(REF(C,1),IF(警示,0.05,0.1));
DT1:=REF(C,1)/L-1>=W-0.01/REF(C,1) AND L<C AND PERIOD=5;

{卧龙湾}

连阴:=COUNT((C<REF(C,1) OR L<REF(L,1)),10)>=5;
卧龙柱:=REF(连阴,1) AND (DT OR DT1);

距今:=BARSLAST(卧龙柱);

卧龙湾:=HHV(C,距今)<REF((C+O)/2,距今) AND 距今<15 ;

{黄金坑}
假阳:=REF(C<=O,1) AND H<REF(O,1) AND C<(REF(O-C,1))/3+REF(C,1) AND AMOUNT/V/100<REF(C,1) AND C>O;
黄金阳:REF(DT OR DT1,1) AND 假阳,COLORYELLOW,LINETHICK2;

阳距:=BARSLAST(黄金阳);

黄金坑:=HHV(C,阳距)<REF((C+O)/2,阳距+1) AND 阳距<15 ;

卧龙潜:=黄金坑 OR 卧龙湾,COLORWHITE;

SY:=H/MAX(C,O);
XY:=MIN(C,O)/L;

卧龙深潜:卧龙潜 AND C>O AND XY>1.02 AND SY<1.015,COLORFFFF00,LINETHICK2;

ADA:=(HIGH+LOW+CLOSE)/3;
下:=-100*(0.015*AVEDEV(ADA,14))+MA(ADA,14);
买入:=CROSS(C,下);

潜龙飞天:EXIST(卧龙潜,10) AND 买入,LINETHICK2;
月线:=WMA(C,21);{{www.171415.com}}
月角:=ATAN((WMA(C,21)/REF(WMA(C,21),1)-1)*100)*180/3.1416;
卧龙出水:HHV(C,距今)<=REF((C+O)*0.5,距今) AND CROSS(C,月线) AND 月角>-20 AND 距今<30,NODRAW;

STICKLINE(卧龙出水,0,0.2,2,0),COLORLIBLUE;
STICKLINE(卧龙出水,0.2,0.4,2,0),COLORYELLOW;
STICKLINE(卧龙出水,0.4,0.6,2,0),COLORLIMAGENTA;

卧龙根:CROSS(C,REF((C+O)/2,距今)) AND BETWEEN(距今,1,20),COLORLIMAGENTA,LINETHICK2;

再龙根:COUNT(CROSS(C,REF((C+O)/2,距今)),距今)=2 AND CROSS(C,REF((C+O)/2,距今)),COLORRED,LINETHICK2;

{过峰}

AQA:=REF(H,M)=HHV(H,2*M+1);
QY:=BACKSET(AQA,M+1);
峰顶:=FILTER(QY,M) AND H=HHV(H,M+1);
峰距:=BARSLAST(峰顶);

过峰:ZT AND CROSS(C,REF(H,峰距)),LINETHICK2E;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址