• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

通达信生死界主图指标公式

通达信公式 第一股票指标公式网 4周前 (08-19) 24次浏览 已收录 0个评论 扫描二维码

DRAWGBK(C>0,RGB(0,0,0),RGB(00,0,0),0,’BJT8′,0);
阴线:=C<O;
STICKLINE(阴线,O,C,2.8,0),COLOR009933;
STICKLINE(阴线,H,L,0,0),COLOR009933;
阳线:=C>O;
STICKLINE(阳线,O,C,2.8,1),COLOR0000CC;
STICKLINE(阳线,C,H,0,1),COLOR0000CC;
STICKLINE(阳线,O,L,0,1),COLOR0000CC;
十字线:=C=O AND H>L;
STICKLINE(十字线,O,C,2.8,1),COLORWHITE;
STICKLINE(十字线,L,H,0,1),COLORWHITE;
现价:=REFDATE(C,DATE),DOTLINE,COLORLIGRAY;
昨半:REF((C+O)/2,1),NODRAW;
半分:(C+O)/2,NODRAW,COLORWHITE;
高H:=REF(HHV(H,72),5);
龙门:REFDATE(高H,DATE),COLORWHITE,LINETHICK2;
{以下是主题特色参数}
N:=100;
高1:=REFDATE(HHV(H,N),DATE);
低1:=REFDATE(LLV(L,N),DATE);
高:=REF(HHV(H,N),DATE);
低:=REF(LLV(L,N),DATE);
HH1:=高1-(高1-低1)*0.191;
HH2:=高1-(高1-低1)*0.382;
HH3:=高1-(高1-低1)*0.5;
HH4:=高1-(高1-低1)*0.618;
HH5:=高1-(高1-低1)*0.809;
一809:REFDATE(HH1,DATE),COLOR444444,DOTLINE;
二618:REFDATE(HH2,DATE),COLOR444444,DOTLINE;
生死界:REFDATE(HH3,DATE),COLORRED,DOTLINE;
四382:REFDATE(HH4,DATE),COLOR444444,DOTLINE;
五191:REFDATE(HH5,DATE),COLOR444444,DOTLINE;
DRAWNUMBER(ISLASTBAR,一809,一809),COLORYELLOW;
DRAWNUMBER(ISLASTBAR,二618,二618),COLORYELLOW;
DRAWNUMBER(ISLASTBAR,生死界,生死界),COLORRED;
DRAWNUMBER(ISLASTBAR,四382,四382),COLORYELLOW;
DRAWNUMBER(ISLASTBAR,五191,五191),COLORYELLOW;
TM:=1200823;
涨停:IF(DATE<TM,ZTPRICE(REF(C,1),IF(CODELIKE(‘688’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1))),ZTPRICE(REF(C,1),IF(CODELIKE(‘688’) OR CODELIKE(‘300’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1)))),NODRAW,COLORRED;
跌停:IF(DATE<TM,DTPRICE(REF(C,1),IF(CODELIKE(‘688’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1))),DTPRICE(REF(C,1),IF(CODELIKE(‘688’) OR CODELIKE(‘300’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1)))),NODRAW,COLORGREEN;
明涨停:IF(DATE<TM,C*IF(CODELIKE(‘688’),1.2,IF(NAMEINCLUDE(‘S’),1.05,1.1)),C*(IF(CODELIKE(‘688’) OR CODELIKE(‘300’),1.2,IF(NAMEINCLUDE(‘S’),1.05,1.1)))),NODRAW,COLORLIMAGENTA;
明跌停:IF(DATE<TM,C*IF(CODELIKE(‘688’),0.8,IF(NAMEINCLUDE(‘S’),0.45,0.9)),C*(IF(CODELIKE(‘688’) OR CODELIKE(‘300’),0.8,IF(NAMEINCLUDE(‘S’),0.45,0.9)))),NODRAW,COLORFFFF00;
ZT:=C=涨停 AND PERIOD=5 AND H=C;
ZT1:=H=涨停 AND PERIOD=5 AND H>C;
DT:=C=跌停 AND PERIOD=5 AND L=C;
DT1:=L=跌停 AND PERIOD=5 AND L<C;
{涨停K线颜色设置}
STICKLINE(ZT,C,(O+C)/2,3,0),COLOR000099;
STICKLINE(ZT,C,(O+C)/2,2.2,0),COLOR0000CC;
STICKLINE(ZT,C,(O+C)/2,1.5,0),COLOR0000FF;
STICKLINE(ZT,C,(O+C)/2,0.5,0),COLORCC66FF;
STICKLINE(ZT,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(ZT,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(ZT,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(ZT,O,(O+C)/2,0.5,0),COLORFFFFFF;
STICKLINE(DT,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(DT,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(DT,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(DT,O,(O+C)/2,0.5,0),COLORFFFFFF;
STICKLINE(DT,C,(O+C)/2,3,0),COLOR009900;
STICKLINE(DT,C,(O+C)/2,2.2,0),COLOR00BB00;
STICKLINE(DT,C,(O+C)/2,1.5,0),COLOR00DD00;
STICKLINE(DT,C,(O+C)/2,0.5,0),COLOR00FF00;
{曾涨跌停打开K线颜色设置}
STICKLINE(ZT1,C,(O+C)/2,3,0),COLORFF00FF;
STICKLINE(ZT1,C,(O+C)/2,2.2,0),COLORFF00FF;
STICKLINE(ZT1,C,(O+C)/2,1.5,0),COLOR0000FF;
STICKLINE(ZT1,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(ZT1,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(ZT1,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(DT1,O,(O+C)/2,3,0),COLOR888888;
STICKLINE(DT1,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(DT1,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(DT1,C,(O+C)/2,3,0),COLOR009900;
STICKLINE(DT1,C,(O+C)/2,2.2,0),COLOR00BB00;
STICKLINE(DT1,C,(O+C)/2,1.5,0),COLOR00DD00;
STICKLINE(DT1,C,(O+C)/2,0.5,0),COLOR00FF00;
DRAWTEXT(ZT AND DT1 AND PERIOD=5,L-0.03,’地天板’),COLORCC00CC;{从跌停到涨停}
DRAWTEXT(DT AND ZT1 AND PERIOD=5,H+0.03,’天地板’),COLOR00CC00;{从涨停到跌停};
DRAWTEXT(DT1,L-0.09,’撬板’),COLORCC00CC;{从涨停到跌停};
DRAWTEXT(ZT1,H+0.03,’炸板’),COLOR00CC00;{从涨停到跌停};
假阴:=REF(C>=O,1) AND AMOUNT/V/100>REF(C,1) AND C<O;
假阳:=REF(C<=O,1) AND H<REF(O,1) AND C<(REF(O-C,1))/3+REF(C,1) AND AMOUNT/V/100<REF(C,1) AND C>O;
STICKLINE(假阴,O,C,0.2,0),COLORRED;{假阴柱};
STICKLINE(假阳,O,C,0.7,0),COLORLIGREEN;{假阳柱};
连阴:=COUNT((C<REF(C,1) OR L<REF(L,1)),10)>=5;
间谍柱:=REF(连阴,1) AND (DT OR DT1) ;
DRAWLINE(间谍柱,(C+O)/2,REF(间谍柱,1),REF((C+O)/2,1),1),COLOR55FFCC;
STICKLINE(L>REF(H,1),L-0.02,REF(H,1)+0.02,3,0),COLORLIGRAY;
STICKLINE(REF(L,1)>H,REF(L,1)-0.02,H+0.02,3,0),COLORLIGRAY;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址