• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信跟庄EXPMA主图指标 源码 贴图

通达信公式 第一股票指标公式网 1个月前 (08-21) 200次浏览 已收录 0个评论 扫描二维码

EXP1:EMA(CLOSE,M1);
EXP2:EMA(CLOSE,M2);
DRAWICON(CROSS(EXP1,EXP2),MIN(L,MIN(EXP1,EXP2)),7),COLORYELLOW;
乖离率:H/EXP2,NODRAW,COLORLIGREEN;
DRAWICON(FILTER(乖离率>=1.1 AND H>C,5),H*1.02,8);
DRAWICON(FILTER(乖离率<=0.85 AND C>L,5),L*0.98,7);
Z1:=STRCAT(HYBLOCK,’ ‘);
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,’ ‘);
DRAWTEXT_FIX(ISLASTBAR,0,10,0,STRCAT(Z3,GNBLOCK)),COLOR0000FF;现价:REFDATE(C,DATE),DOTLINE,COLORLIGRAY;
 DRAWTEXT_FIX(1,0.00,0.00,0,’主题投资:’)COLOR0000FF;
DRAWTEXT_FIX(1,0.06,0.00,0,EXTERNSTR(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.06,0,’主营业务:’)COLORFF00FF;
DRAWTEXT_FIX(1,0.06,0.06,0,EXTERNSTR(0,2))COLORFF00FF;
TM:=1200823;
涨停:IF(DATE<TM,ZTPRICE(REF(C,1),IF(CODELIKE(‘688’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1))),ZTPRICE(REF(C,1),IF(CODELIKE(‘688’) OR CODELIKE(‘300’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1)))),NODRAW,COLORRED;
跌停:IF(DATE<TM,DTPRICE(REF(C,1),IF(CODELIKE(‘688’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1))),DTPRICE(REF(C,1),IF(CODELIKE(‘688’) OR CODELIKE(‘300’),0.2,IF(NAMEINCLUDE(‘S’),0.05,0.1)))),NODRAW,COLORGREEN;
明涨停:=IF(DATE<TM,C*IF(CODELIKE(‘688’),1.2,IF(NAMEINCLUDE(‘S’),1.05,1.1)),C*(IF(CODELIKE(‘688’) OR CODELIKE(‘300’),1.2,IF(NAMEINCLUDE(‘S’),1.05,1.1)))),NODRAW,COLORLIMAGENTA;
明跌停:=IF(DATE<TM,C*IF(CODELIKE(‘688’),0.8,IF(NAMEINCLUDE(‘S’),0.45,0.9)),C*(IF(CODELIKE(‘688’) OR CODELIKE(‘300’),0.8,IF(NAMEINCLUDE(‘S’),0.45,0.9)))),NODRAW,COLORFFFF00;ZT:=C>=涨停 AND PERIOD=5 AND H=C;
ZT1:=H>=涨停 AND PERIOD=5 AND H>C;
DT:=C<=跌停 AND PERIOD=5 AND L=C;
DT1:=L<=跌停 AND PERIOD=5 AND L<C;
{涨停K线颜色设置}
STICKLINE(ZT,C,(O+C)/2,3,0),COLOR000099;
STICKLINE(ZT,C,(O+C)/2,2.2,0),COLOR0000CC;
STICKLINE(ZT,C,(O+C)/2,1.5,0),COLOR0000FF;
STICKLINE(ZT,C,(O+C)/2,0.5,0),COLORCC66FF;STICKLINE(ZT,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(ZT,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(ZT,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(ZT,O,(O+C)/2,0.5,0),COLORFFFFFF;STICKLINE(DT,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(DT,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(DT,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(DT,O,(O+C)/2,0.5,0),COLORFFFFFF;STICKLINE(DT,C,(O+C)/2,3,0),COLOR009900;
STICKLINE(DT,C,(O+C)/2,2.2,0),COLOR00BB00;
STICKLINE(DT,C,(O+C)/2,1.5,0),COLOR00DD00;
STICKLINE(DT,C,(O+C)/2,0.5,0),COLOR00FF00;{曾涨跌停打开K线颜色设置}
STICKLINE(ZT1,C,(O+C)/2,3,0),COLORFF00FF;
STICKLINE(ZT1,C,(O+C)/2,2.2,0),COLORFF00FF;
STICKLINE(ZT1,C,(O+C)/2,1.5,0),COLOR0000FF;
STICKLINE(ZT1,O,(O+C)/2,3,0),COLOR999999;
STICKLINE(ZT1,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(ZT1,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(DT1,O,(O+C)/2,3,0),COLOR888888;
STICKLINE(DT1,O,(O+C)/2,2.2,0),COLORBBBBBB;
STICKLINE(DT1,O,(O+C)/2,1.5,0),COLORDDDDDD;
STICKLINE(DT1,C,(O+C)/2,3,0),COLOR009900;
STICKLINE(DT1,C,(O+C)/2,2.2,0),COLOR00BB00;
STICKLINE(DT1,C,(O+C)/2,1.5,0),COLOR00DD00;
STICKLINE(DT1,C,(O+C)/2,0.5,0),COLOR00FF00;LB:=REF(EVERY(ZT,3),2) AND REF(H=HHV(H,20),1) AND H<REF(H,1);
LBQ:=BARSLAST(LB);
打折:=REF(H,LBQ+1)*0.667,NODRAW,COLORWHITE;
SLB:=EVERY(ZT,3);
KK2:=SUMBARS(REFX(SLB,1),1);
STICKLINE(KK2,REF(C,KK2-1),REF(C,KK2-1),5,0),COLORFFCC99;
龙回头天数:=SUMBARS(REFX(SLB,1),1)-2,NODRAW,COLORFF00FF;TT:=DRAWTEXT(REFX(NOT(ZT),1) AND SLB,REF(C,1),’回头线’);
STICKLINE(打折,打折,打折,5,0),COLORFFFF44;
Q3:=STRCAT(CON2STR(打折,2),’打折线’);
DRAWTEXT(ISLASTBAR,打折,VARCAT(VARCAT(‘打折价’,VAR2STR(打折,2)),’元’))COLORFFFF00;假阴:=AMOUNT/V/100>REF(C,1) AND C<O;
假阳:=AMOUNT/V/100<REF(C,1) AND C>O;
STICKLINE(假阴,O,C,0.2,0),COLORRED;{假阴柱};
STICKLINE(假阳,O,C,0.7,0),COLORLIGREEN;{假阳};流通市值:(FINANCE(40)/100000000),NODRAW,COLORYELLOW;ZTT:=BARSLAST(ZT);DRAWTEXT(ZTT=2,L*0.99,’2′),COLORYELLOW;
DRAWTEXT(ZTT=4,L*0.99,’4′),COLORYELLOW;
DRAWTEXT(ZTT=6,L*0.99,’6′),COLORYELLOW;
DRAWTEXT(ZTT=8,L*0.99,’8′),COLORYELLOW;
DRAWTEXT(ZTT=10,L*0.99,’10.’),COLORYELLOW;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
MA55:=MA(C,55);
低ZK:=REF(C,1)<MA5 AND REF(C,1)<MA10 AND REF(C,1)<MA20 AND REF(L,1)<MA30 AND REF(L,1)<MA55;
低K:=O<MA5 AND O<MA10 AND O<MA20 AND L<MA30 AND L<MA55;
高K:=C>MA5 AND C>MA10 AND H>MA20 AND H>MA30 AND H>MA55;
HSLZ:=V*10000/FINANCE(46);{{www.171415.com}}穿多线:=C>REF(C,1)*1.02 AND H<C+0.06 AND (低K OR 低ZK) AND 高K AND V>REF(V,1) AND HSLZ>=1.5;DRAWTEXT(穿多线,L*0.99,’↖一穿五’),COLORYELLOW;
VASS1:=HHV(H,60);
VASS2:=LLV(L,60);
VASS3:=REF((VASS1/VASS2-1)*100<=30,1);
AHC1:=C*V;
AHC22:=EMA((EXPMA(AHC1,23)/EXPMA(V,23)+EXPMA(AHC1,54)/EXPMA(V,54)+EXPMA(AHC1,108)/EXPMA(V,108)+EXPMA(AHC1,316)/EXPMA(V,316))/4,34);
通道:=1.0668*AHC22;
起爆:=CROSS(C,通道) AND REF(C,1)*1.05-C<0.005 AND C>O*0.5;
VARR1:=V;
VARR2:=VARR1>MA(V,89);
VARR3:=EXPMA(C,5);
VARR4:=EXPMA(C,29);
VARR5:=VARR3>VARR4;
LC:=REF(C,1);
RSI1:=SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),12,1)*100;
RSI2:=SMA(MAX(C-LC,0),56,1)/SMA(ABS(C-LC),56,1)*100;
VARR6:=RSI1>RSI2 AND VARR5 AND VARR2 AND C>REF(HHV(H,60),1);
黑马起爆:=起爆 AND VARR6 AND VASS3,COLORFF00FF,LINETHICK2;DRAWTEXT(黑马起爆,L,’↖黑马1号’),COLORFF00FF;
DGT:=(CROSS(C,MA55) OR (REF(C,1)<MA55 AND C>=MA55)) AND C>MA5 AND C>MA10 AND C>MA20 AND MA20<MA55,NODRAW;DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2,COLORSTICK;主升启动:COUNT(DGT,40)>=1 AND DGT AND MACD>0 AND DIF>DEA,COLORYELLOW,LINETHICK2;
DRAWTEXT(主升启动,MA20,’主升’),COLORYELLOW;
阴阳皇帝:=EXIST(L=LLV(L,10),3) AND REF(DT OR DT1,1) AND (ZT1 OR ZT);
DRAWTEXT(阴阳皇帝,L*0.97,’皇帝’),COLORFFFFFF;
{板块排名 运行慢,暂时不用}
{TAX:=HORCALC(HYBLOCK,105,1,DRAWNULL);}
{TAA:=STRCAT(HYBLOCK,’ 排名 :’);}
{DRAWTEXT_FIX(ISLASTBAR,0.70,0.005,0,STRCAT(TAA,CON2STR(TAX,0)));};


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址