• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信短线皇帝主图指标公式

通达信公式 第一股票指标公式网 2个月前 (11-21) 23次浏览 已收录 0个评论 扫描二维码

DRAWGBK(C>O,RGB(8,28,47),RGB(0,0,0),0,’1′,0);DRAWKLINE(H,O,L,C);长期循环线:ema(C,68)COLORLICYAN,LINETHICK1,CIRCLEDOT;IF(长期循环线>REF(长期循环线,1),长期循环线,DRAWNULL),COLORRED,LINETHICK1,CIRCLEDOT;IF(长期循环线<REF(长期循环线,1),长期循环线,DRAWNULL),COLORLICYAN,LINETHICK1,CIRCLEDOT;操作线:Ema(C,12),COLORLICYAN,LINETHICK2;IF(操作线>REF(操作线,1),操作线,DRAWNULL),COLORYELLOW,LINETHICK2;IF(操作线<REF(操作线,1),操作线,DRAWNULL),COLORLICYAN,LINETHICK2;MA8:EMA(C,23),COLORRED,POINTDOT;IF(MA8<REF(MA8,1),MA8,DRAWNULL),COLORGREEN,POINTDOT;MA9:EMA(C,25),COLORRED,POINTDOT;IF(MA9<REF(MA9,1),MA9,DRAWNULL),COLORGREEN,POINTDOT;短循环线:EMA(C,24),COLORRED,DOTLINE;IF(短循环线>REF(短循环线,1),短循环线,DRAWNULL),COLORRED,DOTLINE;IF(短循环线<REF(短循环线,1),短循环线,DRAWNULL),COLORGREEN,DOTLINE;{基本面}总股本:=stRCAT(STRCAT(‘总股本: ‘,CON2STR(TOTALCAPITAL/1000000,2)),’亿’);流通盘:=STRCAT(STRCAT(‘ 流通盘: ‘,CON2STR(CAPITAL/1000000,2)),’亿’);市值:=STRCAT(STRCAT(‘ 流通市值: ‘,CON2STR((CAPITAL/1000000)*C,2)),’亿’);上市日期:=STRCAT(‘ 上市天数: ‘,CON2STR(FINANCE(42),0));股本市值:=STRCAT(‘股本市值: ‘,STRCAT(STRCAT(STRCAT(总股本,流通盘),市值),上市日期));DRAWTEXT_FIX(ISLASTBAR,0.02,0.06,0,股本市值),COLORGRAY;DRAWTEXT_FIX(ISLASTBAR=1 ,0.295,0.01,1,’【 操作原则 】: 小三线顺上短线做多;五线顺上中线做多 ‘),COLORLIGRAY;{所属板块、概念}DRAWTEXT_FIX(1,0.02,0.115,0,’行业地域:’),COLORGRAY;DRAWTEXT_FIX(1,0.07,0.115,0,HYBLOCK),COLORGRAY;{所属行业}DRAWTEXT_FIX(1,0.12,0.115,0,GNBLOCK),COLORGRAY;{所属概念};AAA:=(3*C+H+L+O)/6;VAR1AA:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;波段线:VAR1AA,COLORRED,LINETHICK1;{<<波段绝品>>} SHORT:=12;LONG:=26;MID:=9;dif:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);DEA:=EMA(DIF,MID);空头:STICKLINE((REF(macd,1)>MacD ) AND (C<波段线 OR (C>波段线 AND 波段线<REF(波段线,1))),C,O,3,0),COLOR808000;STICKLINE((REF(MACD,1)> MACD AND C<波段线),H,L,0,0),COLOR808000;头:STICKLINE(C<波段线,C,O,3,0),COLOR808000;STICKLINE(( C<波段线),H,L,0,0),COLOR808000;STICKLINE(空头,C,O,2.8,0),COLOR555500;STICKLINE(空头,C,O,2,0),COLOR888800;STICKLINE(空头,C,O,1.5,0),COLORAAAA00;STICKLINE(空头,C,O,1,0),COLORCCCC00;STICKLINE(空头,C,O,0.5,0),COLOREEEE00;STICKLINE(头,C,O,2.8,0),COLOR555500;STICKLINE(头,C,O,2,0),COLOR888800;STICKLINE(头,C,O,1.5,0),COLORAAAA00;STICKLINE(头,C,O,1,0),COLORCCCC00;STICKLINE(头,C,O,0.5,0),COLOREEEE00;{涨停}{跌停}AAK:=CLOSE/REF(C,1)>=1.097 AND C=H AND C>EMA(C,68);STICKLINE(AAK,C,O,1.5,0),COLORYELLOW;STICKLINE(AAK,O,C,0.2,0),COLOR0000FF;{共振涨板三色花}超短:=100*(C-LLV(L,3))/(HHV(C,3)-LLV(L,3));短期:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));中期:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));中长:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));长期:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));T2X:=MA(C,20)>REF(MA(C,20),1);T3X:= V>MA(V,5) AND V>MA(V,63);T4:=MACD.DIF>REF(MACD.DIF,1) AND MACD.DIF>MACD.DEA;T5:= kdj.K>REF(kdJ.K,1) AND KDJ.K>50;T6:=短期>=99 AND 中期>=99 AND 中长>=99 AND 长期>=99;T7:=H>=REF(C,1)*1.099 AND C>REF(C,1);TTS:=T2X AND T3X AND T4 AND T5 AND T6,NODRAW;涨停1:=C>=REF(C,1)*1.0990 AND C=H AND C>EMA(C,24);STICKLINE(涨停1 AND TTS,O,C,2,0),COLOR0000FF;STICKLINE(涨停1 AND TTS,O,O+(C-O)*2/3,2,0),COLORYELLOW;STICKLINE(涨停1 AND TTS,O,O+(C-O)*1/2.5,2,0),COLORFF80FF;{攻击点}箱底:=TROUGH(C,10,1)*1.02;箱底1:=TROUGH(C,10,1)*1.02;价低箱底:=COUNT(L<箱底,3);底箱:=TROUGH(C,10,1)*1.05,COLOR008888,LINETHICK1,DOTLINE;白银:=(EMA(C,24)<EMA(C,68) AND C>EMA(C,24) AND C<EMA(C,68))OR (EMA(C,24)>EMA(C,68) AND C<EMA(C,24) AND C>EMA(C,68)) AND 价低箱底>=1 AND 箱底<EMA(C,24) AND C>波段线 AND EMA(C,12)>REF(EMA(C,12),1) AND crOSS(C,底箱),COLOR00AAAA,NODRAW;DRAWTEXT((EMA(C,24)<EMA(C,68) AND C>EMA(C,24) AND C<EMA(C,68))OR (EMA(C,24)>EMA(C,68) AND C<EMA(C,24) AND C>EMA(C,68)) AND 价低箱底>=1 AND 箱底<EMA(C,24) AND C>波段线 AND EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),L*0.98,’↖白银’),COLORA8A8A8;STICKLINE(白银,OPEN,CLOSE,3.5,0),COLOR5F5F5F;STICKLINE(白银,OPEN,CLOSE,3.0,0),COLOR6E6E6E;STICKLINE(白银,OPEN,CLOSE,2.5,0),COLOR747474;STICKLINE(白银,OPEN,CLOSE,2.0,0),COLOR919191;STICKLINE(白银,OPEN,CLOSE,1.5,0),COLORA8A8A8;STICKLINE(白银,OPEN,CLOSE,1.0,0),COLORCDCDCD;STICKLINE(白银,OPEN,CLOSE,0.5,0),COLOREBEBEB;STICKLINE(白银,OPEN,CLOSE,0.1,0),COLORWHITE;杂银:=C<EMA(C,24) AND C<EMA(C,68) AND 价低箱底>=1 AND 箱底<EMA(C,24) AND C>波段线 AND EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),COLOR00AAAA,NODRAW;DRAWTEXT(C<EMA(C,24) AND C<EMA(C,68) AND 价低箱底>=1 AND 箱底<EMA(C,24) AND C>波段线 AND EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),L*0.98,’↖杂银’),COLORA8A8A8;BG1:=(C-O);STICKLINE(杂银,OPEN,C,3.5,0),COLOR5F5F5F;STICKLINE(杂银,OPEN,C,1,0),COLORB3F5F9;STICKLINE(杂银,OPEN,O+BG1/2,3.5,0),COLOR5F5F5F;STICKLINE(杂银,OPEN,O+BG1/2,3.0,0),COLOR6E6E6E;STICKLINE(杂银,OPEN,O+BG1/2,2.5,0),COLOR747474;STICKLINE(杂银,OPEN,O+BG1/2,2.0,0),COLOR919191;STICKLINE(杂银,OPEN,O+BG1/2,1.5,0),COLORA8A8A8;STICKLINE(杂银,OPEN,O+BG1/2,1.0,0),COLORCDCDCD;STICKLINE(杂银,OPEN,O+BG1/2,0.5,0),COLOREBEBEB;STICKLINE(杂银,OPEN,O+BG1/2,0.1,0),COLORWHITE;白金:C>EMA(C,24) AND C>EMA(C,68) AND EMA(C,24)>EMA(C,68) AND (EMA(C,24)>REF(EMA(C,24),1) AND EMA(C,68)>REF(EMA(C,68),1)) AND 价低箱底>=1 AND 箱底<EMA(C,24) AND C>波段线 AND EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),COLOR00AAAA,NODRAW;DRAWTEXT(C>EMA(C,24) AND C>EMA(C,68) AND EMA(C,24)>EMA(C,68) AND (EMA(C,24)>REF(EMA(C,24),1) AND EMA(C,68)>REF(EMA(C,68),1)) AND 价低箱底>=1 AND 箱底<EMA(C,24) AND C>波段线 AND EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),L*0.98,’↖白金’),COLOR00CCCC;STICKLINE(白金,OPEN,CLOSE,3.5,0),COLOR008888;STICKLINE(白金,OPEN,CLOSE,1.6,0),COLOR00AAAA;STICKLINE(白金,OPEN,CLOSE,0.8,0),COLOR00CCCC;STICKLINE(白金,OPEN,CLOSE,0.2,0),COLOR00FFFF;黄金:C>EMA(C,24) AND C>EMA(C,68) AND EMA(C,24)<EMA(C,68) AND 价低箱底>=1 AND 箱底<EMA(C,24) AND C>波段线 AND EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),COLOR00AAAA,NODRAW;DRAWTEXT(C>EMA(C,24) AND C>EMA(C,68) AND EMA(C,24)<EMA(C,68) AND 价低箱底>=1 AND 箱底<EMA(C,24) AND C>波段线 AND EMA(C,12)>REF(EMA(C,12),1) AND CROSS(C,底箱),L*0.98,’↖黄金’),COLOR00CCCC;BG:=(C-O);STICKLINE(黄金,OPEN,C,3.5,0),COLOR008888;STICKLINE(黄金,OPEN,C,1,0),COLORWHITE;STICKLINE(黄金,OPEN,O+BG/2,3.5,0),COLOR008888;STICKLINE(黄金,OPEN,O+BG/2,1.6,0),COLOR00AAAA;STICKLINE(黄金,OPEN,O+BG/2,0.8,0),COLOR00CCCC;STICKLINE(黄金,OPEN,O+BG/2,0.2,0),COLOR00FFFF;IF(波段线<REF(波段线,1),波段线,DRAWNULL),COLORGREEN,LINETHICK1;攻击线:MA(C,3),COLORGRAY,LINETHICK1,DOTLINE;IF(攻击线>REF(攻击线,1),攻击线,DRAWNULL),COLORWHITE,LINETHICK1,DOTLINE;IF(攻击线<REF(攻击线,1),攻击线,DRAWNULL),{COLOR045324}COLORGRAY,LINETHICK1,DOTLINE;低点转折:=DRAWICON(CROSS(zig(3,6),REF(ZIG(3,6),1)),L*0.98,9) ;DRAWTEXT((低点转折=1),L*0.99,’买’),COLOR1665F8;高点转折:=DRAWICON(CROSS(REF(ZIG(3,4),1),ZIG(3,4)),H*1.015,15);DRAWTEXT((高点转折=1),H*1.01,’卖’),COLOR77EE3E;{KD\MACD金叉、死叉显示}金叉:=CROSS(KDJ.J,KDJ.D);死叉:=CROSS(KDJ.D,KDJ.J);CO1:=(C-O);STICKLINE(金叉,O,C,0,0),COLORYELLOW;STICKLINE(金叉,O,O+CO1/2,0.01,0),COLORYELLOW;STICKLINE(金叉,O,O+CO1/2,0,0),COLORRED;STICKLINE(金叉,O,O+CO1/5,3.4,0),COLOR335555;STICKLINE(金叉,O,O+CO1/5,2,0),COLOR338888;STICKLINE(金叉,O,O+CO1/5,1.5,0),COLOR33AAAA;STICKLINE(金叉,O,O+CO1/5,1,0),COLOR33CCCC;STICKLINE(金叉,O,O+CO1/5,0,0),COLOR33EEEE;金:=CROSS(MACD.DIF,MACD.DEA);CO11:=(C-O);STICKLINE(金,O,C,0,0),COLORYELLOW;STICKLINE(金,O,O+CO11/2,0.3,0),COLORYELLOW;STICKLINE(金,O,O+CO11/2,0,0),COLORRED;STICKLINE(金,O,O+CO11/5,3.4,0),COLOR000055;STICKLINE(金,O,O+CO11/5,2,0),COLOR000088;STICKLINE(金,O,O+CO11/5,1.5,0),COLOR0000AA;STICKLINE(金,O,O+CO11/5,1,0),COLOR0000CC;STICKLINE(金,O,O+CO11/5,0,0),COLOR0000EE;STICKLINE(死叉,O,O+CO1/5,1.4,0),COLOR4BFE59;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址