• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信均线粘合突破指标公式

通达信公式 第一股票指标公式网 3周前 (01-06) 19次浏览 已收录 0个评论 扫描二维码

SOZ:=3;N := 14;M := 8;N1 := 4;M1:= 6;HL:=SQRT(Abs(CLOSE-OPEN))+(CLOSE=OPEN);JFC:=IF(CAPITAL>0,HL,SQRT(CLOSE));DHL:=IF(3=1,JFC,IF(3=2,1,1/JFC));M2:=ema(C*DHL,2)/Ema(DHL,2);M3:=EMA(C*DHL,3)/EMA(DHL,3);M5:=EMA(C*DHL,5)/EMA(DHL,5);M8:=EMA(C*DHL,8)/EMA(DHL,8);M13:=EMA(C*DHL,13)/EMA(DHL,13);M21:=EMA(C*DHL,21)/EMA(DHL,21);M34:=EMA(C*DHL,34)/EMA(DHL,34);M55:=EMA(C*DHL,55)/EMA(DHL,55);M89:=EMA(C*DHL,89)/EMA(DHL,89);M144:=EMA(C*DHL,144)/EMA(DHL,144);M233:=EMA(C*DHL,233)/EMA(DHL,233);M377:=EMA(C*DHL,377)/EMA(DHL,377);M610:=EMA(C*DHL,610)/EMA(DHL,610);HJ:=C;AA:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(M2,M3),M5),M8),M13),M21),M34),M55),M89),M144),M233),M377),M610);BB:=MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(MIN(M2,M3),M5),M8),M13),M21),M34),M55),M89),M144),M233),M377),M610);粘合14:=(AA-BB)/BB,volstICK;粘合3均:=EMA(粘合14*DHL,3)/EMA(DHL,3);粘合13均:=EMA(粘合14*DHL,13)/EMA(DHL,13);粘合26均:=EMA(粘合14*DHL,26)/EMA(DHL,26);粘合55均:=EMA(粘合14*DHL,55)/EMA(DHL,55);粘合144均:=EMA(粘合14*DHL,144)/EMA(DHL,144);粘合243均:=EMA(粘合14*DHL,233)/EMA(DHL,233);A:=MA(AMOUNT,5)/REF(MA(AMOUNT,250),1),DRAWNULL;B:=MA(AMOUNT,3)/REF(MA(AMOUNT,5),1),DRAWNULL;CC:=MA(AMOUNT,5)/REF(MA(AMOUNT,35),1),DRAWNULL;E:=MA(AMOUNT,3)/REF(MA(AMOUNT,35),1),DRAWNULL;F:=EMA(SLOPE(CC,21)*21+C,42),DRAWNULL;TRR:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);HD:=HIGH-REF(HIGH,1);LD:=REF(LOW,1)-LOW;DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N,1);DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N,1);pdi:=DMP*100/TRR,COLORRED;mdi:=DMM*100/TRR,COLORGREEN;ADX:=SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1),COLORYELLOW;ADXR:=(ADX+REF(ADX,M))/2;DDD := (MA(CLOSE,10)-MA(CLOSE,50));AMA1 := MA(DDD,10);强上升:PDI > MDI AND ADX >= 30 AND ADX>ADXR,NODRAW;强下降:PDI < MDI AND ADX >= 30 AND ADX>ADXR,NODRAW;小上升:PDI > MDI AND BETWEEN( ADX, 16, 30) AND ADX>ADXR,NODRAW;调整:PDI < MDI AND BETWEEN( ADX, 16, 30) AND ADX>ADXR,NODRAW;多头箱体:PDI > MDI AND BETWEEN( ADX, 16, 30) AND ADX-ADXR<REF(ADX-ADXR,1),NODRAW;空头箱体:PDI < MDI AND BETWEEN( ADX, 16, 30) AND ADX-ADXR<REF(ADX-ADXR,1),NODRAW;静寂期:=ADX <=16 AND (PDI > MDI OR PDI < MDI),DRAWNULL;高位危险区:=PDI > MDI AND ADX >= 30 AND ADX-ADXR<REF(ADX-ADXR,1),DRAWNULL;空头区域:=PDI<MDI OR DDD<AMA1,DRAWNULL;多头线:PDI,COLORRED,LINETHICK2;空头线:MDI,COLORCYAN,LINETHICK2;顺势线_多或空:=MA(ABS(MDI-PDI)/(MDI+PDI)*100,M1);顺势线:=(顺势线_多或空+REF(顺势线_多或空,M1))/2;{引用微积分额比}D:=ABS(AMOUNT-REF(AMOUNT,1));EI:=SUM(D,5)/5;FI:=REF(SUM(D,250)/250,1);微元条件1:=D>REF(D,1) AND 3*(EMA(C,3)-EMA(C,8)-EMA(EMA(C,3)-EMA(C,8),20))*5+20>20 AND EI/FI>0 AND EI/FI<3;粘合突破:顺势线_多或空>顺势线 AND 多头线>36 AND C>F AND F>REF(F,1) AND 粘合14>=粘合3均 AND 粘合3均>=粘合13均 AND 粘合13均>粘合26均 AND 粘合3均>粘合243均 AND A>1 AND E>MA(E,5) AND E>0.618*MA(E,250) AND MA(DYNAINFO(37),7)>0.236*MA(DYNAINFO(37),250) AND AMOUNT>MA(AMOUNT,35),COLORYELLOW;STICKLINE(粘合突破,0,0.809*粘合14,7,0),COLORYELLOW;下跌突破:顺势线_多或空>36 AND C<F AND F<REF(F,1) AND 粘合14>=粘合3均 AND 粘合3均>=粘合13均 AND 粘合13均>=粘合26均 AND 粘合3均>=粘合243均 AND MA(DYNAINFO(37),7)>=0.236*MA(DYNAINFO(37),250) AND AMOUNT>=MA(AMOUNT,35),DRAWNULL;STICKLINE(下跌突破,0,粘合14,7,0),COLORBLUE;下跌粘合发散:C<F AND F<REF(F,1)AND 粘合14>=粘合3均 AND 粘合3均>=粘合13均 AND 粘合13均>=粘合26均 AND 粘合26均>=粘合55均 AND 粘合26均>=粘合144均 AND 粘合13均>=粘合243均 AND NOT(粘合突破),COLORBLUE;STICKLINE(下跌粘合发散,0,0.5*粘合14,7,0),COLORGREEN;上涨粘合发散:顺势线_多或空>顺势线 AND 多头线>空头线 AND C>F AND F>=REF(F,1) AND 粘合14>=粘合3均 AND 粘合3均>=粘合13均 AND 粘合13均>=粘合26均 AND 粘合3均>=粘合243均 AND E>=0.618*MA(E,250) AND MA(DYNAINFO(37),7)>=0.236*MA(DYNAINFO(37),250) AND AMOUNT>=MA(AMOUNT,35) AND NOT(下跌粘合发散),COLORMAGENTA;STICKLINE(上涨粘合发散,0,0.5*粘合14,7,0),COLORMAGENTA;上涨发散:微元条件1 AND 顺势线_多或空>顺势线 AND 多头线>空头线 AND C>=F AND F>REF(F,1),COLORWHITE;STICKLINE(上涨发散,0,0.2*粘合14,7,0),COLORWHITE;下跌发散:顺势线_多或空>顺势线 AND C<F AND F<REF(F,1),COLORGREEN;STICKLINE(下跌发散,0,0.2*粘合14,7,0),COLORGREEN;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址