• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

通达信行业板块看盘主图指标公式

通达信公式 第一股票指标公式网 3周前 (01-06) 23次浏览 已收录 0个评论 扫描二维码

{行业板块看盘幅图}创业板:=INBLOCK(‘创业板’);中小企业:=INBLOCK(‘中小板’);上证A股:=INBLOCK(‘上证A股’);深证A股:=INBLOCK(‘深证A股’);INDEH:=IF(中小企业=1,”399005$H”,IF(创业板=1,”399006$H”,IF(上证A股=1,”999999$H”,”399001$H”))),NODRAW;INDEO:=IF(中小企业=1,”399005$O”,IF(创业板=1,”399006$O”,IF(上证A股=1,”999999$O”,”399001$O”))),NODRAW;INDEL:=IF(中小企业=1,”399005$L”,IF(创业板=1,”399006$L”,IF(上证A股=1,”999999$L”,”399001$L”))),NODRAW;INDEC:=IF(中小企业=1,”399005$C”,IF(创业板=1,”399006$C”,IF(上证A股=1,”999999$C”,”399001$C”))),NODRAW;板块:=IF(中小企业=1,’中小板指数’,IF(创业板=1,’创业板指数’,IF(上证A股=1,’上证指数’,’深证指数’)));指数涨幅:=(INDEC-REF(INDEC,1))*100/REF(INDEC,1);A:=stRCAT(板块,STRCAT(‘:’,CON2STR(INDEC,2)));B:=STRCAT(STRCAT(‘指数涨跌:’,CON2STR(指数涨幅,2)),’ %’);DRAWTEXT_FIX(ISLASTBAR,0,0,0,A),COLOR0055FF;DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,B),COLOR0055FF;沪A涨家数:=”999999$ADVANCE”,COLORRED,NODRAW;沪A跌家数:=”999999$DECLINE”,COLORGREEN,NODRAW;深A涨家数:=”399001$ADVANCE”,COLORRED,NODRAW;深A跌家数:=”399001$DECLINE”,COLORGREEN,NODRAW;中小涨家数:=”399005$ADVANCE”,COLORRED,NODRAW;中小跌家数:=”399005$DECLINE”,COLORGREEN,NODRAW;创业涨家数:=”399006$ADVANCE”,COLORRED,NODRAW;创业跌家数:=”399006$DECLINE”,COLORGREEN,NODRAW;上涨总家数:=沪A涨家数+深A涨家数,COLORRED,NODRAW;下跌总家数:=沪A跌家数+深A跌家数,COLORGREEN,NODRAW;BBB1:=STRCAT(‘沪A涨家数: ‘,CON2STR(沪A涨家数,0));DRAWTEXT_FIX(ISLASTBAR,0,0.06,0,BBB1),COLORRED;BBB2:=STRCAT(‘沪A跌家数: ‘,CON2STR(沪A跌家数,0));DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,BBB2),COLORGREEN;BBB3:=STRCAT(‘深A涨家数: ‘,CON2STR(深A涨家数,0));DRAWTEXT_FIX(ISLASTBAR,0.1,0.06,0,BBB3),COLORRED;BBB4:=STRCAT(‘深A跌家数: ‘,CON2STR(深A跌家数,0));DRAWTEXT_FIX(ISLASTBAR,0.1,0.12,0,BBB4),COLORGREEN;BBB5:=STRCAT(‘中小涨家数: ‘,CON2STR(中小涨家数,0));DRAWTEXT_FIX(ISLASTBAR,0.2,0.06,0,BBB5),COLORRED;BBB6:=STRCAT(‘中小跌家数:’,CON2STR(中小跌家数,0));DRAWTEXT_FIX(ISLASTBAR,0.2,0.12,0,BBB6),COLORGREEN;BBB7:=STRCAT(‘创业涨家数: ‘,CON2STR(创业涨家数,0));DRAWTEXT_FIX(ISLASTBAR,0.3,0.06,0,BBB7),COLORRED;BBB8:=STRCAT(‘创业跌家数: ‘,CON2STR(创业跌家数,0));DRAWTEXT_FIX(ISLASTBAR,0.3,0.12,0,BBB8),COLORGREEN;上涨总家数比:=上涨总家数/(上涨总家数+下跌总家数)*100,COLORRED,NODRAW;下跌总家数比:=下跌总家数/(上涨总家数+下跌总家数)*100,COLORGREEN,NODRAW;沪A上涨家数比:=沪A涨家数/(沪A涨家数+沪A跌家数)*100,COLORRED,NODRAW;沪A下跌家数比:=沪A跌家数/(沪A涨家数+沪A跌家数)*100,COLORGREEN,NODRAW;深A上涨家数比:=深A涨家数/(深A涨家数+深A跌家数)*100,COLORRED,NODRAW;深A下跌家数比:=深A跌家数/(深A涨家数+深A跌家数)*100,COLORGREEN,NODRAW;中小上涨家数比:=中小涨家数/(中小涨家数+中小跌家数)*100,COLORRED,NODRAW;中小下跌家数比:=中小跌家数/(中小涨家数+中小跌家数)*100,COLORGREEN,NODRAW;创业上涨家数比:=创业涨家数/(创业涨家数+创业跌家数)*100,COLORRED,NODRAW;创业下跌家数比:=创业跌家数/(创业涨家数+创业跌家数)*100,COLORGREEN,NODRAW;AAA1:=STRCAT(STRCAT(‘上涨总家数比 ‘,CON2STR(上涨总家数比,0)),’ %’);DRAWTEXT_FIX(ISLASTBAR,0.4,0.06,0,AAA1),COLORRED;AAA2:=STRCAT(STRCAT(‘下跌总家数比 ‘,CON2STR(下跌总家数比,0)),’ %’);DRAWTEXT_FIX(ISLASTBAR,0.4,0.12,0,AAA2),COLORGREEN;AAA3:=STRCAT(STRCAT(‘沪A上涨家数比 ‘,CON2STR(沪A上涨家数比,0)),’ %’);DRAWTEXT_FIX(ISLASTBAR,0.5,0.06,0,AAA3),COLORRED;AAA4:=STRCAT(STRCAT(‘沪A下跌家数比 ‘,CON2STR(沪A下跌家数比,0)),’ %’);DRAWTEXT_FIX(ISLASTBAR,0.5,0.12,0,AAA4),COLORGREEN;AAA5:=STRCAT(STRCAT(‘深A上涨家数比 ‘,CON2STR(深A上涨家数比,0)),’ %’);DRAWTEXT_FIX(ISLASTBAR,0.6,0.06,0,AAA5),COLORRED;AAA6:=STRCAT(STRCAT(‘深A下跌家数比 ‘,CON2STR(深A下跌家数比,0)),’ %’);DRAWTEXT_FIX(ISLASTBAR,0.6,0.12,0,AAA6),COLORGREEN;AAA7:=STRCAT(STRCAT(‘中小上涨家数比 ‘,CON2STR(中小上涨家数比,0)),’ %’);DRAWTEXT_FIX(ISLASTBAR,0.7,0.06,0,AAA7),COLORRED;AAA8:=STRCAT(STRCAT(‘中小下跌家数比 ‘,CON2STR(中小下跌家数比,0)),’ %’);DRAWTEXT_FIX(ISLASTBAR,0.7,0.12,0,AAA8),COLORGREEN;AAA9:=STRCAT(STRCAT(‘创业上涨家数比 ‘,CON2STR(创业上涨家数比,0)),’ %’);DRAWTEXT_FIX(ISLASTBAR,0.8,0.06,0,AAA9),COLORRED;AAA10:=STRCAT(STRCAT(‘创业下跌家数比 ‘,CON2STR(创业下跌家数比,0)),’ %’);DRAWTEXT_FIX(ISLASTBAR,0.8,0.12,0,AAA10),COLORGREEN;CCC:=HY_INDEXC;OOO:=HY_INDEXO;LLL:=HY_INDEXL;HHH:=HY_INDEXH;DRAWKLINE(HHH,OOO,LLL,CCC);ma5:MA(CCC,5);MA10:MA(CCC,10);MA20:MA(CCC,20);MA60:MA(CCC,60);上涨:=VARCAT(‘行业上涨:’,VAR2STR(HY_INDEXADV,0));下跌:=VARCAT(‘行业下跌:’,VAR2STR(HY_INDEXDEC,0));DRAWTEXT_FIX(ISLASTBAR,0.7,0,0,上涨),COLORMAGENTA;DRAWTEXT_FIX(ISLASTBAR,0.8,0,0,下跌),COLORYELLOW;ZF:=(C-REF(C,1))/REF(C,1)*100;行业指数:=(CCC-REF(CCC,1))*100/REF(CCC,1);DD:=STRCAT(‘行业指数:’,CON2STR(CCC,2));E:=STRCAT(STRCAT(‘行业涨跌:’,CON2STR(行业指数,2)),’ %’);DRAWTEXT_FIX(ISLASTBAR,0.2,0,0,DD),COLORYELLOW;DRAWTEXT_FIX(ISLASTBAR,0.3,0,0,E),COLORYELLOW;DRAWTEXT_FIX(ISLASTBAR,0.4,0,0,HYBLOCK),COLORYELLOW;{所属行业}DRAWTEXT_FIX(ISLASTBAR AND 指数涨幅<=行业指数,0.5,0,0,’板块强’),COLORRED;DRAWTEXT_FIX(ISLASTBAR AND 指数涨幅>行业指数,0.5,0,0,’板块弱’),COLORCYAN;DRAWTEXT_FIX(ISLASTBAR AND ZF>=行业指数,0.6,0,0,’个股强’),COLORRED;DRAWTEXT_FIX(ISLASTBAR AND ZF<行业指数,0.6,0,0,’个股弱’),COLORCYAN;DRAWTEXT_FIX(1,0.0,0.43,0,’【说明:早盘如果持有的股票:板弱、股弱。遇到急拉,坚决高抛低吸。】’),COLOR0080FF;DRAWTEXT_FIX(1,0.0,0.50,0,’【如果板强、股弱:等待股弱转股强。如果盘中一直处于板强、股弱:坚决做T】’),COLOR0080FF;DRAWTEXT_FIX(1,0.0,0.57,0,’【遇到板强、股强:持股不动。遇到板弱、股强:看个股量,如果放量强持股不动。如果急拉不放量,应高抛低吸】’),COLOR0080FF;DRAWTEXT_FIX(1,0.0,0.64,0,’【遇到上涨家数迅速增加:考虑补仓或者持股不动,反之减仓。】’),COLOR0080FF;个股强弱:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,30)*100,COLORWHITE;行业强弱:=(HY_INDEXC-MA(HY_INDEXC,30))/MA(HY_INDEXC,30)*100,COLORYELLOW,LINETHICK2;大盘强弱:=(INDEXC-MA(INDEXC,30))/MA(INDEXC,30)*100,COLORRED,LINETHICK4;煤炭A:=(“880301$C”-REF(“880301$C”,1))/REF(“880301$C”,1)*100;电力A:=(“880305$C”-REF(“880305$C”,1))/REF(“880305$C”,1)*100;石油A:=(“880310$C”-REF(“880310$C”,1))/REF(“880310$C”,1)*100;钢铁A:=(“880318$C”-REF(“880318$C”,1))/REF(“880318$C”,1)*100;有色A:=(“880324$C”-REF(“880324$C”,1))/REF(“880324$C”,1)*100;化纤A:=(“880330$C”-REF(“880330$C”,1))/REF(“880330$C”,1)*100;化工A:=(“880335$C”-REF(“880335$C”,1))/REF(“880335$C”,1)*100;建材A:=(“880344$C”-REF(“880344$C”,1))/REF(“880344$C”,1)*100;造纸A:=(“880350$C”-REF(“880350$C”,1))/REF(“880350$C”,1)*100;矿物制品A:=(“880351$C”-REF(“880351$C”,1))/REF(“880351$C”,1)*100;日用化工A:=(“880355$C”-REF(“880355$C”,1))/REF(“880355$C”,1)*100;农林牧渔A:=(“880360$C”-REF(“880360$C”,1))/REF(“880360$C”,1)*100;纺织服饰A:=(“880367$C”-REF(“880367$C”,1))/REF(“880367$C”,1)*100;食品饮料A:=(“880372$C”-REF(“880372$C”,1))/REF(“880372$C”,1)*100;酿酒A:=(“880380$C”-REF(“880380$C”,1))/REF(“880380$C”,1)*100;家用电器A:=(“880387$C”-REF(“880387$C”,1))/REF(“880387$C”,1)*100;汽车类A:=(“880390$C”-REF(“880390$C”,1))/REF(“880390$C”,1)*100;医疗保健A:=(“880398$C”-REF(“880398$C”,1))/REF(“880398$C”,1)*100;家居用品A:=(“880399$C”-REF(“880399$C”,1))/REF(“880399$C”,1)*100;医药A:=(“880400$C”-REF(“880400$C”,1))/REF(“880400$C”,1)*100;商业连锁A:=(“880406$C”-REF(“880406$C”,1))/REF(“880406$C”,1)*100;商贸代理A:=(“880414$C”-REF(“880414$C”,1))/REF(“880414$C”,1)*100;传媒娱乐A:=(“880418$C”-REF(“880418$C”,1))/REF(“880418$C”,1)*100;广告包装A:=(“880421$C”-REF(“880421$C”,1))/REF(“880421$C”,1)*100;文教休闲A:=(“880422$C”-REF(“880422$C”,1))/REF(“880422$C”,1)*100;酒店餐饮A:=(“880423$C”-REF(“880423$C”,1))/REF(“880423$C”,1)*100;旅游A:=(“880424$C”-REF(“880424$C”,1))/REF(“880424$C”,1)*100;航空航天A:=(“880430$C”-REF(“880430$C”,1))/REF(“880430$C”,1)*100;船舶A:=(“880431$C”-REF(“880431$C”,1))/REF(“880431$C”,1)*100;运输设备A:=(“880432$C”-REF(“880432$C”,1))/REF(“880432$C”,1)*100;通用机械A:=(“880437$C”-REF(“880437$C”,1))/REF(“880437$C”,1)*100;工业机械A:=(“880440$C”-REF(“880440$C”,1))/REF(“880440$C”,1)*100;电气设备A:=(“880446$C”-REF(“880446$C”,1))/REF(“880446$C”,1)*100;工程机械A:=(“880447$C”-REF(“880447$C”,1))/REF(“880447$C”,1)*100;电器仪表A:=(“880448$C”-REF(“880448$C”,1))/REF(“880448$C”,1)*100;电信运营A:=(“880452$C”-REF(“880452$C”,1))/REF(“880452$C”,1)*100;公共交通A:=(“880453$C”-REF(“880453$C”,1))/REF(“880453$C”,1)*100;水务A:=(“880454$C”-REF(“880454$C”,1))/REF(“880454$C”,1)*100;供气供热A:=(“880455$C”-REF(“880455$C”,1))/REF(“880455$C”,1)*100;环境保护A:=(“880456$C”-REF(“880456$C”,1))/REF(“880456$C”,1)*100;运输服务A:=(“880459$C”-REF(“880459$C”,1))/REF(“880459$C”,1)*100;仓储物流A:=(“880464$C”-REF(“880464$C”,1))/REF(“880464$C”,1)*100;交通设施A:=(“880465$C”-REF(“880465$C”,1))/REF(“880465$C”,1)*100;银行类A:=(“880471$C”-REF(“880471$C”,1))/REF(“880471$C”,1)*100;证券类A:=(“880472$C”-REF(“880472$C”,1))/REF(“880472$C”,1)*100;保险类A:=(“880473$C”-REF(“880473$C”,1))/REF(“880473$C”,1)*100;多元金融A:=(“880474$C”-REF(“880474$C”,1))/REF(“880474$C”,1)*100;建筑A:=(“880476$C”-REF(“880476$C”,1))/REF(“880476$C”,1)*100;房地产A:=(“880482$C”-REF(“880482$C”,1))/REF(“880482$C”,1)*100;电脑设备A:=(“880489$C”-REF(“880489$C”,1))/REF(“880489$C”,1)*100;通信设备A:=(“880490$C”-REF(“880490$C”,1))/REF(“880490$C”,1)*100;半导体A:=(“880491$C”-REF(“880491$C”,1))/REF(“880491$C”,1)*100;元器件A:=(“880492$C”-REF(“880492$C”,1))/REF(“880492$C”,1)*100;软件服务A:=(“880493$C”-REF(“880493$C”,1))/REF(“880493$C”,1)*100;互联网A:=(“880494$C”-REF(“880494$C”,1))/REF(“880494$C”,1)*100;综合类A:=(“880497$C”-REF(“880497$C”,1))/REF(“880497$C”,1)*100;最大值1A:=MAX(煤炭A,MAX(电力A,MAX(石油A,MAX(钢铁A,MAX(有色A,MAX(化纤A,MAX(化工A,MAX(建材A,MAX(造纸A,MAX(矿物制品A,日用化工A))))))))));最大值2A:=MAX(农林牧渔A,MAX(纺织服饰A,MAX(食品饮料A,MAX(酿酒A,MAX(家用电器A,MAX(汽车类A,MAX(医疗保健A,MAX(家居用品A,MAX(医药A,MAX(商业连锁A,商贸代理A))))))))));最大值3A:=MAX(传媒娱乐A,MAX(广告包装A,MAX(文教休闲A,MAX(酒店餐饮A,MAX(旅游A,MAX(航空航天A,MAX(船舶A,MAX(运输设备A,MAX(通用机械A,MAX(工业机械A,电气设备A))))))))));最大值4A:=MAX(工程机械A,MAX(电器仪表A,MAX(电信运营A,MAX(公共交通A,MAX(水务A,MAX(供气供热A,MAX(环境保护A,MAX(运输服务A,MAX(仓储物流A,MAX(交通设施A,银行类A))))))))));最大值5A:=MAX(证券类A,MAX(保险类A,MAX(多元金融A,MAX(建筑A,MAX(房地产A,MAX(电脑设备A,MAX(通信设备A,MAX(半导体A,MAX(元器件A,MAX(软件服务A,MAX(互联网A,综合类A)))))))))));ZZDZ:=CONST(MAX(最大值1A,MAX(最大值2A,MAX(最大值3A,MAX(最大值4A,最大值5A)))));DRAWTEXT_FIX(ISLASTBAR,0.9,0,0,’ ████████████████’),COLORRED;XSWZ1:=CONST(IF(ZZDZ-煤炭A=0 OR ZZDZ-电力A=0 OR ZZDZ-石油A=0 OR ZZDZ-钢铁A=0 OR ZZDZ-有色A=0 OR ZZDZ-化纤A=0 OR ZZDZ-化工A=0 OR ZZDZ-建材A=0 OR ZZDZ-造纸A=0 OR ZZDZ-旅游A=0 OR ZZDZ-船舶A=0 OR ZZDZ-水务A=0 OR ZZDZ-建筑A=0 OR ZZDZ-医药A=0,614,IF(ZZDZ-汽车类A=0 OR ZZDZ-银行类A=0 OR ZZDZ-证券类A=0 OR ZZDZ-保险类A=0 OR ZZDZ-房地产A=0 OR ZZDZ-半导体A=0 OR ZZDZ-元器件A=0 OR ZZDZ-互联网A=0 OR ZZDZ-综合类A=0,627,643)));DRAWTEXT_FIX(ISLASTBAR,0.9,0,0,IF(ZZDZ-煤炭A=0,’【今强势板块】:煤炭行业’,IF(ZZDZ-电力A=0,’【今强势板块】:电力行业’,IF(ZZDZ-石油A=0,’【今强势板块】:石油行业’,IF(ZZDZ-钢铁A=0,’【今强势板块】:钢铁行业’,IF(ZZDZ-有色A=0,’【今强势板块】:有色行业’,IF(ZZDZ-化纤A=0,’【今强势板块】:化纤行业’,IF(ZZDZ-化工A=0,’【今强势板块】:化工行业’,IF(ZZDZ-建材A=0,’【今强势板块】:建材行业’,IF(ZZDZ-造纸A=0,’【今强势板块】:造纸行业’,IF(ZZDZ-矿物制品A=0,’【今强势板块】:矿物制品’,IF(ZZDZ-日用化工A=0,’【今强势板块】:日用化工’,IF(ZZDZ-农林牧渔A=0,’【今强势板块】:农林牧渔’,IF(ZZDZ-纺织服饰A=0,’【今强势板块】:纺织服饰’,IF(ZZDZ-食品饮料A=0,’【今强势板块】:食品饮料’,IF(ZZDZ-酿酒A=0,’【今强势板块】:酿酒行业’,IF(ZZDZ-家用电器A=0,’【今强势板块】:家用电器’,IF(ZZDZ-汽车类A=0,’【今强势板块】:汽车行业’,IF(ZZDZ-医疗保健A=0,’【今强势板块】:医疗保健’,IF(ZZDZ-家居用品A=0,’【今强势板块】:家居用品’,IF(ZZDZ-医药A=0,’【今强势板块】:医药行业’,IF(ZZDZ-商业连锁A=0,’【今强势板块】:商业连锁’,IF(ZZDZ-商贸代理A=0,’【今强势板块】:商贸代理’,DRAWNULL))))))))))))))))))))))),COLORWHITE;DRAWTEXT_FIX(ISLASTBAR,0.9,0,0,IF(ZZDZ-传媒娱乐A=0,’【今强势板块】:传媒娱乐’,IF(ZZDZ-广告包装A=0,’【今强势板块】:广告包装’,IF(ZZDZ-文教休闲A=0,’【今强势板块】:文教休闲’,IF(ZZDZ-酒店餐饮A=0,’【今强势板块】:酒店餐饮’,IF(ZZDZ-旅游A=0,’【今强势板块】:旅游行业’,IF(ZZDZ-航空航天A=0,’【今强势板块】:航空航天’,IF(ZZDZ-船舶A=0,’【今强势板块】:船舶行业’,IF(ZZDZ-运输设备A=0,’【今强势板块】:运输设备’,IF(ZZDZ-通用机械A=0,’【今强势板块】:通用机械’,IF(ZZDZ-工业机械A=0,’【今强势板块】:工业机械’,IF(ZZDZ-电气设备A=0,’【今强势板块】:电气设备’,IF(ZZDZ-工程机械A=0,’【今强势板块】:工程机械’,IF(ZZDZ-电器仪表A=0,’【今强势板块】:电器仪表’,IF(ZZDZ-电信运营A=0,’【今强势板块】:电信运营’,IF(ZZDZ-公共交通A=0,’【今强势板块】:公共交通’,IF(ZZDZ-水务A=0,’【今强势板块】:水务行业’,IF(ZZDZ-供气供热A=0,’【今强势板块】:供气供热’,IF(ZZDZ-环境保护A=0,’【今强势板块】:环境保护’,IF(ZZDZ-运输服务A=0,’【今强势板块】:运输服务’,IF(ZZDZ-仓储物流A=0,’【今强势板块】:仓储物流’,IF(ZZDZ-交通设施A=0,’【今强势板块】:交通设施’,IF(ZZDZ-银行类A=0,’【今强势板块】:银行板块’,IF(ZZDZ-证券类A=0,’【今强势板块】:证券板块’,IF(ZZDZ-保险类A=0,’【今强势板块】:保险板块’,IF(ZZDZ-多元金融A=0,’【今强势板块】:多元金融’,IF(ZZDZ-建筑A=0,’【今强势板块】:建筑行业’,IF(ZZDZ-房地产A=0,’【今强势板块】:房产板块’,IF(ZZDZ-电脑设备A=0,’【今强势板块】:电脑设备’,IF(ZZDZ-通信设备A=0,’【今强势板块】:通信设备’,IF(ZZDZ-半导体A=0,’【今强势板块】:半导体类’,IF(ZZDZ-元器件A=0,’【今强势板块】:元器件类’,IF(ZZDZ-软件服务A=0,’【今强势板块】:软件服务’,IF(ZZDZ-互联网A=0,’【今强势板块】:互联网类’,IF(ZZDZ-综合类A=0,’【今强势板块】:综合板块’,DRAWNULL))))))))))))))))))))))))))))))))))),COLORWHITE;DRAWTEXT_FIX(ISLASTBAR,0.6,0.2,0,’股东统计分析:’),COLORGREEN;DRAWTEXT_FIX(ISLASTBAR,0.7,0.2,0,’1、前十大股东持股合计:’),COLORYELLOW;环比增减1:=(FINONE(245,0,0)-FINONE(245,0,1))/FINONE(245,0,1)*100;HG111:=IF(环比增减1>0,VARCAT(VARCAT( ‘增加 ‘ ,VAR2STR( 环比增减1,2)),’ % ’),IF(环比增减1<0,VARCAT(VARCAT( ‘减少 ‘ ,VAR2STR(-环比增减1,2)),’ % ’),’ ‘));HGH111:=STRCAT(STRCAT(‘占总股本 ‘,STRCAT(CON2STR(FINVALUE(245)/FINVALUE(238)*100,2),’ % ’)),STRCAT(‘占流通盘 ‘,STRCAT(CON2STR(FINVALUE(245)/FINVALUE(239)*100,2),’ % ’)));SDGDCGLXFX:=IF(FINONE(245,0,0)<FINONE(245,0,1) AND FINONE(245,0,1)<FINONE(245,0,2) AND FINONE(245,0,2)<FINONE(245,0,3),’连续三季度减少’,IF(FINVALUE(245)>FINONE(245,0,1) AND FINONE(245,0,1)>FINONE(245,0,2) AND FINONE(245,0,2)>FINONE(245,0,3),’连续三季度增加’,”));DRAWTEXT_FIX(ISLASTBAR,0.7,0.294,0,HGH111),COLORYELLOW;DRAWTEXT_FIX(ISLASTBAR,0.7,0.381,0,STRCAT(‘较上期 ‘,STRCAT(HG111,SDGDCGLXFX))),COLORYELLOW;GDrslXZJFX:=IF(FINONE(242,0,0)<FINONE(242,0,1) AND FINONE(242,0,1)<FINONE(242,0,2) AND FINONE(242,0,2)<FINONE(242,0,3),’连续三季度减少’,IF(FINVALUE(242)>FINONE(242,0,1) AND FINONE(242,0,1)>FINONE(242,0,2) AND FINONE(242,0,2)>FINONE(242,0,3),’连续三季度增加’,”));DRAWTEXT_FIX(ISLASTBAR AND ((FINVALUE(242)-FINONE(242,0,1))/FINONE(242,0,1))<=0,0.7,0.468,0,STRCAT(‘2、本期股东人数较上期减: ‘,STRCAT(CON2STR((FINVALUE(242)-FINONE(242,0,1))/FINONE(242,0,1)*100,2),STRCAT(‘ %,’,GDRSLXZJFX)))),COLORFFAAFF;DRAWTEXT_FIX(ISLASTBAR AND ((FINVALUE(242)-FINONE(242,0,1))/FINONE(242,0,1))> 0,0.7,0.468,0,STRCAT(‘2、本期股东人数较上期增: ‘,STRCAT(CON2STR((FINVALUE(242)-FINONE(242,0,1))/FINONE(242,0,1)*100,2),STRCAT(‘ %,’,GDRSLXZJFX)))),COLORFFAA00;HGH222:=STRCAT(STRCAT(‘占总股本 ‘,STRCAT(CON2STR(FINVALUE(247)/FINVALUE(238)*100,2),’ % ’)),STRCAT(‘占流通盘 ‘,STRCAT(CON2STR(FINVALUE(247)/FINVALUE(239)*100,2),’ % ’)));JGCGLXZJFX:=IF(FINONE(247,0,0)<FINONE(247,0,1) AND FINONE(247,0,1)<FINONE(247,0,2) AND FINONE(247,0,2)<FINONE(247,0,3),’连续三季度减少’,IF(FINVALUE(247)>FINONE(247,0,1) AND FINONE(247,0,1)>FINONE(247,0,2) AND FINONE(247,0,2)>FINONE(247,0,3),’连续三季度增加’,”));DRAWTEXT_FIX(ISLASTBAR,0.7,0.555,0,STRCAT(‘3、共 ‘,STRCAT(CON2STR(FINVALUE(246),0),STRCAT(‘ 家机构,共持有 ‘,STRCAT(CON2STR(FINVALUE(247)/10000,2),’ 万股’))))),COLORGREEN;DRAWTEXT_FIX(ISLASTBAR,0.7,0.642,0,HGH222),COLORGREEN;DRAWTEXT_FIX(ISLASTBAR,0.7,0.729,0,STRCAT(‘增幅 ‘,STRCAT(CON2STR((FINONE(247,0,0)-FINONE(247,0,1))/FINONE(247,0,1)*100,2),STRCAT(‘ % ‘,JGCGLXZJFX)))),COLORGREEN;环比增减3:=(FINONE(284,0,0)-FINONE(284,0,1))/FINONE(284,0,1)*100;HG333:=IF(环比增减3>0,VARCAT(VARCAT( ‘增加 ‘ ,VAR2STR( 环比增减3,2)),’ % ’),IF(环比增减3<0,VARCAT(VARCAT( ‘减少 ‘ ,VAR2STR(-环比增减3,2)),’ % ’),’ ‘));GJDCGLXFX:=IF(FINONE(284,0,0)<FINONE(284,0,1) AND FINONE(284,0,1)<FINONE(284,0,2) AND FINONE(284,0,2)<FINONE(284,0,3),’连续三季度减少’,IF(FINVALUE(284)>FINONE(284,0,1) AND FINONE(284,0,1)>FINONE(284,0,2) AND FINONE(284,0,2)>FINONE(284,0,3),’连续三季度增加’,”));DRAWTEXT_FIX(ISLASTBAR,0.7,0.816,0,STRCAT(‘4、国家队持 ‘,STRCAT(CON2STR(FINVALUE(284),2),STRCAT(‘ 万股,占总股本 ‘,STRCAT(CON2STR(FINVALUE(284)*10000/FINVALUE(238)*100,2),’ % ’))))),COLORWHITE;DRAWTEXT_FIX(ISLASTBAR,0.7,0.903,0,STRCAT(‘较上期 ‘,STRCAT(HG333,GJDCGLXFX))),COLORWHITE;


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址