• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

三平底主图—–源码及选股公式

钱龙公式 第一股票指标公式网 1年前 (2019-10-03) 27次浏览 0个评论 扫描二维码

三平底主图—–源码及选股公式介绍

日均价:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
JF1:=SMA(SMA(EMA(日均价,5)*2-MA(日均价,5),3,1),3,1),COLOR999900;
补偿:=FLOOR(((JF1-MA(JF1,5))/MA(JF1,5)*100));
操作线:=SMA(SMA((EMA(日均价,(5+ABS(补偿)))),2,1),2,1),COLORWHITE LINETHICK4;
上轨:=操作线+2*STD(日均价,10),COLORA08888;
下轨:=操作线-2*STD(日均价,10);
DRAWBAND(上轨,RGB(100,300,150),操作线,RGB(100,300,130));
DRAWBAND(下轨,RGB(50,50,50),操作线,RGB(100,100,300));
B1:=REF(C,1);B2:=REF(C,2);
SS:=IF(C>REF(C,1) AND REF(C,1)>=REF(C,2),1,IF(C<REF(C,1) AND REF(C,1)<=REF(C,2),-1,IF(C>REF(C,2) AND REF(C,2)>REF(C,1),2,IF(C<REF(C,2) AND REF(C,2)<REF(C,1),-2,0))));
SM:=IF(REF(SS,1)!=0,REF(SS,1),IF(REF(SS,2)!=0,REF(SS,2),IF(REF(SS,3)!=0,REF(SS,3),IF(REF(SS,5)!=0,REF(SS,5),IF(REF(SS,6)!=0,REF(SS,6),IF(REF(SS,7)!=0,REF(SS,7),0))))));
{STICKLINE(SS=1 OR SM>=1 AND SS=0,B1,C,2.8,0),COLORBLUE;
STICKLINE(SS=-1 OR SM<=-1 AND SS=0,B1,C,2.8,0),COLORYELLOW;
STICKLINE(SS=2,B2,C,2.8,0),COLORBLUE;
STICKLINE(SS=-2,B2,C,2.8,0),COLORYELLOW;}
STICKLINE((SS=-1 OR SS=-2) AND SM>0,B2,B1,2.8,0),COLORGREEN;
STICKLINE((SS=1 OR SS=2) AND SM<0,B2,B1,2.8,0),COLORYELLOW;
AA:=CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>REF(CLOSE,2) AND REF(CLOSE,1)<REF(CLOSE,3) AND IF(REF(CLOSE,3)<REF(CLOSE,4),1,IF(REF(CLOSE,4)<REF(CLOSE,5),REF(CLOSE,1)<REF(CLOSE,4) OR (REF(CLOSE,2)<REF(CLOSE,4) AND REF(CLOSE,3)>=REF(CLOSE,5)),IF(REF(CLOSE,5)<REF(CLOSE,6),1,REF(CLOSE,6)<REF(CLOSE,7))));
BB:=CLOSE<REF(CLOSE,1) AND REF(CLOSE,1)<REF(CLOSE,2) AND REF(CLOSE,1)>REF(CLOSE,3) AND IF(REF(CLOSE,3)>REF(CLOSE,4),1,IF(REF(CLOSE,4)>REF(CLOSE,5),REF(CLOSE,1)>REF(CLOSE,4) OR (REF(CLOSE,2)>REF(CLOSE,4) AND REF(CLOSE,3)<=REF(CLOSE,5)),IF(REF(CLOSE,5)>REF(CLOSE,6),1,REF(CLOSE,6)>REF(CLOSE,7))));
DRAWTEXT(AA AND CLOSE>REF(OPEN,2),LOW*0.99,’三平底’),COLORWHITE;
DRAWTEXT(BB AND CLOSE<REF(CLOSE,2),HIGH*1.01,’三平顶’),COLORCYAN;
MA60:MA(CLOSE,60) COLORGREEN;
D_D:=MA(IF(L<=LLV(L,13),1,0),3); C_D1:=(3*C+2*O+L+H)/7;
WMA5:(5*C_D1+4*REF(C_D1 ,1 )+3*REF(C_D1 ,2 )+2*REF(C_D1 ,3 )+REF(C_D1 ,4 ))/15 COLORYELLOW;
C_D2:REVERSE(C_D1)+2*WMA5 COLORGREEN;
DRAWBAND(WMA5,RGB(205,92,92),C_D2,RGB(28,134,238));
DRAWICON(CROSS(C_D2,WMA5*0.997),H*1.005,2);
DRAWICON(CROSS(WMA5,C_D2*0.997),L*0.995,1);
F:=C/O;
STICKLINE(F>=1,C,O,2.8,1),COLORRED;
STICKLINE(F>=1,C,H,0.00001,0),COLORRED;
STICKLINE(F>=1,L,O,0.00001,0),COLORRED;
STICKLINE(F<1,C,O,2.8,0),COLORCYAN;
STICKLINE(F<1,O,H,0.00001,0),COLORCYAN;
STICKLINE(F<1,L,C,0.00001,0),COLORCYAN;

选股公式
C_D1:=(3*C+2*O+L+H)/7;
WMA5:=(5*C_D1+4*REF(C_D1 ,1 )+3*REF(C_D1 ,2 )+2*REF(C_D1 ,3 )+REF(C_D1 ,4 ))/15;
C_D2:=REVERSE(C_D1)+2*WMA5;
红箭头:CROSS(WMA5,C_D2*0.997);


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址