• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

全新解读任意两点黄金分割(主图 源码 帖图)

钱龙公式 第一股票指标公式网 1年前 (2019-10-03) 24次浏览 0个评论 扫描二维码

全新解读任意两点黄金分割(主图 源码 帖图)介绍

{解读任意两点黄金分割线}
INPUT:高(0,0,9999),DHV(0,0,1),低L(0,0,255);
TTt:=ISLASTBAR=1;
TA1:=BARPOS=SYSPARAM(1);
T1:=datacount-barpos+0;
T2:=DATEDIFF(date,CURRENTDATE);
DRAWTEXTEX(TTt,0,2,5,’★交易天:’+NUMTOSTR(T1[SYSPARAM(1)],0)+'(天) / ‘+’◆自然天:’+NUMTOSTR(T2[SYSPARAM(1)],0)+'(天) ‘),COLORbbbbbb;
X:=SYSPARAM(2);
X1:=SYSPARAM(3);
YG:=REF(H,BARSLAST(TA1));
N:=((X1 – X) + 1);
BHC:=IF(DHV=0,H,C);
DHC:=IF(DHV=0,L,C);
AHH:=HHV(BHC,N);
ZG:=ref(BHC,高);
BHH:=HHV(zg,1);
YD:=REF(DHC,BARSLAST(TA1));
ZDL:=ref(L,低L);
BDL:=LLV(ZDL,1);
DDL:=BDL[X1];
HH:=IF(高=0,AHH,BHH);
LL:=LLV(L,N);
GG:HH[X1],colorFF00FF;
DD1:LL[X1],colorff0000;
DD:=YD[X1],color005555,LINEDOT;
PARTLINE(YD,YD),LINETHICK1,COLOR008F00;
DRAWTEXT(TTT ,DD1,’最低’+NUMTOSTR(DD1,2)),ALIGN1,colorFFEE00,,pxup25;
DRAWTEXT(TTT ,GG,’ 最高’+NUMTOSTR(GG,2)),ALIGN1,colorffaaaa,,pxDN5;
Q:=(DD + ((GG – DD) * 0.191));
Q2:=(DD + ((GG – DD) * 0.382));
Q3:=(DD + ((GG – DD) * 0.50));
Q4:=(DD + ((GG – DD) * 0.618));
Q5:=(DD + ((GG – DD) * 0.809));
Q6:=(DD + ((GG – DD) * 0.45));
Q7:=(DD + ((GG – DD) * 0.55));
Y_1:=REF(Q,BARSLAST(TA1));
Y_2:=REF(Q2,BARSLAST(TA1));
Y_3:=REF(Q3,BARSLAST(TA1));
Y_4:=REF(Q4,BARSLAST(TA1));
Y_5:=REF(Q5,BARSLAST(TA1));
Y_6:=REF(Q6,BARSLAST(TA1));
Y_7:=REF(Q7,BARSLAST(TA1));
PARTLINE(Y_1,Y_1),LINEDOT,Color005555;
PARTLINE(Y_2,Y_2),LINEDOT,Color005555;
PARTLINE(Y_3,Y_3),LINEDOT,Color888888;
PARTLINE(Y_4,Y_4),LINEDOT,Color005555;
PARTLINE(Y_5,Y_5),LINEDOT,Color005555;
DRAWTEXT(TA1,Y_1,’ 191*(‘+NUMTOSTR(Q,2)),COLOR00bbbb,ALIGN1,PXDN5;
DRAWTEXT(TA1,Y_2,’ 382*(‘+NUMTOSTR(Q2,2)),COLOR00bbbb,ALIGN1,PXUP22;
DRAWTEXT(TA1,Y_3,’ ★:1/2(‘+NUMTOSTR(Q3,2)),COLOReeeeee,ALIGN1,PXDN5;
DRAWTEXT(TA1,Y_4,’ 618*(‘+NUMTOSTR(Q4,2)),COLOR00bbbb,ALIGN1,PXDN5;
DRAWTEXT(TA1,Y_5,’ 809*(‘+NUMTOSTR(Q5,2)),COLOR00bbbb,ALIGN1,PXDN5;
DRAWTEXT(TA1,Y_6,’ 45﹡→(‘+NUMTOSTR(Q6,2)),COLOReeeeee,ALIGN1,PXDN5;
DRAWTEXT(TA1,Y_7,’ 55﹡→(‘+NUMTOSTR(Q7,2)),COLOReeeeee,ALIGN1,PXDN5;
STICKLINE(TA1,gg,dd,0,0),LINETHICK0,COLORFFAAAA;
DRAWTEXT(TA1,dd,’▲’),ALIGN0,color00FFdd,pxdn5;
DRAWTEXT(TA1,dd,’ –‘+NUMTOSTR(yd,2)),ALIGN0,color00FFdd,pxdn5;

全新解读任意两点黄金分割(主图 源码 帖图)


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址