• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

资金流动

股票公式编写 第一股票指标公式网 3周前 (06-27) 6次浏览 0个评论 扫描二维码

资金流动 指标公式:分仓资金主图、机散动向分时、资金活动主图,资金K线,鱼头鱼身鱼尾:资金翻番主图机构大户中户散户资金流。

通达信资金流动指标公式

N:=27; PP:=0.03;
{预测当天最低价公式}
A1:=REF(O,1);
A2:=ABS((REF(C,1)-A1)/A1);
A3:=ABS((REF(H,1)-A1)/A1);
A4:=ABS((REF(L,1)-A1)/A1);
B1:=ABS((A2+A3+A4)/3);
B2:=O*B1;
预测低一:=O-B2;
预测高一:=O+B2;
{预测当天股价公式}
开盘价1:=OPEN;
开盘价2:=REF(OPEN,1);
最高价1:=HIGH;
最高价2:=REF(HIGH,1);
最低价1:=LOW;
最低价2:=REF(LOW,1);
收盘价1:=CLOSE;
收盘价2:=REF(CLOSE,1);
AA:=最高价2;
BB:=最低价2;
CC:=开盘价2;
DD:=收盘价2;
EE:=(AA+BB+CC+2*DD)/5;
AAA:=EE+(AA-BB);
BBB:=2*EE-BB;
CCC:=2*EE-AA;
DDD:=EE-(AA-BB);
上升突破价:=AAA;
上升阻力价:=BBB;
下跌支撑价:=CCC;
下跌反转价:=DDD;
EEE:=(EE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5;
心理价:=EEE;
FFF:=(EEE+开盘价1)/2;
GGG:=(预测低一+FFF)/2;
预测低二:=GGG;
{预测今日最高价公式}
预测高二:=MA(REF(HIGH,1)/REF(CLOSE,2),N)*REF(CLOSE,1);
DRAWTEXT_FIX(1,0.04,0.35,0,’预测低一:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.10,0.35,0,CONST(预测低一)),COLORYELLOW;
DRAWTEXT_FIX(1,0.04,0.70,0,’预测高一:’),COLORGREEN;
DRAWNUMBER_FIX(1,0.10,0.70,0,CONST(预测高一)),COLORGREEN;
DRAWTEXT_FIX(1,0.18,0.35,0,’预测低二:’),COLORYELLOW;
DRAWNUMBER_FIX(1,0.24,0.35,0,CONST(预测低二)),COLORYELLOW;
DRAWTEXT_FIX(1,0.18,0.70,0,’预测高二:’),COLORGREEN;
DRAWNUMBER_FIX(1,0.24,0.70,0,CONST(预测高二)),COLORGREEN;
买回价:=预测低二*1.015;
卖出价:=买回价*(1+PP);
DRAWTEXT_FIX(1,0.04,0.01,0,’卖出价:’),COLORMAGENTA,LINETHICK1;
DRAWNUMBER_FIX(1,0.10,0.0`,0,CONST(卖出价)),COLORMAGENTA;
DRAWTEXT_FIX(1,0.18,0.01,0,’买回价:’),COLORMAGENTA,LINETHICK1;
DRAWNUMBER_FIX(1,0.24,0.01,0,CONST(买回价)),COLORMAGENTA;
{www.171415.com 第一股票指标公式网_最全最好股票指标公式}
(ISLASTBAR=1,RGB(90,90,90),RGB(90,90,90),0,”,0);
总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=流入-流出;
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,30,0),ABS(画),DRAWNULL),RGB(0,30,50),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,27,26),CONST(总额),DRAWNULL),RGB(150,10,0),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,26,25),CONST(流入*100000000),DRAWNULL),RGB(250,0,250),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,25,24),CONST(流出*100000000),DRAWNULL),RGB(0,255,255),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,20,19),CONST(总额3),DRAWNULL),RGB(150,10,0),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,19,18),CONST(流入3*100000000),DRAWNULL),RGB(250,0,250),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,18,17),CONST(流出3*100000000),DRAWNULL),RGB(0,255,255),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,13,12),CONST(总额5),DRAWNULL),RGB(150,10,0),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,12,11),CONST(流入5*100000000),DRAWNULL),RGB(250,0,250),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,11,10),CONST(流出5*100000000),DRAWNULL),RGB(0,255,255),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,6,5),CONST(总额10),DRAWNULL),RGB(150,10,0),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,5,4),CONST(流入10*100000000),DRAWNULL),RGB(250,0,250),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,4,3),CONST(流出10*100000000),DRAWNULL),RGB(0,255,255),0,DRAWNULL);
DRAWTEXT(CURRBARSCOUNT=30,画*1,’总额亿’),COLORRED;
DRAWTEXT(CURRBARSCOUNT=30,画*0.73,’流入亿’),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=30,画*0.50,’流出亿’),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=30,画*0.25,’净流亿’),COLOR0099FF;
DRAWTEXT(CURRBARSCOUNT=26,画*1,’1日’),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=19,画*1,’3日’),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=12,画*1,’5日’),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=5,画*1,’10日’),COLORMAGENTA;
DRAWNUMBER(CURRBARSCOUNT=23,画*1,CONST(总额/100000000)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=23,画*0.75,CONST(流入)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=23,画*0.50,CONST(流出)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=23,画*0.25,CONST(净流)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=16,画*1,CONST(总额3/100000000)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=16,画*0.75,CONST(流入3)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=16,画*0.50,CONST(流出3)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=16,画*0.25,CONST(净流3)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=9,画*1,CONST(总额5/100000000)), COLORDDFFFF;
DRAWNUMBER(CURRBARSCOUNT=9,画*0.75,CONST(流入5)), COLORDDFFFF;
DRAWNUMBER(CURRBARSCOUNT=9,画*0.50,CONST(流出5)), COLORDDFFFF;
DRAWNUMBER(CURRBARSCOUNT=9,画*0.25,CONST(净流5)), COLORDDFFFF;
DRAWNUMBER(CURRBARSCOUNT=2,画*1,CONST(总额10/100000000)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=2,画*0.75,CONST(流入10)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=2,画*0.50,CONST(流出10)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=2,画*0.25,CONST(净流10)),COLORYELLOW;

通达信坐船神器主图指标公式

MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA30:=MA(CLOSE,30);
MA60:MA(CLOSE,60);
成本价:=MCST,COLORLICYAN;{市场成本,无未来}
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);{主体K线,无未来}
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
{STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 ORVAR8
OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,1),COLORRED;{红1}
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
{STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 ORVAR14
OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),1.0,0),COLORFFCC66;}
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13
OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
黄柱体选股:STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),4,0),COLORYELLOW;
趋势线:=MA((CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ,2);{抄大底,无未来}
抄大底十字选股: DRAWICON((FILTER(趋势线<-20,5)),L-0.6,23);
支撑线:=TROUGH(CLOSE,10,1)*1.02,LINETHICK2;
VAR24:=IF(TROUGHBARS{波谷位置,未来函数}(3,16,1)=0 AND HIGH>L+0.04,10,0);
VAR25:=ZIG{未来函数}(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR26:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR27:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR28:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR29:=CLOSE/MA(CLOSE,40)*100<78;
VAR30:=CLOSE/MA(CLOSE,60)*100<74;
VAR31:=HIGH>LOW*1.051;
VAR32:=VAR28 AND COUNT(VAR31,5)>1;
VAR33:=(C=L AND H=L);
VAR34:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
单枪出击选股:{无未来}DRAWICON((VAR32 AND (VAR29 OR VAR30) AND NOT(VAR33) AND L<支撑线),L-0.4,27)COLORLIMAGENTA;
组合买1选股:{有未来}DRAWICON((VAR24 AND L<支撑线),L-0.2,26)COLORYELLOW;
组合买2选股:{有未来}DRAWICON(((VAR25+VAR26+VAR27+VAR28) AND L<支撑线),L-0.3,25)COLORRED;
DRAWTEXT(VAR26,L-0.4,’★’)COLORRED;
VAR35:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);{大资金活动有未来}
大资金买进A选:{有未来}DRAWTEXT(VAR35 AND COUNT(VAR35,30)=1,LOW*0.98,’⊙大资金买进A’),LINETHICK1,COLORFF00FF;
VAR36:=(100 – ((90 * (HHV(HIGH,20) – CLOSE)) / (HHV(HIGH,20) – LLV(LOW,20))));
VAR37:=(100 – MA(((100 * (HHV(HIGH,5) – CLOSE)) / (HHV(HIGH,5) – LLV(LOW,5))),34));
AABB:=IF(CROSS(VAR36,MA(VAR37,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLOREE00EE;
大资金买进B选:{无未来+有未来}DRAWTEXT((CROSS(VAR36,MA(VAR37,5)) AND (VAR35 AND COUNT(VAR35,30)=1)),L*0.96,’⊙大资金活动B’);
WZ:=CURRBARSCOUNT;{主图画面文字}
{DRAWTEXT(WZ=1,HHV(C,50)*0.99,’ ★红钻=组合买2 有’)COLORRED;
DRAWTEXT(WZ=1,HHV(C,50)*0.97,’ 黄钻=组合买1 有’)COLORYELLOW;
DRAWTEXT(WZ=1,HHV(C,50)*0.95,’ 绿钻=单枪出击 无’)COLORGREEN;
DRAWTEXT(WZ=1,HHV(C,50)*0.93,’ 十字=抄大底 无’),COLORWHITE;}
{注1:上面的“有”于“无”代表有未来函数和无未来函数};
{注2:本指标包含了11项选股功能};
VAR001:=REF(H,5)=HHV(H,2*5+1);
VAR002:=BACKSET(VAR001,5+1);
VAR003:=FILTER(VAR002,5) AND H=HHV(H,5+1);
VAR004:=IF(VAR003,CURRBARSCOUNT,0);
VAR005:=BARSLAST(VAR003);
VAR006:=IF(VAR005,REF(VAR004,VAR005),VAR004);
VAR007:=BACKSET(ISLASTBAR,VAR006);
VAR008:=CONST(REF(H,VAR006-1));
VAR009:=REF(VAR006,VAR005+1);
VAR0010:=BACKSET(ISLASTBAR,VAR009);
VAR0011:=CONST(REF(H,VAR009-1));
VAR0012:=FILTER((VAR003 AND VAR0010),50);
VAR0001:=REF(L,5)=LLV(L,2*5+1);
VAR0002:=BACKSET(VAR0001,5+1);
VAR0003:=FILTER(VAR0002,5) AND L=LLV(L,5+1);
VAR0004:=IF(VAR0003,CURRBARSCOUNT,0);
VAR0005:=BARSLAST(VAR0003);
VAR0006:=IF(VAR0005,REF(VAR0004,VAR0005),VAR0004);
VAR0007:=CONST(VAR0006);
VAR0008:=BACKSET(ISLASTBAR,VAR0007);
VAR0009:=CONST(REF(L,VAR0007-1));
VAR00010:=VAR0003*L*VAR0008;
VAR00011:=REF(VAR0006,VAR0005+1);
VAR00012:=BACKSET(ISLASTBAR,VAR00011);
VAR00013:=CONST(REF(L,VAR00011-1));
STICKLINE(VAR00012,VAR00013,VAR00013,0.5,1),COLORCYAN,LINETHICK3;
{STICKLINE(VAR010,L,L/1.02,3.5,0),COLORYELLOW,LINETHICK3;}
STICKLINE(VAR0008,VAR0009,VAR0009,0.5,0),COLORYELLOW,LINETHICK3;
参考线一: DRAWLINE(VAR003,H,CROSS(C,VAR008) AND VAR007,VAR008,0)COLORYELLOW;
参考线二:=DRAWLINE(VAR0012,H,CROSS(C,VAR0011),VAR0011,0)COLORLIBLUE;
{选股一: DRAWICON(SUM(单枪,2),参考线一*1.1,25);
选股二: DRAWICON(SUM(匹马,2),参考线二*1.1,26);};
QQ:=C/REF(C,1)>=1.05;
DRAWTEXT(QQ,L*1.03,’5%’)COLORYELLOW;
AH:=((REF(H,1)+REF(L,1)+REF(C,1)*2)/4)+(REF(H,1)-REF(L,1));
STICKLINE(C>AH,AH,AH,3,0)COLORYELLOW;
VAR000011:=REF(CLOSE,1);
VAR000012:=SMA(MAX(CLOSE-VAR000011,0),7,1)/SMA(ABS(CLOSE-VAR000011),7,1)*100,COLORYELLOW;
底进:=(FILTER(REF(VAR000012,1)<20 AND VAR000012>REF(VAR000012,1),5)),COLORRED;
高出:=(FILTER(REF(VAR000012,1)>80 AND VAR000012<REF(VAR000012,1),5)),COLORFFFF50;
DRAWICON(FILTER(REF(VAR000012,1)<20 AND VAR000012>REF(VAR000012,1),5),L-0.5,13 );
DRAWICON(FILTER(REF(VAR000012,1)>80 AND VAR000012<REF(VAR000012,1),5),H+0.3,2);

资金运作方向庄家资金,庄家资金开始变红及选股、检测资金流,优化五行量化资金个股,资金增减趋势。


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址