• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

改进版立脏量主图

股票公式编写 第一股票指标公式网 6天前 5次浏览 0个评论 扫描二维码

改进版立脏量主图 指标公式:老鼠仓+见底主图、黑牛战法主图及选股、价格天梯主图,箱体A主图,ENE季月线主图:神兵五彩主图归一操盘主图。

通达信改进版立脏量主图指标公式

N:=80;M:=3;M1:=3;M2:=6;M3:=12;M4:=24;M5:=34;M6:=48;M7:=89;M8:=144;M9:=21;
水平面:MA(CLOSE,89),COLORFFA2FF;
BBI:(MA(CLOSE,M1)+MA(CLOSE,M2)+MA(CLOSE,M3)+MA(CLOSE,M4))/4;
BAA:(MA(CLOSE,M5)+MA(CLOSE,M6)+MA(CLOSE,M7)+MA(CLOSE,M8)+MA(CLOSE,M9))/5,COLOR0000CD,LINETHICK4;
长线EBBI:(EMA(C,6)+EMA(C,18)+EMA(C,54)+EMA(C,162))/4,COLORFF00FF,LINETHICK2;
STICKLINE(CROSS(BBI,长线EBBI),L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(CROSS(BBI,长线EBBI),L-0.13,’走牛’) ,COLORYELLOW;
STICKLINE(CROSS(BBI,BAA),L,L-0.11,5,0),COLORWHITE;
DRAWTEXT(CROSS(BBI,BAA),L-1.0,’买入持股’) ,COLORFFA2FF,LINETHICK3;
DRAWTEXT(CROSS(BAA,BBI),L-0.13,’注意仓位’) ,COLOR00E300,LINETHICK3;
IF(BBI>REF(BBI,1),BBI,DRAWNULL),COLORRED,LINETHICK2;
IF(BBI<REF(BBI,1),BBI,DRAWNULL),COLORBLUE,LINETHICK2;
MA1:MA(CLOSE,24),COLOR00E300,LINETHICK1;
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(V2>=1,O,C,2,0),COLORYELLOW;
MA13:=MA(CLOSE,13);
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
A1:=MIN(O,C);
B1:=ABS(O-C);
T1:=FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10);
STICKLINE(T1,A1,A1+B1/4,2,0),COLOR007575;
STICKLINE(T1,A1+B1/4,A1+B1/2,2,0),COLORFF0000;
STICKLINE(T1,A1+B1/2,A1+B1*3/4,2,0),COLOR007575;
STICKLINE(T1,A1+B1*3/4,A1+B1,2,0),COLORFF0000;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE – LC),0),3,1) / SMA(ABS((CLOSE – LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
{DRAWTEXT(CROSS(FF,MA15),(LOW * 0.97),’底背离’),COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.04),’顶背离’),COLOR1880FF;}
STICKLINE(CROSS(FF,MA15),A1,A1+B1/2,2,0),COLOR7F017F;
STICKLINE(CROSS(88,RSI),A1+B1,A1+B1/2,2,0),COLORGREEN;
T2:=COUNT(CROSS(BBI,3),3)=1 AND CROSS(C,BBI);
DRAWTEXT(T2,H*1.05,’反转’),COLORWHITE;
STICKLINE(T2,O,C,2,0),COLORRED;
T12:=V2>=1;
T0:=BARSLAST(T12);
L1:=REF(L,T0);
H1:=REF(H,T0);
STICKLINE(REF(T12,1) OR REF(T12,2) OR REF(T12,3),H1,H1,4,-1),COLORWHITE;
STICKLINE(REF(T12,1) OR REF(T12,2) OR REF(T12,3),L1,L1,4,-1),COLORWHITE;
{T11:=REF(T12,3) AND COUNT(L<L1,4)=0 AND COUNT(L>H1,4)>1;
DRAWTEXT(T11,H*1.05,’三天’),COLORWHITE;
STICKLINE(T11,O,C,2,0),COLORFF00FF;}
{(REF(V2>=1,3) OR REF(V2>=1,2) OR REF(V2>=1,1)) };
L11:=MIN(REF(L,1),L);
L10:=MIN(L11,REF(L,2));
L21:=MAX(REF(L,1),L);
L20:=MAX(L21,REF(L,2));
T111:=(REF(V2>=1,3) OR REF(V2>=1,2) OR REF(V2>=1,1)) AND
((L10>L1 AND L20>H1) OR (L11>L1 AND L21>H1));
T11:=T111 AND REF(T111,1)=0;
STICKLINE(T11,O,C,2,0),COLORFF00FF;
高:=REF(HHV(H,N),M);
低:=REF(LLV(L,N),M);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
顶点:REFDATE(高,DATE),POINTDOT,LINETHICK2,COLORWHITE;
%19.8:REFDATE(H19,DATE),POINTDOT,LINETHICK2,COLORYELLOW;
%38.2:REFDATE(H38,DATE),POINTDOT,LINETHICK2,COLORGREEN;
%50:REFDATE(H中,DATE),POINTDOT,LINETHICK2,COLORRED;
%61.8:REFDATE(H61,DATE),POINTDOT,LINETHICK2,COLORMAGENTA;
%80.9:REFDATE(H80,DATE),POINTDOT,LINETHICK2,COLORBLUE;
低点:REFDATE(低,DATE),POINTDOT,LINETHICK2,COLORWHITE;
DRAWTEXT(ISLASTBAR,顶点,’顶点’),COLORWHITE;
DRAWTEXT(ISLASTBAR,低点,’低点’),COLORWHITE;
STICKLINE(T1,A1,A1+B1/2,2,0),COLOR007575;
STICKLINE(T1,A1+B1/2,A1+B1,2,0),COLORBLUE;
STICKLINE(T11 AND T12,A1,A1+B1/2,2,0),COLORFF00FF;
STICKLINE(T11 AND T12,A1+B1/2,A1+B1,2,0),COLORYELLOW;
STICKLINE(T1 AND T12,A1+B1/3,A1+B1,2,0),COLORYELLOW;
STICKLINE(T1 AND T12,A1,A1+B1/3,2,0),COLOR007575;
STICKLINE(T1 AND T12,A1+B1/3,A1+B1*2/3,2,0),COLORBLUE;
STICKLINE(T2 AND T12,A1+B1/2,A1+B1,2,0),COLORRED;
STICKLINE(T2 AND T12,A1,A1+B1/2,2,0),COLORYELLOW;

通达信苏秦背剑主图及选股指标公式

ZT:=(C/REF(C,1)-1)*100>=4;
SX:=REF(ZT,1) AND REF(L,1)>REF(H,2)*1.01 AND MAX(C,O)/MIN(C,O)<1.01 AND H>MAX(C,O)*1.01 AND MIN(C,O)>L*1.01;
TJ:=REF(SX,1) AND C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01;
DRAWTEXT(TJ,H,’背剑’)COLORYELLOW DRAWABOVE;
DRAWTEXT(SX AND REFX(C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01,1),H,’剑身’)COLORYELLOW DRAWABOVE;
W0:=BARSLAST(TJ);
ZG1:IF(W0<10,REF(H,W0),DRAWNULL)DOTLINE;
TJ1:=ZT AND L>REF(H,1)*1.01 AND REFX(SX,1) AND REFX(C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01,2);
DRAWTEXT(TJ1,H,’跳空’)COLORYELLOW DRAWABOVE;
W1:=COUNT(C>ZG1,W0+1)=1 AND C>ZG1;
W2:=CROSS(C,ZG1);
TJ2:=(W1||(W2));
DRAWICON(TJ2 AND W0<10,L,1);
DRAWTEXT(TJ2 AND W0<10,H,’剑出鞘’)COLORRED DRAWABOVE;

{
选股公式:

ZT:=(C/REF(C,1)-1)*100>=4;
SX:=REF(ZT,1) AND REF(L,1)>REF(H,2)*1.01 AND MAX(C,O)/MIN(C,O)<1.01 AND H>MAX(C,O)*1.01 AND MIN(C,O)>L*1.01;
TJ:=REF(SX,1) AND C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01;
W0:=BARSLAST(TJ);
ZG1:=IF(W0<10,REF(H,W0),DRAWNULL);
W1:=COUNT(C>ZG1,W0+1)=1 AND C>ZG1;
W2:=CROSS(C,ZG1);
TJ2:=(W1||(W2));
COUNT(TJ2 AND W0<10,60);
}

智能分时买卖主图坐船神器主图,天堂分笔主图、战神推荐主图,凌波微步主图DK决策主图,力挽牛熊主图。


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址