• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

牛线箱主图

股票公式编写 第一股票指标公式网 2周前 (06-27) 8次浏览 0个评论 扫描二维码

牛线箱主图 指标公式:老鼠仓+见底主图、黑牛战法主图及选股、价格天梯主图,箱体A主图,ENE季月线主图:神兵五彩主图归一操盘主图。

通达信牛线箱主图指标公式

{箱顶底}
AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8);
BA:=EMA(AB,5);
A18:=REFDATE(REF(HHV(H,96),5),DATE);{高}
B1:=REFDATE(REF(LLV(L,96),5),DATE);{低}
DY:=((A18)+(B1))/2;{中}
顶:IF(AB>0 AND AB-BA<=0,A18,A18),DOTLINE,COLORCYAN;
腰:IF(AB>0 AND AB-BA<=0,DY,DY),DOTLINE,COLORCYAN;
底:IF(AB>0 AND AB-BA<=0,B1,B1),DOTLINE,COLORCYAN;
MC:=C#MONTH,NODRAW;
MO1:=IF(DAY<REF(DAY,1),O,DRAWNULL);
MO:=HHV(MO1,DAY),NODRAW;
STICKLINE(MC>=MO,MO,MC,4,-1)COLOR00009C;
STICKLINE(MC<MO,MO,MC,4,-1),COLOR4F2F4F;
AQ:=O#WEEK;B:=C#WEEK;
AAQ:=H#WEEK;BB:=L#WEEK;
STICKLINE(B>=AQ,AAQ,BB,4,0),COLOR00006B;
STICKLINE(B<AQ,AAQ,BB,4,0),COLOR663300;
{猎击止损}
P:=9;
WH1:=IF(L=LLV(L,P),L,DRAWNULL);
WH2:=CONST(BARSLAST(WH1!=DRAWNULL));
WH3:=CONST(IF(WH2=0,H,REF(H,WH2)));
WH4:=CONST(REF(BARSLAST(H>WH3),WH2+1)+WH2+1);
WH5:=CONST(IF(WH4=0,H,REF(H,WH4)));
WH6:=CONST(REF(BARSLAST(H>WH5),WH4+1)+WH4+1);
赢:IF(CURRBARSCOUNT<=WH2+10,CONST(IF(WH6=0,H,REF(H,WH6))),DRAWNULL),COLORMAGENTA,LINETHICK2;
DRAWTEXT(ISLASTBAR,赢,’ YW’),COLORMAGENTA;
{www.171415.com 第一股票指标公式网_最全最好股票指标公式}
H1:=IF(H=HHV(H,P),H,DRAWNULL);
H2:=CONST(BARSLAST(H1!=DRAWNULL));
H3:=CONST(IF(H2=0,L,REF(L,H2)));
H4:=CONST(REF(BARSLAST(L<H3),H2+1)+H2+1);
H5:=CONST(IF(H4=0,L,REF(L,H4)));
H6:=CONST(REF(BARSLAST(L<H5),H4+1)+H4+1);
损:IF(CURRBARSCOUNT<=H2+10,CONST(IF(H6=0,L,REF(L,H6))),DRAWNULL),COLORGREEN,LINETHICK2;
DRAWTEXT(ISLASTBAR,损,’ SW’),COLORGREEN;
{九线}
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1:(EMA(VAR1,3)+EMA(VAR1,6)+EMA(VAR1,12)+EMA(VAR1,24))/4,COLOR0044BB;
A2:EMA(A1,2),COLOR3355BB;
A3:EMA(A2,2),COLOR4455BB;
A4:EMA(A3,2),COLOR5555BB;
A5:EMA(A4,2),COLOR6655BB;
A6:EMA(A5,2),COLOR7755BB;
A7:EMA(A6,2),COLOR8855BB;
{K线}
DRAWKLINE(H,O,L,C);
STICKLINE(C>=O,C,O,3,0),COLOR1F1AC5;
STICKLINE(C>=O,C,O,1.3,0),COLOR1F1AD5;
STICKLINE(C>=O,C,O,0,0),COLOR1F1AF5;
STICKLINE(C<O,C,O,3,0),COLORBBBB00;
STICKLINE(C<O,C,O,1.3,0),COLORDDDD00;
STICKLINE(C<O,H,L,0,0),COLORFFFF00;
A8:EMA(VAR1,2.78)*1.028,COLORWHITE,LINETHICK1;
A9:MA(OPEN,3.2)*1.028,COLORYELLOW,LINETHICK1;
{涨停显示}
C6:=REF(C,1);
涨停:=IF((C-C6)*100/C6>=(10-0.01*100/C6),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(涨停,H,L,0,0),COLORLIRED;
{高位}
VAR2:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR3:=MA(CLOSE,20)+2*STD(CLOSE,20);
DRAWTEXT(CROSS(VAR2,VAR3),HIGH*1.045,’↓高’),COLORCYAN;
{逃顶}
VAR7:=REF(C,1);
VAR8:=SMA(MAX(C-VAR7,0),6,1)/SMA(ABS(C-VAR7),6,1)*100;
DRAWTEXT(CROSS(82,VAR8),H*1.025,’↓逃’),COLORCYAN;
{KDJ金叉}
VAR4:=(100 – ((90 * (HHV(HIGH,14) – CLOSE)) / (HHV(HIGH,14) – LLV(LOW,14))));
VAR5:=(100 – ((90 * (HHV(HIGH,14) – CLOSE)) / (HHV(HIGH,14) – LLV(LOW,14))));
VAR6:=(100 – MA(((100 * (HHV(HIGH,6) – CLOSE)) / (HHV(HIGH,6) – LLV(LOW,6))),34));
DRAWICON(CROSS(VAR5,MA(VAR6,6)),(LOW – (LOW*0.015)),38);
DRAWICON(CROSS(MA(VAR6,6),VAR4),(HIGH+(HIGH*0.015)),39);
STICKLINE(CROSS("KDJ.K"(3,5,3),"KDJ.D"(3,5,3)),O,C,0.6,0),COLORYELLOW;
STICKLINE(CROSS("KDJ.D"(3,5,3),"KDJ.K"(3,5,3)),O,C,0.6,0),COLORBLUE;
{黑马}
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.95),’★马’),COLORMAGENTA;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.97),’★加’),COLORMAGENTA;
{主力进场}
VAR9:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR10:=SMA(VAR9,3,1);
VAR11:=SMA(VAR10,3,1);
VAR12:=SMA(VAR11,3,1);
主力出现:DRAWICON(CROSS(VAR11,VAR12) AND (VAR11<40),L*0.98,23);
{突破追涨}
A10:=HHV(H,73);
A11:=LLV(L,73);
M1:=MA(C,13);
M2:=MA(C,36);
M3:=MA(C,73);
K1:=(0.618*A10+0.382*A11),COLORGREEN;
K2:=(0.5*A10+0.5*A11),COLORGREEN;
K3:=(0.382*A10+0.618*A11),COLORGREEN;
K4:=(0.191*A10+0.809*A11),COLORRED;
K5:=(0.809*A10+0.191*A11),COLORRED;
牛:=V=HHV(V,64) AND V>REF(V,1)*1.5;
单阳:=C AND 牛;
单阳收:=C;
单阳开:=O;
高不破价:=REF(C,BARSLAST(单阳));
前高:=HHV(高不破价,13);
STICKLINE(前高,高不破价,高不破价,5,0)DOTLINE,COLORBLUE;
突破:=CROSS(C,前高) AND C>MA(C,36) AND (C-O)/O>0.030 AND MA(C,13)>REF(MA(C,13),1) AND C>K5;
DRAWTEXT(CROSS(C,前高) AND C>MA(C,36) AND (C-O)/O>0.035 AND MA(C,13)>REF(MA(C,13),1) AND MA(C,36)>REF(MA(C,36),1) ,L*1.00,’☆突’) ,COLORMAGENTA;
DRAWTEXT(单阳 >REF(单阳,1) AND (C-O)/O>0.0455,L*1.00,’★追’) ,COLORMAGENTA;
{行业}
所属地域:DRAWTEXT_FIX(ISLASTBAR ,0.05,0.01,1,DYBLOCK),COLORYELLOW;
所属行业:DRAWTEXT_FIX(ISLASTBAR ,0.06,0.01,0,HYBLOCK),COLORYELLOW;
低:IF(CURRBARSCOUNT<=WH2+1,IF(L=LLV(L,P),L*0.98,DRAWNULL),DRAWNULL),COLORRED,CIRCLEDOT,LINETHICK6;
高:IF(CURRBARSCOUNT<=H2+1,IF(H=HHV(H,P),H*1.012,DRAWNULL),DRAWNULL),COLORGREEN,CIRCLEDOT,LINETHICK6;

通达信苏秦背剑主图及选股指标公式

ZT:=(C/REF(C,1)-1)*100>=4;
SX:=REF(ZT,1) AND REF(L,1)>REF(H,2)*1.01 AND MAX(C,O)/MIN(C,O)<1.01 AND H>MAX(C,O)*1.01 AND MIN(C,O)>L*1.01;
TJ:=REF(SX,1) AND C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01;
DRAWTEXT(TJ,H,’背剑’)COLORYELLOW DRAWABOVE;
DRAWTEXT(SX AND REFX(C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01,1),H,’剑身’)COLORYELLOW DRAWABOVE;
W0:=BARSLAST(TJ);
ZG1:IF(W0<10,REF(H,W0),DRAWNULL)DOTLINE;
TJ1:=ZT AND L>REF(H,1)*1.01 AND REFX(SX,1) AND REFX(C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01,2);
DRAWTEXT(TJ1,H,’跳空’)COLORYELLOW DRAWABOVE;
W1:=COUNT(C>ZG1,W0+1)=1 AND C>ZG1;
W2:=CROSS(C,ZG1);
TJ2:=(W1||(W2));
DRAWICON(TJ2 AND W0<10,L,1);
DRAWTEXT(TJ2 AND W0<10,H,’剑出鞘’)COLORRED DRAWABOVE;

{
选股公式:

ZT:=(C/REF(C,1)-1)*100>=4;
SX:=REF(ZT,1) AND REF(L,1)>REF(H,2)*1.01 AND MAX(C,O)/MIN(C,O)<1.01 AND H>MAX(C,O)*1.01 AND MIN(C,O)>L*1.01;
TJ:=REF(SX,1) AND C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01;
W0:=BARSLAST(TJ);
ZG1:=IF(W0<10,REF(H,W0),DRAWNULL);
W1:=COUNT(C>ZG1,W0+1)=1 AND C>ZG1;
W2:=CROSS(C,ZG1);
TJ2:=(W1||(W2));
COUNT(TJ2 AND W0<10,60);
}

智能分时买卖主图坐船神器主图,天堂分笔主图、战神推荐主图,凌波微步主图DK决策主图,力挽牛熊主图。


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址