• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

MACD+KDJ完美同图

股票公式编写 第一股票指标公式网 2周前 (06-27) 8次浏览 0个评论 扫描二维码

MACD+KDJ完美同图 指标公式:红色MACD、MACD和KDJ组合、最佳MACD,MACD提前交叉,MACD零轴主图:一成MACD背离复合MACD。

通达信MACD+KDJ完美同图指标公式

STICKLINE(C>0,0,10,5,0),COLOR222222;
STICKLINE(C>0,100,90,5,0),COLOR222222;
DLCL:=CROSS(0.9,"KDJ.J"<0);
STICKLINE(DLCL,9,1,3,0),COLOR353500;
STICKLINE(DLCL,9,1,2.5,0),COLOR454500;
STICKLINE(DLCL,9,1,2,0),COLOR555500;
STICKLINE(DLCL,9,1,1.5,0),COLOR656500;
STICKLINE(DLCL,9,1,1,0),COLOR757500;
STICKLINE(DLCL,9,1,0.5,0),COLOR858500;
DLMC:="KDJ.K">80 AND "KDJ.D">80 AND CROSS("KDJ.D","KDJ.K");
STICKLINE(DLMC,91,99,3,0),COLOR353500;
STICKLINE(DLMC,91,99,2.5,0),COLOR454500;
STICKLINE(DLMC,91,99,2,0),COLOR555500;
STICKLINE(DLMC,91,99,1.5,0),COLOR656500;
STICKLINE(DLMC,91,99,1,0),COLOR757500;
STICKLINE(DLMC,91,99,0.5,0),COLOR858500;
{C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");}
C1:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D1:=REF(C,C1+1)<C AND REF("KDJ.K",C1+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");
STICKLINE(D1>0 ,99,91,3,0),COLOR555555;
STICKLINE(D1>0 ,99,91,2.5,0),COLOR777777;
STICKLINE(D1>0 ,99,91,2,0),COLOR999999;
STICKLINE(D1>0 ,99,91,1.5,0),COLORBBBBBB;
STICKLINE(D1>0 ,99,91,1,0),COLORDDDDDD;
STICKLINE(D1>0 ,99,91,0,0),COLORFFFFFF;
{www.171415.com 第一股票指标公式网_股票通达信指标公式}
LAW1:=MA(INDEXC,13)/INDEXC;
TJ1:=LAW1>1.05;
LAW3:=(C-MA(C,60))/MA(C,60)*100;
STICKLINE(PERIOD=5 && LAW3<-24 AND TJ1,0,2,3,0),COLOR006600;
STICKLINE(PERIOD=5 && LAW3>24,100,98,3,0),COLOR006600;
N:=9;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1),COLOR444444;
D:=SMA(K,3,1),COLOR666633;
J:3*K-2*D,COLOR444444;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
KX:=BARSSINCE(CLOSE);
HK:=HHV(K,KX);
HD:=HHV(D,KX);
HJ:=HHV(J,KX);
LK:=LLV(K,KX);
LD:=LLV(D,KX);
LJ:=LLV(J,KX);
HKMAX:=MAX(HK,MAX(HD,HJ));
LKMIN:=MIN(LK,MIN(LD,LJ));
KDBL:=(HKMAX+LKMIN)/2;
KDC:=HKMAX-LKMIN;
MHF:=HHV(DIFF,KX);
MHD:=HHV(DEA,KX);
MHM:=HHV(MACD,KX);
MLF:=LLV(DIFF,KX);
MLD:=LLV(DEA,KX);
MLM:=LLV(MACD,KX);
HMAX:=MAX(MHF,MAX(MHD,MHM));
LMIN:=MIN(MLF,MIN(MLD,MLM));
FDBL:=(HMAX+LMIN)/100;
FDC:=HMAX-LMIN;
SH:=(0-FDBL)*(KDC/FDC)+KDBL;
DF:(DIFF-FDBL)*(KDC/FDC)+KDBL,COLORA68064;{COLORWHITE};
DA:(DEA-FDBL)*(KDC/FDC)+KDBL,COLORGRAY{COLORA8A8A8;COLORYELLOW};
MACDA:=(MACD-FDBL)*(KDC/FDC)+KDBL;
CDA:=MACD<REF(MACD,1) AND MACD>0;
CDB:=MACD>=REF(MACD,1) AND MACD>0;
CDC:=MACD>REF(MACD,1) AND MACD<0;
CDD:=MACD<=REF(MACD,1) AND MACD<0;
STICKLINE(CDB,50,(MACDA-SH)+50,1,0),COLOREE00EE;
STICKLINE(CDA,50,(MACDA-SH)+50,1,0),{COLOR00DDDD}COLOR3299CC;
STICKLINE(CDC,50,(MACDA-SH)+50,1,0),{COLORAA11BB}COLORCC3299{COLOR9370DB};
STICKLINE(CDD,50,(MACDA-SH)+50,1,0),COLOR666633;

通达信涨跌超前MACD指标公式

0,COLORGRAY;
DIF12:=(EMA(CLOSE,12)-EMA(CLOSE,26))/((EMA(CLOSE,12)+EMA(CLOSE,26))/2)*1000;
DEA12:=EMA(DIF12,9);
KDIF12:=3*(DIF12-DEA12);
KDEA12:=SMA(KDIF12,5,2);
微分DIF:=KDIF12*5,COLORWHITE,LINETHICK1;
微分DEA:=KDEA12*5,COLORYELLOW,LINETHICK1;
MACD2:2*(微分DIF-微分DEA),COLORBLACK;
MAMACD:=MA(MACD2,3),,COLORBLACK;
STICKLINE(MACD2>REF(MACD2,1) AND MACD2>0,0,MACD2,1,0),COLORRED;
STICKLINE(MACD2<=REF(MACD2,1) AND MACD2>0,0,MACD2,1,0),COLORYELLOW;
STICKLINE(MACD2<REF(MACD2,1) AND MACD2<0,0,MACD2,1,0),COLORCYAN;
STICKLINE(MACD2>=REF(MACD2,1) AND MACD2<0,0,MACD2,1,0),COLORMAGENTA;
STICKLINE(MAMACD<1*REF(MAMACD,1), MAMACD, MACD2 ,3, 0),COLORBLUE;
STICKLINE(MAMACD>1*REF(MAMACD,1), MAMACD, MACD2 , 3, 0),COLORLIRED;
微分DIF2:KDIF12*5,COLORRED,LINETHICK1;
微分DEA2:KDEA12*5,COLORMAGENTA,LINETHICK1;
NOTEXT强:IF(微分DIF2<MA(微分DIF2,2),微分DIF2,DRAWNULL),COLORGREEN;
NOTEXT弱:IF(微分DEA2<MAX(微分DEA2,REF(微分DEA2,1)),微分DEA2,DRAWNULL),COLORYELLOW;
DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*300,COLORWHITE,DOTLINE;
DEA:=EMA(DIF,9),COLORYELLOW,DOTLINE;
DIF普:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA普:=EMA(DIF,9);
MACD:=(DIF普-DEA普)*2,COLORSTICK;
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");
{DRAWTEXT(B1>0,DIF*0.7,’↙MACD底背’),COLORFF00FF; }
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");
{DRAWTEXT(D1>0,DIF*1.2,’↙MACD顶离’),COLORBLUE;}{MACD顶背离}
JC := DEA-DIF;
绿柱面积:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);
红柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));
X1:=IF (MACD<0,BARSLAST(CROSS(DIF,DEA)),0);
前次绿柱面积:=REF(绿柱面积,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积)
AND 本次最低价<前次最低价 ),1,0);
RS1:= MACD<0 AND REF(MACD,1)<0 AND C<前次最低价
AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(MACD)<ABS(REF(MACD,1));
底背驰: IF (CROSS(DIF,DEA),REF(Y1,1),0);
DRAWTEXT(底背驰,DIF*0.8,’↙积底背’),COLOR00FFFF;
X2:=IF (MACD>0,BARSLAST(CROSS(DEA,DIF)),0);
前次红柱面积:=REF(红柱面积,X2+1);
前次最高价:=REF(本次最高价,X2+1);
Y2:=IF((红柱面积>0 AND 红柱面积<前次红柱面积 AND 本次最高价>前次最高价 ),1,0);
RS2:= MACD>0 AND REF(MACD,1)>0 AND C>前次最高价 AND ABS(红柱面积)<ABS(前次红柱面积) AND ABS(MACD)<ABS(REF(MACD,1));
顶背驰:= IF (CROSS(DEA,DIF),REF(Y2,1),0);
DRAWTEXT(顶背驰,DIF*0.8,’↙顶底背’),COLORGREEN;
MACD高:=HHV(MACD,5);
E:=REF(C,C1+1)>C AND DEA>0 AND REF(MACD高,C1+1)<MACD高 AND CROSS("MACD.DEA","MACD.DIF") ;
{DRAWTEXT(E>0,DIF*1.1,’↙柱顶背’),COLORRED;}
F:=REF(C,A1+1)>C AND DEA<0 AND REF(MACD高,A1+1)<MACD高 AND CROSS("MACD.DIF","MACD.DEA");
{DRAWTEXT(F>0,DIF*0.9,’↙柱底背’),COLORYELLOW;}

MACD+神奇数字+挖坑KDJ全景,实战型MACD、MACD上主图,加速MACDMACD交易主图,MACD仓位控制。


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址