• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

文字主图

股票公式编写 第一股票指标公式网 2周前 (06-29) 10次浏览 0个评论 扫描二维码

文字主图 指标公式:老鼠仓+见底主图、黑牛战法主图及选股、价格天梯主图,箱体A主图,ENE季月线主图:神兵五彩主图归一操盘主图。

通达信文字主图指标公式

DRAWTEXT_FIX(1,0.7,0,0,’所属板块:’),COLORFF6000;
DRAWTEXT_FIX(1,0.77,0,0,HYBLOCK),COLORRED;
DRAWTEXT_FIX(1,0.835,0,0,DYBLOCK),COLORYELLOW;
总股本:=STRCAT(STRCAT(‘总股本: ‘,CON2STR(TOTALCAPITAL/1000000,2)),’亿’);
流通盘:=STRCAT(STRCAT(‘ 流通盘: ‘,CON2STR(CAPITAL/1000000,2)),’亿’);
全流通:=STRCAT(‘ 全流通: ‘,CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(‘ 流通市值: ‘,CON2STR((CAPITAL/1000000)*C,2)),’亿’);
上市日期:=STRCAT(‘ 上市日期: ‘,CON2STR(FINANCE(42),0));
股本市值:=STRCAT(‘股本市值: ‘,STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));
{}
市盈率:=STRCAT(‘市盈率: ‘,CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(‘ 市销率: ‘,CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(‘ 市净率: ‘,CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(‘ 净资收益率: ‘,CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(‘ 毛利率: ‘,CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(‘ 净利润率 ‘,CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(‘ 主营利润率 ‘,CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT(‘当前业绩: ‘,STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率));
{}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,’重警’,IF(Z值>=1.2 AND Z值<2.6,’轻警’,’无警’));
{www.171415.com 第一股票指标公式网_最全最好股票指标公式}
财务预警:=STRCAT(‘财务预警: ‘,STRCAT(预警,STRCAT(‘-Z值: ‘,CON2STR(Z值,3))));
优质资产率:=STRCAT(‘ 优质资产率: ‘,CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(‘ 现金负债比: ‘,CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT(‘风险系数: ‘,STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
{}
DRAWTEXT_FIX(ISLASTBAR,0.005,0.01,0,财务系数),COLOR888888;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.06,0,当前业绩),COLOR888888;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.115,0,股本市值),COLOR888888;

通达信苏秦背剑主图及选股指标公式

ZT:=(C/REF(C,1)-1)*100>=4;
SX:=REF(ZT,1) AND REF(L,1)>REF(H,2)*1.01 AND MAX(C,O)/MIN(C,O)<1.01 AND H>MAX(C,O)*1.01 AND MIN(C,O)>L*1.01;
TJ:=REF(SX,1) AND C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01;
DRAWTEXT(TJ,H,’背剑’)COLORYELLOW DRAWABOVE;
DRAWTEXT(SX AND REFX(C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01,1),H,’剑身’)COLORYELLOW DRAWABOVE;
W0:=BARSLAST(TJ);
ZG1:IF(W0<10,REF(H,W0),DRAWNULL)DOTLINE;
TJ1:=ZT AND L>REF(H,1)*1.01 AND REFX(SX,1) AND REFX(C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01,2);
DRAWTEXT(TJ1,H,’跳空’)COLORYELLOW DRAWABOVE;
W1:=COUNT(C>ZG1,W0+1)=1 AND C>ZG1;
W2:=CROSS(C,ZG1);
TJ2:=(W1||(W2));
DRAWICON(TJ2 AND W0<10,L,1);
DRAWTEXT(TJ2 AND W0<10,H,’剑出鞘’)COLORRED DRAWABOVE;

{
选股公式:

ZT:=(C/REF(C,1)-1)*100>=4;
SX:=REF(ZT,1) AND REF(L,1)>REF(H,2)*1.01 AND MAX(C,O)/MIN(C,O)<1.01 AND H>MAX(C,O)*1.01 AND MIN(C,O)>L*1.01;
TJ:=REF(SX,1) AND C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01;
W0:=BARSLAST(TJ);
ZG1:=IF(W0<10,REF(H,W0),DRAWNULL);
W1:=COUNT(C>ZG1,W0+1)=1 AND C>ZG1;
W2:=CROSS(C,ZG1);
TJ2:=(W1||(W2));
COUNT(TJ2 AND W0<10,60);
}

智能分时买卖主图坐船神器主图,天堂分笔主图、战神推荐主图,凌波微步主图DK决策主图,力挽牛熊主图。


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址