• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

一根线搞定DMI

股票公式编写 第一股票指标公式网 1周前 (06-29) 4次浏览 0个评论 扫描二维码

一根线搞定DMI 指标公式:DMI高手、优化的DMI、DMI强弱线,自用DMI,DMI优化:DMI背离DMI腹中金叉选股。

通达信一根线搞定DMI指标公式

MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:= DMP*100/MTR;
MDI:= DMM*100/MTR;
DM:=PDI-MDI,NODRAW;
TRR1:=EMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(REF(C,1)-L)),14);
DMP1:=EMA(IF(HD>0 && HD>LD,HD,0),14);
DMM1:=EMA(IF(LD>0 && LD>HD,LD,0),14);
ADX0:=EMA((DMP1-DMM1)/(DMP1+DMM1)*100,6);
ADXR0:=EMA(ADX0,6);
PDI1:=DMP1/TRR1*100;
MDI1:=DMM1/TRR1*100;
DM1:=PDI1-MDI1;
AAJ:=(3*ADX0-2*ADXR0);
MAAD:=(ADX0-ADXR0),NODRAW;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6),COLORFF00FF;{www.171415.com 第一股票指标公式网_最全最好股票指标公式}
ADXR:EXPMEMA(ADX,6),POINTDOT,LINETHICK7,COLORGREEN;
IF(DM>0,ADXR,DRAWNULL),POINTDOT,LINETHICK7,COLORRED;
助涨:DRAWICON(DM>0 AND ADX>ADXR AND ADX>20,ADXR,15);
助跌:DRAWICON(DM<0 AND ADX>ADXR AND ADX>20,ADXR,12);
DRAWICON(CROSS(ADXR0,ADX0) AND ADXR0>60 ,ADXR*1.2,8);
DRAWICON(CROSS(ADXR0,ADX0) AND ADXR0<60 ,ADXR*1.4,2);
20,COLORYELLOW,DOTLINE;
60,COLORGREEN,DOTLINE;

通达信新DMI修改版本指标公式

MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI: DMP*100/MTR;
MDI: DMM*100/MTR;
ADX: EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6),LINETHICK1;
ADXR:EXPMEMA(ADX,6),COLORWHITE,LINETHICK3;
DRAWBAND(ADX,RGB(139,101,108),ADXR,RGB(72,118,255));
DMM*100/MTR,COLOR00FF00,LINETHICK3;
DMP*100/MTR,COLOR0000FF,LINETHICK3;
VARA4:=(L+H+C+O)/4;

高手优化DMI趋向DMI,DMI精简、一招鲜DMI选股,DMI简单化DMI的用法,顶底DMI。


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址