• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

上下线波段

股票公式编写 第一股票指标公式网 1周前 (06-29) 8次浏览 0个评论 扫描二维码

上下线波段 指标公式:树缠藤主图、奔走顺畅主图、天涯爱胜主图,庄进庄撤,超级优化波段买点:财源滚滚金股起航主图。

通达信上下线波段指标公式

上线:=SMA(C,6.5,1);
下线:=SMA(C,13.5,1);
上线1:=SMA(C,3,1);
下线1:=SMA(C,8,1);
STICKLINE(上线>下线 , 上线,下线 ,2.5, 0),COLORRED,LINETHICK2;
STICKLINE(下线>上线,上线,下线,2.5,0),COLORGREEN,LINETHICK2;
DRAWTEXT( CROSS(上线,下线),LOW *0.98,’●
全仓买’ ),COLOR00FF00;
DRAWTEXT(CROSS(下线1,上线1),H*1.02,’◆
清仓’),COLORYELLOW;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
UPR:=BBI+3*STD(BBI,13),LINETHICK2;
DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,60),LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT( CROSS(82,RSI) , HIGH*1.02,’◆
减仓’) ,COLORFF9966,LINETHICK2;
A7:=(2*C+H+L)/4;
操作:MA(A7,5),LINETHICK2;
操作1:=MA(A7,5)*1.03,LINETHICK2;
操作2:=MA(A7,5)*0.97,LINETHICK2;
VAR1:LLV(A7,21);
VAR0:HHV(A7,21);
SK:=EMA((A7-VAR1)/(VAR0-VAR1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>6/10 AND VOL>=1.5*MA(VOL,5) AND
COUNT(SK>=SD,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW*0.98,’●
买进’) ,COLOR0099FF;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND
COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND
REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
OPEN>REF(CLOSE,1),1,0),LOW*0.98,’●
买进’) ,COLORYELLOW;
D:=MA(CLOSE,80)-MA(CLOSE,10)/3;
DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.98,’●
抄底’),COLORYELLOW;
VAR12:=((VOL / CAPITAL) * 100);
VAR15:=HHVBARS(HIGH,50);
VAR17:=(((CLOSE – REF(OPEN,VAR15)) / REF(OPEN,VAR15)) * 100);
VAR22:=(REF(CLOSE,2) * 0.865);
VAR23:=(REF(CLOSE,13) * 0.772);
VAR24:=MIN(VAR22,VAR23);
超跌反弹:=(IF((((((CLOSE – VAR24) / CLOSE) < 0.03) AND (VAR17 < (0 – 35))) AND ((SUM(VAR12,5) / 5) < 1.8)),1,0) * 5);
DRAWTEXT(超跌反弹,L*0.95,’♂’),COLORRED;
VAR2:=C<0.98*REF(C,1);
VAR3:=O<REF(C,1);
VAR4:=(C-REF(C,1))/REF(C,1)*100;
VAR5:=(C-REF(O,29))/REF(O,29)*100;
VAR6:=MA(COST(22)/L,3);
成功率99:=VAR6>1.5 AND VAR4>5 AND VAR5<-30;
DRAWTEXT(成功率99>0 AND REF(成功率99,1)=0,L*0.82,’↑99%’),COLORRED;
{www.171415.com 第一股票指标公式网_最全最好股票指标公式}
仓:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,5);
仓1:=INDEXC;
仓2:=MA(仓1,5);
仓3:=MA(仓1,20);
仓4:=MA(仓1,30);
B2:=仓2>仓1*1.03 AND 仓3>仓1*1.13;
操盘手:=仓<6 AND B2;
DRAWTEXT(操盘手,L*0.88,’仓’),COLORRED;
底1:=IF((((((EMA(CLOSE,5) / EMA(EMA(CLOSE,9),16)) <= 0.85) AND ((CLOSE / REF(CLOSE,1)) > 0.905)) AND ((CLOSE / REF(CLOSE,1)) < 1.05)) AND (((VOL / CAPITAL) * 100) < 5)),50,0);
底2:=((0 – ((100 * (HHV(HIGH,34) – CLOSE)) / (HHV(HIGH,34) – LLV(LOW,34)))) + 100);
底3:=((0 – ((100 * (HHV(HIGH,50) – CLOSE)) / (HHV(HIGH,50) – LLV(LOW,50)))) + 100);
底:=((0 – ((100 * (HHV(HIGH,70) – CLOSE)) / (HHV(HIGH,70) – LLV(LOW,70)))) + 100);
底4:=(((((CLOSE – MA(CLOSE,34)) / MA(CLOSE,34)) * 100) + 10) * 5);
底5:=(((((CLOSE – MA(CLOSE,50)) / MA(CLOSE,50)) * 100) + 10) * 5);
底6:=(((((CLOSE – MA(CLOSE,70)) / MA(CLOSE,70)) * 100) + 10) * 5);
S1:=((((((底2 + 底3) + 底) + 底4) + 底5) + 底6) / 6);
S2:=EMA(S1,3);
S3:=ABS((底4 – 底6));
S4:=((S1 + S3) / 2);
S5:=(((0 – 1) * (EMA((100 * (1 – WINNER(CLOSE))),1) – 50)) + 50);
S6:=(S5 + S4);
S7:=IF(((底1 > 0) AND (S6 < 0)),200,0);
S8:=IF((((((S4 < 0) AND (CLOSE = LLV(CLOSE,5))) AND ((CLOSE / REF(CLOSE,1)) > 0.905)) AND ((CLOSE / REF(CLOSE,1)) < 1.05)) AND (((VOL / CAPITAL) * 100) < 5)),(0 – 50),0);
S9:=IF(((S6 < 0) AND (S8 = (0 – 50))),100,0);
底C0:=(REF(CLOSE,2) * 0.865);
底C1:=(REF(CLOSE,13) * 0.772);
底C2:=MIN(底C0,底C1);
底C3:=((100 * VOL) / CAPITAL);
底C4:=IF(((((CLOSE – 底C2) / CLOSE) < (3 / 100)) AND ((SUM(底C3,5) / 5) < 1.8)),1,0);
底AA:=IF(((底C4 > 0) AND ((S8 < 0) OR (底1 > 0))),100,0);
V1:=(((((S7 > 0) AND (S9 > 0)) AND ((SUM(((VOL / CAPITAL) * 100),5) / 5) < 1)) OR (底C4 > 0)) AND ((S8 < 0) OR (底1 > 0)));
V2:=((((S7 > 0) AND (S9 > 0)) AND ((SUM(((VOL / CAPITAL) * 100),5) / 5) < 1)) OR ((底C4 > 0) AND ((REF(CLOSE,1) / REF(CLOSE,2)) > 0.902)));
V3:=(V1 OR V2);
V4:=(底AA OR V3);
V5:=底AA;
G:=(MA(CLOSE,80) – (MA(CLOSE,10) / 3));
Z:=IF((V4 > 0),87,0);
Z1:=IF((V5 > 0),91,0);
Z2:=IF(((底AA > 0) AND (CLOSE < G)),97,0);
Z3:=MAX(MAX(Z2,Z),Z1);
DRAWTEXT(FILTER(((((Z > 80) AND (Z1 > 90)) AND (Z2 > 90)) AND (Z3 > 90)),13),L*0.75,’↑底95%’),COLORRED;

通达信战神推荐主图指标公式

短高H:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
短低L:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
D90H:=EMA(短高H,90)-(EMA(短高H,90)-EMA(短低L,90))*0.2,COLORRED,LINETHICK1;
D90L:=EMA(短低L,90)+(EMA(短高H,90)-EMA(短低L,90))*0.2,COLORRED,LINETHICK1;
高0:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK1,COLORWHITE;
低0:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK1,COLORWHITE;
多头定位:=(高0+低0)/2>(D90H+D90L)/2;
空头定位:=(高0+低0)/2<(D90H+D90L)/2;
波段顶0:=(XMA(XMA(H,120),120)-XMA(XMA(L,120),120))*4+XMA(XMA(H,120),120),LINETHICK1,COLORRED;
波段底0:=XMA(XMA(L,120),120)-(XMA(XMA(H,120),120)-XMA(XMA(L,120),120))*4,LINETHICK1,COLORGREEN;
STICKLINE(多头定位=1,波段顶0,波段底0,5,0),COLOR001050;
STICKLINE(空头定位=1,波段顶0,波段底0,5,0),COLOR404050;
中中中:=((XMA(XMA(H,15),15)+XMA(XMA(H,20),20)+XMA(XMA(H,30),30)+XMA(XMA(H,40),40))/4+(XMA(XMA(L,15),15)+XMA(XMA(L,20),20)+XMA(XMA(L,30),30)+XMA(XMA(L,40),40))/4)/2,LINETHICK0,COLORGREEN;
EMA中中中:=EMA(中中中,10),LINETHICK0,COLORWHITE;
A:=(3*C+L+O+H)/6;
B:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210,COLORRED,LINETHICK1;
D:=MA(B,10),COLORRED,LINETHICK1;
D14:=MA(B,14),COLORRED,LINETHICK1;
D21:=MA(B,21),COLORRED,LINETHICK1;
A1:=MA((3*C+L+O+H)/6,28);
B1:=(20*A1+19*REF(A1,1)+18*REF(A1,2)+17*REF(A1,3)+16*REF(A1,4)+15*REF(A1,5)+14*REF(A1,6)
+13*REF(A1,7)+12*REF(A1,8)+11*REF(A1,9)+10*REF(A1,10)+9*REF(A1,11)+8*REF(A1,12)
+7*REF(A1,13)+6*REF(A1,14)+5*REF(A1,15)+4*REF(A1,16)+3*REF(A1,17)+2*REF(A1,18)+
REF(A1,12))/210,COLORGREEN,LINETHICK1;
D1:=MA(B1,14),COLORGREEN,LINETHICK1;
DRAWBAND(B1,RGB(255,0,0),D1,RGB(255,255,0));
DRAWBAND(D14,RGB(255,0,0),D21,RGB(255,255,0));
DRAWBAND(B,RGB(255,0,0),D,RGB(255,255,0));
中中顶:=(XMA(XMA(H,15),15)+XMA(XMA(H,20),20)+XMA(XMA(H,30),30)+XMA(XMA(H,40),40))/4*2-(XMA(XMA(L,15),15)+XMA(XMA(L,20),20)+XMA(XMA(L,30),30)+XMA(XMA(L,40),40))/4,LINETHICK2,COLORGREEN;
中中底:=(XMA(XMA(L,15),15)+XMA(XMA(L,20),20)+XMA(XMA(L,30),30)+XMA(XMA(L,40),40))/4*2-(XMA(XMA(H,15),15)+XMA(XMA(H,20),20)+XMA(XMA(H,30),30)+XMA(XMA(H,40),40))/4,LINETHICK2,COLORGREEN;
短中顶:=(XMA(XMA(H,5),5)+XMA(XMA(H,8),8)+XMA(XMA(H,11),11)+XMA(XMA(H,14),14)+XMA(XMA(H,4),4))/5+((XMA(XMA(H,5),5)+XMA(XMA(H,8),8)+XMA(XMA(H,11),11)+XMA(XMA(H,14),14)+XMA(XMA(H,4),4))/5-(XMA(XMA(L,5),5)+XMA(XMA(L,8),8)+XMA(XMA(L,11),11)+XMA(XMA(L,14),14)+XMA(XMA(L,4),4))/5)/2,LINETHICK0,COLORWHITE;
短中底:=(XMA(XMA(L,5),5)+XMA(XMA(L,8),8)+XMA(XMA(L,11),11)+XMA(XMA(L,14),14))/4-((XMA(XMA(H,5),5)+XMA(XMA(H,8),8)+XMA(XMA(H,11),11)+XMA(XMA(H,14),14)+XMA(XMA(H,4),4))/5-(XMA(XMA(L,5),5)+XMA(XMA(L,8),8)+XMA(XMA(L,11),11)+XMA(XMA(L,14),14)+XMA(XMA(L,4),4))/5)/2,LINETHICK0,COLORWHITE;
中顶:=(XMA(XMA(H,30),30)+XMA(XMA(H,40),40)+XMA(XMA(H,50),50)+XMA(XMA(H,60),60))/4*2.03-(XMA(XMA(L,30),30)+XMA(XMA(L,40),40)+XMA(XMA(L,50),50)+XMA(XMA(L,60),60))/4,LINETHICK2,COLORRED;
中底:=(XMA(XMA(L,30),30)+XMA(XMA(L,40),40)+XMA(XMA(L,50),50)+XMA(XMA(L,60),60))/4*1.97-(XMA(XMA(H,30),30)+XMA(XMA(H,40),40)+XMA(XMA(H,50),50)+XMA(XMA(H,60),60))/4,LINETHICK2,COLORRED;
长顶:=(XMA(XMA(H,90),90)+XMA(XMA(H,120),120)+XMA(XMA(H,150),150))/3*2.08-(XMA(XMA(L,90),90)+XMA(XMA(L,120),120)+XMA(XMA(L,150),150))/3,LINETHICK2,COLORYELLOW;
长底:=(XMA(XMA(L,90),90)+XMA(XMA(L,120),120)+XMA(XMA(L,150),150))/3*1.92-(XMA(XMA(H,90),90)+XMA(XMA(H,120),120)+XMA(XMA(H,150),150))/3,LINETHICK2,COLORYELLOW;
波段顶:(XMA(XMA(H,120),120)-XMA(XMA(L,120),120))*4+XMA(XMA(H,120),120),LINETHICK1,COLORYELLOW;
波段底:XMA(XMA(L,120),120)-(XMA(XMA(H,120),120)-XMA(XMA(L,120),120))*4,LINETHICK1,COLORYELLOW;
AF长:=EMA((CLOSE+HIGH+LOW)/3,18);
BF长:=REF(AF长,1);
AF中:=EMA((CLOSE+HIGH+LOW)/3,10);
BF中:=REF(AF中,1);
AF5:=EMA((CLOSE+HIGH+LOW)/3,6);
BF5:=REF(AF5,1);
AF3:=EMA((CLOSE+HIGH+LOW)/3,3);
BF3:=REF(AF3,1);
买入定位:=AF长>BF长 OR AF中>BF中 OR AF5>BF5 OR AF3>BF3;
卖出定位:=AF长<BF长 OR AF中<BF中 OR AF5<BF5;
顶底定位:=AF长<BF长 OR AF中<BF中 OR AF5<BF5 OR AF3<BF3;
STICKLINE(买入定位=1,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买入定位=1,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(AF中<BF中,LOW,HIGH,0.0,0),COLORGREEN;
STICKLINE(AF中<BF中,CLOSE,OPEN,2,1),COLORGREEN;
STICKLINE(卖出定位=1 AND 中中顶>中顶,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(卖出定位=1 AND 中中顶>中顶,CLOSE,OPEN,2,1),COLORGREEN;
STICKLINE(顶底定位=1 AND H>中中顶 AND H>中顶,CLOSE,OPEN,2,1),COLORGREEN;
STICKLINE(顶底定位=1 AND H>中中顶 AND H>中顶,LOW,HIGH,0.0,1),COLORGREEN;
加仓定位1:=卖出定位=1 AND 中中顶>中顶;
加仓定位2:=顶底定位=1 AND H>中中顶 AND H>中顶;
DRAWTEXT(中中中<EMA中中中 AND CROSS(AF中,BF中) AND 短中底<中中底 AND 短中底<中底,L*0.97,’↖战神推荐’),COLORFF00FF;
DRAWTEXT(中中中>=EMA中中中 AND CROSS(AF中,BF中) AND 短中底<中中底,L*0.97,’↖强烈推荐’),COLORFF00FF;
DRAWTEXT(CROSS(BF3,AF3) AND H>中中顶 AND H>中顶,H*1.03,’↙【逃顶】’),COLORGREEN;
DRAWTEXT(加仓定位1=0 AND 加仓定位2=0 AND CROSS(AF中,BF中) AND 中中中>=EMA中中中,L*0.995,’↖加’),COLORYELLOW;
DRAWTEXT(CROSS(AF长,BF长) AND 中底<长底,L*0.97,’↖【抄底】’),COLORRED;
DRAWTEXT(CROSS(AF长,BF长) AND 中底<长底 AND 中底>长底,L*0.97,’↖中底’),COLORYELLOW;
STICKLINE(AF中>BF中 AND 短中底<中底 AND 短中底<中底,CLOSE,OPEN,2,0),COLORRED;
DRAWTEXT(AF3>BF3 AND 短中底<中中底 AND H<中中底,L*0.985,’↖投机’),COLORWHITE;
STICKLINE(AF3>BF3 AND 短中底<中中底 AND H<中中底,CLOSE,OPEN,1,0),COLORRED;
STICKLINE(中中中>=EMA中中中 AND CROSS(AF中,BF中) AND AF中<中中中 AND AF中<(中顶+中底)/2 AND H<短中顶,CLOSE,OPEN,3,0),COLORRED;
DRAWTEXT(中中中>=EMA中中中 AND CROSS(AF中,BF中) AND AF中<中中中 AND AF中<(中顶+中底)/2 AND H<短中顶,L*0.97,’↖【买】’),COLORFFFF00;
DRAWTEXT(CROSS(BF中,AF中) AND 中中中<EMA中中中,H*1.01,’↙卖’),COLORGREEN;
DRAWICON(AF中<中中中 AND AF中<(中顶+中底)/2 AND H<短中顶 AND CROSS(AF中,BF中) AND 中中中<EMA中中中,L*0.99,1);
DRAWTEXT(CROSS((高0+低0)/2,(D90H+D90L)/2),波段底0*0.965,’↖【空转多】’),COLORRED;
DRAWTEXT(CROSS((D90H+D90L)/2,(高0+低0)/2),波段顶0*1.04,’↙【多转空】’),COLORWHITE;
DX:DRAWLINE(HIGH>=HHV(HIGH,12),HIGH,LOW<=LLV(LOW,12),HHV(HIGH,4),1),LINETHICK1,COLORMAGENTA;
KX:DRAWLINE(LOW<=LLV(LOW,12),LOW,HIGH>=HHV(HIGH,12),LLV(LOW,4),1),LINETHICK1,COLORWHITE;
DRAWTEXT(ISLASTBAR,波段底,’底’),COLORYELLOW;
DRAWTEXT(ISLASTBAR,波段顶,’顶’),COLORYELLOW;

稳赚策略主图操盘王波段,审时度势、红黄二龙主图,波段MACD主图花之波段,回归主图。


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址