• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

阻力价主图

股票公式编写 第一股票指标公式网 2周前 (06-30) 8次浏览 0个评论 扫描二维码

阻力价主图 指标公式:老鼠仓+见底主图、黑牛战法主图及选股、价格天梯主图,箱体A主图,ENE季月线主图:神兵五彩主图归一操盘主图。

通达信阻力价主图指标公式

N:=17;N1:=7;N2:=69;LH:=79;
LOCK:=1;
M8:=EMA(CLOSE,8);
M13:=EMA(M8,13);
VAR1:=EMA(M13,62);
VAR2:=(CLOSE+HIGH+LOW)/3;
VAR3:=EMA(VAR2,10)*LOCK;
VAR4:=REF(VAR3,1)*LOCK;
X1:STICKLINE(VAR3>VAR4,VAR3,VAR4,2.0,0),COLOR00FFFF;
X2:STICKLINE(VAR3<VAR4,VAR3,VAR4,2.0,0),COLORFF0000;
MA13:MA(C,13),COLORRED,LINETHICK2;
K1:=BACKSET(MA13<REF(MA13,1),2);
IF(K1,MA13,DRAWNULL),COLOR00CC33,LINETHICK2;
MA34:MA(C,34),COLORYELLOW,LINETHICK2;
K2:=BACKSET(MA34<REF(MA34,1),2);
IF(K2,MA34,DRAWNULL),COLORFFCC66,LINETHICK2;
MA55:MA(C,55),COLOR9933CC,LINETHICK2;
K3:=BACKSET(MA55<REF(MA55,1),2);
IF(K3,MA55,DRAWNULL),COLORBLUE,LINETHICK2;
阻力价:HHV(HIGH,19),LINETHICK1,NODRAW;
AAA:=MA(C,10);
BBB:=ATAN((AAA/REF(AAA,1)-1)*100)*180/3.1416;
CCC:=FILTER(CROSS(BBB,30),5);
X4:DRAWTEXT(CCC AND C>AAA,AAA*0.95,’←10三十度’);
AR1:=MA55>MA34 AND MA34>MA13;
AR2:=BARSLAST((C-MA13)/MA13*100<-6);
AR3:=MA13>=REF(MA13,1);
AR4:=COUNT(CROSS(C,MA13),AR2)=1;
AR5:=AR1 AND AR2 AND AR3 AND AR4;
AR6:=AR5 AND FILTER(AR5,10);
X5:DRAWTEXT(AR6,L-0.3,’←红杏’),COLORYELLOW;
BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;
BR2:=ABS((MA13-MA34)+(MA34-MA55))/C<0.2;
BR3:=C>MA55 AND (REF(C,1)<REF(MA55,1) OR REF(C,2)<REF(MA55,2) OR
REF(C,3)<REF(MA55,3) OR REF(C,4)<REF(MA55,4) OR REF
(C,5)<REF(MA55,5));BR4:=BR1 AND BR2 AND BR3;
X6:DRAWTEXT(BR4 AND FILTER(BR4,10),H+0.3,’←上树’),COLOR00C5FF;
Y:=(MA(C,13)-MA(C,55))/MA(C,13)*100;
YY1:=C>MA(C,13) AND OPEN<MA(C,13);{一阳三线}
YY3:=C>MA(C,34) AND OPEN<MA(C,34);
YY5:=C>MA(C,55) AND OPEN<MA(C,55);
X7:DRAWTEXT(YY1 AND YY5 AND YY3,LOW-0.1,’←三线’),COLORRED;
SJ1:=ABS(MA(CLOSE,13)-MA(CLOSE,34))<C*0.01;{13线34线55线接近}
SJ2:=ABS(MA(CLOSE,34)-MA(CLOSE,55))<C*0.01;
SJ3:=CROSS(MA(CLOSE,13),MA(CLOSE,55));{13线上穿55线}
X8:DRAWTEXT(SJ1 AND SJ2 AND SJ3,HIGH+0.1,’←集结’),COLORRED;
RY1:=C/OPEN>1.04;{阳线4%}
RY2:=REF(OPEN,1)/REF(CLOSE,1)>1.04;{阴线4%}
RY3:=ABS(OPEN-REF(C,1))<C*0.02 AND ABS(C-REF(OPEN,1))<C*0.02;{两线相等}
X9:DRAWTEXT(RY1 AND RY2 AND RY3 ,LOW,’←合璧’),COLORYELLOW;
HK1:=CROSS(MA(C,13),MA(C,55));{13线上穿55线}
HK2:=C<O;{当日收阴}
HK3:=ABS(L-MA(C,13))<C*0.03 OR ABS(C-MA(C,13))<C*0.04;{收盘价或最低价在13线}
HK:=HK1 AND HK2 AND HK3;
X10:DRAWTEXT(HK,LOW,’←黑客’),COLORGREEN;
JG1:=ABS(MA(C,13)-MA(C,34))<C*0.02 AND ABS(MA(C,13)-MA(C,55))<C*0.02;
JG2:=O>MA(C,13) OR O=MA(C,13);
JG3:=C/OPEN>1.03 ; {阳线3%}
JG:=JG1 AND JG2 AND JG3;
X11:DRAWTEXT(JG,LOW-0.2,’←揭竿’),COLORYELLOW;
HY1:=CROSS(MA(C,13),MA(C,55));{13线上穿55线}
HY2:=OPEN<C AND C/OPEN>1.02; {阳线3%}
HY3:=ABS(OPEN-MA(C,13))<C*0.05;{开盘在13线附近}
HY:=HY1 AND HY2 AND HY3;
X12:DRAWTEXT(HY,LOW,’←侠女’),COLORRED;
JW1:=C<OPEN AND REF(C,1)<REF(OPEN,1);
JW2:=OPEN<REF(C,1) AND C>REF(L,1);
JW3:=O<MA(C,13) AND O<MA(C,34) AND O<MA(C,55);
JW:=JW1 AND JW2 AND JW3;
X13:DRAWTEXT(JW,LOW-0.2,’←藏娇’),COLORYELLOW;
TS1:=CROSS(MA(C,13),MA(C,34));{13线上穿34线}
TS2:=MA(C,13)<MA(C,55);
TS:=TS1 AND TS2;
X14:DRAWTEXT(TS,LOW-0.2,’←投石’),COLORF00FF0;
MK1:=MA(C,13)>MA(C,55) AND MA(C,34)>MA(C,55);
MK:=TS1 AND MK1;
X15:DRAWTEXT(MK,H+0.4,’←二度’),COLORF00FF0;
{STICKLINE(GR6 AND GR7,H,H+0.09,4,0),COLOR00FF00;}
HR2:=MA13>=REF(MA13,3) AND MA34>=REF(MA34,1) AND MA55>=REF(MA55,1) AND
CROSS(C,MA13) AND CROSS(C,MA34) AND CROSS(C,MA55);
X16:DRAWTEXT(HR2 AND FILTER(HR2,10),L-0.09,’←三线’),COLORFFC8FF;
STICKLINE(HR2 AND FILTER(HR2,10),H,L,0,1),COLORFFC8FF;
FF:=EMA(CLOSE,3);MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),’←底背’),COLORA6E500;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.04),’←顶背’),COLOR1880FF;
STICKLINE(HR2 AND FILTER(HR2,10),O,C,3,1),LINETHICK2,COLORFFC8FF;
YZ1:=C/O>1.02 AND H/C>1.02 AND O/L<1.02;{收阳有上影}
YZ2:=REF(C,1)>REF(O,1) AND O>MA(C,11);{昨收阳 今大于均线}
YZ:=YZ1 AND YZ2 AND Y>10;
X17:DRAWTEXT(YZ,HIGH+0.2,’←独秀’),COLORF00FF0;
DS1:=OPEN/C>1.04 AND O/REF(C,1)>1.03;{高开收阴}
DS2:=V*100/FINANCE(7)>0.08 AND Y>8;{换手高涨幅大}
DS:=DS1 AND DS2;
X18:DRAWTEXT(DS,HIGH+0.1,’←高楼’),COLORGREEN;
YJ1:=H/O>1.04;
YJ2:=ABS(C-O)<C*0.03;
YJ3:=C/MA(C,13)>1.1;
YJ:=YJ1 AND YJ2 AND DS2 AND YJ3 AND YZ2;
X19:DRAWTEXT(YJ,HIGH+0.1,’←封喉’),COLORRED;
{www.171415.com 第一股票指标公式网_最全最好股票指标公式}
GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5) );
GR2:=MA13>MA34 AND MA34>MA55 AND MA13>REF(MA13,1);
GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1);
GR4:=H=HHV(H,GR1);
GR5:="MACD.MACD"(12,26,9)<REF("MACD.MACD"(12,26,9),1);
GR6:=GR2 AND GR3 AND GR4;
GR7:=GR2 AND GR3 AND GR4 AND GR5;
X20:DRAWTEXT(GR6 AND GR7,H+0.13,’←好收!’),COLOR00FF00;
T:=(MA(C,13)-MA(C,55))/MA(C,13)*100;
TT1:=C<MA(C,13) AND OPEN>MA(C,13);{一阴破三线}
TT3:=C<MA(C,34) AND OPEN>MA(C,34);
TT5:=C<MA(C,55) AND OPEN>MA(C,55);
X21:DRAWTEXT(TT1 AND TT5 AND TT3,LOW-0.6,’←破三’),COLORRED;
X22:DRAWTEXT(CROSS(MA34,MA13),MA34*1.01,’←分道’), COLOR00FF00,LINETHICK9;
X23:DRAWTEXT(CROSS(MA55,MA13),MA55*1.01,’←穿心’), COLOR00FF00,LINETHICK9;
X24:DRAWTEXT(CROSS(MA55,MA34),MA55*1.01,’←为政’), COLOR00FF00,LINETHICK9;
VAR5:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR6:=MA(CLOSE,N)+2*STD(CLOSE,N);
VAR7:=REF(CLOSE,1);
VAR8:=(SMA(MAX(CLOSE-VAR7,0),N1,1))/(SMA(ABS(CLOSE-VAR7),N1,1))*100;
VAR9:=CROSS(N2,VAR8);
VARA:=FILTER(VAR9,4);
VARB:=(2*CLOSE+HIGH+LOW)/4;
VARC:=LLV(LOW,34);
VARD:=HHV(HIGH,34);
VARE:=EMA((VARB-VAR1)/(VAR5-VAR1)*100,7);
VARF:=EMA(0.667*REF(VARE,1)+0.333*VARE,5);
VAR10:=MA(CLOSE,80)-MA(CLOSE,10)/3;
X25:DRAWTEXT(IF(CLOSE<VAR10 AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF
(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW-0.3,’←进场’),COLORRED;
VAR11:=REF(CLOSE,1);
VAR12:=(SMA(MAX(CLOSE-VAR11,0),N,1))/(SMA(ABS(CLOSE-VAR11),N,1))*100*LOCK;
X26:DRAWICON(CROSS(LH,VAR12),HIGH*1.035,2);
X27:DRAWTEXT(CROSS(LH,VAR12),HIGH*1.06,’←减仓’);
X28:DRAWTEXT(CROSS(VAR3,VAR4),L-0.2,’←短买’);
X29:DRAWTEXT(CROSS(MA13,MA34),H+0.08,’←增持’),COLORYELLOW,LINETHICK9;
X30:DRAWTEXT(CROSS(MA13,MA55),H+0.1,’←加仓’),COLORYELLOW,LINETHICK9;
X31:DRAWTEXT(CROSS(MA34,MA55),L-0.5,’←重仓’),COLORYELLOW,LINETHICK9;
X32:DRAWTEXT(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>REF(OPEN,1),
L*0.97,’←克阴’),COLORFF00FF;
X33:DRAWTEXT(REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<REF(OPEN,1),
H*1.02,’←克阳’),COLOR00FF00;
X235:DRAWICON(CROSS(MA13,MA34),MA34,1);
X36:DRAWICON(CROSS(MA13,MA55),MA55,1);
X37:DRAWICON(CROSS(MA34,MA55),MA55,1);
X38:DRAWICON(CROSS(MA34,MA13),MA34,2);
X39:DRAWICON(CROSS(MA55,MA13),MA55,2);
X40:DRAWICON(CROSS(MA55,MA34),MA55,2);

通达信苏秦背剑主图及选股指标公式

ZT:=(C/REF(C,1)-1)*100>=4;
SX:=REF(ZT,1) AND REF(L,1)>REF(H,2)*1.01 AND MAX(C,O)/MIN(C,O)<1.01 AND H>MAX(C,O)*1.01 AND MIN(C,O)>L*1.01;
TJ:=REF(SX,1) AND C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01;
DRAWTEXT(TJ,H,’背剑’)COLORYELLOW DRAWABOVE;
DRAWTEXT(SX AND REFX(C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01,1),H,’剑身’)COLORYELLOW DRAWABOVE;
W0:=BARSLAST(TJ);
ZG1:IF(W0<10,REF(H,W0),DRAWNULL)DOTLINE;
TJ1:=ZT AND L>REF(H,1)*1.01 AND REFX(SX,1) AND REFX(C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01,2);
DRAWTEXT(TJ1,H,’跳空’)COLORYELLOW DRAWABOVE;
W1:=COUNT(C>ZG1,W0+1)=1 AND C>ZG1;
W2:=CROSS(C,ZG1);
TJ2:=(W1||(W2));
DRAWICON(TJ2 AND W0<10,L,1);
DRAWTEXT(TJ2 AND W0<10,H,’剑出鞘’)COLORRED DRAWABOVE;

{
选股公式:

ZT:=(C/REF(C,1)-1)*100>=4;
SX:=REF(ZT,1) AND REF(L,1)>REF(H,2)*1.01 AND MAX(C,O)/MIN(C,O)<1.01 AND H>MAX(C,O)*1.01 AND MIN(C,O)>L*1.01;
TJ:=REF(SX,1) AND C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01;
W0:=BARSLAST(TJ);
ZG1:=IF(W0<10,REF(H,W0),DRAWNULL);
W1:=COUNT(C>ZG1,W0+1)=1 AND C>ZG1;
W2:=CROSS(C,ZG1);
TJ2:=(W1||(W2));
COUNT(TJ2 AND W0<10,60);
}

智能分时买卖主图坐船神器主图,天堂分笔主图、战神推荐主图,凌波微步主图DK决策主图,力挽牛熊主图。


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址