• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

赵机三宝

股票公式编写 第一股票指标公式网 6天前 6次浏览 0个评论 扫描二维码

赵机三宝 指标公式:树缠藤主图、奔走顺畅主图、天涯爱胜主图,庄进庄撤,超级优化波段买点:财源滚滚低位强势买卖点主图。

通达信赵机三宝指标公式

N:=18;M1:=3;M2:=3;
DIFF:=(EMA(C,5)-EMA(C,26))/EMA(C,26)*1000,COLOR000000;
DDEA:=EMA(DIFF,50),COLOR000000;
MACD:2*(DIFF-DDEA)+50,COLOR000000;
STICKLINE(MACD<REF(MACD,1)AND MACD>50,50,MACD,1,0),COLORCYAN;
STICKLINE(MACD<REF(MACD,1)AND MACD<50,50,MACD,1,0),COLORCYAN;
STICKLINE(MACD>REF(MACD,1)AND MACD<50,50,MACD,1,0),COLORYELLOW;
STICKLINE(MACD>REF(MACD,1)AND MACD>50,50,MACD,1,0),COLORFF00FF;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
STICKLINE(CROSS(BIAS,乖离) AND 乖离<-9,8,0,2,0),COLORYELLOW;
中轴:50,COLORWHITE;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
%K:MA(RSV,M1),COLORBLUE;
%D:MA(%K,M2),COLORAA00DD;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
VAR1:=HHV(DEA,53);
VAR2:=LLV(DEA,55);
VAR3:=DEA-(DIF-DEA);
UP:=IF(DIF>VAR1 AND DEA=VAR1,MAX(LLV(VAR1,10),VAR3),VAR1);
DN:=IF(DIF<VAR2 AND DEA=VAR2,MIN(HHV(VAR2,10),VAR3),VAR2);
下美人眼:IF(DIF<DN,-5,DRAWNULL),COLOR00BB00,LINETHICK3; {通达信}
上美人眼:IF(DIF>UP,104,DRAWNULL),COLOR00BB00,LINETHICK3; {通达信};
J:=3*%K-2*%D,COLORWHITE;
OBV:=%K;
AAA1:=REF(OBV,5)=HHV(OBV,2*5+1);
BBB1:=FILTER(AAA1,5);
CCC1:=BACKSET(BBB1,5+1);
DDD1:=FILTER(CCC1,5);{高点}
AAA2:=REF(OBV,5)=LLV(OBV,2*5+1);
BBB2:=FILTER(AAA2,5);
CCC2:=BACKSET(BBB2,5+1);
DDD2:=FILTER(CCC2,5);{低点}
DRAWICON(DDD1,OBV,8);
DRAWICON(DDD2,OBV,7);
六日RSI:SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100,LINETHICK2,COLORRED;
趋势线:DRAWLINE(六日RSI>=HHV(六日RSI,10),六日RSI,六日RSI<=LLV(六日RSI,3),HHV(六日RSI,3),1),COLORCYAN;
上穿:=CROSS(六日RSI,趋势线);
DRAWICON(上穿 AND 六日RSI<75,趋势线,25);
{www.171415.com 第一股票指标公式网_最全最好股票指标公式}
P:=5; N1:=6; HIGHN:=20;
LC:=REF(CLOSE,1);
AA:=REF(六日RSI,HIGHN)=HHV(六日RSI,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND 六日RSI=HHV(六日RSI,HIGHN+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
AA1:=REF(六日RSI,HIGHN)=LLV(六日RSI,2*HIGHN+1);
QY1:=BACKSET(AA1,HIGHN+1);
CC1:=FILTER(QY1,HIGHN) AND 六日RSI=LLV(六日RSI,HIGHN+1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
A1:=REF(六日RSI,P)=HHV(六日RSI,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);
A2:=REF(六日RSI,P)=LLV(六日RSI,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
S11:=R11>REF(R11,1);
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
U11:=T11>REF(T11,1);
MID:=MA(六日RSI,20);
UPPER:=MID + 2*STD(六日RSI,20);
LOWER:=MID – 2*STD(六日RSI,20);
高:=REF(HHV(六日RSI,360),1);
低:=REF(LLV(六日RSI,240),1);
DRAWICON(CC,六日RSI*1.03,2);
DRAWICON(CC1,六日RSI*0.97,1);
高压:DRAWLINE(CURRBARSCOUNT=GDCS2,六日RSI,CURRBARSCOUNT=GDCS1,六日RSI,1) COLORBLUE,POINTDOT,LINETHICK4;
低支:DRAWLINE(CURRBARSCOUNT=DDCS2,六日RSI,CURRBARSCOUNT=DDCS1,六日RSI,1) COLORRED,POINTDOT,LINETHICK4;
阻力:DRAWLINE(D1,六日RSI,S11,六日RSI,1),COLORYELLOW;
支撑:DRAWLINE(D2,六日RSI,U11,六日RSI,1),COLOR00FF00;
DRAWTEXT(CROSS(六日RSI,LOWER),LOWER,’抄’),COLOR00FF00;
DRAWTEXT(CROSS(LOWER,六日RSI),LOWER,’▼’),COLOR00FF00;
DRAWTEXT(CROSS(六日RSI,高),MID,’年高’),COLORYELLOW;
DRAWTEXT(CROSS(低,六日RSI),MID,’年低’),COLORYELLOW;
DRAWTEXT(CROSS(UPPER,六日RSI),UPPER,’逃’),COLORYELLOW;
DRAWTEXT(CROSS(六日RSI,UPPER),UPPER,’▲’),COLORYELLOW;
VM:MA(六日RSI,N1),COLORFF00FF,NODRAW;
STICKLINE(CROSS(BIAS,乖离) AND 乖离<-9,6,0,2,0),COLORRED;
DRAWTEXT(ISLASTBAR AND 六日RSI>REF(六日RSI,1),VM,’ ▲’),COLORDD00FF;
DRAWTEXT(ISLASTBAR AND 六日RSI<REF(六日RSI,1),VM,’ ▼’),COLORCCEE00;

通达信战神推荐主图指标公式

短高H:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
短低L:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
D90H:=EMA(短高H,90)-(EMA(短高H,90)-EMA(短低L,90))*0.2,COLORRED,LINETHICK1;
D90L:=EMA(短低L,90)+(EMA(短高H,90)-EMA(短低L,90))*0.2,COLORRED,LINETHICK1;
高0:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK1,COLORWHITE;
低0:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK1,COLORWHITE;
多头定位:=(高0+低0)/2>(D90H+D90L)/2;
空头定位:=(高0+低0)/2<(D90H+D90L)/2;
波段顶0:=(XMA(XMA(H,120),120)-XMA(XMA(L,120),120))*4+XMA(XMA(H,120),120),LINETHICK1,COLORRED;
波段底0:=XMA(XMA(L,120),120)-(XMA(XMA(H,120),120)-XMA(XMA(L,120),120))*4,LINETHICK1,COLORGREEN;
STICKLINE(多头定位=1,波段顶0,波段底0,5,0),COLOR001050;
STICKLINE(空头定位=1,波段顶0,波段底0,5,0),COLOR404050;
中中中:=((XMA(XMA(H,15),15)+XMA(XMA(H,20),20)+XMA(XMA(H,30),30)+XMA(XMA(H,40),40))/4+(XMA(XMA(L,15),15)+XMA(XMA(L,20),20)+XMA(XMA(L,30),30)+XMA(XMA(L,40),40))/4)/2,LINETHICK0,COLORGREEN;
EMA中中中:=EMA(中中中,10),LINETHICK0,COLORWHITE;
A:=(3*C+L+O+H)/6;
B:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210,COLORRED,LINETHICK1;
D:=MA(B,10),COLORRED,LINETHICK1;
D14:=MA(B,14),COLORRED,LINETHICK1;
D21:=MA(B,21),COLORRED,LINETHICK1;
A1:=MA((3*C+L+O+H)/6,28);
B1:=(20*A1+19*REF(A1,1)+18*REF(A1,2)+17*REF(A1,3)+16*REF(A1,4)+15*REF(A1,5)+14*REF(A1,6)
+13*REF(A1,7)+12*REF(A1,8)+11*REF(A1,9)+10*REF(A1,10)+9*REF(A1,11)+8*REF(A1,12)
+7*REF(A1,13)+6*REF(A1,14)+5*REF(A1,15)+4*REF(A1,16)+3*REF(A1,17)+2*REF(A1,18)+
REF(A1,12))/210,COLORGREEN,LINETHICK1;
D1:=MA(B1,14),COLORGREEN,LINETHICK1;
DRAWBAND(B1,RGB(255,0,0),D1,RGB(255,255,0));
DRAWBAND(D14,RGB(255,0,0),D21,RGB(255,255,0));
DRAWBAND(B,RGB(255,0,0),D,RGB(255,255,0));
中中顶:=(XMA(XMA(H,15),15)+XMA(XMA(H,20),20)+XMA(XMA(H,30),30)+XMA(XMA(H,40),40))/4*2-(XMA(XMA(L,15),15)+XMA(XMA(L,20),20)+XMA(XMA(L,30),30)+XMA(XMA(L,40),40))/4,LINETHICK2,COLORGREEN;
中中底:=(XMA(XMA(L,15),15)+XMA(XMA(L,20),20)+XMA(XMA(L,30),30)+XMA(XMA(L,40),40))/4*2-(XMA(XMA(H,15),15)+XMA(XMA(H,20),20)+XMA(XMA(H,30),30)+XMA(XMA(H,40),40))/4,LINETHICK2,COLORGREEN;
短中顶:=(XMA(XMA(H,5),5)+XMA(XMA(H,8),8)+XMA(XMA(H,11),11)+XMA(XMA(H,14),14)+XMA(XMA(H,4),4))/5+((XMA(XMA(H,5),5)+XMA(XMA(H,8),8)+XMA(XMA(H,11),11)+XMA(XMA(H,14),14)+XMA(XMA(H,4),4))/5-(XMA(XMA(L,5),5)+XMA(XMA(L,8),8)+XMA(XMA(L,11),11)+XMA(XMA(L,14),14)+XMA(XMA(L,4),4))/5)/2,LINETHICK0,COLORWHITE;
短中底:=(XMA(XMA(L,5),5)+XMA(XMA(L,8),8)+XMA(XMA(L,11),11)+XMA(XMA(L,14),14))/4-((XMA(XMA(H,5),5)+XMA(XMA(H,8),8)+XMA(XMA(H,11),11)+XMA(XMA(H,14),14)+XMA(XMA(H,4),4))/5-(XMA(XMA(L,5),5)+XMA(XMA(L,8),8)+XMA(XMA(L,11),11)+XMA(XMA(L,14),14)+XMA(XMA(L,4),4))/5)/2,LINETHICK0,COLORWHITE;
中顶:=(XMA(XMA(H,30),30)+XMA(XMA(H,40),40)+XMA(XMA(H,50),50)+XMA(XMA(H,60),60))/4*2.03-(XMA(XMA(L,30),30)+XMA(XMA(L,40),40)+XMA(XMA(L,50),50)+XMA(XMA(L,60),60))/4,LINETHICK2,COLORRED;
中底:=(XMA(XMA(L,30),30)+XMA(XMA(L,40),40)+XMA(XMA(L,50),50)+XMA(XMA(L,60),60))/4*1.97-(XMA(XMA(H,30),30)+XMA(XMA(H,40),40)+XMA(XMA(H,50),50)+XMA(XMA(H,60),60))/4,LINETHICK2,COLORRED;
长顶:=(XMA(XMA(H,90),90)+XMA(XMA(H,120),120)+XMA(XMA(H,150),150))/3*2.08-(XMA(XMA(L,90),90)+XMA(XMA(L,120),120)+XMA(XMA(L,150),150))/3,LINETHICK2,COLORYELLOW;
长底:=(XMA(XMA(L,90),90)+XMA(XMA(L,120),120)+XMA(XMA(L,150),150))/3*1.92-(XMA(XMA(H,90),90)+XMA(XMA(H,120),120)+XMA(XMA(H,150),150))/3,LINETHICK2,COLORYELLOW;
波段顶:(XMA(XMA(H,120),120)-XMA(XMA(L,120),120))*4+XMA(XMA(H,120),120),LINETHICK1,COLORYELLOW;
波段底:XMA(XMA(L,120),120)-(XMA(XMA(H,120),120)-XMA(XMA(L,120),120))*4,LINETHICK1,COLORYELLOW;
AF长:=EMA((CLOSE+HIGH+LOW)/3,18);
BF长:=REF(AF长,1);
AF中:=EMA((CLOSE+HIGH+LOW)/3,10);
BF中:=REF(AF中,1);
AF5:=EMA((CLOSE+HIGH+LOW)/3,6);
BF5:=REF(AF5,1);
AF3:=EMA((CLOSE+HIGH+LOW)/3,3);
BF3:=REF(AF3,1);
买入定位:=AF长>BF长 OR AF中>BF中 OR AF5>BF5 OR AF3>BF3;
卖出定位:=AF长<BF长 OR AF中<BF中 OR AF5<BF5;
顶底定位:=AF长<BF长 OR AF中<BF中 OR AF5<BF5 OR AF3<BF3;
STICKLINE(买入定位=1,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买入定位=1,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(AF中<BF中,LOW,HIGH,0.0,0),COLORGREEN;
STICKLINE(AF中<BF中,CLOSE,OPEN,2,1),COLORGREEN;
STICKLINE(卖出定位=1 AND 中中顶>中顶,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(卖出定位=1 AND 中中顶>中顶,CLOSE,OPEN,2,1),COLORGREEN;
STICKLINE(顶底定位=1 AND H>中中顶 AND H>中顶,CLOSE,OPEN,2,1),COLORGREEN;
STICKLINE(顶底定位=1 AND H>中中顶 AND H>中顶,LOW,HIGH,0.0,1),COLORGREEN;
加仓定位1:=卖出定位=1 AND 中中顶>中顶;
加仓定位2:=顶底定位=1 AND H>中中顶 AND H>中顶;
DRAWTEXT(中中中<EMA中中中 AND CROSS(AF中,BF中) AND 短中底<中中底 AND 短中底<中底,L*0.97,’↖战神推荐’),COLORFF00FF;
DRAWTEXT(中中中>=EMA中中中 AND CROSS(AF中,BF中) AND 短中底<中中底,L*0.97,’↖强烈推荐’),COLORFF00FF;
DRAWTEXT(CROSS(BF3,AF3) AND H>中中顶 AND H>中顶,H*1.03,’↙【逃顶】’),COLORGREEN;
DRAWTEXT(加仓定位1=0 AND 加仓定位2=0 AND CROSS(AF中,BF中) AND 中中中>=EMA中中中,L*0.995,’↖加’),COLORYELLOW;
DRAWTEXT(CROSS(AF长,BF长) AND 中底<长底,L*0.97,’↖【抄底】’),COLORRED;
DRAWTEXT(CROSS(AF长,BF长) AND 中底<长底 AND 中底>长底,L*0.97,’↖中底’),COLORYELLOW;
STICKLINE(AF中>BF中 AND 短中底<中底 AND 短中底<中底,CLOSE,OPEN,2,0),COLORRED;
DRAWTEXT(AF3>BF3 AND 短中底<中中底 AND H<中中底,L*0.985,’↖投机’),COLORWHITE;
STICKLINE(AF3>BF3 AND 短中底<中中底 AND H<中中底,CLOSE,OPEN,1,0),COLORRED;
STICKLINE(中中中>=EMA中中中 AND CROSS(AF中,BF中) AND AF中<中中中 AND AF中<(中顶+中底)/2 AND H<短中顶,CLOSE,OPEN,3,0),COLORRED;
DRAWTEXT(中中中>=EMA中中中 AND CROSS(AF中,BF中) AND AF中<中中中 AND AF中<(中顶+中底)/2 AND H<短中顶,L*0.97,’↖【买】’),COLORFFFF00;
DRAWTEXT(CROSS(BF中,AF中) AND 中中中<EMA中中中,H*1.01,’↙卖’),COLORGREEN;
DRAWICON(AF中<中中中 AND AF中<(中顶+中底)/2 AND H<短中顶 AND CROSS(AF中,BF中) AND 中中中<EMA中中中,L*0.99,1);
DRAWTEXT(CROSS((高0+低0)/2,(D90H+D90L)/2),波段底0*0.965,’↖【空转多】’),COLORRED;
DRAWTEXT(CROSS((D90H+D90L)/2,(高0+低0)/2),波段顶0*1.04,’↙【多转空】’),COLORWHITE;
DX:DRAWLINE(HIGH>=HHV(HIGH,12),HIGH,LOW<=LLV(LOW,12),HHV(HIGH,4),1),LINETHICK1,COLORMAGENTA;
KX:DRAWLINE(LOW<=LLV(LOW,12),LOW,HIGH>=HHV(HIGH,12),LLV(LOW,4),1),LINETHICK1,COLORWHITE;
DRAWTEXT(ISLASTBAR,波段底,’底’),COLORYELLOW;
DRAWTEXT(ISLASTBAR,波段顶,’顶’),COLORYELLOW;

稳赚策略主图操盘王波段,审时度势、红黄二龙主图,波段MACD主图花之波段,运钞火车。


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址