• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

正向好MACD

股票公式编写 第一股票指标公式网 2周前 (06-30) 7次浏览 0个评论 扫描二维码

正向好MACD 指标公式:红色MACD、实战型MACD、MACD上主图,MACD零轴主图,MACD交易主图:精准的变异MACDMACD仓位控制。

通达信正向好MACD指标公式

DIF:EMA(CLOSE,2)-EMA(CLOSE,60);
DEA:EMA(DIF,8);
MACD:(DIF-DEA)*2,COLORSTICK;
DIF1:EMA(VOL,2)-EMA(VOL,60);
DEA1:EMA(DIF,8);
MACD1:DIF1-DEA1,COLORSTICK;

通达信涨跌超前MACD指标公式

0,COLORGRAY;
DIF12:=(EMA(CLOSE,12)-EMA(CLOSE,26))/((EMA(CLOSE,12)+EMA(CLOSE,26))/2)*1000;
DEA12:=EMA(DIF12,9);
KDIF12:=3*(DIF12-DEA12);
KDEA12:=SMA(KDIF12,5,2);
微分DIF:=KDIF12*5,COLORWHITE,LINETHICK1;
微分DEA:=KDEA12*5,COLORYELLOW,LINETHICK1;
MACD2:2*(微分DIF-微分DEA),COLORBLACK;
MAMACD:=MA(MACD2,3),,COLORBLACK;
STICKLINE(MACD2>REF(MACD2,1) AND MACD2>0,0,MACD2,1,0),COLORRED;
STICKLINE(MACD2<=REF(MACD2,1) AND MACD2>0,0,MACD2,1,0),COLORYELLOW;
STICKLINE(MACD2<REF(MACD2,1) AND MACD2<0,0,MACD2,1,0),COLORCYAN;
STICKLINE(MACD2>=REF(MACD2,1) AND MACD2<0,0,MACD2,1,0),COLORMAGENTA;
STICKLINE(MAMACD<1*REF(MAMACD,1), MAMACD, MACD2 ,3, 0),COLORBLUE;
STICKLINE(MAMACD>1*REF(MAMACD,1), MAMACD, MACD2 , 3, 0),COLORLIRED;
微分DIF2:KDIF12*5,COLORRED,LINETHICK1;
微分DEA2:KDEA12*5,COLORMAGENTA,LINETHICK1;
NOTEXT强:IF(微分DIF2<MA(微分DIF2,2),微分DIF2,DRAWNULL),COLORGREEN;
NOTEXT弱:IF(微分DEA2<MAX(微分DEA2,REF(微分DEA2,1)),微分DEA2,DRAWNULL),COLORYELLOW;
DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*300,COLORWHITE,DOTLINE;
DEA:=EMA(DIF,9),COLORYELLOW,DOTLINE;
DIF普:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA普:=EMA(DIF,9);
MACD:=(DIF普-DEA普)*2,COLORSTICK;
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");
{DRAWTEXT(B1>0,DIF*0.7,’↙MACD底背’),COLORFF00FF; }
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");
{DRAWTEXT(D1>0,DIF*1.2,’↙MACD顶离’),COLORBLUE;}{MACD顶背离}
JC := DEA-DIF;
绿柱面积:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);
红柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));
X1:=IF (MACD<0,BARSLAST(CROSS(DIF,DEA)),0);
前次绿柱面积:=REF(绿柱面积,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积)
AND 本次最低价<前次最低价 ),1,0);
RS1:= MACD<0 AND REF(MACD,1)<0 AND C<前次最低价
AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(MACD)<ABS(REF(MACD,1));
底背驰: IF (CROSS(DIF,DEA),REF(Y1,1),0);
DRAWTEXT(底背驰,DIF*0.8,’↙积底背’),COLOR00FFFF;
X2:=IF (MACD>0,BARSLAST(CROSS(DEA,DIF)),0);
前次红柱面积:=REF(红柱面积,X2+1);
前次最高价:=REF(本次最高价,X2+1);
Y2:=IF((红柱面积>0 AND 红柱面积<前次红柱面积 AND 本次最高价>前次最高价 ),1,0);
RS2:= MACD>0 AND REF(MACD,1)>0 AND C>前次最高价 AND ABS(红柱面积)<ABS(前次红柱面积) AND ABS(MACD)<ABS(REF(MACD,1));
顶背驰:= IF (CROSS(DEA,DIF),REF(Y2,1),0);
DRAWTEXT(顶背驰,DIF*0.8,’↙顶底背’),COLORGREEN;
MACD高:=HHV(MACD,5);
E:=REF(C,C1+1)>C AND DEA>0 AND REF(MACD高,C1+1)<MACD高 AND CROSS("MACD.DEA","MACD.DIF") ;
{DRAWTEXT(E>0,DIF*1.1,’↙柱顶背’),COLORRED;}
F:=REF(C,A1+1)>C AND DEA<0 AND REF(MACD高,A1+1)<MACD高 AND CROSS("MACD.DIF","MACD.DEA");
{DRAWTEXT(F>0,DIF*0.9,’↙柱底背’),COLORYELLOW;}

MACD+神奇数字+挖坑MACD和KDJ组合,量化MACD主图、无钝化滞后的MACD,波段MACD主图复合MACD,MACD水下三金叉股价双背离副图。


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址