• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

三通道主图

股票公式编写 第一股票指标公式网 1年前 (2020-06-30) 112次浏览 已收录 0个评论 扫描二维码

三通道主图 指标公式:老鼠仓+见底主图、黑牛战法主图及选股、价格天梯主图,箱体A主图,ENE季月线主图:神兵五彩主图归一操盘主图。

通达信三通道主图指标公式

N:=13;N1:=102;M:=7;N2:=20;TS:=7;
EMA30:EMA(C,30),LINETHICK4,POINTDOT,COLOR6F4343;
VAR2:=CLOSE*VOL;
VAR3:=EMA((EXPMA(VAR2,3)/EXPMA(VOL,3)+EXPMA(VAR2,6)/EXPMA(VOL,6)
+EXPMA(VAR2,12)/EXPMA(VOL,12)+EXPMA(VAR2,24)/EXPMA(VOL,24))/4,N);
SUP:1.06*VAR3,LINETHICK2,COLOR545454;
SDN:VAR3*0.94,LINETHICK2,COLOR545454;
VAR4:=EXPMA(CLOSE,9);
LUP:EXPMA(VAR4*1.14,5),LINETHICK1,COLORYELLOW;
LDN:EXPMA(VAR4*0.86,5),LINETHICK1,COLORYELLOW;
DRAWBAND(SUP,RGB(120,0,100),LUP,RGB(60,100,50));
DRAWBAND(SDN,RGB(120,0,100),LDN,RGB(60,100,50));
{极点H}
A1:=REF(C,TS)=HHV(C,2*TS+1); B1:=FILTER(A1,TS);
C1:=BACKSET(B1,TS+1); HD:=FILTER(C1,TS);
波峰: REF(C,BARSLAST(HD)),POINTDOT,LINETHICK4,COLOR990099;
{极点L}
AL1:=REF(L,TS)=LLV(L,2*TS+1); BL1:=FILTER(AL1,TS);
CL1:=BACKSET(BL1,TS+1); LD:=FILTER(CL1,TS);
波谷: REF(L,BARSLAST(LD)),POINTDOT,LINETHICK4,COLOR4A766A;
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD);
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
STICKLINE(T1,波峰,波峰,40,0),COLOR990099;
STICKLINE(T2,波谷,波谷,40,0),COLOR4A766E;
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR000033;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000066;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000CC;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000FF;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCC66FF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR990000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3.1,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
AAX:=MA((2*CLOSE+HIGH+LOW)/4,5);
通道1:AAX*N1/100,COLORWHITE;
通道2:AAX*(200-N1)/100,COLORWHITE;
{www.171415.com 第一股票指标公式网_最全最好股票指标公式}
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
通道3:(1+M/100)*DD,COLOR007FFF;
通道4:(1-M/100)*DD,COLOR007FFF;
F:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(C<REF(O,1) AND F<0,1,0);
P1:=今小昨;
今小前:=IF(C<REF(O,2) AND F<0,1,0);
P2:=今小前;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,1.0,0),COLORFF1CAE;
STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0,OPEN,CLOSE,1.2,0),COLORAAAAAA;
CC2:=REF(C,1);
涨停:=IF((C-CC2)*100/CC2>=(10-0.01*100/CC2),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((CC2-C)*100/CC2>=(10-0.01*100/CC2),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
BOLL:=MA(CLOSE,N2);
UB:BOLL+2*STD(CLOSE,N2),LINETHICK2,COLOR8E2323;
LB:BOLL-2*STD(CLOSE,N2),LINETHICK2,COLOR8E2323;
双穿通道:=REF(L,1)<LDN AND REF(L,1)<LB AND C>LB OR (L<LDN AND L<LB AND C>LB);
DRAWICON(双穿通道 ,L*0.96,12);
DRAWTEXT( 双穿通道 ,L*0.94,’双穿通道隔日低买’),COLOR236B8E;
A0:=(L+H+C*2)/4;
A5:EMA(A0,5)COLORFF7F00,LINETHICK3;
A1A:=EMA(A0,11);
A1X:=(A5-REF(A5,1))/REF(A5,1)*100;
A2X:=(A1A-REF(A1A,1))/REF(A1A,1)*100;
买入持股:IF(A1X>=0,A5,DRAWNULL)COLORFF00FF,LINETHICK2;
卖出空仓:IF(A1X<0 AND A2X<0,A5,DRAWNULL)COLOR7FFF00,LINETHICK2;

通达信苏秦背剑主图及选股指标公式

ZT:=(C/REF(C,1)-1)*100>=4;
SX:=REF(ZT,1) AND REF(L,1)>REF(H,2)*1.01 AND MAX(C,O)/MIN(C,O)<1.01 AND H>MAX(C,O)*1.01 AND MIN(C,O)>L*1.01;
TJ:=REF(SX,1) AND C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01;
DRAWTEXT(TJ,H,’背剑’)COLORYELLOW DRAWABOVE;
DRAWTEXT(SX AND REFX(C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01,1),H,’剑身’)COLORYELLOW DRAWABOVE;
W0:=BARSLAST(TJ);
ZG1:IF(W0<10,REF(H,W0),DRAWNULL)DOTLINE;
TJ1:=ZT AND L>REF(H,1)*1.01 AND REFX(SX,1) AND REFX(C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01,2);
DRAWTEXT(TJ1,H,’跳空’)COLORYELLOW DRAWABOVE;
W1:=COUNT(C>ZG1,W0+1)=1 AND C>ZG1;
W2:=CROSS(C,ZG1);
TJ2:=(W1||(W2));
DRAWICON(TJ2 AND W0<10,L,1);
DRAWTEXT(TJ2 AND W0<10,H,’剑出鞘’)COLORRED DRAWABOVE;

{
选股公式:

ZT:=(C/REF(C,1)-1)*100>=4;
SX:=REF(ZT,1) AND REF(L,1)>REF(H,2)*1.01 AND MAX(C,O)/MIN(C,O)<1.01 AND H>MAX(C,O)*1.01 AND MIN(C,O)>L*1.01;
TJ:=REF(SX,1) AND C>REF(MAX(C,O),1) AND O<REF(MIN(C,O),1) AND H/C<1.01;
W0:=BARSLAST(TJ);
ZG1:=IF(W0<10,REF(H,W0),DRAWNULL);
W1:=COUNT(C>ZG1,W0+1)=1 AND C>ZG1;
W2:=CROSS(C,ZG1);
TJ2:=(W1||(W2));
COUNT(TJ2 AND W0<10,60);
}

智能分时买卖主图坐船神器主图,天堂分笔主图、战神推荐主图,凌波微步主图DK决策主图,力挽牛熊主图。


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址