• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

分享自用买卖点参考–买卖决策(副图+专家指示+条件选股+源码+贴图)

钱龙公式 第一股票指标公式网 1年前 (2019-10-04) 22次浏览 0个评论 扫描二维码

分享自用买卖点参考–买卖决策(副图+专家指示+条件选股+源码+贴图)介绍

指标说明:融合了买卖共振集合(32个买入指示+14个卖出指示),这些指标全部是拥有大批使用者的经典指标,确认无未来函数,不会飘移。

制作思路:很简单,利用羊群效应—-指标是意识形态对价格走势判断最终形态,而任何指标都有人在遵照执行,尤其是基本指标,而当这些指标在相同点同时出现是,就会造成使用不同指标人的行动一致性,这会造成何等推波助澜效应!
适用范围:个股

本次下载附件中指标分3部分,分别为:|副图|选股公式|交易系统指示
也许有人没用过交易系统指示,其实就是把买卖点直接标注在主图上而已,使用方法为:主图右键——>专家系统指示–>交易系统指示
顺便提一下:指标过于庞杂,选股公式使用时我I7+8G内存,TDX得假死2分钟以上,机器一般的话慎用,所以千万别当预警用

副图指标:麻雀-买卖决策
选股公式:麻雀-买卖选股
交易系统指示:交易决策系统

分享自用买卖点参考--买卖决策(副图+专家指示+条件选股+源码+贴图)

TYP:=(HIGH+LOW+CLOSE)/3;
LC:=REF(CLOSE,1);
{NO.1}
VAR001:=(TYP-MA(TYP,15))/(0.016*AVEDEV(TYP,15));
VAR002:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
B001:=IF(CROSS(VAR001,-150),1,0);
S001:=IF(CROSS(80,VAR002),1,0);

{NO.2}
VAR003:=EMA(100*(CLOSE-LLV(LOW,31))/(HHV(HIGH,31)-LLV(LOW,31)),3)/4;
B002:=IF(VAR003<1,1,0);
S002:=IF(VAR003>23,1,0);

{NO.3}
VAR004:=(CLOSE – LLV(LOW,18))/(HHV(HIGH,18) – LLV(LOW,18))*100;
VAR005:=EMA(VAR004,3);
VAR006:=EMA(VAR005,3);
VAR007:=(3*VAR005-2*VAR006);
VAR008:=REF(COUNT(VAR007<REF(VAR007,1),5)>=3,1) AND REF(VAR007,1)<20;
VAR009:=VAR007>REF(VAR007,1);
B003:=IF(FILTER(VAR008 AND VAR009,3),1,0);

{NO.4}
VAR010:=AMOUNT/VOL/1000;
VAR011:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR012:=SUM(AMOUNT,13)/VAR010/1000;
VAR013:=DMA(VAR011,VOL/VAR012);
VAR014:=(CLOSE-VAR013)/VAR013*1000;
B004:=IF(CROSS(VAR014,-166),1,0);
B005:=IF(CROSS(VAR014,-120),1,0);
B006:=IF(CROSS(VAR014,-88),1,0);

{NO.5}
VAR015:=(TYP-MA(TYP,15))/(0.015*AVEDEV(TYP,15));
VAR016:=(TYP-MA(TYP,70))/(0.015*AVEDEV(TYP,70));
VAR017:=IF(VAR015>=150 AND VAR015<200 AND VAR016>=150 AND VAR016<200,100,0);
VAR018:=0-IF(VAR016>=200,200,VAR017)+400;
S003:=IF(VAR018=300,1,0);

{NO.6}
VAR019:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/1000)/1000));
B007:=IF(CROSS((CLOSE-VAR019)/VAR019*1000,-166),1,0);

{NO.7}
VAR020:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
VAR021:=SMA(VAR020,2,1);
B008:=IF(VAR021<10,1,0);

{NO.8}
VAR022:=SUM(IF(TYP>REF(TYP,1),TYP*VOL,0),5)/SUM(IF(TYP<REF(TYP,1),TYP*VOL,0),5);
MFI:=IF(CROSS(100-(100/(1+VAR022)),20),1,0);
RSI:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
B009:=IF(MFI,1,0);
B010:=IF(CROSS(RSI,20),1,0);

{NO.9}
VAR023:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
VAR024:=REF(C,VAR023+1)>C AND REF("RSI.RSI1"(6,12,24),VAR023+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
VAR025:=IF(VAR024>0,1,0);
B011:=IF(VAR025,1,0);

{NO.10}
VAR026:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
VAR027:=(TYP-MA(TYP,70))/(0.015*AVEDEV(TYP,70));
VAR028:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR029:=100-ABS(VAR028);
VAR030:=IF(BARSCOUNT(CLOSE)<13,100,IF(VAR029<88 AND VAR028>0,1,0));
VAR031:=IF(BARSCOUNT(CLOSE)<13,-100,0-IF(VAR029<92 AND VAR028<0,1,0));
VAR032:=IF(BARSCOUNT(CLOSE)<70,1,IF(VAR027>=200 AND VAR026>=150,1,0));
B012:=IF(VAR031,1,0);
S004:=IF(VAR030,1,0);
S005:=IF(VAR032,1,0);

{NO.11}
VAR033:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
VAR034:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
B013:=IF(CROSS(VAR033,11)*80,1,0);
B014:=IF(CROSS(VAR034,3),1,0);
B015:=IF(VAR034<=3,1,0);
B016:=IF(VAR034<5,1,0);
B017:=IF(VAR034<7,1,0);

{NO.12}
VAR035:=AMOUNT/VOL;
VAR036:=L<VAR035*0.9;
VAR037:=(C-REF(C,1))/REF(C,1)*100> 1.2;
VAR038:=L< MA(C,5)*0.921;
VAR039:=VOL< MA(V,5)*1.5;
B018:=IF(VAR036 AND VAR037 AND VAR038 AND VAR039,1,0);

{NO.13}
VAR040:=100-(3)*(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))+(2)*(SMA(SMA(((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
VAR041:=100-(3)*(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1))+(2)*(SMA(SMA(((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75)))*(100),20,1),15,1));
VAR042:=(VAR040<REF(VAR041,1)) AND (VOL>REF(VOL,1)) AND (CLOSE>REF(CLOSE,1));
VAR043:=((HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21)))*(100)-10;
VAR044:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);
VAR045:=SMA(VAR044,13,8);
VAR046:=SMA(VAR043,21,8);
VAR047:=SMA(VAR045,13,8);
VAR048:=FILTER((COUNT((VAR047-VAR046<(-65)),3)=3),34);
VAR049:=MA(CLOSE,80)-(MA(CLOSE,13))/(3);
VAR050:=MA((CLOSE-VAR049)/(VAR049),1);
VAR051:=(EMA(VAR050,12))*(0.69999998);
VAR052:=EMA(VAR050,3);
VAR053:=IF((LLV(VAR052-VAR051,12)>0),0,(-30));
VAR054:=FILTER((COUNT((VAR053<(-20)),3)=3),34);
B019:=IF(VAR048,1,0);
B020:=IF(VAR054,1,0);

{NO.14}
VAR055:=C/REF(C,1)>1.045;
VAR056:=C/HHV(H,34)<0.7;
VAR057:=MAX(FORCAST(COST(24)/L,3),SMA(COST(24)/L,3,1))>1.526 ;
VAR058:=VAR055 AND VAR056 AND VAR057;
B021:=IF(VAR058,1,0);

{NO.15}
VAR059:=LLV(LOW,60);
VAR060:=HHV(HIGH,60);
VAR061:=EMA((CLOSE-VAR059)/(VAR060-VAR059)*100,5);
VAR062:=EMA(0.667*REF(VAR061,1)+0.333*VAR061,2);
VAR063:=CROSS(VAR062,VAR061) AND VAR061>85;
S006:=IF(VAR063,1,0);

{NO.16}
VAR064:=REF(LOW,1);
VAR065:=SMA(ABS(LOW-VAR064),13,1)/SMA(MAX(LOW-VAR064,0),13,1)*4;
VAR066:=EMA(VAR065,13);
VAR067:=LLV(LOW,34);
VAR068:=EMA(IF(LOW<=VAR067,VAR066,0),3);
B022:=IF(VAR068>REF(VAR068,1),1,0);

{NO.17}
VAR069:=IF(HHV((MA(CLOSE,1)<HHV(MA(TYP,5),10)),5),0,1);
VAR070:=IF(LLV((MA(CLOSE,1)<LLV(MA(TYP,5),10)),5),1,0);
VAR071:=IF(LLV((MA(CLOSE,1)<LLV(MA(TYP,5),10)),10),1,0);
S007:=IF(VAR069,1,0);
B023:=IF(VAR070,1,0);
B024:=IF(VAR071,1,0);

{NO.18}
VAR072:=SUM(MAX(MAX((HIGH-LOW),ABS((HIGH-REF(CLOSE,1)))),ABS((LOW-REF(CLOSE,1)))),5);
VAR073:=HIGH-REF(HIGH,1);
VAR074:=REF(LOW,1)-LOW;
VAR075:=SUM(IF(((VAR073>0)AND(VAR073>VAR074)),VAR073,0),5);
VAR076:=SUM(IF(((VAR074>0)AND(VAR074>VAR073)),VAR074,0),5);
VAR077:=(VAR075*100)/VAR072;
VAR078:=(VAR076*100)/VAR072;
VAR079:=MA(((ABS((VAR078-VAR077))/(VAR078+VAR077))*100),3);
VAR080:=IF(((VAR079>88)AND(VAR077<5.8)),80,0);
B025:=IF(VAR080,1,0);

{NO.19}
VAR081:=INDEXV*INDEXC;
VAR082:=EMA(VAR081,5)/EMA(INDEXV,5);
VAR083:=(INDEXC-VAR082)/VAR082*100;
VAR084:=VAR083<=-1.5 AND VAR083>-100;
VAR085:=SUM(VAR084>0,11)/SUM(VAR084=0,11);
VAR086:=VAR085<5 AND VAR085>=0.25;
VAR087:=(TYP-MA(TYP,13))/(0.015*AVEDEV(TYP,13));
VAR088:=EMA(VAR087,3);
VAR089:=SUM(MAX(0,HIGH-REF(TYP,1)),21)/SUM(MAX(0,REF(TYP,1)-LOW),21)*100;
VAR090:=REF(MA(VAR089,3),2.2);
VAR091:=CROSS(VAR090,VAR089) AND VAR089>150;
VAR092:=IF(VAR086 AND CROSS(VAR087,VAR088),1,0),,COLORRED;
VAR093:=IF(VAR091,1,0),,COLORGREEN;
S008:=IF(VAR093,1,0);
B026:=IF(VAR092,1,0);

{NO.20}
VAR094:="RSI.RSI1"(3,14,24);
VAR095:="RSI.RSI2"(3,14,24);
VAR096:=IF((VAR095-VAR094)/VAR094>5,50,0);
B027:=IF(VAR096,1,0);

{NO.21}
VAR097:=REF(LOW,1);
VAR098:=SMA(ABS(LOW-VAR097),3,1)/SMA(MAX(LOW-VAR097,0),3,1)*100;
VAR099:=EMA(IF(CLOSE*1.2,VAR098*10,VAR098/10),3);
VAR100:=LLV(LOW,38);
VAR101:=HHV(VAR099,38);
VAR102:=IF(LLV(LOW,90),1,0);
VAR103:=EMA(IF(LOW<=VAR100,(VAR099+VAR101*2)/2,0),3)/618*VAR102;
VAR104:=VAR103>5;
VAR105:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR106:=SMA(ABS(LOW-VAR105),13,1)/SMA(MAX(LOW-VAR105,0),10,1);
VAR107:=EMA(VAR106,10);
VAR108:=LLV(LOW,33);
VAR109:=EMA(IF(LOW<=VAR108,VAR107,0),3);
B028:=IF(COUNT(VAR104,2)=2 AND VAR109>REF(VAR109,1),1,0);

{NO.22}
VAR110:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
VAR111:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR112:=SMA(VAR111,3,1);
VAR113:=SMA(VAR112,3,1);
VAR114:=(VAR113/2+40)*1.1;
VAR115:=SMA(VAR114,3,1);
VAR116:=IF(CROSS(VAR115,VAR110),1,0);
VAR117:=IF(CROSS(80,VAR110),1,0);
S009:=IF(VAR116,1,0);
S010:=IF(VAR117,1,0);

{NO.23}
VAR118:=(2*CLOSE+HIGH+LOW)/4;
VAR119:=EMA((VAR118-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100,6);
VAR120:=EMA(0.667*REF(VAR119,1)+0.333*VAR119,4);
VAR121:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR122:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
VAR123:=100*VOL/CAPITAL;
VAR124:=IF(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VAR119>VAR120,3) AND REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),52,0);
VAR125:=IF(CROSS(VAR121,3),52,0);
VAR126:=IF(CROSS(84,VAR122),(-1)*VAR122,0);
VAR127:=IF(REF(0.34*VAR123,1)>4 AND REF(0.34*VAR123,1)<4.2,-60,0);
B029:=IF(VAR124,1,0);
B030:=IF(VAR125,1,0);
S011:=IF(VAR126,1,0);
S012:=IF(VAR127,1,0);

{NO.24}
VAR128:=SMA(MAX(CLOSE-LC,0),18,1)/SMA(ABS(CLOSE-LC),18,1)*100;
VAR129:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;
S013:=IF(CROSS(68,VAR128),1,0);
S014:=IF(CROSS(84,VAR129),1,0);

{NO.25}
VAR130:=IF(C/O>1.02 AND "BIAS.BIAS3"<-13,1,0);
B031:=IF(VAR130,1,0);

{NO.26}
VAR131:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),7);
VAR132:=HIGH-REF(HIGH,1);
VAR133:=REF(LOW,1)-LOW;
VAR134:=SUM(IF(VAR132>0 AND VAR132>VAR133,VAR132,0),7);
VAR135:=SUM(IF(VAR133>0 AND VAR133>VAR132,VAR133,0),7);
VAR136:=VAR134*100/VAR131;
VAR137:=VAR135*100/VAR131;
VAR138:=MA(ABS(VAR137-VAR136)/(VAR137+VAR136)*100,3);
B032:=IF(VAR138>90 AND VAR136=0,1,0);

{EXPORT}
BVALUE:=B001+B002+B003+B004+B005+B006+B007+B008+B009+B010+B011+B012+B013+B014+B015+B016+B017+B018+B019+B020+B021+B022+B023+B024+B025+B026+B027+B028+B029+B030+B031+B032;
SVALUE:=S001+S002+S003+S004+S005+S006+S007+S008+S009+S010+S011+S012+S013+S014;
BUYVALUE:=5*BVALUE;
SELLVALUE:=10*SVALUE;
买点决策:BVALUE,COLORFFD0FF,NODRAW;
风险决策:SVALUE,COLORFFD0FF,NODRAW;
STICKLINE(BUYVALUE,0,BUYVALUE,1,1),STICK,COLORRED;
STICKLINE(SELLVALUE,0,SELLVALUE,1,1),STICK,COLORGREEN;


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址