• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

新颖的DMI指标 ——(副图指标,源码,贴图,无未来函数,,简单说明)

钱龙公式 第一股票指标公式网 1年前 (2019-10-04) 25次浏览 0个评论 扫描二维码

新颖的DMI指标 ——(副图指标,源码,贴图,无未来函数,,简单说明)介绍

通过将指标用彩带(ADX与ADXR交叉)和彩柱(PDI,MDI)的变化来反映个股的走势情况,效果将更加明显。
N;1 100 14 M: 1 50 6
TR1:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:= DMP*100/TR;
MDI:= DMM*100/TR;
STICKLINE(PDI>=MDI,PDI-MDI,0,2,1),COLOR9900FF;
STICKLINE(PDI<MDI,PDI-MDI,0,2,1),COLORF69ECE;
ADX:= EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M);
ADXR:=EXPMEMA(ADX,M);
DRAWBAND(ADX,RGB(200,0,200),ADXR,RGB(150,150,150));
ADX2:EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,M),COLOR00EEEE,LINETHICK1;
ADXR2:EXPMEMA(ADX,M),COLORFFFFFF,LINETHICK1;
关注线:=50,COLORF0F000,POINTDOT;
IF(ADX>=ADXR,85,DRAWNULL),COLORF580F5,LINETHICK8;
IF(ADX<ADXR,85,DRAWNULL),COLORCCDD66,LINETHICK6;
IF(PDI>=MDI,-55,DRAWNULL),COLOR0000EE,LINETHICK8;
IF(PDI<MDI,-55,DRAWNULL),COLOR33AA33,LINETHICK6;

新颖的DMI指标 ——(副图指标,源码,贴图,无未来函数,,简单说明)


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址