• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

MACD+KD 研判提示!赢利更轻松(源码 副图 贴图)

钱龙公式 第一股票指标公式网 1年前 (2019-10-04) 21次浏览 0个评论 扫描二维码

MACD+KD 研判提示!赢利更轻松(源码 副图 贴图)介绍

这是在【艺术指标】上加入MACD KD 股价大于EMA17线及其他条件设置有图标提示
可结合着研判买卖!!
KD+量在这里:http://www.55188.com/thread-3805301-1-1.html
使用6.12以下版本可把这一语句去掉:DRAWNUMBER(ISLASTBAR,LJF2*1.05,LJF2),COLOR999999;

A1:=((C-LLV(L,10))/(HHV(H,10)-LLV(L,10)))*(100);
A2:=EMA(A1,10);
A3:=EMA(A2,10);
A4:=(3)*(A2)-(2)*(A3);
A5:=EMA(A4,5);
QA:=(EMA(A5,1)),COLOR007700,LINETHICK1;
KU:=(REVERSE(QA)),COLORFFFFFF,LINETHICK1;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
QAA:=IF(K>D,QA,DRAWNULL);
DRAWBAND(QA,RGB(0,115,0),KU,RGB(0,115,0));
DRAWBAND(QAA,RGB(143,41,16),KU,RGB(0,115,0));
顶:82,COLORFFFF00,LINETHICK1;
顶A:92,COLOR999599,LINETHICK5;
QS:=(5)*(SMA(((C-LLV(L,27))/(HHV(H,27)-LLV(L,27)))*(100),5,1))-(3)*(SMA(SMA(((C-LLV(L,27))/(HHV(H,27)-LLV(L,27)))*(100),5,1),3,1))-SMA(SMA(SMA(((C-LLV(L,27))/(HHV(H,27)-LLV(L,27)))*(100),5,1),3,1),2,1);
挖坑:IF((QS<=5),-58,0),COLOR00FFFF;
0,COLORFFFF00,LINETHICK2;
RF1:=MA(HHV(HIGH,485),17);
RF2:=MA(HHV(HIGH,222),17);
RF3:=MA(HHV(HIGH,96),17);
RF4:=MA(LLV(LOW,485),17);
RF5:=MA(LLV(LOW,222),17);
RF6:=MA(LLV(LOW,96),17);
RF7:=MA((RF4*0.96+RF5*0.96+RF6*0.96+RF1*0.558+RF2*0.558+RF3*0.558)/6,17);
RF8:=MA((RF4*1.25+RF5*1.23+RF6*1.2+RF1*0.55+RF2*0.55+RF3*0.65)/6,17);
RF9:=MA((RF4*1.3+RF5*1.3+RF6*1.3+RF1*0.68+RF2*0.68+RF3*0.68)/6,17);
RFA:=MA((RF7*3+RF8*2+RF9)/6*1.738,17);
RFB:=IF(C=C,RFA,RFA*DAY);RFC:=LOW;
RFD:=REF(LOW,1);RFE:=SMA(ABS(RFC-RFD),3,1)/SMA(MAX(RFC-RFD,0),3,1)*100;
RFF:=MA(IF(CLOSE*1.35<=RFB,RFE*10,RFE/10),3);
RF10:=LLV(LOW,30);RF11:=HHV(RFF,30);
绝佳买点:IF(C=C,MA(IF(LOW<=RF10,(RFF+RF11*2)/2,0),3),DRAWNULL),COLOR00FFFF,NODRAW;
低:-82,COLOR208FFF,LINETHICK1,DOTLINE;
低A:-91,COLORFFF000,LINETHICK1,DOTLINE;
STICKLINE(绝佳买点,-91,-85,5,1),COLOR00FFFF;
DIFF := EMA(CLOSE,12) – EMA(CLOSE,26);
DEA := EMA(DIFF,9);
MACD :=100*(DIFF-DEA);
STICKLINE(MACD>0,0,MACD,0.1,0) ,COLOR00FFFF;
STICKLINE(MACD<0,0,MACD,0.1,0) ,COLORFFF000;
GMB:IF(CROSS(DIFF,DEA) AND DIFF>0,0,DRAWNULL),CROSSDOT,LINETHICK4,COLOR00FFFF;
GMC:IF(CROSS(DIFF,DEA) AND DIFF<0,0,DRAWNULL),CROSSDOT,LINETHICK4,COLOR208FFF;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF>0,-2,’金叉>0′),COLORYELLOW;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF<0,-2,’金叉<0′),COLORYELLOW;
AS:=(O+H+L+C)/4;
BL:=EMA(AS,17);
XGM:=CROSS(C,BL);
DRAWICON(XGM,-1,9);
GJD:IF(CROSS(K,D) AND K>20 AND D<50,4,DRAWNULL),CROSSDOT,LINETHICK3,COLORFF00FF;
DRAWTEXT(CROSS(K,D) AND K>20 AND D<50,10,’K>20 D<50 KD金叉 ‘),COLOREEAAEE;
LJ1:=(C-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
LJ2:=(C-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
LJ3:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
LJF1:=SMA(LJ1,13,8);
LJF2:(EMA(LJ2,3)-50)*2,COLORFF22FF,LINETHICK2;
LJF3:=LJ3+100;
RSV1:=EMA(100*(C-LLV(LOW,18))/(HHV(H,18)-LLV(LOW,18)),3);
主A:=EMA(RSV1,3),COLOR208FFF,LINETHICK1;
DRAWTEXT(ISLASTBAR AND LJF2>REF(LJF2,1),LJF2,’ ▲’),COLORFF00FF;
DRAWTEXT(ISLASTBAR AND LJF2<REF(LJF2,1),LJF2,’ ▼’),COLOR00FF00;
DRAWNUMBER(ISLASTBAR,LJF2*1.05,LJF2),COLOR999999;
106,COLORFFFFFF;
STICKLINE(LJF3>80,102,99,1.5,0) ,COLOR00FF00;
STICKLINE(LJF1>86,104,102,1.5,0) ,COLOR00FFFF;
STICKLINE(LJF2>80,106,104,1.5,0) ,COLOR0000FF;
STICKLINE(主A>87,99,95,1.5,0) ,COLORFF0000;

MACD+KD 研判提示!赢利更轻松(源码 副图 贴图)

草根 涨幅量尺(主图 源码 帖图)

草根 涨幅量尺(主图 源码 帖图) 
{ ZZ:0 20 0 高B: 0 256 0 J:0 3 0 BLL:0 26 0 N1:0 256 0 }
AMOV:=VOL*(OPEN+CLOSE)/2;
成本价:SUM(AMOV,5)/SUM(VOL,5),LINETHICK1,COLOR209FFF;
TT3:=(CURRBARSCOUNT=6+1) AND 高B>0;
TT1:=(CURRBARSCOUNT=2+1);
BG:=REF(H,高B);
BH := HHV(BG,1);
BHG:=CONST(BH );
高价_:DRAWLINE(TT3, BHG, TT1, BHG, 1),COLOR67A2FA;
DRAWTEXT(ISLASTBAR AND 高B>0,高价_,’高点’),COLOR67A2FA;
FUG:=高价_-C;
高当前幅度:FUG/高价_*100,NODRAW,COLOR67A2FA;
最低:=TROUGHBARS(L,ZZ,1);{调整之字幅度找到低位起点}
低价:=REF(L,BARSLAST(最低=0));
低价_:DRAWLINE(最低=0 AND ZZ>0,L,ISLASTBAR,低价,0),COLORFFFF00;
FU:=C-低价_;
到当前幅度:FU/低价_*100,NODRAW,COLOR00FFFF;
DRAWTEXT(ISLASTBAR AND J=3, C, ‘← -到当前幅度%’),COLOR00EFFF;
DRAWTEXT(ISLASTBAR AND ZZ>0,低价_,’低点’),COLORFFFF00;
_3%:DRAWLINE(最低=0 AND J>=3,L*1.03,ISLASTBAR,低价*1.03,0),COLOR999999;
_5%:DRAWLINE(最低=0 AND J>=3,L*1.05,ISLASTBAR,低价*1.05,0),COLOR999999;
_8%:DRAWLINE(最低=0 AND J>=3,L*1.08,ISLASTBAR,低价*1.08,0),COLOR999999;
_13%:DRAWLINE(最低=0 AND J=3,L*1.13,ISLASTBAR,低价*1.13,0),COLOR999999;
_18%:DRAWLINE(最低=0 AND J=3,L*1.18,ISLASTBAR,低价*1.18,0),COLOR999999;
_25%:DRAWLINE(最低=0 AND J=3,L*1.25,ISLASTBAR,低价*1.25,0),COLOR999999;
DRAWTEXT(ISLASTBAR AND J>=3,_3%,’3%’),COLOR208FFF;
DRAWTEXT(ISLASTBAR AND J>=3,_5%,’5%’),COLOR208FFF;
DRAWTEXT(ISLASTBAR AND J>=3,_8%,’8%’),COLOR208FFF;
DRAWTEXT(ISLASTBAR AND J=3,_13%,’13%’),COLOR208FFF;
DRAWTEXT(ISLASTBAR AND J=3,_18%,’18%’),COLOR208FFF;
DRAWTEXT(ISLASTBAR AND J=3,_25%,’25%’),COLOR208FFF;
AS:=(O+H+L+C)/4;
BL:EMA(AS,17),LINETHICK2,COLOR0000FF;
IF(BL>REF(BL,1),BL,DRAWNULL),LINETHICK2,COLORYELLOW;
IF(BL<REF(BL,1),BL,DRAWNULL),LINETHICK2,COLOR00FF00;
DRAWTEXT(ISLASTBAR AND BL>REF(BL,1),BL,’ ↑E17′),COLOR00FFFF;
DRAWTEXT(ISLASTBAR AND BL<REF(BL,1),BL,’ ↓E17′),COLOR00FF00;
BLS: BL+2.58*STDP(C,BLL),LINETHICK1,COLOR00FFFF;
BL2: BL+1.96*STDP(C,BLL),LINETHICK1,COLORFF00FF;
BL3: BL-1.96*STDP(C,BLL),LINETHICK1,COLORF0FF00;
BLX: BL-2.58*STDP(C,BLL),LINETHICK1,COLOR00FF00;
XGM:=CROSS(C,BL);
DRAWICON(XGM,BL,9);
FUZ:=L+((H-L)/2);FUS:=O+((C-O)/2); FUSY:=C+((O-C)/2);SSFU:=(FUZ+IF(C>O,FUS,FUSY))/2;
FUZ1:=L+((H-L)*0.333);FUS1:=O+((C-O)*0.333);FUS1Y:=C+((O-C)*0.333);SSFU1:=(FUZ1+IF(C>O,FUS1,FUS1Y))/2;
FUZ2:=L+((H-L)*0.667);FUS2:=O+((C-O)*0.677);FUS2Y:=C+((O-C)*0.667);SSFU2:=(FUZ2+IF(C>O,FUS2,FUS2Y))/2;
STICKLINE(C=C AND J=1,SSFU2,SSFU2,1.5,0),COLOR208FFF,LINETHICK1;
STICKLINE(C=C AND J=1,SSFU1,SSFU1,1.5,0),COLOR208FFF,LINETHICK1;
STICKLINE(C=C AND J=1,SSFU,SSFU,2.6,0),COLOR00FFFF,LINETHICK1;
STICKLINE(C=C AND J=1,IF(C>O,H-((H-C)/2),H-((H-O)/2)),IF(C>O,H-((H-C)/2),H-((H-O)/2)),0.5,0),COLOR00FFFF,LINETHICK1;
STICKLINE(C=C AND J=1,IF(C<O,L+((C-L)/2),L+((O-L)/2)),IF(C<O,L+((C-L)/2),L+((O-L)/2)),0.5,0),COLOR00FFFF,LINETHICK1;
BGD:=C=HHV(C,6),LINETHICK0;
BDD:=C=LLV(C,6),LINETHICK0;
N10:=BARSLAST(BGD);
N20:=BARSLAST(BDD);
高S:=IF(N10,REF(C,N10),REF(C,N10))*1.005,POINTDOT,COLOR00FF00;
低S:=IF(N20,REF(C,N20),REF(C,N20))*0.995,POINTDOT,COLORFF00FF;
STICKLINE(C>0 AND J=2,高S,高S,1,0),COLOR00FF00;
STICKLINE(C>0 AND J=2,低S,低S,1,0),COLORFF00FF;
MAA:MA(C,N1),COLOR00FF00;
DRAWTEXT(ISLASTBAR AND N1>0 AND MAA>REF(MAA,1),MAA,’↑’),COLOR00FF00;
DRAWTEXT(ISLASTBAR AND N1>0 AND MAA<REF(MAA,1),MAA,’↓’),COLOR00FF00;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
GB:IF(RSI1>76,H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORFFFF00;
GBB:IF(RSI1>80,H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLOR0000FF;
DIFF:=EMA(CLOSE,12) – EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA),;
GMB:IF(CROSS(DIFF,DEA) AND DIFF>0,L-0.05,DRAWNULL),CROSSDOT,LINETHICK3,COLOR00FFFF;
GMC:IF(CROSS(DIFF,DEA) AND DIFF<0,L-0.05,DRAWNULL),CROSSDOT,LINETHICK3,COLOR00FFFF;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF>0,L-0.14,’金叉> 0 ‘),COLORYELLOW;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF<0,L-0.14,’金叉> 0 ‘),COLORYELLOW;
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
GJD:IF(CROSS(K,D) AND K>20 AND D<50,L-0.09,DRAWNULL),CROSSDOT,LINETHICK3,COLORFF00FF;
DRAWTEXT(CROSS(K,D) AND K>20 AND D<50,L-0.19,’K>20 D<50 KD金叉 ‘),COLOREEAAEE;
{请设置计算参数:
ZZ: PARAM#0 (0.00–20.00)调整任意低点;
高B:PARAM#1 (0.00–255.00)取任意高点;
J: PARAM#2 (0.00–3.00)显示分价线;
BLL:PARAM#3 (0.00–26.00)显示布林线;
N1: PARAM#4 (0.00–255.00)显示任意均线;
};
三楼的朋友
说的未来函数“TROUGHBARS”你看看在这下面里有影响吗?
高当前幅度:FUG/高价_*100,NODRAW,COLOR67A2FA;
最低:=TROUGHBARS(L,ZZ,1);{调整之字幅度找到低位起点}
低价:=REF(L,BARSLAST(最低=0));
低价_:DRAWLINE(最低=0 AND ZZ>0,L,ISLASTBAR,低价,0),COLORFFFF00;
FU:=C-低价_;
到当前幅度:FU/低价_*100,NODRAW,COLOR00FFFF;
DRAWTEXT(ISLASTBAR AND J=3, C, ‘← -到当前幅度%’),COLOR00EFFF;
DRAWTEXT(ISLASTBAR AND ZZ>0,低价_,’低点’),COLORFFFF00;
_3%:DRAWLINE(最低=0 AND J>=3,L*1.03,ISLASTBAR,低价*1.03,0),COLOR999999;
_5%:DRAWLINE(最低=0 AND J>=3,L*1.05,ISLASTBAR,低价*1.05,0),COLOR999999;
_8%:DRAWLINE(最低=0 AND J>=3,L*1.08,ISLASTBAR,低价*1.08,0),COLOR999999;
_13%:DRAWLINE(最低=0 AND J=3,L*1.13,ISLASTBAR,低价*1.13,0),COLOR999999;
_18%:DRAWLINE(最低=0 AND J=3,L*1.18,ISLASTBAR,低价*1.18,0),COLOR999999;
_25%:DRAWLINE(最低=0 AND J=3,L*1.25,ISLASTBAR,低价*1.25,0),COLOR999999;
DRAWTEXT(ISLASTBAR AND J>=3,_3%,’3%’),COLOR208FFF;
DRAWTEXT(ISLASTBAR AND J>=3,_5%,’5%’),COLOR208FFF;
DRAWTEXT(ISLASTBAR AND J>=3,_8%,’8%’),COLOR208FFF;
DRAWTEXT(ISLASTBAR AND J=3,_13%,’13%’),COLOR208FFF;
DRAWTEXT(ISLASTBAR AND J=3,_18%,’18%’),COLOR208FFF;
DRAWTEXT(ISLASTBAR AND J=3,_25%,’25%’),COLOR208FFF;

MACD+KD 研判提示!赢利更轻松(源码 副图 贴图)


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址