• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

KD通道——右侧短线助手——大智慧L2副图——FNC格式源码

钱龙公式 第一股票指标公式网 1年前 (2019-10-04) 26次浏览 0个评论 扫描二维码

KD通道——右侧短线助手——大智慧L2副图——FNC格式源码介绍

2011新年大礼之KD通道——右侧短线助手——大智慧L2副图——FNC格式源码
注意事项:指标无未来,是在本论坛红树林园的RSI复合通道理念下的优化,大家感谢他吧,向他致敬!此指标适合右侧短线交易辅助判断。
使用说明:和KD指标一样,注意上穿和下穿,注意顶底背离,另要注意KD通道上或下溢出布林通道为短线超买或超卖。

公式源码如下:

DRAWGBK(DATE>900101,STRIP(RGB(50,0,0),RGB(50,50,0),2));
MN:=9;
N1:=3;
TNT:=9;
M:=3;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
RS1:=SMA(RSV,3,1);
DIFF:SMA(RSV,3,1),COLORFF00FF,LAYER0,LINETHICK2;
DIFF1:=SMA(RSV,3,1);
DEA : EMA(DIFF1,M),COLORWHITE,LINETHICK2;
DEA1:=EMA(DIFF1,M);
MACD:=2*(DIFF1-DEA1);
IF(DIFF<0,DIFF,0),COLORFF00FF,LINETHICK2,LAYER0;
IF(DIFF<0,0,DIFF),COLORYELLOW,LINETHICK2,LAYER0;
{PARTLINE(DEA,BBDEA>0,RGB(255,0,255)),LINETHICK2;
PARTLINE(DEA,BBDEA<0,RGB(255,255,225)),LINETHICK2;
PARTLINE(DIFF,BBDIFF>0,RGB(255,255,0)),LINETHICK2;
PARTLINE(DIFF,BBDIFF<0,RGB(0,0,255)),LINETHICK2;}
{绿色}
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,8,0 ),COLOR008800;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,7,0 ),COLOR009900;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,6,0 ),COLOR00AA00;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,5,0 ),COLOR00BB00;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,4,0 ),COLOR00CC00;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,3,0 ),COLOR00DD00;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR00EE00;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR00FF00;
{红色}
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,8,0 ),COLOR000088;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,7,0 ),COLOR000099;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,6,0 ),COLOR0000AA;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,5,0 ),COLOR0000BB;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,4,0 ),COLOR0000CC;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,3,0 ),COLOR0000DD;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR0000EE;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR0000FF;
{黄色}
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,8,0 ),COLOR338FDD;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,7,0 ),COLOR339FDD;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,6,0 ),COLOR33AFDD;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,5,0 ),COLOR33BFDD;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLOR33CFDD;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3,0 ),COLOR33DFDD;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLOR33EFDD;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLOR33FFDD;
{兰色}
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,8,0 ),COLORFF4400;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,7,0 ),COLORFF6600;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,6,0 ),COLORFF7700;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,5,0 ),COLORFF8800;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLORFF9900;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,3,0 ),COLORFFAA00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFFBB00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFFCC00;
ATR:=MA(MAX(MAX((RS1-RS1),ABS(REF(RS1,1)-RS1)),ABS(REF(RS1,1)-RS1)),15);
VM:=MA(RS1,N1);
SM:MA(RS1,TNT),PRECIS1,Coloraaee00,LINETHICK0;
SU:SM+2*STD(RS1,TNT),PRECIS1,Coloraaee00,LINETHICK0;
SD:SM-2*STD(RS1,TNT),PRECIS1,Coloraaee00,LINETHICK0;
VU:VM+2.3*ATR,PRECIS1,Colorffffff,LINETHICK0;
VD:VM-2.1*ATR,PRECIS1,Colorffffff,LINETHICK0;
{DRAWGBKLAST(C>0),Color7a6500};
FILLRGN(SU,SD,C>0,RGB(0,170,140)),PRECIS1;
FILLRGN(VU,VD,C>0,RGB(210,210,210)),PRECIS1;
RSI:RS1,PRECIS1,COLORRED,LINETHICK2,LAYER0;
三日:MA(RS1,3),PRECIS1,COLORBLACK,LINETHICK1,LAYER0;
DRAWTEXT(BARSTATUS=2 and RSI>REF(RSI,1),Vm,’ ▲’),COLORRED,LINETHICK2;
DRAWTEXT(BARSTATUS=2 and RSI<REF(RSI,1),Vm,’ ▼’),COLOREEEE00,LINETHICK2;

KD通道——右侧短线助手——大智慧L2副图——FNC格式源码


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址