• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

红牛起步 主图公式 源码

钱龙公式 第一股票指标公式网 1年前 (2019-10-05) 24次浏览 0个评论 扫描二维码

红牛起步 主图公式 源码介绍

红牛起步

{青松红牛 大智慧2}
DRAWTEXTREL(20,30,’红牛起步’),LINETHICK6,Coloryellow;
DRAWTEXTREL(250,30,STKLABEL+’ ‘+STKNAME),LINETHICK6,ColorFFFF80;
if DISPSTATUS=2 then begin;
var100:=’所属板块:’;
if inblock(‘电力’)=1 then var100:=var100+’ 电力’;
if inblock(‘电脑’)=1 then var100:=var100+’ 电脑’;
if inblock(‘电器’)=1 then var100:=var100+’ 电器’;
if inblock(‘电子信息’)=1 then var100:=var100+’ 电子信息’;
if inblock(‘房地产’)=1 then var100:=var100+’ 房地产’;
if inblock(‘纺织服装’)=1 then var100:=var100+’ 纺织服装’;
if inblock(‘钢铁’)=1 then var100:=var100+’ 钢铁’;
if inblock(‘工程建筑’)=1 then var100:=var100+’ 工程建筑’;
if inblock(‘供水供气’)=1 then var100:=var100+’ 供水供气’;
if inblock(‘化工’)=1 then var100:=var100+’ 化工’;
if inblock(‘化纤’)=1 then var100:=var100+’ 化纤’;
if inblock(‘机械’)=1 then var100:=var100+’ 机械’;
if inblock(‘建材’)=1 then var100:=var100+’ 建材’;
if inblock(‘交通工具’)=1 then var100:=var100+’ 交通工具’;
if inblock(‘交通设施’)=1 then var100:=var100+’ 交通设施’;
if inblock(‘教育传媒’)=1 then var100:=var100+’ 教育传媒’;
if inblock(‘金融’)=1 then var100:=var100+’ 金融’;
if inblock(‘旅游酒店’)=1 then var100:=var100+’ 旅游酒店’;
if inblock(‘煤炭石油’)=1 then var100:=var100+’ 煤炭石油’;
if inblock(‘酿酒食品’)=1 then var100:=var100+’ 酿酒食品’;
if inblock(‘农林牧渔’)=1 then var100:=var100+’ 农林牧渔’;
if inblock(‘其他行业’)=1 then var100:=var100+’ 其他行业’;
if inblock(‘汽车’)=1 then var100:=var100+’ 汽车’;
if inblock(‘汽配’)=1 then var100:=var100+’ 汽配’;
if inblock(‘商业连锁’)=1 then var100:=var100+’ 商业连锁’;
if inblock(‘石化’)=1 then var100:=var100+’ 石化’;
if inblock(‘通信’)=1 then var100:=var100+’ 通信’;
if inblock(‘外贸’)=1 then var100:=var100+’ 外贸’;
if inblock(‘医药’)=1 then var100:=var100+’ 医药’;
if inblock(‘仪电仪表’)=1 then var100:=var100+’ 仪电仪表’;
if inblock(‘有色金属’)=1 then var100:=var100+’ 有色金属’;
if inblock(‘运输物流’)=1 then var100:=var100+’ 运输物流’;
if inblock(‘造纸印刷’)=1 then var100:=var100+’ 造纸印刷’;
if inblock(‘安徽’)=1 then var100:=var100+’ 安徽’;
if inblock(‘北京’)=1 then var100:=var100+’ 北京’;
if inblock(‘福建’)=1 then var100:=var100+’ 福建’;
if inblock(‘甘肃’)=1 then var100:=var100+’ 甘肃’;
if inblock(‘广东’)=1 then var100:=var100+’ 广东’;
if inblock(‘广西’)=1 then var100:=var100+’ 广西’;
if inblock(‘贵州’)=1 then var100:=var100+’ 贵州’;
if inblock(‘海南’)=1 then var100:=var100+’ 海南’;
if inblock(‘河北’)=1 then var100:=var100+’ 河北’;
if inblock(‘河南’)=1 then var100:=var100+’ 河南’;
if inblock(‘黑龙江’)=1 then var100:=var100+’ 黑龙江’;
if inblock(‘湖北’)=1 then var100:=var100+’ 湖北’;
if inblock(‘湖南’)=1 then var100:=var100+’ 湖南’;
if inblock(‘吉林’)=1 then var100:=var100+’ 吉林’;
if inblock(‘江苏’)=1 then var100:=var100+’ 江苏’;
if inblock(‘江西’)=1 then var100:=var100+’ 江西’;
if inblock(‘辽宁’)=1 then var100:=var100+’ 辽宁’;
if inblock(‘内蒙古’)=1 then var100:=var100+’ 内蒙古’;
if inblock(‘宁夏’)=1 then var100:=var100+’ 宁夏’;
if inblock(‘青海’)=1 then var100:=var100+’ 青海’;
if inblock(‘山东’)=1 then var100:=var100+’ 山东’;
if inblock(‘山西’)=1 then var100:=var100+’ 山西’;
if inblock(‘陕西’)=1 then var100:=var100+’ 陕西’;
if inblock(‘上海’)=1 then var100:=var100+’ 上海’;
if inblock(‘深圳’)=1 then var100:=var100+’ 深圳’;
if inblock(‘四川’)=1 then var100:=var100+’ 四川’;
if inblock(‘天津’)=1 then var100:=var100+’ 天津’;
if inblock(‘***’)=1 then var100:=var100+’ ***’;
if inblock(‘新疆’)=1 then var100:=var100+’ 新疆’;
if inblock(‘云南’)=1 then var100:=var100+’ 云南’;
if inblock(‘浙江’)=1 then var100:=var100+’ 浙江’;
if inblock(‘重庆’)=1 then var100:=var100+’ 重庆’;
if inblock(‘3G’)=1 then var100:=var100+’ 3G’;
if inblock(‘H股’)=1 then var100:=var100+’ H股’;
if inblock(‘QFII持股’)=1 then var100:=var100+’ QFII持股’;
if inblock(‘ST’)=1 then var100:=var100+’ ST’;
if inblock(‘奥运’)=1 then var100:=var100+’ 奥运’;
if inblock(‘创投’)=1 then var100:=var100+’ 创投’;
if inblock(‘次新股’)=1 then var100:=var100+’ 次新股’;
if inblock(‘大盘’)=1 then var100:=var100+’ 大盘’;
if inblock(‘股权改革’)=1 then var100:=var100+’ 股权改革’;
if inblock(‘股权投资’)=1 then var100:=var100+’ 股权投资’;
end;
DD5:=FINANCE2( 35);
SS5:=FINANCE2( 37);
FF5:=FINANCE2(18);
GG5:=FINANCE2(3);
HH5:=DYNAINFO(39);
DRAWTEXTREL(20,190,var100),color00ffff;
DRAWTEXTREL(20,150,’市盈率:’+NUMTOSTRN(HH5,2)+’%’+’ 每股收益:’+NUMTOSTRN(GG5,3)),COLORbbffff;
IF C>0 AND DISPSTATUS=2 THEN
DRAWTEXTREL(20,110,’总股本:’+NUMTOSTRN(DD5,0)+’万股’ +’ 流通A股:’+NUMTOSTRN(SS5,0)+’万股’),COLORbbffff;
DRAWGBKLAST(c>0,STRIP(RGB(10,60,0),RGB(10,10,0),0));
获利90:EMA(COST(90),5),LINETHICK0,colorFFFFFF;
a:=(3*c+l+o+h)/6;
X:=WMA(a,20);
rcc:=DYNAINFO(3);
s2:=sma(c,3,1);
s6:=sma(c,5,1);
dk:=2*(s2-s6);
STICKLINE(dk>0,rcc,rcc+dk,0,1),COLORRED;
STICKLINE(dk<0,rcc,rcc+dk,0,1),COLORCYAN;
主力成本:eMA(X,13),colorFF00FF,LINETHICK0;
短期底部:LLV(HIGH,30),LINETHICK2,COLORFFCC00;
STICKLINE(open>=close ,O,C,6,0 ),COLORbbbbbb;
STICKLINE(open>=close ,O,C,2.4,0 ),COLORcccccc;
STICKLINE(open>=close ,O,C,1.1,0 ),COLORdddddd;
STICKLINE(close>open,O,C,9,0 ),COLOr6666cc;
STICKLINE(close>open,O,C,6 ,0 ),COLOR7777dd;
STICKLINE(close>open,O,C,2.4 ,0 ),COLOR8888ee;
STICKLINE(close>open,O,C,1.1 ,0 ),COLOR9999ff;
STICKLINE(close>open,open,low,0.5,0 ),COLOR1199ff;
STICKLINE(close>open,close,HIGH,0.5 ,0 ),COLOR1199ff;
STICKLINE(open>=close,close,low,0.5 ,0 ),COLORcccccc;
STICKLINE(open>=close,open,HIGH,0.5 ,0 ),COLORcccccc;
rc:rcc,COLORBROWN;
ma(c,9);
STICKLINE(cross(ma(c,1),ma(c,9)),CLOSE,OPEN,8,0),colorred;
STICKLINE(cross(ma(c,1),ma(c,9)),HIGH,LOW,0.8,0),COLORred;
STICKLINE(cross(ma(c,1),ma(c,55)),CLOSE,OPEN,6,0),COLORred;
STICKLINE(cross(ma(c,1),ma(c,55)),HIGH,LOW,0.6,0),COLORred;
STICKLINE(cross(ma(c,1),ma(c,23.5)),CLOSE,OPEN,7,0),COLORyellow;
STICKLINE(cross(ma(c,1),ma(c,23.5)),HIGH,LOW,0.7,0),COLORyellow;
STICKLINE(cross(ma(c,1),ma(c,120)),CLOSE,OPEN,5,0),COLORMAGENTA;
STICKLINE(cross(ma(c,1),ma(c,120)),HIGH,LOW,0.5,0),COLORMAGENTA;
partline(ma(c,3),ma(c,3)),coloryellow,linethick2;
partline(ma(c,9),ma(c,9)),COLORMAGENTA,linethick2;
partline(ma(c,23.5),ma(c,23.5)),colorwhite;
ma5:=ma(c,5);
ma10:=ma(c,10);
ma30:=ma(c,30);
fa:=barslast(cross(ma10,ma5)) and cross(ma5,ma10);
fb:=fa and ma5>ma30 and ma10>ma30 and ma10>ref(ma10,1);
STICKLINE(fb,l,l-0.09,4,0),colorred;
DRAWTEXT(fb,l-0.58,’★红牛’),colorred,align0;
v1:=ema(close,5);
v2:=ema(ema(close,90)*1.01,10);
DRAWTEXT(cross(v1,v2),v1+0.05,’牛起步’),color00ff00,LINETHICK0;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE – VAR1) / (VAR2 – VAR1)) * 100),5);
AK:=EMA((((CLOSE – VAR1) / (VAR2 – VAR1)) * 50),13);
AB:=CROSS(AK1,AK);
DRAWICON(cross(v1,v2),v2,4);
DRAWTEXT((AB = 1),(LOW * 0.99),’○牛窝’),colorYELLOW;
{指数贡献值:(c-ref(ma(c,5),5))*finance(1),colorred,LINETHICK0;}
市值贡献值:CAPITAL/100*CLOSE/10000,coloRgreen,LINETHICK0;
{资金贡献值:ema(amount,3)/finance(7),colormagenta,LINETHICK0;}
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠仓:BB1 AND CC1 AND DD1 AND EE1,LINETHICK0,COLOR0099ff;
DRAWTEXT(老鼠仓,l*0.99,’ 老鼠仓’),COLOR0099ff;
STICKLINE(老鼠仓,H,L,2,0),COLOR0099ff;
STICKLINE(老鼠仓,O,C,2,0),COLOR0099ff;
BIAS2 := (CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
STICKLINE(BIAS2<-6,H,L,1,0),COLORGREEN;
STICKLINE(BIAS2<-6,C,O,2,1),COLORGREEN;
DRAWTEXTREL(10,850,’股经:选做强势股,不做无量阴跌股。弱势不追高,强势不抄底。均线角度的上下與大小,’),colorFFFFFF;
DRAWTEXTREL(10,900,’ 決定了趨勢方向及利潤空間。连续三根阴线必杀。空心绿K线(观察大盘)超跌很准。’),colorFFFFFF;
var666:=REF(C,1);
var777:=SMA(MAX(C-var666,0),6,1)/SMA(ABS(C-var666),6,1)*100;
DRAWTEXT(CROSS(82,var777),H*1.01,’▼逃顶’),COLORYELLOW ;
vvv1:=ref(c,ref(hhvbars(v,21),0));
mmm1:=ma(close,1);
aaaa:=V>1*ref(V,1) and (c/ref(C,1)-1)*100>9.5 and mmm1>=vvv1;
DRAWICON(cross(a,1),l*0.98,6),COLORRED;
DRAWTEXT(aaaa,l*0.93,’涨停’),LINETHICK1,COLORRED;

红牛起步 主图公式 源码


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址